How to setup a Ubuntu CraftBukkit Server (x64) running Java x64

Discussion in 'Bukkit Help' started by TnT, Jan 15, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    Kid Tiger

    Well, thanks for all that. But that doesn't help me move forward. I'm still stuck with the same error I had before I installed JRE.
     
  2. Offline

    TnT Retired Staff

    Please type (and paste the output):
    Code:
    ls -lah /tmp
     
  3. Offline

    Kid Tiger

    Code:
    root@Gamingrepublic:~# ls -lah /tmp
    total 20K
    drwxrwxrwt  5 root root 4.0K Feb  7 12:57 .
    drwxr-xr-x 20 root root 4.0K Feb  7 11:59 ..
    drwxrwxrwt  2 root root 4.0K Feb  7 12:57 .ICE-unix
    drwxrwxrwt  2 root root 4.0K Feb  7 12:57 .X11-unix
    drwxr-xr-x  2 root root 4.0K Feb  7 13:04 hsperfdata_root
    root@Gamingrepublic:~#
    
     
  4. Offline

    TnT Retired Staff

    It doesn't look like you've downloaded Java, or at least you haven't placed it in the /tmp directory.
     
  5. Offline

    Kid Tiger

    Assume that I don't know the commands to do these things.

    How do I place it in the /tmp directory? Is JRE the same as Java or JDK-default?

    I know I've installed JRE-default.
     
  6. Offline

    TnT Retired Staff

    type
    Code:
    java -version
    in your command prompt.
     
  7. Offline

    Kid Tiger

    I got it setup. I gave a friend of mine access to the server and it took him literally 5 minutes to activate it and open up a world. And then 10 minutes transferring my pre-prepared world into the server for us to use.

    Thanks for the help guys. I'd say the tut is far from perfect, but your help was appreciated. I picked up some rudimentary Linux lingo for starters.
     
  8. Offline

    TnT Retired Staff

    Glad you got it figured out.

    I'll be happy to fill in the gaps if you want to point them out.
     
  9. Offline

    Luc

    Thanx, it works :),
    but I want something that if the server boot the minecraft server starts autmatically, how can I do that?
     
  10. Offline

    Plague

  11. Offline

    owufail

    This helped me soooooo much!
     
  12. Offline

    TnT Retired Staff

    I'm glad! [​IMG]
     
  13. Offline

    blaize9

    well im useing gentoo(linux) x32 and for this settings what would i put?
    Code:
    #!/bin/sh
    java -d64 -Xincgc -Xmx1024M -jar craftbukkit.jar nogui
    should it be like "java -d32" ??
     
  14. Offline

    TnT Retired Staff

    Remove the -d64, put nothing in its place.
     
  15. Offline

    jpDIV

    Awesome tutorial, thanks. :D

    I've been running a server for a few months on both windows xp and Mac OSX with minimal problems, but I'm tired of having it on my mac, and want to set it up on a Ubuntu server. I managed to install the OS on an old pc, get it running, and follow most of your directions.

    BUT: I can't seem to install java correctly, or something. Every time I try to do anything with java, be it -version or starting the start.sh, it displays this:
    Code:
    UnZipSFX 5.50 of 17 February 2002, by Info-ZIP (ZIP-Bugs@lists.wku.edu).
    replace jre1.6.0_24/bin/java? [y]es, [n]o, [A]ll, [N]one, [r]ename:
    If I select all, it'll run, do its thing, and then say it's done, but if I try to -version or run the start.sh then it just pops up with the same message. I've both run it and not run it when it pops up, and several times each, but it never changes. Help?

    EDIT: I'm running Ubuntu Server x64 10.10, by the way. I'm a total noob at this, so please be patient with me. :p
    --- merged: Mar 6, 2011 9:00 AM ---
    NEVERMIND. I fixed it. :D

    Not really sure what I was doing, but i pretty much shutdown the ubuntu server to revert to the root command line (does that make sense?) and then sorta followed the instructions on #5 of this page, but changed add-apt-repository to apt-add-repository, and ran it like that. Sorta.

    I apoligize to anyone who tries to follow those directions.

    [diamond] BUT. IT WORKS. [diamond]

    Thank you, TnT, for this guide. It's been immensely helpful. +1!
     
  16. Offline

    TnT Retired Staff

    Glad you found it useful. :D
     
  17. Offline

    jpDIV

    Okay, so riddle me this:

    If I want to ssh into the server via a mac terminal window, so that it gives me command line access to the server, etc., how can I get this ssh feed when logged in after the Minecraft server's started to show the Minecraft server feed? When I ssh in right now when a minecraft server's running, it just gives me the standard jpdiv@servername command entry, when instead I want it to show the Minecraft server feed, with player chat, command entry, etc.

    Is this possible? Am I dreaming?

    (Also, server's running Ubuntu server 10.10, java x64, nightly Bukkit, etc.)
     
  18. Offline

    woodzy

    how do i tell it to use more ram?
     
  19. Offline

    TnT Retired Staff

    You should be able to use the screen command on Mac OSX as well - http://www.hantslug.org.uk/wiki/LinuxHints/Screen

    Where it says -Xmx<value>G, change that value to the amount of RAM, in GB, that you want to allocate.
    For example:
    java - Xincgc -Xmx2G -jar craftbukkit.jar nogui will allocate 2 GB RAM. If I had 3G it would be 3 GB RAM.
     
  20. Offline

    woodzy

     
  21. Offline

    TnT Retired Staff

    Are you sure you are using x64 Java? Can you paste the output of the java -version command?
     
  22. Offline

    woodzy

    yes im shure very shure
    java version "1.6.0_20"
    OpenJDK Runtime Environment (IcedTea6 1.9.7) (6b20-1.9.7-0ubuntu1~10.04.1)
    OpenJDK 64-Bit Server VM (build 19.0-b09, mixed mode)

    and no i will not usse sun
     
  23. Offline

    TnT Retired Staff

    Then you may run into problems - I've seen a lot of issues recently with OpenJDK. Those problems are likely the ones you are experiencing. Care to paste you full server.log output?

    Minecraft.net itself recommends using Sun Oracle Java.
     
  24. Offline

    Aniraa

    HELP ME
    I want to open Minecraft server on my own server and installed on linux host but it's facing so many problems. I installed it according to direction but it's not working correctly.

    If possible would you mind to help me out with develop my server and installing minecraft bukkit. Please looking forward your help and reply.

    Best regards,
    Anir
     
  25. Offline

    TnT Retired Staff

    Sure, I can help. What are you getting stuck on? Do you get the server started? Have you got stuck on installing Ubuntu? What's going on?

    I'll help if I can. I don't know where to start giving advice though until I know more of what problems you're running into.
     
  26. Offline

    Color42

    Great guide helped me reinstall my server in no time, is there any chans we could get a simular guide for setting up MySQL in this setup? Im a total linux idiot and would be totaly lost if it wasnt for guides like this! thx a million.

    Edit:
    Found a guide on Unbuntu forums for webmin/mysql solved got my stuff migrated :D
     
  27. Offline

    jonnytow

    when i run my start.sh it just extracts java :/ help please

    Update -

    i got my server running but less than a min in when i start it up this happens

    07:31:09 [WARNING] Can't keep up! Did the system time change, or is the server overloaded
    ?
    07:31:57 [SEVERE] java.net.SocketTimeoutException: Read timed out
    07:31:57 [SEVERE] at java.net.SocketInputStream.socketRead0(Native Method)
    07:31:57 [SEVERE] at java.net.SocketInputStream.read(Unknown Source)
    07:31:57 [SEVERE] at java.net.SocketInputStream.read(Unknown Source)
    07:31:57 [SEVERE] at java.io.FilterInputStream.read(Unknown Source)
    07:31:57 [SEVERE] at net.minecraft.server.Packet.b(Packet.java:75)
    07:31:57 [SEVERE] at net.minecraft.server.NetworkManager.f(NetworkManager.java:124)
    07:31:57 [SEVERE] at net.minecraft.server.NetworkManager.c(NetworkManager.java:223)
    07:31:57 [SEVERE] at net.minecraft.server.NetworkReaderThread.run(SourceFile:62)
    >

    any ideas?
     
  28. Offline

    hawianguy1189

    0 -rw-r--r-- 1 christopher christopher 0 2011-04-01 01:15 banned-ips.txt
    0 -rw-r--r-- 1 christopher christopher 0 2011-04-01 01:15 banned-players.txt
    1472 -rw-r--r-- 1 christopher christopher 1503330 2011-03-31 17:31 craftbukkit.jar
    0 -rw-r--r-- 1 christopher christopher 0 2011-04-01 01:15 ops.txt
    4 drwxr-xr-x 2 christopher christopher 4096 2011-04-01 01:16 plugins
    4 -rw-r--r-- 1 christopher christopher 2833 2011-04-01 01:18 server.log
    4 -rw-r--r-- 1 christopher christopher 250 2011-04-01 01:23 server.properties
    4 -rw-r--r-- 1 christopher christopher 83 2011-04-01 01:35 start.sh
    0 -rw-r--r-- 1 christopher christopher 0 2011-04-01 01:15 white-list.txt
    4 drwxr-xr-x 4 christopher christopher 4096 2011-04-01 01:18 world


    ok this is wat coems up when i do ls -ls /opt/craftbukkit

    When i do ./start.sh its telling me access denied. Plz help
     
  29. Offline

    Grandcruiser

    You have to chmod start.sh
    You have to chmod start.sh so that it is executable by the user.
     
  30. Offline

    hawianguy1189

    Sorry im new to linux english please
     
Thread Status:
Not open for further replies.

Share This Page