Solved How do I allow a non-op to use the /gamemode command in pex? (bukkit.command.gamemode not working)

Discussion in 'Bukkit Help' started by linopa2076, Feb 10, 2014.

Thread Status:
Not open for further replies.
  1. Offline


    I'm not an op on my own server because I don't want to have multiverse's mv.bypass.gamemode permission node, so that I am still put in the default gamemode when teleporting into a world. In PermissionsEX I created a group called "Owner" for myself and added ALL the permission nodes except the mv.bypass.gamemode one to the owner group. I can use all the commands, but when I try to do /gamemode creative it says,"Game mode change for linopa failed!" (linopa is my Minecraft username) Is it possible for me to allow non-ops to use /gamemode creative, or will I have to op myself every time I want to run that command? Do I need to have the mv.bypass.gamemode node to be able to use the /gamemode creative command, because I thought that that permission node only applied to when you where first teleported into a world.
  2. Offline


    try this perm. bukkit.command.gamemode
    and If you running essentials, add this one too essentials.gamemode
  3. Offline


    I already tried the bukkit.command.gamemode and it didn't work. Also, I'm not running essentials.
  4. Offline


    But that is exactly the permissions you would need. Paste your permissions to and let us have a look.
  5. Offline


  6. Offline


    Are you sure you're not using another Gamemode plugin?
  7. Offline


    I'm pretty sure I don't.

    These are the plugins I have:
    • Hub
    • KingKits
    • Multiverse-Core
    • PermissionsEx
    • Simple Prefixer
    • Shopkeepers
  8. Offline


    I know like non of those plugins, so you can do /? <PluginName> and check what commands the plugin has, tell me if you find gamemode in them!
  9. Offline


    You only gave the group Owner the gamemode permission. Also, you have to be more careful with your permission in general, look at this:
        - bukkit.command.*
        - bukkit.command.gamemode.
        - bukkit.command.gamemode
        - multiverse.acces
    This is just ugly and not good. Three bukkit.command in a row, one of them completely wrong (period at end), and the multiverse permission does not even exist, it is called multiverse.access
  10. Offline


    I cleaned up my permissions.yml so that now I only have the bukkit.command.* instead of those other bukkit.command nodes and I fixed the spelling of multiverse.access, but I'm still having the problem.

    I figured out the problem! In the KingKits config, I had "disable gamemode when using kit" set to true. I wasn't using kit when I was having the trouble with the gamemode command before, but setting this to false fixed the problem! :)
  11. Offline


    use essentials and than u give ur users permission

    - essentials.gamemode

    and so they can change it​
Thread Status:
Not open for further replies.

Share This Page