[HELP] Chunks keep getting regenerated, people are losing work!

Discussion in 'Bukkit Help' started by MilitantXIII, Jan 17, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    MilitantXIII

    Basically, that's exactly what's happening. All of a sudden one of my players puts "WTF" in the chat. I warp to him, this gigantic tree home he spent a good amount of hours on has a large-ish chunk missing. Not long after that, another player reports 3 chunks of another structure he was working on being gone too. I killed the server to try and avoid it being saved, but alas, the changes were permanent.

    What the hell is going on? This has happened before, but not with this kind of speed. No, it wasn't the 'missing chunk' error where you can relog and it fixes it, the chunks are regenerated and replaced. This server has been running since mid-Alpha, and chunk replacement HAS happened before, but only like one or two chunks on our gigantic map over the course of months.

    What I'm talking about is 5 chunks in the span of about half an hour.
     
  2. Offline

    MonsieurApple

    If you're using the latest verison of Bukkit, there are quite a few, er, bugs.

    In posts like this, please include what build number you have. It helps alot when diagnosing problems.
     
  3. Offline

    MilitantXIII

    BTW, I'm using the latest Flashlight plugin, ExtendDay plugin, MyWarp plugin, and Scrapbukkit.
    --- merged: Jan 17, 2011 9:44 PM ---
    I thought I was using the latest Craftbukkit and Bukkitmain, but I see its been updated multiple times since a few hours ago. I can't remember which I was running then.

    [EDIT] Looking at the time logs, its looking like Scrapbukkit 20, Bukkit Main 51, and CraftBukkit 69
     
  4. Offline

    Dan

    If it helps, I had this happening on my server as well. I was using build 69 ... it occurred 3 times within an hour. I rolled back to build 66, happened on load.

    I've rolled back to build 63 which I was using last night which had no issues.

    Here is an example of what was rolling through the logs:
    Code:
    java.lang.ClassCastException: net.minecraft.server.NBTTagByte cannot be cast to net.minecraft.server.NBTTagShort
        at net.minecraft.server.NBTTagCompound.c(SourceFile:87)
        at net.minecraft.server.EntityItem.b(SourceFile:181)
        at net.minecraft.server.Entity.e(Entity.java:754)
        at net.minecraft.server.EntityList.a(SourceFile:97)
        at net.minecraft.server.ChunkLoader.a(SourceFile:168)
        at net.minecraft.server.ChunkLoader.a(SourceFile:57)
        at net.minecraft.server.ChunkProviderServer.e(ChunkProviderServer.java:122)
        at net.minecraft.server.ChunkProviderServer.d(ChunkProviderServer.java:57)
        at net.minecraft.server.MinecraftServer.c(MinecraftServer.java:133)
        at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:104)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:177)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:512)
    java.lang.ClassCastException: net.minecraft.server.NBTTagByte cannot be cast to net.minecraft.server.NBTTagShort
        at net.minecraft.server.NBTTagCompound.c(SourceFile:87)
        at net.minecraft.server.EntityItem.b(SourceFile:181)
        at net.minecraft.server.Entity.e(Entity.java:754)
        at net.minecraft.server.EntityList.a(SourceFile:97)
        at net.minecraft.server.ChunkLoader.a(SourceFile:168)
        at net.minecraft.server.ChunkLoader.a(SourceFile:57)
        at net.minecraft.server.ChunkProviderServer.e(ChunkProviderServer.java:122)
        at net.minecraft.server.ChunkProviderServer.d(ChunkProviderServer.java:57)
        at net.minecraft.server.MinecraftServer.c(MinecraftServer.java:133)
        at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:104)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:177)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:512)
    java.lang.ClassCastException: net.minecraft.server.NBTTagByte cannot be cast to net.minecraft.server.NBTTagShort
        at net.minecraft.server.NBTTagCompound.c(SourceFile:87)
        at net.minecraft.server.EntityItem.b(SourceFile:181)
        at net.minecraft.server.Entity.e(Entity.java:754)
        at net.minecraft.server.EntityList.a(SourceFile:97)
        at net.minecraft.server.ChunkLoader.a(SourceFile:168)
        at net.minecraft.server.ChunkLoader.a(SourceFile:57)
        at net.minecraft.server.ChunkProviderServer.e(ChunkProviderServer.java:122)
        at net.minecraft.server.ChunkProviderServer.d(ChunkProviderServer.java:57)
        at net.minecraft.server.MinecraftServer.c(MinecraftServer.java:133)
        at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:104)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:177)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:512)
    java.lang.ClassCastException: net.minecraft.server.NBTTagByte cannot be cast to net.minecraft.server.NBTTagShort
        at net.minecraft.server.NBTTagCompound.c(SourceFile:87)
        at net.minecraft.server.EntityItem.b(SourceFile:181)
        at net.minecraft.server.Entity.e(Entity.java:754)
        at net.minecraft.server.EntityList.a(SourceFile:97)
        at net.minecraft.server.ChunkLoader.a(SourceFile:168)
        at net.minecraft.server.ChunkLoader.a(SourceFile:57)
        at net.minecraft.server.ChunkProviderServer.e(ChunkProviderServer.java:122)
        at net.minecraft.server.ChunkProviderServer.d(ChunkProviderServer.java:57)
        at net.minecraft.server.MinecraftServer.c(MinecraftServer.java:133)
        at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:104)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:177)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:512)
    
     
  5. Offline

    MilitantXIII

    Yes! That's exactly the errors that were popping up. I'll roll back, thanks!
     
  6. Offline

    Ante0

    #65 works too. Anything over 66 has this bug.
     
  7. Offline

    ScytheX10

    #66 seems fine to me.

    Edit, just looked through logs, no such error.

    Also, it's bee running since #66 release
     
  8. Offline

    TnT

    Running build 79 and I'm having no more issues. I had to restore from backups though, to fix the loss of world data.
     
  9. Offline

    Liger_XT5

    So the current version is stable?
     
  10. Offline

    ScytheX10

    I'm using 79.
    Been running since its release
    Been pretty stable.
     
  11. Offline

    Duendek86

    i'm using 65 with no issues. Can I try 79 sure┬┐?
     
  12. I tested 79 (I had the problem of chunks destroyed) et all seems OK now.
     
Thread Status:
Not open for further replies.

Share This Page