Solved Having problems with essentials kits.

Discussion in 'Bukkit Help' started by soysuva, Sep 20, 2013.

Thread Status:
Not open for further replies.
  1. Offline


    I'm not sure why the kits in essentials aren't working. Every time I use the command /kit tools it says "the kit was improperly defined. Please contact an admin." The only kits that work are kit dtools, notch, firework, and colors. And those only work when I'm op. My members on my server can't use kits too. I did give the perms "essentials.kit" and "essentials.kit.nameOfTheKit" -->( (group manager) (essentials kit)

    Edit: Solved. Thank you!
  2. Offline


    It's a simple matter of reading the instructions.

    First of all, the permission for individual kits has to be essentials.kits.[kitname] where "kits" is plural. Yours is singluar. See and click on the + before /kit.

    Second, you're not using the correct syntax as shown in the Essentials config.yml:
    # Syntax: - itemID[: DataValue/Durability] Amount [Enchantment:Level].. [itemmeta:value]...
    Note that the 'Amount' is required. You don't have amounts for all your items.
  3. Offline


    Thank you!

    Um, I get this error when I type /kit tools. ID 329 is a saddle.
    2013-09-20 18:57:00 [INFO] soysuva issued server command: /kit tools
    2013-09-20 18:57:00 [WARNING] [Essentials] Error parsing kit item: 329

    Nevermind, I've solved it. Thank you!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jun 4, 2016
Thread Status:
Not open for further replies.

Share This Page