Plugin Help GroupManager doesnt work!

Discussion in 'Plugin Help/Development/Requests' started by DeathSkull7234, Jul 24, 2017.

Thread Status:
Not open for further replies.
  1. Offline


    Ok, so my server is 1.12 and I downloaded essentials and groupmanager, i spent a couple of hours tweaking groupmanager and essentials to get it to work so i went here and people were saying groupmanager isnt updated to 1.12. Now I'm thinking if I should get PermissionsEX instead of GroupManager.
    So can someone clarify is GroupManager works in 1.12 and if I should use PermissionsEX.

    If you could help me with my GroupManager problem here are the essentials file and groupmanager files

    Essentials Config File config.yml :
    GroupManager groups.yml : a
    GroupManager globalgroups.yml :
    I also got an error log for groupmanager where I couldn't use any commands at all
    Heres the error log :

    If you could help me please explain or something. Just to clarify my server is a 1.12 server.
    Last edited: Jul 24, 2017
  2. Offline


    Group manager is no longer maintained by the Essentials team. I recommend switching to PermissionsEx as this will help your server in the long run. Group Manager may become completely incompatible with newer versions of Bukkit.

    Do yourself and your server a favor and switch to PermissionsEx. It will save you from countless headaches.
  3. Offline


  4. Offline


    As far as your error, simply add 'groups:' to your groups.yml such as the example below
        default: false
        - +vanish.effects.toggle.all
        - -vanish.effects.*
        - '*'
        - Co-Owner
          build: true
          prefix: '&4'
          suffix: ''
  5. Offline


    Ok, I guess I'll switch to PEX.

    EDIT: I tried what you said @FrostDevStudios and the permissions worked! Thanks for that, but now I need to know how to make the prefixes show. If possible
    Last edited: Jul 25, 2017
  6. Offline


    Where do you want the prefix to show? Do you want them in the chat?
    Also are you using EssentialsX or Essentials?

    If so, Change this to false or put a # infront of this option
    add-prefix-suffix: true
    Also remove the [{GROUP}] from your format, this will give you a extra prefix. For example, if you have a owner group, it will show in the chat, [owner][Pex's Defined Owner Prefix]
     format: '&7[{GROUP}]&r {DISPLAYNAME}&7:&r {MESSAGE}
    Im not sure if this works, I haven't tested this yet.
    Last edited: Jul 25, 2017
  7. Offline

    Machine Maker

    @DeathSkull7234 Use EssentialsX. The Spigot-Essentials has issues with adding enchantments to kits. Also, EssentialsX has a Vault dependency for its showing prefixes. Make sure you have Vault installed as well.
Thread Status:
Not open for further replies.

Share This Page