Problem/Bug GriefPrevention plugin problems

Discussion in 'Bukkit Help' started by Matomi, Sep 18, 2019.

  1. Offline

    Matomi

    Hi
    Im not sure if you can help with this but Im starting to get desperate here and you might know where I can get help cause Im eager to getting started.

    So I never setup a server before and now I started doing it with my brother and we've come some way and it is fun.

    We are using some plugins for ranks (GroupManager) and antigrief (GriefPrevention). So I've been looking into how to get these to work and I am by no means a genius in coding but I've got some coding experience through my education as a geologist. So the group manager Im pretty sure I've defined some ranks that now work, I just have to put the right permissions into each rank which has yet to be done. I've setup griefprevention and can use all the commands in game but other than claiming an administrative claim it seems like the "trust" system doesn't work properly as I want to allow people with a certain rank on the server, namely "member" and above ranks, to be able to open doors and/or use buttons in that claim, but the default group, as you are just joining the server, "guest", not to be able to do anything. Of course the "member" group shouldn't be able to destroy or build something in the administrative claim. Therefore I've tried the command /accesstrust for the group and just for my own name and the permissions has been given when I check /trustlist both [member] and my own name tag pop up in the "Accesstrust" list, I've also tried to put in /containertrust but it doesnt work either. The way I've tested it is by being an operator I put myself into the member group, give the group the /accesstrust or /containertrust, then remove my self as operator on the server and test. But even when I give my own nametag the permissions Im not allowed to use doors or buttons when I remove operator! Before I remove it, I can do anything perfectly fine, but as soon as I remove operator I can't use doors or buttons when I am in the member group and the permissions have been given. Can you help here?
     

Share This Page