Grass Won't Grow on Server

Discussion in 'Bukkit Help' started by Parrothead, Nov 23, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Grass on my server refuses to grow, even with all of the requirements matched (grass next to it, sunlight etc). It's been happening for about a month now, and it's getting very annoying.

    This has been happening on every build for as long as I can remember (at least build 1000 and up).

    Any ideas?

    Attached Files:

  2. Offline


    No idea whatsoever. None of those plugins interfere with the growth of grass. Just go around placing bone meal everywhere if you are desperate for grass.
  3. Offline


    if you have WorldEdit, select the region, then do //replace 3 2
    will replace all dirt to grass.
  4. Offline


    The solution above may work, but it is not a very goof one. We need to find narrow down out problem, let's try and see if a plugin is causing this. Remove all your plugins and run your server - see if grass will grow then.

    I have a feeling it could be Ptweaks or FlowerPower, but lets see if it is actually a plugin causing this problem first.

    Remove all your plugins, if that fixes the problem - then come back here and I'll help you narrow down which one it could be.

  5. Offline


    grass-growth Allow or block grass from spreading to dirt. Allowed State
    its a worldguard command
     /rg flag __global__ grass-growth allow
  6. Offline


    He doesn't have World Guard on his server, So that is not going to help. Unless you've disabled grass grow in the past with WorldGurad then enabling it isn't going to help - as disabling it using WorldGuard is just listening for the growth of grass and stopping it.

    I also think that that WorldGuard flag for grass growth, is for long grass.
  7. Offline

    XLawless BaronX

    Please do post a list or screenshot of your plugins, since this could be a plugin doing this so the server runs a bit faster and smoother
  8. Offline


    He has already posted a screenshot. :p
  9. Offline

    XLawless BaronX

    none there that come to mind would stop it but have a look around man
  10. Offline


    I tried removing all plugins but I kept bukkit (version 149something I think) on, and grass begun to grow.

    I installed worldguard and tried that global grass command that Jackster21 suggested, but it didn't yield a result.

    Then I removed Ptweaks and FlowerPower, both yielded no result.

    edit: My safefire.jar plugin was causing it. It stops fire spreading, and grass spread.
Thread Status:
Not open for further replies.

Share This Page