[GEN/TP/ADMN] CommandBook 1.7 - Essential and useful commands (/item, etc.) [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by sk89q, Feb 28, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    General commands as used on my server since '10. Warping, item giving, time changing, weather changing -- the usual.

    Thor command, one of many (video by Rubenbeebl):

    Note: You can remove any of these commands from CommandBook using the download link below.
    • General:
      • item [-d] <item[:data]> [amount]
      • give [-d] <target> <item[:data]> [amount]
      • more [-a] [-i] <target>
      • online [filter]
      • motd
      • intro (play intro music)
      • midi (play a MIDI file for yourself)
      • rules
      • setspawn [destination]
      • time [world] <time>
      • weather <'stormy'|'sunny'> [duration] [world]
      • thunder <'on'|'off'> [duration] [world]
      • spawnmob [-p] [-d] [-i] [-r] <mob> [count] [location]
      • kit <kit> [target]
    • Teleportation:
      • spawn
      • tp [target] <destination>
      • bring <target>
      • put <target>
      • call <target> (request a teleport)
    • Messaging:
      • broadcast <message>
      • say <message>
      • me <message>
      • msg <target> <message...>
      • reply <message...>
      • mute <target>
      • unmute <target>
    • Player:
      • whereami
      • compass
      • clear [-a] [target]
      • slap [-s] [-h|-v] [-d] [target]
      • rocket [-s] [-h] [target]
      • barrage [-s] [target]
      • shock [-s] [target]
      • thor [target] (get Thor's hammer)
      • unthor [target] (revoke Thor's hammer)
      • whois [target]
    • Utilities:
      • ping
      • debug info
      • debug clock (very accurate server lag benchmark)
    • Bans:
      • kick <target> [reason...]
      • ban [-e] <target> [reason...]
      • unban <target> [reason...]
    Complimentary plugins:


    [​IMG] CommandBook 1.7
    Requirements: Java 6+, WorldEdit, Bukkit build 753+

    You need WorldEdit: Install WorldEdit. If you don't want WorldEdit, put WorldEdit.jar in the root folder of your server or in the plugins/CommandBook folder.​

    If you find CommandBook useful, [​IMG]

    How to Use

    Check out my server too!

    [​IMG] (CommandBook is open source!)
    dragon8510, Psychoma, Goodi and 26 others like this.
  2. Offline


    I'm having the same issue, it says banned, generates a blank banned list.log file, then the player can still log in.

    His name has no special characters in it.
  3. Offline


    You Sir are awesome! PLEASE add Kit-Cooldowns to this Add-On
  4. Offline


    make sure you use the CAPITALS too
  5. Offline


    @klosen When I was fuddling around with this a little while back, I noticed that to. I believe it is case-sensitive. IMO the author should make it case-insensitive.
  6. Offline


    It should be case in-sensitive. I'll look into it and respond to questions later.
  7. Offline


    Ban is not working. Using the latest recommended craftbukkit.

    Ban is not working. It does not write to the banned_players.txt or banned_ips.txt

    There seems to be a vulnerability where a banned player can also remove their name from the files.

    Entering an IP manually into the bannedips file does nothing.
  8. Offline


    I have noticed issues with banns also 556 Uh saving and loading the bans file with the command after banning some 1 seems to help but Every time i restart the server i must load the bans with the command are you sure its loading it on start up?
  9. Offline


    I gave up with Bans/Kick and disabled them completely. Other than that the plugin works seemingly good. The /tphere and /s don't work though! Using #556
  10. Offline


    Can you add a /warn command to work with your /ban commands?
    E.g after x amount of /warns, it bans the person for all the /warn reasons
  11. Offline


    hey sk,

    got one short question. The /kit Command is not working for the Players on my Server. I myself can use the Command without Problems..

    This is my kits.txt
    And my Permissions Config is like this:
    Should be right? But /kit is not working for anyone except Admins.. other Commands like /whereami /motd /rules do work. I've already reloaded the Config.

    Would be nice if someone could help me with this..

  12. dunno if it's mentioned earlier, but if someone casts /whois someOtherUser, the other user gets the results of the whois, instead of the caster...
  13. Offline


    Having serious issues here. Running 556, use worldedit, use permissions. Basically, nothing works :/ As a specific example (each other command gives the same error), if any of my users try /compass, it gives an internal error message (and they do have that permission flag). The specific message I get is:
    Show Spoiler

    18:18:28 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'compass' in plugin CommandBook v1.2
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:37)
    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:80)
    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:229)
    at net.minecraft.server.NetServerHandler.c(NetServerHandler.java:645)
    at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:608)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:602)
    at net.minecraft.server.Packet3Chat.a(SourceFile:24)
    at net.minecraft.server.NetworkManager.a(SourceFile:230)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:76)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:357)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:272)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    Caused by: java.lang.NullPointerException
    at com.sk89q.bukkit.migration.ConfigurationPermissionsResolver.hasPermission(ConfigurationPermissionsResolver.java:104)
    at com.sk89q.bukkit.migration.ConfigurationPermissionsResolver.hasPermission(ConfigurationPermissionsResolver.java:99)
    at com.sk89q.bukkit.migration.ConfigurationPermissionsResolver.hasPermission(ConfigurationPermissionsResolver.java:99)
    at com.sk89q.bukkit.migration.ConfigurationPermissionsResolver.hasPermission(ConfigurationPermissionsResolver.java:99)
    at com.sk89q.bukkit.migration.PermissionsResolverManager.hasPermission(PermissionsResolverManager.java:102)
    at com.sk89q.commandbook.CommandBookPlugin.hasPermission(CommandBookPlugin.java:381)
    at com.sk89q.commandbook.CommandBookPlugin$1.hasPermission(CommandBookPlugin.java:182)
    at com.sk89q.commandbook.CommandBookPlugin$1.hasPermission(CommandBookPlugin.java:179)
    at com.sk89q.minecraft.util.commands.CommandsManager.hasPermission(CommandsManager.java:372)
    at com.sk89q.minecraft.util.commands.CommandsManager.executeMethod(CommandsManager.java:302)
    at com.sk89q.minecraft.util.commands.CommandsManager.execute(CommandsManager.java:256)
    at com.sk89q.commandbook.CommandBookPlugin.onCommand(CommandBookPlugin.java:226)
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    ... 12 more

    Perhaps I am missing something crucial here. Any help would be appreciated!
  14. Offline


    I got problems with setting up the /rules text.
    # Give ops all permissions
    op-permissions: true
    use-display-names: false
    online-on-join: false
    motd: |
        Willkommen auf unserem Minecraftserver.
        /rules    - Regeln
    rules: |
        - Bauwerke der anderen respektvoll behandeln!
        - Kein unvorsichtiger Umgang mit Feuer oder Lava!
        - Bauwerke sollen zur Atmosphäre passen!
        - Keine Test-/Hilfsbauwerke (z.B. 1x1 Türme) stehen lassen!
        - Kommunikation über TeamSpeak!
    disallowed-items: []
    allowed-items: []
        goldblock: 41
        ice: 79
    Using the default rules text with the edited motd works, but this one doesn't and I don't know why.
    I got the feeling it is a line-/lettercount problem because some test with two lines worked.
    I also wanted to add some lines to the motd but this didn't work, too.
    Can u guys tell me what I did wrong and what I need to do to make it work?
    Thank you.
  15. Offline


    Replace Ä, Ö, Ü etc. with Ae, Oe, Ue..

    (German) Hatte dasselbe Problem.. einfach ä etc. ersetzen.. das sollte es lösen. Mit den ersten zwei Zeilen ging es weil eben kein Umlaut vorhanden war.
  16. Offline


    Thank you it worked.

    Danke dir, es hat geklappt.
  17. Offline


    Would some1 please give me the 556 link again? D:
  18. Offline


    Link below, left hand side, where it says "Build History", go to bottom and hit "More", it'll show all the older builds including 556. And maybe save this link as bookmark!! : http://ci.bukkit.org/job/dev-CraftBukkit/
  19. Offline


    i ment the commandbook 556 but it's alright,i got my server working again^^ thanks although^^
  20. Offline


    Holy Strudenwaffles! This is probably one of the greates plugins out there :D tytytytyvm BUT, when i try to do the /spawnmob i can never get the location thing. I dont know exactly what you mean by location. Basically what im saying is, what do you type for [location]? Help pl0x herp dee derp ima noob.
    EDIT: Okok I found out what you meant by location, as in /setspawn. so now that I set a spawnpoint, whenever I try to do /spawnmob pig 5.....nothing happens. All I see is a message come up telling me that An error has occured in the console. WAT. Please, /spawnmob is probably one of the most useful commands that I would need, although your other commands are Vunerwaffe.
    By the way, the error message I get is a bunch of websites and commandsmanager stuff. This seems to be the only problem. Plox help plox
  21. Offline


    When using /spawnmob command, the location can be coordinates(x),(y),(z), I think a player target, a spawn location, or where you are looking using the "#target" syntax. If you are getting an error, you might have spawn animals and monsters set to false in server.properties file, but it needs to be set to true. If you just try the command as "/spawnmob pig 1", the default location should be right at your location, so basically right next to you.
  22. Offline


    Sk Hi!

    Can u please this epic stuff update to latest RB [602]

    Thank u so much in advence ! ;)
  23. Offline


    I will be updating this on Friday (PST).
  24. Offline


    Are you updating all of your plugins tomorrow? I'm in Mountain Time, can you give me an estimate what time this will be? Sorry if I'm being rude.
  25. Offline


    one word ..

  26. Offline


    "lol" is an acronym or abbreviation, depends how you look at it. Technically not a word. :p

    Looking forward to the update, sk.
  27. Offline


  28. Offline


    Actually, it's three words, not one. And if you count the "one word dot dot dot", it's eight words, So basically, you failed. And, by the way, he is one hour behind you. So midnight your time, will be 11 P.M. his time.
  29. Offline


    you seem to be a smart boy .. ;)
  30. Offline


    Mountain time is, IIRC, 1 hour off (provided that you are in DST).

    But anyway, the thing is, I work until late at night, so for some of my plugins, it might be "tomorrow" (Saturday) depending on your sleeping schedule. I will likely get CommandBook updated first though.
  31. sk89q your a star :)

    cant function without your plugins lol!!!
Thread Status:
Not open for further replies.

Share This Page