[GEN/TP/ADMN] CommandBook 1.7 - Essential and useful commands (/item, etc.) [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by sk89q, Feb 28, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    General commands as used on my server since '10. Warping, item giving, time changing, weather changing -- the usual.

    Thor command, one of many (video by Rubenbeebl):

    Note: You can remove any of these commands from CommandBook using the download link below.
    • General:
      • item [-d] <item[:data]> [amount]
      • give [-d] <target> <item[:data]> [amount]
      • more [-a] [-i] <target>
      • online [filter]
      • motd
      • intro (play intro music)
      • midi (play a MIDI file for yourself)
      • rules
      • setspawn [destination]
      • time [world] <time>
      • weather <'stormy'|'sunny'> [duration] [world]
      • thunder <'on'|'off'> [duration] [world]
      • spawnmob [-p] [-d] [-i] [-r] <mob> [count] [location]
      • kit <kit> [target]
    • Teleportation:
      • spawn
      • tp [target] <destination>
      • bring <target>
      • put <target>
      • call <target> (request a teleport)
    • Messaging:
      • broadcast <message>
      • say <message>
      • me <message>
      • msg <target> <message...>
      • reply <message...>
      • mute <target>
      • unmute <target>
    • Player:
      • whereami
      • compass
      • clear [-a] [target]
      • slap [-s] [-h|-v] [-d] [target]
      • rocket [-s] [-h] [target]
      • barrage [-s] [target]
      • shock [-s] [target]
      • thor [target] (get Thor's hammer)
      • unthor [target] (revoke Thor's hammer)
      • whois [target]
    • Utilities:
      • ping
      • debug info
      • debug clock (very accurate server lag benchmark)
    • Bans:
      • kick <target> [reason...]
      • ban [-e] <target> [reason...]
      • unban <target> [reason...]
    Complimentary plugins:


    [​IMG] CommandBook 1.7
    Requirements: Java 6+, WorldEdit, Bukkit build 753+

    You need WorldEdit: Install WorldEdit. If you don't want WorldEdit, put WorldEdit.jar in the root folder of your server or in the plugins/CommandBook folder.​

    If you find CommandBook useful, [​IMG]

    How to Use

    Check out my server too!

    [​IMG] (CommandBook is open source!)
    dragon8510, Psychoma, Goodi and 26 others like this.
  2. Offline


    allot of errors!!
    21:40:31 [INFO] CommandBook 1.6-customized enabled.
    21:40:31 [WARNING] CommandBook: 0 Warps(s) loaded
    21:40:31 [WARNING] CommandBook: 0 Homes(s) loaded
    21:40:31 [INFO] CommandBook: Maximum wrapper compatibility is enabled. Some features have been disabled to be compatible with poorly written server wrappers.
    21:40:31 [INFO] CommandBook: 0 banned name(s) loaded.
    21:40:31 [INFO] CommandBook: 1 kit(s) loaded.
    21:40:31 [SEVERE] Error occurred while enabling CommandBook v1.6-customized (Is it up to date?): com.sk89q.bukkit.migration.PermissionsResolverManager.<init>(Lorg/bukkit/plugin/Plugin;Ljava/lang/String;Ljava/util/logging/Logger;)V
    java.lang.NoSuchMethodError: com.sk89q.bukkit.migration.PermissionsResolverManager.<init>(Lorg/bukkit/plugin/Plugin;Ljava/lang/String;Ljava/util/logging/Logger;)V
    	at com.sk89q.commandbook.CommandBookPlugin.onEnable(CommandBookPlugin.java:198)
    	at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:126)
    	at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:920)
    	at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:278)
    	at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:173)
    	at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:156)
    	at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:297)
    	at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:284)
    	at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:152)
    	at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:348)
    	at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    using the 1.6 commandbook on a bukkit 1185 met permissions 3.1.6 !
  3. Offline


    are you also running WorldEdit.jar or have it in the plugins/CommandBook folder?
  4. Offline


    Yes i am running WordEdit.jar as plugin, but that hasn't a update ???

    Yeah, WE got a update sorry :3
  5. Offline


    Is there an option to have new players have a welcome message? like

    Welcome!<playername>To <Server Name>
  6. Offline


    Yep the motd, see doc and commands ;)
  7. Offline


    Hey hey, I left you a couple of tweets explaining my situation earlier...
    Just following up and posting everything here.
    Eh, ever since i updated to 1.6, perms for cb have stopped working, and no one except ops can use commands.
    it worked fine with 1.5.2 and all previous versions.
    No errors in the console, it's just denying perms all of the sudden. No other changes.
  8. Offline


    I solved the problem myself :) The problem was that commandbook didnt generate a new config file, and then I didnt had the following configurations:
    per-world-warps: true
    per-world-homes: true
    They acted as "False".
    So when I added this and set it to "true" I got my /home working again for ALL other worlds!
    Hope I helped some of you also.
  9. Offline


    [GEN/TP/ADMN] CommandBook 1.6 - Essential and useful commands (/item, etc.) [1182]

    I think you made a mistake in that title..
    Shouldn't that be [1185] instead of [1182] ?

    If anyone is having problems with permissions. (you are probably using permissionsbukkit and superpermsbridge?)
    I noticed that 'superpermsbridge.commandbook.*' doesn't work anymore, or any other commandbook permission with superpermsbridge in front of it.
    Try using 'commandbook.*' or 'commandbook.teleport' etc... (without 'superpermsbridge' in front)
    That seemed to fix the permissions for me. (also works on all other plugins from sk89q)
  10. Offline


    Need the updated version of World Edit :)
  11. Offline


    is there a way to when a person starts the server, a message to all comes up and says name and server etc.
  12. Offline


    What is new to the new version of commandbook!!!
  13. Offline


    Thank you for making this! Originally I was going to use Essentials for my server, but when I found CommandBook I was like, "Yes! Finally something good that's not as bulky as Essentials." One thing I'd recommend is a few more aliases for commands. There is one command that is giving me trouble by not having a simple name, but I can't remember what it is.
  14. Offline


    I got a problem alright.
    2011-10-05 11:07:43 [INFOCommandBook 1.6 enabled.
    2011-10-05 11:07:43 [SEVERECommandBookUnable to read default configurationconfig.yml
    -10-05 11:07:43 [SEVERECommandBookUnable to read default configurationkits.txt
    -10-05 11:07:43 [WARNINGCommandBook0 Warps(sloaded
    -10-05 11:07:43 [WARNINGCommandBook0 Homes(sloaded
    Using 2011-10-05 11:07:39 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-1112-g54a13b2-b1240jnks (MC: 1.8.1)

    I guess I am going to try to manually create one, I have don't wish to w8 for a fix so I will fix it myself for now and replace jar when it is updated to latest reco.
  15. Offline


    I need some help. So I've installed the latest version of this plugin, and I am NOT using permissions, as I don't believe it's required for this plugin. If it is, then my mistake. Non-ops are unable to use ANY commands. This includes the bare basics, like /spawn, and /time check. If the problem is in fact that I need permissions, does anybody know where to find a decent updated permissions thread?
  16. Offline


    Bad English ahead xD

    Do not rename CommandBook! When i upload CommandBook on my Web Server, my FTp Client rename CommandBook to commanbook, and this make a Problem. Commandbook wont start,, with the Orginal Name no Problem.
    juli7796 likes this.
  17. Offline


    really? they are all pretty short. if it is an item like /i cobblestonestairs you can make an alias of any item like that :) OR if you get command helper, well it helps.
  18. Offline


    Is it possible to restrict the number of /homes a group can set (like new players can set 1, veteran players can set 3, etc...)
  19. Offline


    CB [1185] BukkitPerms/Superbridge.

    I can Not get anyone to /spawnmob anything... Not even OP's.

    And it's the only cmd that doesn't work.

    I've got commandbook.spawnmob, commandbook.spawnmob.many, and I've tried commandbook.spawnob.pig. What am I not doing right here? Does this One specific node need superpermbridge.commandbook.spawnmob?
  20. Offline


    I've got a bad error (no error in console)... With the new bukkit 1240 build + this plugin i get a huge redstone lag, so redstone torches have a delay of about 30 seconds when powering them. That's pretty bad cuz it bricked the light-button (no lever, levers are for n00bs) in my house (it's made of 4 RS NOR's and 1 AND)... Basically, my server is unusable because of this bug.
    I hope this gets fixed soon...

  21. Offline


    This is a problem that happens when locking the time. I think it still isn't fixed.
    Everything should be fine if you don't lock the time.
    blade00362 likes this.
  22. Offline


    Ohh thanks it's working now :D
  23. Offline


    Ironic right, it's called "essentials" yet it's soooooooo bulky.
  24. Offline


    I found the problem with the latest version of CB...
    Did you drop GroupManager support, or is it just a bug in the release?
    It says it doesn't detect a permissions plugin, yet all of my other plugins do...
    Commandbook 1.6, WorldEdit 4.7, and WorldGuard 5.3 no longer work with my perm plugin now :(
    Would be great to have a fix!
    Thanks bunches :)

    [edit]: I suppose, in the mean time, i'll have to roll back to the previous version until then.
    People on my server are yelling at me for not being able to teleport, and everything else ._.

    [edit2]: Just tested it with PermissionsEX, and CommandBook doesn't work with that either.
    It works for WorldEdit and WorldGuard though.
  25. Offline


    Uhmm CommandBook doesnt work with Build 1240 :p
  26. Offline


    • item[-d] <item[:data]> [amount]
    What exactly is :data? I'm trying to spawn in various silverfish blocks, /i me 97:1,2,3 1 and it keeps giving me the smooth stone silverfish.
  27. Offline


    02:49:06 [SEVERE] Could not load 'plugins\CommandBook.jar' in folder 'plugins':
    java.lang.NoClassDefFoundError: com/sk89q/minecraft/util/commands/CommandExcepti
            at java.lang.Class.forName0(Native Method)
            at java.lang.Class.forName(Unknown Source)
            at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.j
            at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.
            at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:138)
            at org.bukkit.craftbukkit.CraftServer.<init>(CraftServer.java:103)
            at net.minecraft.server.ServerConfigurationManager.<init>(ServerConfigur
            at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:136)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:348)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    Caused by: java.lang.ClassNotFoundException: com.sk89q.minecraft.util.commands.C
            at java.net.URLClassLoader$1.run(Unknown Source)
            at java.security.AccessController.doPrivileged(Native Method)
            at java.net.URLClassLoader.findClass(Unknown Source)
            at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.
            at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.
            at java.lang.ClassLoader.loadClass(Unknown Source)
            at java.lang.ClassLoader.loadClass(Unknown Source)
            ... 11 more
  28. Offline


    I need help badly. I've checked everything I can think of, but I can't fix my problem. CommandBook seems to have just broke all by itself, as everything was going great and then a reload broke it. I've tried redownloading an everything, but I keep getting this error:
  29. My download doesn't work, when i download commandbook and start server it says: ''Could not load 'plugins\CommandBook.jar' in folder plugins'' I got no other plugins... Help?

    It also says 1 line down: Caused by: java.lang.ClassNotFoundExeption: com.sk89.minecraft.util.commands.CommandExeption
  30. Offline


    Tested with CB RB #1185 and last CB RB #1240:
    I have the same error :(
    I've tested with everything, many combinations of CB dev builds and RC builds, even with the CommandBook dev builds but nothing.
    I need this plug-in so much, please, fix it.
    P.S.: I have to say that I've tested customizing CommandBook, leaving just the commands I need more, but no go!
  31. Offline


    19:13:40 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'give' in plugin CommandBook v1.6-customized
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:41)
    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:163)
    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:353)
    at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:756)
    at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:721)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:714)
    at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
    at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:92)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:464)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:374)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    Caused by: java.lang.NullPointerException
    at com.sk89q.commandbook.CommandBookPlugin.onCommand(CommandBookPlugin.java:266)
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:39)
    ... 12 more
Thread Status:
Not open for further replies.

Share This Page