[GEN/TP/ADMN] CommandBook 1.7 - Essential and useful commands (/item, etc.) [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by sk89q, Feb 28, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    General commands as used on my server since '10. Warping, item giving, time changing, weather changing -- the usual.

    Thor command, one of many (video by Rubenbeebl):

    Note: You can remove any of these commands from CommandBook using the download link below.
    • General:
      • item [-d] <item[:data]> [amount]
      • give [-d] <target> <item[:data]> [amount]
      • more [-a] [-i] <target>
      • online [filter]
      • motd
      • intro (play intro music)
      • midi (play a MIDI file for yourself)
      • rules
      • setspawn [destination]
      • time [world] <time>
      • weather <'stormy'|'sunny'> [duration] [world]
      • thunder <'on'|'off'> [duration] [world]
      • spawnmob [-p] [-d] [-i] [-r] <mob> [count] [location]
      • kit <kit> [target]
    • Teleportation:
      • spawn
      • tp [target] <destination>
      • bring <target>
      • put <target>
      • call <target> (request a teleport)
    • Messaging:
      • broadcast <message>
      • say <message>
      • me <message>
      • msg <target> <message...>
      • reply <message...>
      • mute <target>
      • unmute <target>
    • Player:
      • whereami
      • compass
      • clear [-a] [target]
      • slap [-s] [-h|-v] [-d] [target]
      • rocket [-s] [-h] [target]
      • barrage [-s] [target]
      • shock [-s] [target]
      • thor [target] (get Thor's hammer)
      • unthor [target] (revoke Thor's hammer)
      • whois [target]
    • Utilities:
      • ping
      • debug info
      • debug clock (very accurate server lag benchmark)
    • Bans:
      • kick <target> [reason...]
      • ban [-e] <target> [reason...]
      • unban <target> [reason...]
    Complimentary plugins:


    [​IMG] CommandBook 1.7
    Requirements: Java 6+, WorldEdit, Bukkit build 753+

    You need WorldEdit: Install WorldEdit. If you don't want WorldEdit, put WorldEdit.jar in the root folder of your server or in the plugins/CommandBook folder.​

    If you find CommandBook useful, [​IMG]

    How to Use

    Check out my server too!

    [​IMG] (CommandBook is open source!)
    dragon8510, Psychoma, Goodi and 26 others like this.
  2. Offline


  3. Offline


    Midis aren't working for me, getting the following error in console whenever it claims to be playing one ingame:

    Show Spoiler
    2011-05-06 02:41:10 [SEVERE] Exception in thread "JingleNotePlayer for Rogueleader89"
    2011-05-06 02:41:10 [SEVERE] java.lang.NoSuchMethodError: org.bukkit.entity.Player.sendBlockChange(Lorg/bukkit/Location;IB)V
    2011-05-06 02:41:10 [SEVERE] at com.sk89q.jinglenote.JingleNotePlayer.run(JingleNotePlayer.java:36)
    2011-05-06 02:41:10 [SEVERE] at java.lang.Thread.run(Thread.java:636)

    Running craftbukkit 740, commandbook 1.5.1
  4. Offline


    I forgot to mention that you need CraftBukkit 753 or newer.
  5. Offline


    Hmm, I get this when a midi should play:
    10:37:13 [SEVERE] Exception in thread "JingleNotePlayer for TobbenTM"
    10:37:13 [SEVERE] java.lang.NoSuchMethodError: org.bukkit.entity.Player.sendBlockChange(Lo
    10:37:13 [SEVERE]       at com.sk89q.jinglenote.JingleNotePlayer.run(JingleNotePlayer.java
    10:37:13 [SEVERE]       at java.lang.Thread.run(Unknown Source)
    Edit: Oh, ok.. I'll update CB then
  6. Offline



    When I set colored-names to true, and I type /online, players are all in white.
    If I enable group names, they are well seperated, but still, no colors, any idea ?
    Running CommandBook 1.5.1, Permissions 2.7.2 and IChat 2.2.3 (relevant ?), on CB 740.
    Also, when doing a /msg, everything is in white as well, note sur if that's relevant or not

    Edit: Also, /say isn't working here. Just outputs a message as if I had sent it, except with no color on my name.

    Aside from that, all works fine !

    Thanks :)
  7. Offline


    Hi !
    Is the /return command works to return to the death location ?
    Thanks for this awesome plugin
    EDIT : tested : don't work (yet ?)
  8. Offline


    I have a strange issue where using the time command breaks redstone circuits?
    I wish I could provide more information.

    I have an issue in which Redstone, buttons, and pressure plates (who knows what else) break when locking the time.

    I managed to recreate this error in a video, and will be linking it once it finishes uploading.


    Here is the video of which I speak.
  9. Offline


    This sounds great, how can I do this?

    I tried the command below, but it is not persistent through restarts. Am I missing an option or config setting? I didn't see anything new on the wiki about it.
    /time -l nether 22
  10. Offline


    I notice the player list still doesn't seem to support display names (even though display name support is turned on), which is a shame. Essential's /nick feature and the display name support in /list is really the only reason I'm still using Essentials at all.
  11. Offline


    for me it's the same i'd like to use easyrules for multipage rules but i can't. so is there a way for deactivating commandbook.rules, i.e. an option in config.yml: using-rules: true|false
    or alternativly it would be fine to me if i can use commandbook.rules with multipage. if it's builtin, i didn't found an example how to use it correctly?
  12. Offline


    For some reason after upgrading to this new version my server keeps restarting..
    I do have WorldEdit
    07.05 06:04:00 [Disconnect] User danny157 has disconnected, reason: Server shutting down
    07.05 06:04:00 [Disconnect] User holo716 has disconnected, reason: Server shutting down
    07.05 06:04:00 [Multicraft] Minecraft stopped
    07.05 06:03:59 [Multicraft] Minecraft shut down
    07.05 06:03:59 [Server] INFO Stopping server
    07.05 06:03:59 [Server] INFO Saving chunks
    07.05 06:03:59 [Server] INFO [Factions v1.1.7] Disabled
    07.05 06:03:58 [Server] INFO WorldEdit: Permissions plugin detected! Using Permissions plugin for permissions.
    07.05 06:03:58 [Server] INFO [Permissions] (Phoenix) disabled successfully.
    07.05 06:03:58 [Server] INFO [Permissions] (Phoenix) saved all data.
    07.05 06:03:58 [Server] INFO ThunderJoin disabled
    07.05 06:03:58 [Server] INFO SimpleReserve disabled!
    07.05 06:03:58 [Server] INFO TreeAssist Disabled
    07.05 06:03:58 [Server] INFO Stopping server
    07.05 06:03:58 [Server] INFO CONSOLE: Stopping the server..
    07.05 06:03:58 [Server] INFO Stopping the server..
    07.05 06:03:58 [Server] INFO Save complete.
    07.05 06:03:58 [Server] INFO Saving chunks
    07.05 06:03:58 [Server] INFO CONSOLE: Forcing save..
    07.05 06:03:58 [Server] INFO Forcing save..
    07.05 06:03:58 [Multicraft] Stopping Minecraft!
    07.05 06:03:58 [Multicraft] Received stop command
    07.05 06:03:27 [Server] INFO Connection reset
    07.05 06:03:27 [Disconnect] User yosi3 has disconnected, reason: disconnect.quitting
    07.05 06:02:05 [Multicraft] yosi3 ran command Message of the Day
    07.05 06:02:05 [Connect] User yosi3, IP xx.xx.xx.xxx
    07.05 06:01:11 [Server] INFO [CONSOLE] §8The time is: 06:01
    07.05 06:01:11 [Multicraft] holo716 ran command Time
    07.05 06:01:08 [Server] INFO /xx.xx.xx.xxx:xxxxx lost connection
    07.05 06:00:46 [Multicraft] danny157 ran command Message of the Day
    07.05 06:00:46 [Connect] User danny157, IP xx.xx.xx.xx
    07.05 06:00:43 [Server] INFO Connection reset
    07.05 06:00:43 [Disconnect] User yosi3 has disconnected, reason: disconnect.quitting
    07.05 06:00:17 [Multicraft] yosi3 ran command Message of the Day
    07.05 06:00:17 [Connect] User yosi3, IP xx.xx.xx.xx
    07.05 06:00:13 [Multicraft] holo716 ran command Message of the Day
    07.05 06:00:13 [Connect] User holo716, IP xx.xxx.xxx.xx
    07.05 06:00:10 [Server] Startup Done (0.093s)! For help, type "help" or "?"
    07.05 06:00:10 [Server] INFO [Factions v1.1.7] === INIT DONE (Took 65ms) ===
    07.05 06:00:10 [Server] INFO [Factions v1.1.7] Found and will use plugin Permissions v2.7
    07.05 06:00:10 [Server] INFO [Factions v1.1.7] Loading board from disk
    07.05 06:00:10 [Server] INFO [Factions v1.1.7] Loading factions from disk
    07.05 06:00:10 [Server] INFO [Factions v1.1.7] Loading players from disk
    07.05 06:00:10 [Server] INFO [Factions v1.1.7] Loading conf from disk
    07.05 06:00:10 [Server] INFO [Factions v1.1.7] === INIT START ===
    07.05 06:00:10 [Server] INFO WorldEdit: Permissions plugin detected! Using Permissions plugin for permissions.
    07.05 06:00:10 [Server] INFO [Permissions] version [2.7] (Phoenix)  loaded
    07.05 06:00:10 [Server] INFO ThunderJoin v1.2 enabled
    07.05 06:00:10 [Server] INFO SimpleReserve version 0.2.6 enabled!
    07.05 06:00:10 [Server] INFO WorldEdit: Permissions plugin detected! Using Permissions plugin for permissions.
    07.05 06:00:10 [Server] INFO WorldEdit 4.4 enabled.
    07.05 06:00:10 [Server] INFO [PhysicalShop] version 7 enabled
    07.05 06:00:10 [Server] INFO TreeAssist STARTED
    07.05 06:00:10 [Server] INFO [Permissions] (Phoenix) was Initialized.
    07.05 06:00:09 [Server] INFO Preparing start region
    07.05 06:00:09 [Server] INFO Preparing level "world"
    07.05 06:00:09 [Server] INFO This server is running Craftbukkit version git-Bukkit-0.0.0-706-gf53e007-b740jnks (MC: 1.5_02)
    07.05 06:00:09 [Server] INFO Starting Minecraft server on
    07.05 06:00:09 [Server] INFO Loading properties
    07.05 06:00:09 [Server] WARNING To start the server with more ram, launch it as "java -Xmx1024M -Xms1024M -jar minecraft_server.jar"
    07.05 06:00:09 [Server] WARNING **** NOT ENOUGH RAM!
    07.05 06:00:09 [Server] INFO Starting minecraft server version Beta 1.5_02
    07.05 06:00:09 [Server] INFO 16 achievements
    07.05 06:00:09 [Server] INFO [Lnet.minecraft.server.Statistic;@1cf11404
    07.05 06:00:09 [Server] INFO 146 recipes
    07.05 06:00:09 [Server] INFO [Lnet.minecraft.server.Statistic;@1cf11404
    07.05 06:00:08 [Multicraft] Loaded config for "Mod: Craftbukkit"
    07.05 06:00:08 [Multicraft] Starting Minecraft!
    07.05 06:00:08 [Multicraft] Loading Minecraft instance properties
    07.05 06:00:08 [Multicraft] Received start command
  13. Offline


  14. Offline


    So even the (From Blah): part is white with /msg?

    Hmm. It seems stopping time also stops everything. I am not sure if fixing this is possible, but I will look into it (perhaps in 1.5 weeks).

    In your configuration:

        world: 3am
        netherworld: dusk
    I will look into it.

    Use the customized version and uncheck "/rules"

    Is there anything more above that log?
  15. Offline



    Could you please add a changelog in your first post? I find it a hassle to find the post containing changelog information.


    "Added online list display options."

    What are the config options for that? Nothing was added to my CommandBook config file and I don't really want to restart the server while players are on it to see if it generates a new config file.
  16. Offline


    Yeah, always has been for me.
    Any idea on what's causing this?
  17. Offline


    When I try to use the intro at all, it fails (intro.mid is in the bukkit/plugins/CommandBook folder):
    2011-05-07 21:13:37 [INFO] lolligertyp [////////] logged in with entity id ///
    2011-05-07 21:13:39 [SEVERE] Exception in thread "JingleNotePlayer for lolligertyp"
    2011-05-07 21:13:40 [SEVERE] java.lang.NoSuchMethodError: org.bukkit.entity.Player.sendBlockChange(Lorg/bukkit/Location;IB)V
    2011-05-07 21:13:40 [SEVERE]     at com.sk89q.jinglenote.JingleNotePlayer.run(JingleNotePlayer.java:36)
    2011-05-07 21:13:40 [SEVERE]     at java.lang.Thread.run(Unknown Source)
    2011-05-07 21:13:51 [INFO] lolligertyp used command "/intro"
    2011-05-07 21:13:51 [SEVERE] Exception in thread "JingleNotePlayer for lolligertyp"
    2011-05-07 21:13:51 [SEVERE] java.lang.NoSuchMethodError: org.bukkit.entity.Player.sendBlockChange(Lorg/bukkit/Location;IB)V
    2011-05-07 21:13:51 [SEVERE]     at com.sk89q.jinglenote.JingleNotePlayer.run(JingleNotePlayer.java:36)
    2011-05-07 21:13:51 [SEVERE]     at java.lang.Thread.run(Unknown Source)
    Same by /midi intro.mid (File is in /bukkit/plugins/CommandBook/midi/ folder):
    2011-05-07 21:21:04 [INFO] lolligertyp used command "/midi intro.mid"
    2011-05-07 21:21:04 [SEVERE] Exception in thread "JingleNotePlayer for lolligertyp"
    2011-05-07 21:21:04 [SEVERE] java.lang.NoSuchMethodError: org.bukkit.entity.Player.sendBlockChange(Lorg/bukkit/Location;IB)V
    2011-05-07 21:21:04 [SEVERE]     at com.sk89q.jinglenote.JingleNotePlayer.run(JingleNotePlayer.java:36)
    2011-05-07 21:21:04 [SEVERE]     at java.lang.Thread.run(Unknown Source)
  18. Offline


    Are you using CB 753+ ?
    lolligertyp likes this.
  19. Offline


    No, I will try
    EDIT: Thank you ;)
  20. Offline


    Re new intro.mid
    20:32:05 [SEVERE] Exception in thread "JingleNotePlayer for Pezmc"
    20:32:05 [SEVERE] java.lang.NoSuchMethodError: org.bukkit.entity.Player.sendBlockChange(Lorg/bukkit/Location;IB)V
    20:32:05 [SEVERE] at com.sk89q.jinglenote.JingleNotePlayer.run(JingleNotePlayer.java:36)
    20:32:05 [SEVERE] at java.lang.Thread.run(Thread.java:636)

    Edit: I am using CB 753
  21. Offline


    It should come inside the download.

    New configuration:

    I'm not sure. Maybe you have a conflicting plugin?

    Does /version say 753?
  22. Offline


    If what the command does is stop time, that makes sense. I love your plugins and will continue using them, I'll just refrain from using the time lock.

    Thanks a ton for your help.
  23. Offline


    /motd still doesn't work for me
  24. Offline


    small issue with help...

    The mod says it includes the "/help" mod which should make nice neat pages of help but it dumps it all out in one big screen that makes it unusable. I'm running newest version along side the newest versions of HeroChat, Permissions, WorldEdit, and WorldGuard. My user has full access in Permissions. My craft bukkit version is old I think but I cant change it myself so I would like to avoid doing that...
    This server is running Craftbukkit version git-Bukkit-0.0.0-706-gf53e007-b740jnks (MC: 1.5_02)
    This server is also sporting some funky dev build of Bukkit!

    I tired installing the newer version of help but it wasn't able to list any help commands but the commands that help its self uses.

    I wanted to do a thread search but I couldn't find the functionality on this forum. I did try google and a forum wide search to no avail.
  25. Offline


    i get this Error when starting the server
    using a customized Commandbook 1.5.1 on CB #733

    00:27:01 [SEVERE] Could not load 'plugins/CommandBook.jar' in folder 'plugins':
    unacceptable character #FFFD special characters are not allowed
    in "<reader>", position 512
            at org.yaml.snakeyaml.reader.StreamReader.checkPrintable(StreamReader.java:68)
            at org.yaml.snakeyaml.reader.StreamReader.update(StreamReader.java:159)
            at org.yaml.snakeyaml.reader.StreamReader.peek(StreamReader.java:117)
            at org.yaml.snakeyaml.reader.StreamReader.peek(StreamReader.java:106)
            at org.yaml.snakeyaml.scanner.ScannerImpl.scanToNextToken(ScannerImpl.java:964)
            at org.yaml.snakeyaml.scanner.ScannerImpl.fetchMoreTokens(ScannerImpl.java:237)
            at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(ScannerImpl.java:183)
            at org.yaml.snakeyaml.parser.ParserImpl$ParseImplicitDocumentStart.produce(ParserImpl.java:200)
            at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:163)
            at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(ParserImpl.java:148)
            at org.yaml.snakeyaml.composer.Composer.getSingleNode(Composer.java:104)
            at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseConstructor.java:124)
            at org.yaml.snakeyaml.Yaml.load(Yaml.java:264)
            at org.bukkit.util.config.Configuration.load(Configuration.java:73)
            at org.bukkit.plugin.java.JavaPlugin.initialize(JavaPlugin.java:158)
            at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:140)
            at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:160)
            at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:108)
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:85)
            at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:217)
            at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:204)
            at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:144)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:259)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
  26. Offline


    sk89q you are the man :D

    Everything I tested (mid play, spawnmob from console) works OK
  27. Offline


    Any specific file size required or limit for the .midi? Can't find a tutorial on how to install this.
  28. Offline


    Thanks. It would also be nice for a /whois type command that will tell you the user name behind the display name. Essentials has one but it tells you far too much, like IP Address, and I didn't want to give everyone the ability to look at the IP of everyone else.
  29. Offline


    @sk89q , well, using only iChat, Permissions and COmmandbook, it still isn't working for me :/
  30. Offline


    Not sure if you'll read this but the /whereami command is messed up, same with /tp.

    When I do /whereami, it doesn't give me the proper x,y,z coordinates but instead gives me y z and then x and a second line to tell me what my elevation is (the middle number)

    why's this all twisted around??? i realize this is also messed up in the way coordinates are set for the game generally but can we have it fixed so it's at least 1/2 correct? and likewise for /tp x,y,z - they need to be fixed so they're in the correct order.
  31. Offline


    REQ: A "Super ban" (/sban??) command, that bans name AND IP at the same time. (may even use hardcoded bukkit /ban-ip as backend)

    Thank you again :)
Thread Status:
Not open for further replies.

Share This Page