[GEN/SEC/ECON/TP/ADMN] Essentials - A collection of useful commands

Discussion in 'Archived: Plugin Releases' started by EssentialsTeam, Apr 30, 2011.

  1. Offline


    Deleting the home entry in plugin.yml fixed MyHome for me, i guess its just a case of doing the same for the other commands you dont want Essentials handling.

  2. Offline

    tha d0ctor

    IF you open essentials with winrar and edit the plugin.yml file and take out the home command you can get multihome working
  3. Offline


    I have a question. How can I disable the Economy system of Essential?
  4. Offline


    no its not... i like walked really far away and tried
  5. Hey..
    2 issues I have:
    1. /weather sun does not work. (I get the message "weather has been set in your world" or something like it but it doesn't really do anything, it keeps raining..)
    2. Is there any possibility of adding a insta break tool as cheat command to essentials ? Currently Im using WorldEdit 4.4 to have the "//" command that enables the super pickaxe ... but it feels kinda waste to use a fairly big addon just for one command..
  6. Offline


    2011-05-24 22:31:06 [WARNING] [EssentialsProtect] WorldGuard was detected, in the near future the following features of Protect will be disabled in favor of WorldGuard's versions
    2011-05-24 22:31:06 [WARNING] disable water flow
    2011-05-24 22:31:06 [WARNING] disable lava flow
    2011-05-24 22:31:06 [WARNING] disable water bucket flow
    2011-05-24 22:31:06 [WARNING] disable all fire spread
    2011-05-24 22:31:06 [WARNING] disable tnt explosion
    2011-05-24 22:31:06 [WARNING] disable creeper explosion
    2011-05-24 22:31:06 [WARNING] disable all damage types

    When i use tnt, i can see the explosion but all the blocks reappere (bad english) but
    i've enabled tnt explosion in both worldguard and essentials....
    I want tnt explosion working
  7. Offline


    Updated, But I've found a small problem. All my old members are joining the server and getting the "Welcome <playername> to the server" message.
  8. Offline


    I've removed the sethome and home references from the plugin.yml (within essentials.jar), yet now all I receive message "/home help - displays MyHome commands" when I type /home :\
  9. Offline


    What are the Permissions for Lava flow, water flow and tnt...

    When i give a user -essenitals.* it works, but the they can do all. i wanna only the permissions for lava, water and tnt.

    Pleas Help me.. !
  10. Offline


    I'm having an issue with the new version of essentials... Actually with group manager to be more precise..

    After this error:
    011-05-25 04:49:10 [SEVERE] java.lang.Integer cannot be cast to java.lang.String loading Backup v1.4 (Is it up to date?)
    java.lang.ClassCastException: java.lang.Integer cannot be cast to java.lang.String
    at org.anjocaido.groupmanager.dataholder.WorldDataHolder.load(WorldDataHolder.java:579)
    at org.anjocaido.groupmanager.dataholder.worlds.WorldsHolder.loadWorld(WorldsHolder.java:358)
    at org.anjocaido.groupmanager.dataholder.worlds.WorldsHolder.initialWorldLoading(WorldsHolder.java:68)
    at org.anjocaido.groupmanager.dataholder.worlds.WorldsHolder.initialLoad(WorldsHolder.java:63)
    at org.anjocaido.groupmanager.dataholder.worlds.WorldsHolder.<init>(WorldsHolder.java:56)
    at org.anjocaido.groupmanager.GroupManager.onEnable(GroupManager.java:73)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:127)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:676)
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:249)
    at com.nijikokun.bukkit.Permissions.Permissions.onEnable(Permissions.java:64)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:127)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:676)
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:249)
    at com.nijikokun.bukkit.Permissions.Permissions.checkEnable(Permissions.java:99)
    at com.nijikokun.bukkit.Permissions.Permissions.getHandler(Permissions.java:89)
    at backup.Main.setupPermissions(Main.java:102)
    at backup.Main.onEnable(Main.java:52)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:127)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:676)
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:249)
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:131)
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:109)
    at org.bukkit.craftbukkit.CraftServer.reload(CraftServer.java:336)
    at org.bukkit.command.SimpleCommandMap$ReloadCommand.execute(SimpleCommandMap.java:201)
    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:85)
    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:278)
    at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:682)
    at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:645)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:639)
    at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:32)
    at net.minecraft.server.NetworkManager.a(NetworkManager.java:196)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:372)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:287)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
    All users appear as a group called "default" instead of their actual groups. Any ideas?
  11. Offline


    I think u have a error in the "groups.yml" file because i had this error too.. I fixed the "groups.yml" nd it works..
  12. Offline


    VGlink: eco signs are disabled at config, commands at plugin.yml. essentialseco hooks into iconomy, though

    asiandoof: read my above post

    [email protected]: 1. known issue, report at assembla 2. suggest feature on assembla, i suggest using superpuckaxe plugin by codename_b until essentials add it

    heroanth2345: worldguard issue

    mrelim: paste server.log and config.yml

    jesterb: myhome plugin issue

    edoscyl: edit the essentials config, item usage blacklist

    methosH: update bukkit to 803, essentials to 2.2.21, paste server.log
  13. Offline


    But can you not give only permissions for a group ? Or is there a other plugin who can do this.
  14. Offline


    edocsyl: use the essentials wiki, command refence.
  15. Offline


    I looked but nothing... is this so difficult ..
  16. Offline


    Seriously the best plugin ever. Would you add the ability so that if it is a person's first time on the server (and I'm pretty sure you have the coding to handle this), they do a command? (like get a kit.)
  17. Offline


    Is there a way to do a wildcard kick? I want to use /kick * when running a restart script.

    It warns 15 seconds before restart, then 5 seconds. And then right before it restarts, I want to do a /kick * Server is restarting now!
  18. Offline


    For some reason, after updating to 2.2.21 on a server with RB 803, I, an op that has permission to *, still require a cooldown to teleport.

    Even giving myself permission to essentials.teleport.cooldown.bypass, I still have a cooldown.

  19. Offline


    leslieliang: paste server.log
  20. Offline


    this plugin is amazing, easily the best mod on my server

    however, in the most recent version, what happened to the EssentialsEconomy part? i found it extremely useful due to it's simplicity, but on the download guide it acts like it was never there.

    when will it be coming back?
  21. Offline


    Is there any way to set up the initial/first-time spawn for a new player? I want a player to spawn in a specific location upon first entering the world, instead of in a random location. Can this be implemented into Essentials' functionality?
  22. Offline


    Hi there.

    The server I Admin for uses this, and I really like it. I only have a single problem.

    I'm trying to set up a [Trade] sign that Trades 9 Colored Wool for a set amount of money. Unfortunately, I can't put in the Item ID # for Colored Wool on the [Trade] sign. I can add in the name, but there is only enough room for "blackwool" or "redwool". When I try to set up a sign for "magentawool" or even "purplewool", I run out of room on the sign.

    Is there a way to format the Item ID # to specify Colored Wools and Wool Dye?

    Thanks for producing such a useful Mod.
  23. Offline


    /give doesnt work it says error: listener already listening (in build 814 its for 1.6)
  24. Offline


    obsidianeagle: it was never gone. use wiki

    nuinbot: /setspawn newbie

    helljack: you can use item ID, 35:14 or something. il see if i can provide any proper aliases on items.csv, if you have any sugestions for items.csv item list suggest them

    janttux: added to bug list
  25. Offline


    Hey just a quick note of thanks to the Essentials people this is a great plugin that everyone on my server is loving. Keep up the good work! Just a tip for people who use chest protection, if they use a single chest and protect it with the sign on bedrock and someone else puts another chest next to it and protects that one then they can access the double chest that results. At least thats what I have been told by pple. I have access to all chests as admin so hard for me to test.
  26. Offline


    Wow, Great to see you guys updating this for 1.6 :). This is my main plugin on the server, because...y'know... it has all the essentials! (har har har). I am actually using 2.2 on my 1.6 server right now, and most of it works! Amazing!(just [Trade] signs and [Buy] signs arent working) So i am patiently waiting for 2.3 :).

    Keep up the good work guys!
  27. Offline


    crete21: theres developer versions for 2.3, which will fix a few errors
    anklesneeze: placing second sign should be prevented in the first place. il need more details about bukkit version and essentials version
  28. Offline


    Can't use the download link is tiny.cc down (PS I tried last week also)
  29. Offline


    I own my own server, am running essentials 2.2 and bukkit Build 812 (yeah i know its not recommended and that essentials 2.3 is for minecraft 1.6), on minecraft 1.6 and when i try to spawn anything, it says "Error: Listener already listening" and gives me what i wanted in the quantity i ordered.
    my log says nothing about the error.
  30. Offline


    This is important but how can i make it so when people log out their god mode disables so when they log in again its not enabled?

Share This Page