[GEN] Massband v2.8 - A Measuring Tape [CB 1.4.2-R0.2]

Discussion in 'Inactive/Unsupported Plugins' started by MrX13415, May 19, 2011.

  1. Offline



    Please visit BukkitDev:

    This Thread is deprecated ...
    You can download the newest Version here too
    but for more infos, error reports and help please go to BukkitDev

    Massband - A Measuring Tape:
    Version: v2.7 (r59)

    This Plugin allows you to measure things in Minecraft.

    • Measure in 2D or 3D mode
    • Measure long routes with corners
    • Measures the distance between corners direct ...
    • Measure Surfaces
    • Measure dimensions
    • Measure Blocks count in a cuboid (exept air)
    • The Server dosn't hang completely while counting some Blocks
    • Permissions
    • Configurable command short-forms
    [​IMG] Download
    older Versions: 2.6.6 ; 2.6.5 ; 2.6.4 ; 2.6.3 ; 2.6.2 ; 2.6.1 ; 2.6 ; 2.5.1 ; 2.5 ; 2.4 ; 2.3 ; 2.0

    Download Source (github)

    Massband in Action (open)

    Massband in action:


    Counting Blocks with Version 2.6.4:


    Just right-click with a wood sword (default Item, see 'Config file') at a Block.

    There are three mods: (see below)
    • Simple mode (default)
    • Lenght mode
    • Surface mode
    In default, the Measuring Tape ignores the hieght.

    To measure the hieght of something just use the command '/mb 3D'
    (see 'Command list').

    With '/mb l' you get the lenght of the last measure. (even after '/mb clr')

    Simple mode:

    Just right-click with a wood sword (default Item, see 'Config file') at a Block.
    After the second right click at an other Block the Measuring Tape starts to measure the route
    between the two points (direct way) and rests all Points, so you can start a new measure between to new Points.

    Length tool:

    To measure a long way, with corners, select the lenght tool mit '/mb lm' nd right-click with a wood sword (default Item, see 'Config file') like in Simple mode
    When you right-click a 3rd time at a Block, the Measuring Tape adds the route between the second and the 3rd point, to the current route, and so on ...

    To start a new measure, enter the command '/mb clr'

    Surface tool:

    To measure a Surface, select the surface tool with '/mb sm' and right-click with
    a wood sword (default Item, see 'Config file') two times on to diferent Blocks.
    You will get the dimensions of the Area (or in 3D mode, of the cuboid).
    Now you can count the Block in the Area (or cuboid) wit '/mb cb'.
    It will returns the count of all Blocks exept Air.
    (see 'Massband in Action')

    Command list (open)

    Command list:
    • /massband, /mb - Displays a short help message
    • /massband, /mb clr - clear Clears all measuring points
    • /massband 2D, /mb 2D - Changes the mode to 2D
    • /massband 3D, /mb 3D - Changes the mode to 3D
    • /massband simplemode, /mb sim - Select the simple measuring tool
    • /massband lengthmode, /mb lm - Select the length measuring tool
    • /massband surfacemode, /mb sfm - Select the surface measuring tool
    • /massband stop, /mb stp - Interrupt Block-counting ...
    • /massbans stopall, /mb all - Interrupts all running Block-countings
    • /massband length, /mb l - Returns the last measured length
    - Surface-mode ---------------------------------------

    • /massband dimensions, /mb d - Returns the dimensions of the cuboid
    • /massband countBlocks, /mb cb - Returns the count of Blocks in a cuboid, exept air.
    • /massband expand, /mb ex <<amount> <up|down>|vert> - expands the selection in the given direction. (vert = from bottom to the top)
    • /massband blockList [page], /mb bl [page] - Returns a list of all Blocks in th cuboid
    Note: The command-short-forms are configurable in the config-file ...

    The command '/massband stopall' works also at the console.

    Config-file (open)

    Config file:
    ItemID: 268
    ItemName: wood-sword
    UsePermissions: false
    #This can infect the Server performance ...
    BlockCountingSpeedLimit: true
    #Command short-forms ...
    ClearCommand_ShortForm: clr
    LenghtCommand_ShortForm: l
    DimensionsCommand_ShortForm: d
    CountblocksCommand_ShortForm: cb
    LengthmodeCommand_ShortForm: lm
    SurfacemodeCommand_ShortForm: sfm
    SimplemodeCommand_ShortForm: sim
    ExpandCommand_ShortForm: ex
    StopCommand_ShortForm: stp
    StopallCommand_ShortForm: all
    BlockListCommand_ShortForm: bl
    Defines the Item which is used for Right-clicking. Default: wood sword

    Defines the Name of the Item. (used for the Help Msg)

    Defines whether to use Permissions, if detected.

    Set a speed limit for the Block-counting
    If false the Server counts with the full speed (about 500000 Blocks per second) and
    the Server performance is maybe a litle slow
    If true there is a speed-limit and the server counts slower (about 1000 Blocks per second) so it
    would not infect the server permormance.

    Set the short-form for the command 'xxxx'

    Permissions (open)

    Permission Nodes:
    #You can use Massband
    #Your are able to stop alle runnging Block-countings
    Note: everyone can use the Plugin if no Permission-Plugin is installed. (exept stoping all threads, need op in this case)

    • add Permission for '/mb bl' command
    • (Just keep it up to date)

    Version: 2.6.7
    • ADD: '/massband blockList' command
    Version: 2.6.6
    • ADD: Command short-forms are configable now (Thanks to bukkit-user: baunegaard)
    • FIX: '/massband stopall' command doesn't work correctly
    Version: 2.6.5

    • ADD: Simple mode (see 'commandlist')
    • simple-mode is now default (lenght mode: /mb lm | surface mode: /mb sm)
    Version: 2.6.4

    • FIX: Block-counting runns in a new Thread now.
    • ADD: /massband stop command
    • ADD: /massband stopall command
    • ADD: /massband expand command
    • 'BlockCountingSpeedLimit' setting in config added
    Version: 2.6.3

    • FIX: command bugs.
    • 'UsePermission' setting in config added. (see 'config file')
    Version: 2.6.2

    • FIX: event bug
    • FIX: Permission bug (Plugin crashs after enter a command from someone that has no Permissions)
    Version: 2.6.1

    • FIX: typo.
    Version: 2.6

    • Add Permission Support (see 'Permissions')
    Changelog (open)

    Version: 2.5.1
    • FIX: The short version of some commands doesn't work
    Version: 2.5

    • Add a Surface measuring tool (Thanks to Nitnelave)
    Version: 2.4

    • Add ItemName to the configfile
    • help message improved (see 'command-list')
    • NullPointerExeption fixed
    • FIX: Massband doesn't work anymore after reload all Plugins
    Version: 2.3

    • Add config file
    • Change some more Strings xD
    Version: 2.2

    • Change some Strings. ("vector" to "Point")
    Version: 2.1

    • First public release (bukkit)
    Non-public releases Change-log (open)

    Changelog for non-public releases (version 2.0 and below)
    Version: 2.0 beta r26:
    • FIX: commands changed to only one command.
    Version: 1.9 beta r25:

    • FIX: commands changed again (commands arn't very well yet ;) )
    Version: 1.8 beta r23:

    • FIX: Method signature changed
    Version: 1.7 beta r22:

    • FIX: Minecraft 1.4_1 compatible
    • FIX: Commands changed
    Version: 1.6 beta r19:

    • FIX: typo: '2D' <-> '3D'
    • ADD: allways show the current mode
    • FIX: doesn't switch back to 2D mode, after clear, anymore (/vclear) [/vclear -> /mb clr]
    Version: 1.5 beta r17:

    • ADD: Colored text
    Version: 1.4 beta r16:

    • ADD: /switchMode (/vsw) command added
    • FIX: Ignore Height (see /vsw) [/vsw -> /mb 2D/3D]
    Version: 1.3 beta r15:

    • ADD: Measure a way with more the two Points
    • FIX: More than one user can use it at the same time
    Version: 0.2 alpha r2 - 1.2 beta r14:

    • ADD/FIX: commands
    • ADD/FIX: Measuring
    Version: 0.1 alpha r1:

    • init Version.


    Thanks to everyone who is useing my Plugin !

    Special thanks to:
    Taranis01 and The PC Tech Guy like this.
  2. Offline


    please update to latest recommended CB
  3. Offline


    i test it with 766 and it works fine :D
  4. Offline


    In the Screenshot you misspelled Length. :)
  5. Offline


    I can't see the screenshot. Is there a config for the item? I would use string, because it seems logical.
  6. Offline


    thx I will change this :D

    no config yet - coming soon - just added
    in the config-file you can change the item that is used.
  7. Offline


    Nice plugin :) Using it on my server :D

    MrX13415 likes this.
  8. Offline


    Couldn't use string, unless you also changed the WorldGuard region checker wand to something else.
  9. Offline


    so an Update is released :)
    I add the config file, witch allows you to change the Item ...
  10. Offline


    On CB 803, I get this error:
    error (open)
    [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'massband' in plugin Massband v2.3 beta r30 (Minecraft 1.5_01)
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:37)
    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:127)
    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:279)
    at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:699)
    at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:666)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:660)
    at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:32)
    at net.minecraft.server.NetworkManager.a(NetworkManager.java:196)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:377)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:292)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
    Caused by: java.lang.NullPointerException
    at de.MrX13415.Massband.MassbandCommandExecuter.onCommand(MassbandCommandExecuter.java:42)
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    ... 12 more
    on every command...
  11. Offline


    I dont get any errors on 803. mhm .... ?

  12. Offline


    Nevermind, I tried, and it works... Maybe it was only the Admin?
    Could you maybe add a surface measurement? As another mode. Set first point, then second point, and it gives you the area (dimensions and blocks total). And if you click again, it re-sets the first point. And maybe an option to only count the actual blocks in the cuboid (in 3D) and not just multiplying the dimensions...
    MrX13415 likes this.
  13. Offline


    So I fix a NullpointerExeption.
    It could happen that a variable has no content.
    That cause the NullPointerExeptuion after enter a Command.
    But that should never happen, because any player cannot enter a command if thay aren't at the server exept at the console xD

    Try to add this :D
    Added with version 2.5

    I think Permission will come with the next Update (2.6 [Minecraft 1.6])
  14. Offline


    I tested 'Massband version 2.5' with the first Development Snapshot (build 812) for Minecraft 1.6.4
    and it works fine :D
  15. Offline


    Do you have to be OP in order to use it currently?
  16. Offline


    why is this plugin under economy?
  17. Offline


    No, If the Plugin is installed everyone can use it.

    Arrrg ...
    Sorry, I don't noticed that I put it in the wrong category...

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 15, 2016
  18. Offline


    Purty cool dude, Thanks for the work, its really making things interesting!
  19. Offline


    thx :D
  20. Offline


    Massband v2.6:
    Now Massband supports permissions too :)

    There is just one permission:
    You must have the permission above to use Massband.
    If no Permission plugin is Installed everyone can use it.

    have fun with my Plugin :D
  21. Offline


    Great plugin - simple and highly useful.

    20:34:22 [INFO] [Massband] Permission system dedected: Permissions v3.1
  22. Offline



    fix this ... :D

    If you miss a feature in my Plugin than post it here ... :)
  23. Offline

    The PC Tech Guy

    I'm not sure but I get that an event is replaced by another event. I'm using CB 823, so that could be why... but using 2.5.1 helped fix this...
  24. Offline


    I know that there is that bug, but I don't fixed it yet

    now Try to fix it :)

    FIXED ! with Version 2.6.2
    (bug exists after Version 2.6.1)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 15, 2016
  25. Offline

    The PC Tech Guy

  26. Offline


    New Version is out: Version 2.6.3 !

    Just fixed some bugs, and added a setting that alowes you to deactivate permissions support.
  27. Offline


    Is the download link a static one that is compatible with CraftBukkitUpToDate?

    If it isnt, please change it to a static link and lemme know - I'll contact the dev of UpToDate to add your plugin.
  28. Offline


    No, its not static but I can make a static link for any last release :)

    EDIT: Now the download link is static ...
  29. Offline


    k. adding to CButD list.
  30. Does the server calculate this, or does the client? If the server does, what if someone makes a huge freakin cuboid, or bettter yet, if a gang of grifers does.. the server will have to calculate it, and then what happens? :) Anyway. it looks like a very usefull plugin

Share This Page