[GEN] General 3.6.2 (Webern) -- A plugin for general commands, now on BukkitDev! [1060]

Discussion in 'Inactive/Unsupported Plugins' started by Celtic Minstrel, Mar 6, 2011.

  1. Offline

    Celtic Minstrel

    General 3.6.2 [Webern]
    NOTE: If you are updating from 3.4.1 or earlier, you must copy the aliases section from the sample config file into your own config file. If you don't do this, many commands will not work.
    Download from the BukkitDev page (Older versions | Source)

    General provides a small set of basic commands for your server. See more details on the BukkitDev page.

    General is a fork of Nijikokun's plugin. It adds a few commands to the original set provided by General.

    Without Nijikokun's original General plugin, this plugin would never have been possible. Or at least, I would not have made it. General Essentials (the source of the /kit command) was created by wjykk and has had some input from cjc343. The SpawnMob plugin, from which I adapted the code for the /mobspawn command, was created by xmlns and is now maintained by jordanneil23.

    I recommend using sk89q's CommandHelper in conjunction with this plugin. Starting from 3.4.5, there is a command-helper.txt file included with the download which you can copy to CommandHelper's config.txt for some handy aliases, such as /spawn and /home.

    Differences from cjc343's now-inactive fork
    • Does not detect that another plugin has registered the same command.
    • /playerlist and /who are two separate commands
    • Different items.db format
    • Does not support setting or viewing the raw time.
  2. Offline

    Celtic Minstrel

    Well, there are no kit definition errors, so I have to conclude that there are no kits defined. Do you have a general.kits file in your plugins/General folder?
  3. Offline

    Jan Tojnar

    This is exact content of my general.kits file. It worked before update to 3.3. What was the chamge you made with kits? Can it be the problem?
    # Name:id[-amount][+data],id[-amount][+data],id[-amount][+data]:cooldown
    #       obsidian  tools                                  armor                                  torch apples hodiny  sipy
    I don't know if this is caused by some edit in items/Kits.java, but from this code i think it can be caused by permissions, which i updated recently.
    I will do some tests now.
  4. Offline

    Celtic Minstrel

    It could be Permissions; I know it broke with 561+, but I'm not sure how much.

    It's also possible that I unintentionally broke kits in 3.3. If that's the case, it'll be fixed in 3.3.1.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 11, 2016
  5. Offline

    Jan Tojnar

    I tested it and it is most probably not caused by permissions. I tried /kit armor and it output 'Kit by the name of armor does not exist' (command/kitCommand.java:43). Could it be caused by comments or empty lines? EDIT: there were no empy lines and when i deleted all comments it still didn't work I think the problem is somewhere in function loadKits.

    Could someone test my general.kits file? (I had to rename it because upload form doesn't like .kits extension.)

    Attached Files:

  6. Offline

    Celtic Minstrel

    I have a theory on why it doesn't work, but if I'm right I would expect you to get some kind of ClassNotFoundException, so I dunno.

    In brief: it's entirely possible that one of the things I did broke kits entirely.
  7. Offline

    Jan Tojnar

    I didn't get any error or something.
    Are the kits working for you? Did you try my kits file?
  8. Offline

    Celtic Minstrel

    Kits are working for me, but that's probably because I'm using a version that fixes it. When I release General 3.3.1, it will likely remain compatible with earlier versions of CraftBukkit apart from the /mobspawn command (which I'm guessing is broken anyway in 3.3), so just wait until I release that. :)

    For the impatient, 3.3.1 is on github. It fixes some bugs and updates for CraftBukkit 600. I'll post the formal announcement and update the thread later.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 11, 2016
  9. Offline


    - 'general.kit.*' works however - 'general.kit.diamondtools' does not.
    in the config it says to put general.kit.<kitname>? i clearly did.
  10. Offline


    Add 'general.kit' permission as well.
  11. Offline


    Latest recommended build #602

    2011-03-31 07:04:09 [SEVERE] Could not load plugins/General.jar in plugins: null
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:102)
        at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:158)
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:106)
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:62)
        at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:204)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:191)
        at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:131)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:246)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    Caused by: java.lang.VerifyError: class net.craftstars.general.General$1 overrides final method onPlayerJoin.(Lorg/bukkit/event/player/PlayerEvent;)V
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClassCond(ClassLoader.java:632)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:616)
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
        at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:36)
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:24)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Class.java:247)
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:94)
        ... 8 more
    Just FYI. Stuck on 556 until fixed.
  12. Offline

    Celtic Minstrel

    @piousminion - Upgrade to 3.3.1. You can find it on github (click the source link and go to Downloads).
  13. Offline


    I just got this message from the new version of CB:

    23:52:50 [SEVERE] Nag author: 'Celtic Minstrel' of 'General' about the following: onPlayerJoin has been replaced with a new signature, (PlayerJoinEvent)
  14. Offline

    Celtic Minstrel

    See the post above yours.
  15. The Plugin doesn´t work now
  16. Offline

    Celtic Minstrel

    Yay! That post will be an immense aid in helping me fix whatever your problem is, don't you think? :rolleyes:

    Just to check, did you read a few posts above yours? Because that might fix whatever problem you're having.
  17. 20:00:17 [WARNUNG] [General-3.3] The names section of items.yml is missing or i
    20:00:17 [WARNUNG] [General-3.3] No aliases were defined in items.yml.
    20:00:17 [SCHWERWIEGEND] null loading General v3.3 (Is it up to date?)
    at net.craftstars.general.items.Items.loadHooks(Items.java:137)
    at net.craftstars.general.items.Items.setup(Items.java:132)
    at net.craftstars.general.General.onEnable(General.java:116)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:118)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoade
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManag
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:94)
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:72)
    at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:215)
    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:202)
    at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:142)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:257)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:375)

    This is my error

    EDIT: I Use the General 3.3.1 Plugin
  18. Offline


    Same bug as Fritz3 (bukkit #621 and General 3.3.1):
    2011-04-01 19:43:02 [WARNING] [General-3.3] The names section of items.yml is missing or invalid.
    2011-04-01 19:43:02 [WARNING] [General-3.3] No aliases were defined in items.yml.
    2011-04-01 19:43:02 [SEVERE] null loading General v3.3 (Is it up to date?)
        at net.craftstars.general.items.Items.loadHooks(Items.java:137)
        at net.craftstars.general.items.Items.setup(Items.java:132)
        at net.craftstars.general.General.onEnable(General.java:116)
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:127)
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:514)
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:216)
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:115)
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:93)
        at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:215)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:202)
        at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:142)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:257)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:375)
  19. Offline

    Celtic Minstrel

    Do you have an items.yml in your General folder? If not, copy the one from the zip that you downloaded. If it's already there, make sure that the following line exists in the file:
  20. Offline


    items.yml was empty so I replaced it with the latest, restarted server and it went empty again! Any idea why that's happening?

    It seems to just have the following left in it:
    Edit: Never mind - I've sorted it now.
  21. Offline

    Celtic Minstrel

    Would you mind explaining how? :) It could be useful if anyone else has the same problem, and it might let me fix something.

    The items.yml file is written out whenever the server shuts down, to support in-game editing of it, so the trouble must have been somehow related to that.
  22. Offline


    @Celtic Minstrel
    Well it happened again and was resolved by shutting the server down and replacing the file again.

    It seems like when I update bukkit.jar and restart the server it then writes a file with just {} in it - though I can't be sure if this is the exact cause.
  23. Offline

    Jan Tojnar

    Could you add /mobspawn wolf. I can't find any on my server. Only one player found wolf but he doesn't know where.
  24. Offline

    Celtic Minstrel

    It's in the next release.

    Is it still happening? Does it overwrite on startup rather than shutdown? Do you get any error messages?

    Alright, finally I got around to making the announcement. This was actually available four days ago.

    Version 3.3.1
    • Updated for CraftBukkit 592-600
    • Multiworld support in /tele (you can specify a world name and you'll be teleported to that world's spawn)
    • Bugfix to the /give command (/give <item> <player> did not work correctly)
    • Bugfix to the /time command (didn't work from the console for some reason)

    Before you ask, yes, it works just fine in CraftBukkit 617+. There may be a few glitches (haven't tested everything), and it doesn't support wolves, but most stuff works.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 11, 2016
  25. Offline


    I apologize if this has already been addressed. I searched through the forum and could find anything related. Anyway, I just updated my server with the newest BUKKIT release. In doing so, I decided to download Permissions and General. The server is up, but General doesn't seem to be working... When I type /help, I only get the server help. So, I tried /general help and got a message indication that the help topic wasn't available. Any ideas?
  26. Offline


    Thank you for getting this updated, i was using general chernobyl?? and it wasn't operating as expected. Must be a different fork unlike yours? i prefer your version much more if so.
  27. Offline

    Celtic Minstrel

    You need to create your help file(s).

    General Chernobyl is only being maintained as long as there is no way to easily disable commands so that some other plugin can grab them. This one is much more updated, but there are some incompatibilities (eg different items.db format).
  28. Offline


    Does not work with build 634. It is not a recommended build but most of the bugs are gone

    The commands work in console but not ingame


    18:26:06 [SEVERE] [General-3.3] There was a big problem executing command [give]! Please report this error!
    18:26:06 [SEVERE] [General-3.3] Full command string: [i 1 1]
    18:26:06 [SEVERE] java.lang.NullPointerException
    18:26:06 [SEVERE]       at net.craftstars.general.util.Toolbox.lacksPermission(Toolbox.java:131)
    18:26:06 [SEVERE]       at net.craftstars.general.command.giveCommand.fromPlayer(giveCommand.java:26)
    18:26:06 [SEVERE]       at net.craftstars.general.CommandBase.runCommand(CommandBase.java:13)
    18:26:06 [SEVERE]       at net.craftstars.general.General.onCommand(General.java:239)
    18:26:06 [SEVERE]       at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    18:26:06 [SEVERE]       at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:80)
    18:26:06 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:233)
    18:26:06 [SEVERE]       at net.minecraft.server.NetServerHandler.c(NetServerHandler.java:594)
    18:26:06 [SEVERE]       at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:557)
    18:26:06 [SEVERE]       at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:551)
    18:26:06 [SEVERE]       at net.minecraft.server.Packet3Chat.a(SourceFile:24)
    18:26:06 [SEVERE]       at net.minecraft.server.NetworkManager.a(NetworkManager.java:198)
    18:26:06 [SEVERE]       at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:72)
    18:26:06 [SEVERE]       at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    18:26:06 [SEVERE]       at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:368)
    18:26:06 [SEVERE]       at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:283)
    18:26:06 [SEVERE]       at net.minecraft.server.ThreadServerApplication.run(SourceFile:375)
    It also doesn't show the motd
  29. Offline


    Hi there I get this error when running the latest version of your General, with CB Build 617 and running the mobspawn command (However /mobspawn Giants works fine.. just doesnt give me a Giant lol)


    [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'mobspawn' in plugin General v3.3
        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:37)
        at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:80)
        at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:233)
        at net.minecraft.server.NetServerHandler.c(NetServerHandler.java:594)
        at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:557)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:551)
        at net.minecraft.server.Packet3Chat.a(SourceFile:24)
        at net.minecraft.server.NetworkManager.a(NetworkManager.java:198)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:72)
        at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:368)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:283)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:375)
    Caused by: java.lang.NoSuchMethodError: org.bukkit.World.spawnCreature(Lorg/bukkit/Location;Lorg/bukkit/entity/CreatureType;)Lorg/bukkit/entity/Creature;
        at net.craftstars.general.mobs.xmlns.jordanneil23.MobType.spawn(MobType.java:287)
        at net.craftstars.general.command.mobspawnCommand.fromPlayer(mobspawnCommand.java:92)
        at net.craftstars.general.CommandBase.runCommand(CommandBase.java:13)
        at net.craftstars.general.General.onCommand(General.java:239)
        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
        ... 12 more
  30. Offline


    You left debuggin code in 3.3.1
    10:23:52 [INFO] [General-3.3] [DEBUG] [278]
    10:23:53 [INFO] [General-3.3] [DEBUG] [271]
    10:23:55 [INFO] [General-3.3] [DEBUG] [tek]
  31. Offline


    Ok, so far the only command that works for me (OP) is /who.

    Here's some of the errors:

    2011-04-04 12:02:27 [SEVERE] [General-3.3] There was a big problem executing command [playerlist]! Please report this error!
    2011-04-04 12:02:27 [SEVERE] [General-3.3] Full command string: [online]
    2011-04-04 12:02:27 [SEVERE] java.lang.NullPointerException
    2011-04-04 12:02:27 [SEVERE]     at net.craftstars.general.util.Toolbox.lacksPermission(Toolbox.java:131)
    2011-04-04 12:02:27 [SEVERE]     at net.craftstars.general.command.playerlistCommand.fromPlayer(playerlistCommand.java:21)
    2011-04-04 12:02:27 [SEVERE]     at net.craftstars.general.CommandBase.runCommand(CommandBase.java:13)
    2011-04-04 12:02:27 [SEVERE]     at net.craftstars.general.General.onCommand(General.java:238)
    2011-04-04 12:02:27 [SEVERE]     at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    2011-04-04 12:02:27 [SEVERE]     at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:80)
    2011-04-04 12:02:27 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:233)
    2011-04-04 12:02:27 [SEVERE]     at net.minecraft.server.NetServerHandler.c(NetServerHandler.java:594)
    2011-04-04 12:02:27 [SEVERE]     at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:557)
    2011-04-04 12:02:27 [SEVERE]     at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:551)
    2011-04-04 12:02:27 [SEVERE]     at net.minecraft.server.Packet3Chat.a(SourceFile:24)
    2011-04-04 12:02:27 [SEVERE]     at net.minecraft.server.NetworkManager.a(NetworkManager.java:198)
    2011-04-04 12:02:27 [SEVERE]     at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:72)
    2011-04-04 12:02:27 [SEVERE]     at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    2011-04-04 12:02:27 [SEVERE]     at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:368)
    2011-04-04 12:02:27 [SEVERE]     at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:283)
    2011-04-04 12:02:27 [SEVERE]     at net.minecraft.server.ThreadServerApplication.run(SourceFile:375)
    2011-04-04 12:02:30 [SEVERE] [General-3.3] There was a big problem executing command [time]! Please report this error!
    2011-04-04 12:02:30 [SEVERE] [General-3.3] Full command string: [time day]
    2011-04-04 12:02:30 [SEVERE] java.lang.NullPointerException
    2011-04-04 12:02:30 [SEVERE]     at net.craftstars.general.util.Toolbox.lacksPermission(Toolbox.java:131)
    2011-04-04 12:02:30 [SEVERE]     at net.craftstars.general.command.timeCommand.setTime(timeCommand.java:64)
    2011-04-04 12:02:30 [SEVERE]     at net.craftstars.general.command.timeCommand.fromPlayer(timeCommand.java:42)
    2011-04-04 12:02:30 [SEVERE]     at net.craftstars.general.CommandBase.runCommand(CommandBase.java:13)
    2011-04-04 12:02:30 [SEVERE]     at net.craftstars.general.General.onCommand(General.java:238)
    2011-04-04 12:02:30 [SEVERE]     at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    2011-04-04 12:02:30 [SEVERE]     at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:80)
    2011-04-04 12:02:30 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:233)
    2011-04-04 12:02:30 [SEVERE]     at net.minecraft.server.NetServerHandler.c(NetServerHandler.java:594)
    2011-04-04 12:02:30 [SEVERE]     at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:557)
    2011-04-04 12:02:30 [SEVERE]     at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:551)
    2011-04-04 12:02:30 [SEVERE]     at net.minecraft.server.Packet3Chat.a(SourceFile:24)
    2011-04-04 12:02:30 [SEVERE]     at net.minecraft.server.NetworkManager.a(NetworkManager.java:198)
    2011-04-04 12:02:30 [SEVERE]     at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:72)
    2011-04-04 12:02:30 [SEVERE]     at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    2011-04-04 12:02:30 [SEVERE]     at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:368)
    2011-04-04 12:02:30 [SEVERE]     at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:283)
    2011-04-04 12:02:30 [SEVERE]     at net.minecraft.server.ThreadServerApplication.run(SourceFile:375)
    Not sure why I'm getting these errors

Share This Page