[GEN] General 3.6.2 (Webern) -- A plugin for general commands, now on BukkitDev! [1060]

Discussion in 'Inactive/Unsupported Plugins' started by Celtic Minstrel, Mar 6, 2011.

  1. Offline

    Celtic Minstrel

    General 3.6.2 [Webern]
    NOTE: If you are updating from 3.4.1 or earlier, you must copy the aliases section from the sample config file into your own config file. If you don't do this, many commands will not work.
    Download from the BukkitDev page (Older versions | Source)

    General provides a small set of basic commands for your server. See more details on the BukkitDev page.

    General is a fork of Nijikokun's plugin. It adds a few commands to the original set provided by General.

    Without Nijikokun's original General plugin, this plugin would never have been possible. Or at least, I would not have made it. General Essentials (the source of the /kit command) was created by wjykk and has had some input from cjc343. The SpawnMob plugin, from which I adapted the code for the /mobspawn command, was created by xmlns and is now maintained by jordanneil23.

    I recommend using sk89q's CommandHelper in conjunction with this plugin. Starting from 3.4.5, there is a command-helper.txt file included with the download which you can copy to CommandHelper's config.txt for some handy aliases, such as /spawn and /home.

    Differences from cjc343's now-inactive fork
    • Does not detect that another plugin has registered the same command.
    • /playerlist and /who are two separate commands
    • Different items.db format
    • Does not support setting or viewing the raw time.
  2. Offline

    Celtic Minstrel

    Ah, I think that was in the motd function. It should be gone in 3.2.2, but I don't quite remember.

    If items.db is not found, General falls back on the built-in names if I recall correctly, so that explains why some names work. I'm not sure why you're not getting a message saying that it's not found, but you've put it in the wrong place; it goes in the server directory, the same folder that contains the plugins folder and the craftbukkit.jar.
  3. Offline


    Ah, beautiful! Thank you for that. Now that I review the logs, there is a warning in amongst all the rest of the startup stuff that says it could not find it. *facepalm* It is interesting how it still gave "Invalid Item" messages to things like "diamond_block", when that seems to be one of the built-in names. Anyhow, thanks for the fast reply! Great plugin! :)
  4. Offline


    I added [] around each amount qualifier for each line, so my file now looks like this:

    # give acces with general.kit.<name>
    tools:256 [-1],257 [-1],258 [-1]:300
    shovel:256 [-1]:300
    pickaxe:257 [-1]:300
    axe:258 [-1]:300
    admintools:277 [-1],278 [-1],279 [-1]:5
    adminshovel:277 [-1]:5
    adminpickaxe:278 [-1]:5
    adminaxe:279 [-1]:5
  5. Offline

    Celtic Minstrel

    Odd indeed.

    :confused: And it works like that?
  6. Offline

    Adam McFarland

    Think there would be any possible way to restrict the /give command so a player can't give to others.
    I am having a very difficult time trying to set up the give.group.* command and need some help. I am using Permissions btw. My current config is as follows and works fine. but my problem is I want to create additional ranks each with the ability to spawn additional items.
    Permissions File- (spacing is condensed to reduce post size)
    groups: Builder: permissions: - 'general.give'
    groups: admin: permissions: - 'general.give.*'
    Config.yml -
    give: groups: basic: [(all items they are not allowed to build)]
    My current config restricts the builder class from spawning anything but a small list of items, while admins can still spawn everything.

    What I am Trying to do is make it so the config.yml
    give: groups: basic: [(all items they CAN build)]
    But no matter how I configure permissions and the new command others-for-all: true/false, the builder group keeps getting the message they don't have Permission to spawn any item. Could you please give an example or message me me to walk through what I am doing wrong.
  7. Offline

    Celtic Minstrel

    It's possible. The only reason I didn't do it is because it didn't seem like something that was really necessary (how is giving to others any more dangerous than giving to oneself?). If there's enough demand (say, three or four people), or you can present a convincing argument why it should be added, I'll add it.

    Let me explain with a brief example.
        notitem: [26, 55, 59, 62, 63, 64, 68, 71, 74, 75, 83, 90, 93, 94]
        bedrock: [7]
        fluid: [8, 9, 10, 11]
        basic: [1, 2, 3, 4, 5]
      others-for-all: true
    With the above config, you need special permissions (general.give.group.notitem, general.give.group.bedrock, general.give.group.fluid, general.give.group.basic) to get those items specifically listed, but items not specifically listed are available to anyone.

    If you change others-for-all to false, then items not specifically listed are available only for people with the general.give.any permission, and those specifically listed are available to whoever has the relevant permission. So, if you set others-for-all to false and set basic to the list of items you want them to have access to do, and give them the general.give.group.basic permission, it should work. If it doesn't, it's a bug, and I'll have to fix it for the next update.
  8. Offline


    The iConomy Balance is always reported as 0 with +$ in MOTD

    General 3.2.2
    iConomy 4.3 (Although I tried with 4.4 to see if it would fix it but it didn't)

    Just reporting...
  9. Offline

    Celtic Minstrel

    As with Permissions, General currently doesn't auto-detect; you need to specifically tell it you're using iConomy.
      system: iConomy
    I think I actually forgot to mention that anywhere.
  10. Offline


    Oh alright, thank you very much once again ^^
  11. Offline


    Ehh.... im too stupid or it is just toooo difficult for me to fix these thing.... just dont get it - somehow i made that just Default: group could use few commands, but that came - that nobody cant do anythin'.... ehh... (sorry for my bad english :D)
  12. Offline

    Celtic Minstrel

    Sorry, I'm having trouble parsing your message... is it a question or a thank-you?

    If it's a question, make sure General's config.yml has "system: Permissions" (or "system: GroupManager" if you're using GroupManager).
  13. Offline


    First of all, thank you for your plugin!

    I have 2 questions (actually, one suggestion and one problem).

    Could you change for the next version the way time is printed in MOTD so that it can be formatted (instead of displaying ticks) just like /time command does ?

    As for my problem, I'm using Name Changer, which use setDisplayName when the Player Join event is fired. It works fine, even with /general motd, but NOT when the motd is displayed at first when a player join the game.
    According to the log file, your plugin is initialized before, so I suppose that means that you display the motd before Name Changer actually change the Display Name.
    Is there a way to change this order?

  14. Offline


    Does this work with multiworlds?
  15. Offline


    is there a simple setup for permissions file please

    i dont suppose anyone has a cool motd file they would care to share please

    Any help appreciated.
  16. Offline

    Celtic Minstrel

    I don't know how I managed to miss that. It'll go in the next version for sure.

    Yes, it's determined by who receives the join event first, which is determined by the priority the plugin assigned to the event. I just now changed the priority from "Normal" to "Monitor", since I don't need to change anything in the event; that should fix your problem.

    The order of initialization is nothing to do with this, by the way. :)

  17. Offline


    Thanks for making this.

    I am having some problems with setup; I can not get this to use permissions. It always uses isOP and nothing works (no permission). The really odd thing is I am an OP on the server. I don't want to use isOP anyway, but its odd. I think I am having trouble with the config.yml file; Where it should be and what it should exactly look like. All my other plugins seem to work fine.

    Edit: Works now! Did this:

    system: Permissions
  18. Offline

    Celtic Minstrel

    I should probably get around to making a proper auto-detect system, but it's not really high priority. Besides, the default config it now ships with should specify WorldEdit as the permissions system, meaning that if you have WorldEdit installed it will automatically detect Permissions.
  19. Offline

    Adam McFarland

    If anyone else could test this and let me know, but this is not working for me, I tried spawning items 1, 3 and 4 and all of them got a message saying I don't have permission.

    Config file.
    system: Permissions

    basic: [3, 4, 12, 13, 18, 35, 78, 79]
    others-for-all: false

    show-health: true
    show-coords: true
    show-world: true

    Permissions file
    default: true
    prefix: ''
    suffix: ''
    build: true
    - 'general.give.group.basic'
  20. Offline


    hey cm, can you like make the directory in the zip be like so when you unzip in the plugins dir it alls falls into place
  21. Offline


    I'm loving your plugin, I just have a small request:
    Would it be possible to add a variable to MOTD that shows the online players (I don't mean number, but a list of names)? I'd prefer not to load an extra MOTD plugin just for this small feature.
    I read the Wiki but couldn't find this, if it's already in there please let me know what variable to use.
  22. Offline

    Celtic Minstrel

    The first thing checked when a player issues the /give command is whether they have the general.give permission. If they don't, it just stops right there. So give them the general.give permission and it should work.

    Eh, I could, but the only reason those files are included in the zip at all is because there were errors in auto-generating them. My preferred method would be that you just drop the jar in the plugins folder and the config files automatically generate if they're missing. I don't know why it didn't work for some people. :|

  23. Offline


    Does this interfere with TelePlus?
  24. Offline

    Celtic Minstrel

    Yes, but if you want to use it with TelePlus, you can do this.
  25. Offline


    Got a little Problem, but i don't know whether it is a Problem with the Permissions Plugin or this one..
    If someone joins the Server, who is not Specified as Admin, he is not able to do anything. If he mines anything, it doesnt Drop something and it comes back again...
    Any Idea?
  26. Offline


    Umm.. I really want a plugin with everything in it.. Not a separate plugin for MOTD, colors, prefixes, commands!
    It's really a pain to find every plugin for each version of Bukkit every time there is an update, and most plugins are broken after a update.. Please make ONE plugin that works with all commands.. You don't need a separate plugin for things like message of the day.. Thats only needed if you don't add it to you plugin..! :(
  27. Offline


    can someone share a cool MOTD file please
  28. Offline


    Check in the file "plugins/Permissions/<world.yml>" the value for "group.[...].info.build".
    If it's set to "false" for a given group, it will do what you described. Since it's the default value for the Default group, anyone who is ot in any group will not be able to build or mine.
  29. Offline


    I'm not sure what's going on, but is there an overlap with General and Craft Essence? I'm not getting any errors running the two together, other than whenever someone logs in it displays General's MotD twice, even if it is disabled in the config file.

    btw here's a pretty simple MotD for whoever wanted:

    &3 Welcome to &2 -minecraft server name here- &f +d &3!
    &3 There are +online players online!

    Just put that into a file named


    and you are good to go :)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 11, 2016
  30. Offline


    Thanks Phantum
    Ive done exactly as you add, my world yml has motd enabled
    ALAS no motd is available when i log in.
    ive tried it as General.motd and general.motd
    ive tried it in minecraft root dir, the plugins dir and the General dir, but to no avail.
  31. Offline


    what other plugins are you running?

Share This Page