[GEN] General 3.6.2 (Webern) -- A plugin for general commands, now on BukkitDev! [1060]

Discussion in 'Inactive/Unsupported Plugins' started by Celtic Minstrel, Mar 6, 2011.

  1. Offline

    Celtic Minstrel

    General 3.6.2 [Webern]
    NOTE: If you are updating from 3.4.1 or earlier, you must copy the aliases section from the sample config file into your own config file. If you don't do this, many commands will not work.
    Download from the BukkitDev page (Older versions | Source)

    General provides a small set of basic commands for your server. See more details on the BukkitDev page.

    General is a fork of Nijikokun's plugin. It adds a few commands to the original set provided by General.

    Without Nijikokun's original General plugin, this plugin would never have been possible. Or at least, I would not have made it. General Essentials (the source of the /kit command) was created by wjykk and has had some input from cjc343. The SpawnMob plugin, from which I adapted the code for the /mobspawn command, was created by xmlns and is now maintained by jordanneil23.

    I recommend using sk89q's CommandHelper in conjunction with this plugin. Starting from 3.4.5, there is a command-helper.txt file included with the download which you can copy to CommandHelper's config.txt for some handy aliases, such as /spawn and /home.

    Differences from cjc343's now-inactive fork
    • Does not detect that another plugin has registered the same command.
    • /playerlist and /who are two separate commands
    • Different items.db format
    • Does not support setting or viewing the raw time.
  2. Offline

    Celtic Minstrel

    Oh good! :D I was slightly worried that I might have broken it instead, but fortunately not.

    I'm guessing you're an Owner but the Moderators can't use it? Are you also an op according to ops.txt? Does your General config file say either "Permissions" or "WorldEdit" as the permissions system, or does it say "Basic"?
  3. Offline


    Ohh it is basin there and i am op, yes.
  4. Offline

    Celtic Minstrel

    General won't even try to use permissions unless put something other than Basic there.
  5. Offline


    What's with all this ".DS_Store" garbage in every folder? Is that needed?
  6. Offline

    Celtic Minstrel

    That's some invisible file that the Mac creates for some reason. You can safely delete it.


    Apparently there was a paragraph in the opening post saying the General yields to other plugins, which caused some confusion for some people. Sorry about that; it has never been true that General 3.x yields to other plugins, and I'm not sure how that paragraph slipped through my filter. (I did copy cjc343's post and edit it to fit my needs, but still... it's astonishing I didn't notice it sooner.)
  7. Offline


    wow cm just relised this was here, installed onto our server, works great, see you on the server
  8. Offline


    I have a little problem with the motd... it is displayed in the game but not the whole message (only about 50 letters) ... anyone know how to fix it?
    now another problem... the motd shows up five times, but still onlx thr first letters...
  9. Offline

    Celtic Minstrel

    Is it all on one line? If so, it's probably a bug in the splitting algorithm. Can you post your MOTD so that I can test it? And adding more lines in the file should be a temporary fix.
  10. Offline


    Is there any way to override the default Minecraft spawn behaviour and set the spawn inside buildings with this plugin? Maybe something like "exact-spawn" option?
  11. Offline

    Celtic Minstrel

    I think it's possible to make the spawn exact, but this plugin doesn't do that.
  12. Offline


    Hey Celtic,
    I've got a problem fixing my permissions... I dont get it whats wrong... I just dont understand how to fix those commands to work for admins, moderators and defaults...
    My Permissions:

    # System is no longer used, but may become used in the future
    # Copies is for multiple-world support
    # Put the name of the world you wish for it to be a clone of, otherwise leave it empty.
    # If this file is for your default world (the one in server.properties) then you must
    # leave copies blank.
    # Example: copies: Derp - This will clone the permissions of the world Derp
    # Make sure to rename this file to the name of the world that is in sever.properties under
    # level-name. So if it is level-name: world then this should be world.yml and in the
    # plugins/Permissions directory (ie. plugins/Permissions/world.yml)
    # NOTE: Do not use tabs while editing this document. Use only spaces. A good way to avoid
    # doing this is to use Notepad++ and replace the tab with 4 spaces.
    system: default

    # AntiBuild is included with this. To disable a group from being able to build then
    # set the build: flag to false (build: false). If you want a group to be able to build
    # then set it to true.
    # Groups can contain inheritance.
    # To make a group inherit the permissions from another
    # group simply place the groups name in the "inheritance:" like so:
    # Example:
    # inheritance:
    # - Default
    # All permissions including the asterisks must be placed in single quotes.
    # like so:
    # - 'foo.bar'
    # Otherwise errors will happen!
    # Globalized Permission settings:
    # If a permission contains periods (.) you can denote a globalized parameter:
    # - 'foo.*'
    # This will allow you to use all general commands.
    # Single Asterisk denotes all commands:
    # - '*'
    # If you give a group this permissions, do not have the group inherit any permissions
    # from other groups. Any users assigned to this group should NOT be given any additional
    # permissions either.
    # To exempt a node use the - prefix like so:
    # - '-foo.bar'
    # prefix: and suffix: do not do anything on their own. You need another outside plugin
    # such as iChat or HeroChat in order for these to do anything.
    default: true
    prefix: ''
    suffix: ''
    build: false
    - 'foo.bar'
    default: false
    prefix: ''
    suffix: ''
    build: true
    - Default
    - 'bar.foo'
    default: false
    prefix: ''
    suffix: ''
    build: true
    - '*'

    # Users denote which users are included in which group.
    # TheNo1Yeti is in the Admin group
    # Herpina is a member of the Moderator group but also has access
    # to the herp.derp permissions
    # Derpina is a member of the admin group but does not have access
    # to the derp.derp permission node
    # Users can also have a prefix and suffix as seen with Herpina
    group: Admins
    group: Moderator
    prefix: 'Moo'
    suffix: 'Cow'
    - 'herp.derp'
    group: Admins
    - '-derp.derp'
    group: Admins
    - *
    group: Moderator
    - general.give
    - general.spawn.set

    My Server Console, maybe u will find whats wrong:

    Error 1.jpg

    Error 2.jpg

  13. Offline


    Hey. Could you please add options to completely disable (prevent from registering) specific commands? This Plugin overwrites the more advanced teleport commands from TelePlus for example.
  14. Offline


    My general doesn't connect to permissions 2.5.4(phoenix)
    but [Basic(isOp)]
    what should i do?
  15. Offline

    Celtic Minstrel

    @Taksioras - Any and all asterisks (*) must be enclosed in single quotes, so replace " - * " with " - '*' ".

    Maybe in a future version (such as 4.0 or something), when CraftBukkit makes this easier to do. In the meantime, it's possible to prevent General from registering the teleport command. The following should work on a Mac and mostly will apply to Windows as well.
    1. Rename General.jar to General.zip.
    2. Open General.zip; it should unzip to a folder containing four files and two folders.
    3. Edit plugin.yml – replace this line:
          aliases: [tp]
      with just this:
    4. Save, then select the six files you unzipped and re-zip them, rename the archive to General.jar, and hopefully everything will work.
    5. Replace the old General.jar with the new if applicable and delete the folder.
    If you're on Windows it may be even easier, since I think it might let you navigate into zip files as if they were a folder. I recommend working with file extension hiding turned off in your system/explorer/finder/wherever preferences.

    You should go to General's config.yml and replace "Basic" with "Permissions". If you can't find "Basic" anywhere, add these two lines:
      system: Permissions
  16. Offline


    if your on linux you can do
    vim General.jar
    and it will open it up as a zip file which you can choose the file you want to edit
  17. Offline

    Celtic Minstrel

    Bah, I would never recommend vim. It doesn't make any sense. <_<
  18. Offline


    vim is ugly but it was quicker than downloading extracting w/ 7zip and uploading again ;). thanks for this quickfix.
  19. Offline


    Still doesn't work.... It just says "you dont have permissions to do that"... Im not good at things like that dont understand... Need better explanation or better example... ;(
  20. Offline

    Celtic Minstrel

    Do you have "system: Basic" in General's config.yml? If so, change Basic to Permissions.
  21. Offline


    Is there any /online command?
  22. Offline

    Celtic Minstrel

    Yes. Did you try it before asking?
  23. Offline


    yea, but it works dor me, not others O_O
    OH Shi* sorry, it is 4 am now, and i just did not see the permission of it :D:D:D
  24. Offline

    Celtic Minstrel

    Ehh, maybe I should add a blanket permission for the "info" type commands.


    Version 3.2.2 released.
    • Basic iConomy support added; you can now include the player balance and currency name in the MOTD. Note that the balance includes the currency name.
    • The /time command now supports human-friendly times and durations; also, the = is now optional for setting to a specific time.
    • The /time command also displays in human-friendly format. There are two config options to control how it does this (12-hr vs 24-hr, and whether to show the ticks).
    • Bugfix: /time midnight did not work. It now does.
    • The /away command is back (/afk is an alias)! If you are away, your away message is now shown if someone whispers to you and also in the /who display.
    • The /take command was not fully updated to match the new /give syntax; this is now done.
    • The /give and /take commands now show feedback when invoked from the console.
    • The /give command now says "infinite" instead of "-1".
  25. Why can't anyone but mods use /msg and /online? How can I fix this :S
  26. Offline


    Why it shows DEBUG? or something :D
  27. Offline

    Celtic Minstrel

    Give them permissions nodes "general.tell" and "general.playerlist".

    What? Did I forget to remove a debugging statement somewhere? What's the message?
  28. Offline


    Ok, so I have tried to set up kits for my users, but I am getting a warning message when the server starts:

    2011-03-13 05:29:09 [WARNING] [General-3.2.2] Note: line 2 in general.kits is improperly defined and is ignored (java.lang.ArrayIndexOutOfBoundsException)
    2011-03-13 05:29:09 [WARNING] [General-3.2.2] Note: line 3 in general.kits is improperly defined and is ignored (java.lang.ArrayIndexOutOfBoundsException)
    2011-03-13 05:29:09 [WARNING] [General-3.2.2] Note: line 4 in general.kits is improperly defined and is ignored (java.lang.ArrayIndexOutOfBoundsException)
    2011-03-13 05:29:09 [WARNING] [General-3.2.2] Note: line 5 in general.kits is improperly defined and is ignored (java.lang.ArrayIndexOutOfBoundsException)
    2011-03-13 05:29:09 [WARNING] [General-3.2.2] Note: line 6 in general.kits is improperly defined and is ignored (java.lang.ArrayIndexOutOfBoundsException)
    2011-03-13 05:29:09 [WARNING] [General-3.2.2] Note: line 7 in general.kits is improperly defined and is ignored (java.lang.ArrayIndexOutOfBoundsException)
    2011-03-13 05:29:09 [WARNING] [General-3.2.2] Note: line 8 in general.kits is improperly defined and is ignored (java.lang.ArrayIndexOutOfBoundsException)
    2011-03-13 05:29:09 [WARNING] [General-3.2.2] Note: line 9 in general.kits is improperly defined and is ignored (java.lang.ArrayIndexOutOfBoundsException)
    2011-03-13 05:29:09 [INFO] [General-3.2.2] Using [Permissions 2.5.4] for permissions.
    2011-03-13 05:29:09 [INFO] [General-3.2.2] [Codename: Sibelius] Plugin successfully loaded!
    2011-03-13 05:29:09 [INFO] [General-3.2.2] [Help 0.1.1] support enabled.

    I followed the Wiki page thing for setting up my gneral.kits file, here is what it looks like currently:

    # give acces with general.kit.<name>
    tools:256 -1,257 -1,258 -1:300
    shovel:256 -1:300
    pickaxe:257 -1:300
    axe:258 -1:300
    admintools:277 -1,278 -1,279 -1:5
    adminshovel:277 -1:5
    adminpickaxe:278 -1:5
    adminaxe:279 -1:5

    If anyone can tell me where my error is I would appreciate it.

    Nevermind, I figured out i was missing the [] for the amounts.
  29. Offline

    Celtic Minstrel

    Not sure what you mean by this. I would guess it's the spaces that are causing problems, though.
  30. Offline


    I'm not sure if I'm doing something terribly wrong, but I can't seem to access half the items via the /give command. Most of the time, I just get "Invalid item.", even though I KNOW I'm using an alias in items.db.

    I can't seem to pinpoint a pattern to the thing, but I know most single word items work, and multi-word items do not (multiword not meaning "diamond block", but rather typed as "diamondblock", "diamondBlock", "DiamondBlock", and "diamond_block" (the last working before I installed the plugin)).

    The items.db is located in /plugins/General/items.db, and the plugin hasn't given any notification that it can't find it. I commented out one line before I started the plugin for the first time (SSword = a stone shovel???), but have made no other modifications to that file. Is there something I'm doing wrong?

  31. Offline


    [INFO] [General-3.2.1] [DEBUG] Time is 22043
    2011-03-13 15:14:06
    There is or was something like this.

Share This Page