[GEN] General 3.6.2 (Webern) -- A plugin for general commands, now on BukkitDev! [1060]

Discussion in 'Inactive/Unsupported Plugins' started by Celtic Minstrel, Mar 6, 2011.

  1. Offline

    Celtic Minstrel

    General 3.6.2 [Webern]
    NOTE: If you are updating from 3.4.1 or earlier, you must copy the aliases section from the sample config file into your own config file. If you don't do this, many commands will not work.
    Download from the BukkitDev page (Older versions | Source)

    General provides a small set of basic commands for your server. See more details on the BukkitDev page.

    General is a fork of Nijikokun's plugin. It adds a few commands to the original set provided by General.

    Without Nijikokun's original General plugin, this plugin would never have been possible. Or at least, I would not have made it. General Essentials (the source of the /kit command) was created by wjykk and has had some input from cjc343. The SpawnMob plugin, from which I adapted the code for the /mobspawn command, was created by xmlns and is now maintained by jordanneil23.

    I recommend using sk89q's CommandHelper in conjunction with this plugin. Starting from 3.4.5, there is a command-helper.txt file included with the download which you can copy to CommandHelper's config.txt for some handy aliases, such as /spawn and /home.

    Differences from cjc343's now-inactive fork
    • Does not detect that another plugin has registered the same command.
    • /playerlist and /who are two separate commands
    • Different items.db format
    • Does not support setting or viewing the raw time.
  2. Offline


    I got * in permissions, i need to add theese [ /i /time.. ] manually?
  3. Offline


    The REVERSE swastica is a Hindu symbol. As for his avatar, it looks like somebody took the swastica and unbanded them and laid them side by side.
  4. Offline

    Celtic Minstrel

    Both were Hindu, but I imagine Hindus don't normally use the non-reverse one much anymore.

    If you have '*' in permissions, you have everything... I'm not really sure what you're asking?

    Please, anyone with a question, try to be more detailed.
  5. Offline


    On my avatar two stylized letter B, from the name of a local forum BlackBoard. Capish?
  6. Offline


    Well, i am owner and i have '*' in permissions, but /i and other general commands are not working for me ;/
  7. Offline

    SweetCraft Girl

    What is there to not like any McDocs when you can change it yourself??? Why would you stick with the standard templated McDocs.txt motd anyways?

    Originality for the win, maybe.
  8. Offline


    Honestly, who cares - stop bringing your emotions into a thread, I was making an observation - deal with it :D
  9. Offline


    Regarding the /give command, what are the item aliases for item names with spaces?
    For example, i want to give me 10 "Clay Block"s...
    /give clayblock 10 doesn't work...
    Do i have to use the id numbers here or are there aliases?

    And i think there is a mistake in your items.yml...
    Line 266 should be item44 instead of item43, right?
  10. Offline

    Celtic Minstrel

    Paste General's loading message, please.

    Well, that works for me, so I have to conclude that, most likely, items.db is either missing or invalid (or empty, or in the wrong place). Make sure it's in the server root directory (same directory as craftbukkit.jar) and that it includes either "clayblock:82" or "clayblock=82" on a line somewhere. You can either use the included items.db or make your own.

    There should be a warning message printed on startup if the items.db is missing. Once you've fixed it, just put "general reload" in the console.

    Wow, you're right! Thanks for catching that.
  11. Offline


    Sorry to bother you but I am a noob at installing plug-ins and I am not sure how to Install General.
    Do I just put the General-3.1.1 folder in the plugins folder of do I put all the files in there?
  12. Offline

    Celtic Minstrel

    Copy General.jar into the plugins folder. The .yml files are theoretically not needed as the should auto-generate, but if you get errors, you can copy them into the General folder in the plugins folder. The items.db file, if you choose to use it, goes in the same folder as craftbukkit.jar. It's optional, but using it means you can refer to items by their name. (You can also make your own items.db if you prefer.)

    This reminds me, I should put install instructions in the readme.
  13. Offline


  14. Offline


    Hey, just installed your plugin and I have to say it rocks! Very clean and straight forward!
    The only thing that seems to be a little odd is that I want to disable the MotD function but I am not totally sure how.

    I'm quite the noob but I've been looking around the yml files and can't seem to find anything that mentions motd's ^^'. I am using MCDocs and would like to disable it so I don't get the "No Message of the Day" popup.
    I tried putting a simple 'motd.txt' in the general's folder with empty text but it didn't seem to work.

    Thanks :D
  15. Offline

    Celtic Minstrel

    I was going to add a config option to disable the motd (specifically for users of MCDocs), but I forgot to do that; it'll be there in a later version, but for now I think it should suffice to have general.motd be an empty file. Presumably your problem was that you gave the file the wrong name.

    EDIT: Actually, I'll upload the fix right now. It was just one line of code, anyway.
  16. Offline


    Right... items.db wasn't in server root... [​IMG]
    Everything works fine. Great plugin.
    Thank you! :)
  17. Offline

    Celtic Minstrel

    To Kalamity: Just download 3.1.2 and add a line with "show-motd: false" to your config.yml.
  18. Offline


    Ah all fixed ^^. Thanks for the quick response!
  19. Offline


    it turned out i had the wrong config code so all the commands other than /setspawn (which brings up text that shows /setspawn [player] .etc that text i just called it a help notice) were not in the config file or the items so there was no commands that worked other than /spawn.
    thanks for replying

  20. Offline

    Kyle Haugrud

    Today I was upgrading General to 3.1.2, and honestly I dont know what version I have (Works on 493) but it seems 3.1.2 doesn't not work at all for me. I get a [Severe] null plugin general 3.1.2 or something for that matter. It does load because when I type /i glass I get no glass but a message comes up saying to make sure its the right format, like /i [player] [item] etc...I have reverted my General and everything is working fine. So not sure what the issue is.
  21. Offline

    Celtic Minstrel

    Kyle, make sure that items.yml is in the General folder (you may have to copy it there). If you still get an error, paste the entire error here for me to see.

    Actually, it would be nice to see the entire error anyway before you check the items.yml, because I suspect this is the same issue someone else had with the default config files failing to auto-generate, and I'd like to fix it if I can figure out why it's happening.
  22. Offline


    Can someone give me an example of how my motd should look like if i wanted to change the colour to people's names?
  23. Offline

    Kyle Haugrud

    Well Items.yml is in the general folder but ill post the error right away

    Edit: Here is the error. Before I started the server I checked and made sure both the files were in the General Folder and they were, not sure why i get the error.

  24. Offline

    Celtic Minstrel

    For example, to make the names green:
    Make sure it is not empty, too.
  25. Offline

    Kyle Haugrud

    Well since I use my personal items.db the items.yml is empty, how would i go on about fixing that?
  26. Offline


    Would be nice if you add option for disabling some command. For example, disable teleport commands.
  27. can you please add stack and repair command ?
    then i will use it on my server.
  28. Offline


    i cant use /general help is says: help topic unavailable

    could you make a /help pluging that generates the commands from all plugins?
  29. Offline


    # System is no longer used, but may become used in the future
    # Copies is for multiple-world support
    #   Put the name of the world you wish for it to be a clone of, otherwise leave it empty.
    #   Does not work for the default world.
            system: default
    # Groups can contain inheritance.
    #   To make a group inherit the permissions from another
    #   group simply place the groups name in the "inheritance:" like so:
    #   Example:
    #       inheritance:
    #           - Default
    #   All permissions including the asterisks must be placed in single quotes.
    #   like so:
    #       - 'general.spawn'
    #   Otherwise errors will happen!
    #   Globalized Permission settings:
    #       If a permission contains periods (.) you can denote a globalized parameter:
    #           - 'general.*'
    #       This will allow you to use all general commands.
    #   Single Asterisk denotes all commands:
    #       - '*'
    #   To exempt a node use the - prefix like so:
    #       - '-general.time'
            default: true
                build: true
                - 'general.spawn'
                - 'iConomy.payment'
                - 'iConomy.list'
                - 'iConomy.rank'
                - 'myhome.home.soc.others'
                - 'myhome.home.basic.*'
                - 'lwc.protect'
                - 'jail.usercmd.jailcheck'
                - 'mcdocs*'
                - 'general.tell'
            default: false
                prefix: '&f[&8Member&f]&7'
                build: true
                - Default
                - 'myhome.home.soc.*'
                - 'general.clear'
            default: false
                prefix: '&f[&6VIP&f]&e'
                build: true
                - Member
            default: false
                prefix: '&f[&3Moder&f]&9'
                build: true
                - Member
                - 'jail.command.jail'
                - 'general.teleport'
                - 'general.teleport.here'
                - 'general.player-info'
                - 'jail.command.unjail'
                - 'jail.command.jailtransfer'
                - 'jail.command.jailtransferall'
                - 'jail.command.jailcheck'
                - 'iConomy.access'
                - 'myhome.admin'
            default: false
                prefix: '&f[&4Admin&f]&c'
                build: true
                - Moderator
                - 'bb.admin'
                - 'general.time'
            default: false
                prefix: '&f[&2OWNER&f]&a'
                suffix: '&4'
                build: true
                - '*'
    # DarkGrave has control over all commands.
            group: Owner
    What is wrong there? Nobody can use /spawn, i cant use /i.. ;/
  30. Offline


    would be nice if i could actually do something with those commands than getting explainations of how they work.
    /give petomatick 262 64
    -Random text about how the give function works...

Share This Page