[GEN] General 3.6.2 (Webern) -- A plugin for general commands, now on BukkitDev! [1060]

Discussion in 'Inactive/Unsupported Plugins' started by Celtic Minstrel, Mar 6, 2011.

  1. Offline

    Celtic Minstrel

    General 3.6.2 [Webern]
    NOTE: If you are updating from 3.4.1 or earlier, you must copy the aliases section from the sample config file into your own config file. If you don't do this, many commands will not work.
    Download from the BukkitDev page (Older versions | Source)

    General provides a small set of basic commands for your server. See more details on the BukkitDev page.

    General is a fork of Nijikokun's plugin. It adds a few commands to the original set provided by General.

    Without Nijikokun's original General plugin, this plugin would never have been possible. Or at least, I would not have made it. General Essentials (the source of the /kit command) was created by wjykk and has had some input from cjc343. The SpawnMob plugin, from which I adapted the code for the /mobspawn command, was created by xmlns and is now maintained by jordanneil23.

    I recommend using sk89q's CommandHelper in conjunction with this plugin. Starting from 3.4.5, there is a command-helper.txt file included with the download which you can copy to CommandHelper's config.txt for some handy aliases, such as /spawn and /home.

    Differences from cjc343's now-inactive fork
    • Does not detect that another plugin has registered the same command.
    • /playerlist and /who are two separate commands
    • Different items.db format
    • Does not support setting or viewing the raw time.
  2. Offline

    Celtic Minstrel

    /tp spawn
  3. Offline


    Are the general.teleport permissions different? the only way i can enable teleport now is using
    If I use this, then no one can teleport:
    I'm following what's on the wiki.

    When users with general.basic use /away or /afk it says "you are not away". That message only makes sense if there was a /back or /noafk command.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 11, 2016
  4. Offline


    Hm...giving books doesn't work.

    I've tried /i book 1 dj_idol, /give book 1 dj_idol etc. etc. none of them work. It works for all other items, but it doesn't give books. Just a heads up.
  5. Offline


    I have the same problem as Zathras.

    I tested the following nodes:


    only "general .*" works

    (I use CB1000 & Permissions)
  6. Offline

    Celtic Minstrel

    Unless you're using superperms, you need to give 'general.teleport' in order for anyone to be able to teleport; this is in addition to any other teleport nodes you want to give them. I think things like 'general.teleport.*' and 'general.teleport.basic' will automatically give this when used with superperms, but they won't when used with other Permissions plugins. Also, you need one of general.teleport.self, general.teleport.other, or general.teleport.mobs in order for any teleporting to be allowed, plus at least one destination of the form general.teleport.to.something.

    As for the /away thing, it functions as /back when used without arguments; to actually set yourself as away you need to provide an away message.

    @DJ_Idol – Huh, that's odd. Do you have BookWorm installed? Does '/i book' work? What if you use the item ID for book?
  7. Offline


    So how would i give my default members just tp spawn because i dont want them able to teleport.
  8. Offline

    Celtic Minstrel

    Give general.teleport, general.teleport.self, and general.teleport.to.spawn. That'll give them permission to teleport themselves to spawn and nowhere else.
  9. Offline


    I have got everything working fine, but there seems to be an issue when I used \give Sorontar 55 64. They certainly were redstone wires that it gave me, but they came up as spiderwebs on the hot key boxes (and I think the inventory). When I used them, they became redstone wires. Is this a items.db issue? I noticed when updating that your zip file has a items.yml, but not an items.db. I also found a comment from you about a previous version converting items.db into items.yml. I had an out-of-date items.db from cjc343's version of General when I installed your version. Has your code converted that into items.yml, overwriting your current version with an out-of-date version? (ie. should I get rid of items.db and reinstall your items.yml).

    I realise I could test this myself, but thought I better ask here in case others have had the same problem.

    Thanks for all the work you have been doing on the mods and helping us understand them.

    ps. Current plugins: MyHome, BorderGuard, MyWarp, Permissions, iChat, BigBrother, HeroicDeath, PermissionsSql, General
    Bukkit v770, Craftbukkit v1000
  10. Offline

    Celtic Minstrel

    You're using the wrong ID for redstone; 55 is redstone wire that exists in the world, but 331 is redstone for your inventory. I don't know why you're using IDs at all though when you can just use the item's name.

    I'm not entirely sure if cjc's items.db is compatible with mine; does it have the item names on the left or the item IDs on the left? If it's compatible though, General will read it and push all the info into the items.yml. If you didn't install the items.yml initially, though, it'll be missing all the basic stuff, so you may want to delete it, install my items.yml, and start up the server. Once you've done that and checked that the aliases in your items.db work you should be able to delete items.db without loss.

    When converting items.db to items.yml, it doesn't overwrite an existing items.yml; it simply adds the aliases from the items.db into the items.yml.
  11. Offline


    I am not sure what is going on but here it is if I am in game and I type /i lime wool 20 I tells me "there is no player named lime " but if I use /i 35:5 20 then I get the 20 lime wool, am I doing something wrong ? Second I went back several pages trying to find out why you took out the /spawn command either I missed it or it was not explained ? I know we have /tp spawn just wondering.
  12. Why is it, that there is no name shortcut, to wooden/plank and cobble slabs? :)
  13. Offline

    Celtic Minstrel

    Yes you are; item names can't contain spaces. Try /i wool:lime 20.

    It's pretty much because we have /tp spawn; plus if you have CommandHelper you can use it along with General to make a /spawn command (see command-helper.txt in the download).

    Because you didn't add one? However, if you used the default items.yml, there probably is one. For example, slab:wood.
  14. Offline


    I am using data values because that is what I am used for cjc343's General. Your version will make things so much easier, especially now I can ask for specific colours of wool!

    I worked out my problem. Yes, I should have asked for redstone, but I *was* getting the redstone wire I asked for. It just wasn't red (like on the ground) because its on/off state hadn't been selected because it was incorrectly in the inventory. Hence it looked like it was spiderweb. Hence my confusion. Thanks for responding so quickly.

    I got rid of the items.db and reinstalled your mod anyway, just to be sure.


  15. Offline

    Celtic Minstrel

    cjc's version already supported specific colours of wool, you know.

    Yeah, the redstone wire doesn't display properly in the inventory... probably because it was never intended to exist in the inventory.
  16. Offline


    With all updating, I must have missed the instructions on that. The first post on his thread didn't say that. No matter, /give isn't used much at present and now I am using your mod and I have the wiki (and the community here) to help me.

  17. Offline


    Is there a way with permissions to limit a player to be able to only teleport themselves to spawn and nowhere else?
  18. Offline

    Celtic Minstrel

    Yes. Give the following permissions:

  19. Offline


    Any word on this problem yet? Has it been fixed?
  20. Offline


    So adding that to any group will let them teleport only to spawn and nowhere else?
  21. Offline


    This is such a great plugin. We used to use Essentials, but it would keep breaking with every update, and would always clash with our other plugins. General has been nothing but a good experience, and we have had ZERO errors so far.
    KEEP IT UP! :)
  22. Offline

    Celtic Minstrel

    @Satros – Haven't looked into that yet. Feel free to check yourself and submit a pull request; the latest code is, I believe, currently on github.

    @DeathQueen – Correct; those three permissions are sufficient for that for any permissions system. If you're using superperms (eg PermissionsBukkit, or I think PermissionsEX also fits this) I think just general.teleport.self.to.spawn should be sufficient.

    @Firewolf34 – Good to hear. :)
  23. Offline


    Worked fine, thanks, but now the /heal command is not working. I gave a rank the general.heal permissions, yet they can't use that command.
  24. Offline

    Celtic Minstrel

    If you have WorldGuard, I believe it steals the /heal command from General. Check your startup log to see if there's a message about heal not being registered.
  25. Offline


    Hi Celtic,

    My server has just died on me and we have to restore the map from back up. All plugins were lost and i've had to re-install everything. I am unable to give players all commands, although the config file is the newest it seems like the issue described in your beginning thread:

    Admins work fine, just the mods cant use some commands.

    Running bukkit 1000, permissions 3 yeti.
  26. Offline

    Celtic Minstrel

    If there is anyone who can use the commands, that's not your issue; forgetting to do that would prevent commands from working even for ops and even from the console. Sounds like your issue is rather with permissions. Which commands can mods not use that they should be able to? Permissions for some commands have changed over time, especially for teleport.
  27. Offline


    Thanks for the quick reply, at least I can stop playing with that config file now :)

            - 'general.time.set'
            - 'general.teleport.*'
    I have tried without the * and with .basics

    The time permission works fine though.
  28. Offline

    Celtic Minstrel

    Since you're using Niji/Yeti permissions, you need it both with and without the *.
  29. Offline


    You are a legend, thats been wreckin my head for about 4 hrs!!!

    Thank Celtic :)
  30. Offline


    when i try to tp in a new world called world2 it says Inviald target but the world is in my home directory.
    Can anyone help me?

    and sy for my bad english ;D
  31. Offline


    When will be the balance error in motd fixed?

Share This Page