Inactive [GEN] Essentials v2.1 [?]

Discussion in 'Inactive/Unsupported Plugins' started by Zenexer, Jan 19, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. Offline


    @Zenexer Is there anything I need to do to allow you to set up the wiki?
  3. Offline


    @Aelux Just sent you a message about it :)

    - Improved and fixed /mail

    156: [In Development]
    - Ops can now use /modgrp on anyone
    - Removed /b alias
    - Nether support! /world nether, /world normal
  4. Offline


    You all need any help let me know. Just not in a real good mood with these people lol.
  5. Offline

    Cosmic Break

    whats wrong with it?

    i cant create nether, i cant go to nether, whenever i type /world nether, the server shuts down.
  6. Offline


    First of all, that does not appear to be an Essentials issue, that looks to be a server issue. Please post your server issues HERE.
    Second of all, please don't just say "What's wrong with it" ... You should specify your CB build and the plugin build version that you're having problems with.
    --- merged: Feb 7, 2011 7:14 AM ---
    I will do some testing now to make for certain that it's not an Essentials issue.
  7. Offline

    Cosmic Break

    full console log

    essentials dev build 179
  8. Offline


    Ok, don't expect help on dev builds. Use release build 156, it's updated with the nether code and works just fine on my test server.

    I got the same error you did though when trying it on my main server. So I am going to do some more testing.
  9. Offline

    Cosmic Break

    that stable build was just release after i made the initial post
    edit: stable build still produce same error
  10. Offline


    @Cosmic Break Ok, there appears to be a conflict with another plugin, but I have several plugins on my server. I won't know which one it is until I go through them all. What plugins do you have installed on your server?
    --- merged: Feb 7, 2011 7:27 AM ---
    *laughs* I took a look at your console log and you have a lot more plugins then me. I guess i'll just go through mine one by one.
    --- merged: Feb 7, 2011 7:35 AM ---
    Ok, tests are done. Verdict....

    WormHoleXtreme and DynMap both kill the Essentials plugin.

    Safe plugins: WorldEdit, WorldGuard, HeroChat, HeroDeath, Vanish, MyWarp, iChat, Permissions, AutoMessage, LWC, and MCDocs.

    The safe plugins are just the ones that I was able to test on my server, there will possibly be more.
  11. Offline


    havent tried it out myself, but after reading this I think he is right: NOT giving tpaccept to someone should make it impossible for him to be moved by tpahere

    please add this
  12. Offline

    Cosmic Break

    Essentials, Multicast, LWC, MCBans, Vanish, TimeAnnounce, Trivia, BorderGuard, iAuction, Elevators, DeathTPPlus, AFKkick, iChat, Permissions, WorldGuard/WorldEdit, BigBrother, CraftIRC, vPlayersOnline, iConomy, Guardian, MCDocs, MagicCarpet, Cleaner, BackupPlugin

    I figured synap would, i removed it, before you told me.
  13. Offline


    That actually does make sense. The way the other guy explained it, it didn't make sense.
    --- merged: Feb 7, 2011 7:40 AM ---
    @Cosmic Break Go ahead and remove all non-safe plugins that I listed and then add them one by one until the error occures... Make sure you test all of them, even if you find one that doesn't work, it doesn't mean that it's the only one that crashes it.
  14. Offline


    After updating our server today, I had to disable Essentials, because it broke MyWarps.

    At a guess, both plugins are implmenting the /warp command, and Essentials grabbed the command before MyWarps could get to it.

    Craftbukkit version git-Bukkit-0.0.0-354-g502b903-b265 (MC: 1.2_01)
    MyWarp version 1.9
    Essentials (Release) build #156
  15. Offline


    You have to use the workaround that I already suggested earlier... For command conflicts, either set essentials to use it's own alias (/e:warp, /e:tp, /e:home, etc...) OR edit the plugin.yml file within the Essentials.jar file and remove the "/warp" command.
  16. Offline


    My question is, do the nether gates work, that's all I want.
  17. Offline


    Sadly no... The only way to get to the nether is with the command "/world nether"
  18. Offline


    I get an odd error.

    Feb 7, 2011 3:15:26 AM org.bukkit.craftbukkit.CraftServer loadPlugins
    SEVERE: null (Is it up to date?)
            at net.minecraft.server.World.a(
            at net.minecraft.server.World.a(
            at net.minecraft.server.Chunk.c(
            at net.minecraft.server.ChunkProviderServer.d(
            at net.minecraft.server.ChunkProviderServer.b(
            at net.minecraft.server.World.c(
            at net.minecraft.server.World.getTypeId(
            at net.minecraft.server.World.isEmpty(
            at net.minecraft.server.World.a(
            at net.minecraft.server.WorldProviderHell.a(SourceFile:45)
            at net.minecraft.server.World.<init>(
            at net.minecraft.server.WorldServer.<init>(
            at org.bukkit.craftbukkit.CraftServer.createWorld(
            at org.bukkit.earth2me.essentials.Essentials.onEnable(
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(
            at org.bukkit.craftbukkit.CraftServer.loadPlugin(
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(
            at net.minecraft.server.MinecraftServer.e(
            at net.minecraft.server.MinecraftServer.c(
            at net.minecraft.server.MinecraftServer.d(
    latest bukkit and I tried both dev and release version of essentials and 0 plugins.
  19. Offline

    Cosmic Break

    i figured it out. Needed to update the essentials plugin file. but now i only spawn inside a hole in the nether rock, and have to make a new spawn for the nether world to get out.

    also, the TimeAnnounce Plugin doesnt work with it either.

    edit: everything else works fine! [​IMG]
  20. Offline


    That's good to know, thanks.
  21. Offline


    @Cosmic Break

    Your worldguard is oudated ver 3.2.1 is now 3.2.2

    Yes there is a known issue with nether spawn Zenexer was talking about it on his IRC.

    Apparently just dig a block out from under ur spawn and u wont die.
  22. Offline

    Cosmic Break

    i updated that while testing which of my plugins didnt work or not
  23. Offline


  24. Offline


    So whenever I try and use the /world nether command it stops my server.

    Using the recently posted build of essentials and the most up to date CraftBukkit.

    Server CMD Window:

    Config File:

    Edit: Originally it wouldn't load essentials, so I just moved the config file to make it generate a new one and see what was going on. After editing and adding in the nether line it all worked fine except the for the nether world crashing the server.
  25. Offline


    just installed this plugin because I hoped for working gates ... well ... sad, deleted it now
    if you get gates working ill check it out again(and if itll feature nether-mobs ill love it) ;D
  26. Offline


    I just noticed a trivial bug in the source. When displaying the time left in the teleport cooldown and heal cooldown functions, it checks against "60", but should check "60000" since the value is in milliseconds. As a result, it always displays the time left in minutes.

    I've continued tinkering with adding in teleport timers, and I've got it basically working. It of course has a configurable delay and an option to cancel the teleport if the player moves more than 1 block in any direction while the timer is running. I still need to do a few more things like checking the cooldown before initiating the timer and updating the cooldown after, and likewise with the charge function, along with hooking timer usage it into each appropriate teleport method (just set up on /home and /spawn at the moment).
    I'll continue working on it tomorrow in my free time. Shouldn't take too much more work. I'll post a diff patch once I finish it.
  27. Offline


    This error is caused by a conflicting plugin. Make sure you're running the safe plugins as described in my previous post... Test all plugins NOT in the safe plugins by removing all of them, then adding them in one by one...

    I'm sure zenexer will fix this tomorrow, so no worries. This was the first release for a working nether, there was bound to be issues. I'm heading to bed, night all.
  28. Offline


    I am only using Essentials, Permissions, WorldEdit, WorldGuard, and iChat.

    Also I updated the pastebin links in my first post -

    Server CMD Window:

    Config File:
  29. Offline


Thread Status:
Not open for further replies.

Share This Page