Inactive [GEN] Essentials v2.1 [?]

Discussion in 'Inactive/Unsupported Plugins' started by Zenexer, Jan 19, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. This will be my last contribution for a few weeks. Please raise any issues through the bug tracker Bugs

    - Fixed /me not using all args
    - Fixed /broadcast not using all args + added broadcast tag.
    - Fixed /spawnmob with mobs that don't do groups.

    This will be an unpopular revert but is necessary at the moment.
    - Reverted /help limits by permissions for the time being. (we do not know non-essentials commands permissions)
  3. Offline


    Bah and you called me a shit admin for struggling with the permissions config.ymal file for the first time, I will have you know I'm pro at it now it always works for me. Also in regards your post. It was the ONLY thing I had an issue with since I installed bukkit after Hmod died.

    Its been stated at least 5 times in the past 5 pages that you MUST manually extract the essentials .jar and open the plugin.ymal file and remove any and ALL conflicting commands that other plugin's use.

    For example to get your Myhomes working.remove /home and /sethome from essentials plugin.ymal file, disabling the command only disables it for essentials but it’s not the issue here it is that for some reason any same name commands get conflicted and cancel each other out.

    Oh and when you’re done open your Essentails.jar and move the plugin.ymal back into it then restart your server.

    FYI: I don't think it really matters if your caftbukkit is version 138 I use 132 " have not updated yet" and Essentials 137+ works fine for me. Just had to remove commands from the plugin completely to get it work with Mywarp and Spawncontrol. Ie, Stop echoing the command in chat.

    Great stuff i'm sure it will work just as well as your other updates. I will probably update craftbukkit first but I don't see it breaking anything, only time craftbukkit breaks plugins is when they decide to change the way they handle code around.
  4. Offline


    Fixed the above mentioned log-spam. Also, for me at least, allowed essentials to add a few more commands it was having trouble showing on the previous versions.

    A weird bug, though... You did indeed fix the /me and /broadcast bugs, but they are now showing everything EXCEPT the first words. O_O
    I'm running cb238.
  5. Offline

    Don Redhorse

  6. Offline


    The /help command in this plugin is far greater than that of any other, and a whole new plugin just for a single command is pointless. What you described in your topic is almost exactly how /help works in Essentials. (Also, integration to Bukkit is pointless because until you add a plugin Bukkit has no commands to list...) As for the Alias'... That is really up to the developers. Either it will or won't change. You can't just expect EVERYONE to conform to one uniform way of doing things, otherwise what would be the point of an Open API instead of just a core dev team?
    Posting that here is basically spam, as I'm sure the OP would agree.
  7. Offline


    I think the whole open API is eaither going to make or brake bukkit in the end while it is supiror to Hmod in many wasys, in others it so far is on a collision course with fail, Tho the only excuse I cane make for it right now is that its " Not Finished"

    Hmod had a uniform way and it worked you only needed to add commands in the uniform way and it was then picked up and displayed in help. Same goes with groups and permissions.

    Where bukkit currently lacks is a UNIFORM API and help and permissions system. you people all seem to think Uniform means " YOUR PLUGIN has to do it this way or it wont work" Thats a fairly liner way to think about it.

    Unifrom is actually the way it has to go, but not the way you are suggesting it to be, the Uniform API has to be just a set of HOOKs that bukkit will then read from " skipping all details here"

    This way as a developer you can create any kind of layout you want ect bla bla and as long as you follow the set of rules " per say" in the API bukkit should then be able to talk with the plugin gather some information and then display it in its OWN help menu and same goes for permissions.

    As long as permissions use the set of rules supplied in an API it will be unisversaly compatible with almost anything else following the same set of rules.

    As for right its just all over the show sure your using bukkit plugin API but thats a foundation for making plugins not actually presenting them to the user. Right now people have differnt varying methods for doing this and this were you will find nothing but conflict.

    I will leave this opinon at that as thats mainly what it is and I'm not about to start a debate here in this theard about what is wrong with bukkit currently.

    - @Zenexer sorry about replying to that rant, I don't have any knowladge of coding my self but I have a basic understanding on what must be achived. I wont carry it any further as its basicly spam.

    I could be totally comming into this in the wrong direciton ect, so please forgive I dont have any history with such creations I just think that Policy if you will must be present before harmoney can be avhived between all plugins.
  8. Offline

    Don Redhorse

    i'm sorry if you see it as spam. but why do I need to edit a plugin to make it work with others? every plugin uses bukkit and bukkits api... so bukkit needs to supply an api to register help and commands and those commands needs to be UNIQUE otherwise it can't work. but I agree that it shouldn't be discussed here but in the thread I referenced.. I will not post here again about it.
  9. Offline


    Your half right, It does not need commands per say unique it just needs the API and the Help system ect, that everyone else can then refer bascily it just bukkit needs a middle man that everyone talks to and it the middleman is what bukkit talk to.

    Anyway we both should have just said that lol instead over complicating our explinations. I feel like such an idiot now for not just saying it that way to start with.

    Well so to get back on topic event tho tech its all on topic we are all talking about conflicting commands and the reason it happens is what we both have said in our posts.

    Anway you need to edit the plugin due the fact IT WONT work as you stated tho it wont work as currently same name commands cannot co exist and in effect cancle each other out. dumb I know but I think it happens with all plugins now.
    Don Redhorse likes this.
  10. Offline

    Don Redhorse

    well I will do that.. I just now need to figure out the inheritance in permissions to make my server work... comming from the IT and being used to interheritance, filters etc.. you have perhaps a different view on how permissions should work.. but that is a different plugin...
  11. Offline


    • /modgrp [Alias: /mod]: Moves a player to a Permissions group. (Caution: backup your permissions file first)

    (i use /mod username groupname)

    This doesn't works. It adds the nick to the Permissions config file but i still need to restart/reload the server for it to work. Am i doing something wrong?
  12. Offline


    I can help you if you use Niji permissions. Just look at mine and work from that.

    <Edit by Moderator: Redacted mediafire url>
    Last edited by a moderator: Dec 15, 2016
  13. Offline


    Yep, that's what happened. A simple test would have revealed this before releasing the fix, but...and I'm not bitching here, you devs do a great work. It just frustrates sometimes to find that there is a fix build which doesn't actually fix the problem. (To be honest, this fix DID fix the Java error problem with /help by reverting back. But you see, we are now back at where we started yesterday.)
  14. Offline


    Wait, what was wrong with help in the first place ? eh. I dont understand what reverting back has changed. In terms of its use that is.
  15. Offline


    If you haven't followed the discussion - please don't ask tor a recap, as that would take at least 3 pages of text.
  16. ah the goold old i=1 instead of i=0. Fixed, redownload from the same link.

    *ementalo is afk
  17. Offline


    You don't want to use it but if you do, no you don't have to restart you can simply use /pr or /reloadall I believe.
  18. Offline


    Yep, works now. Good job!
  19. This was reverted as it caused unwanted side effects, please use /pr (a permissions command) after
  20. Offline


    Oh ok sure should have just said it like that in the first place lol. That change is fine with me were not open to public right now.
  21. Offline


    Yeah it kinda killed my permissions config file. But i try to enter it manually and then use that command for reload.
  22. Offline


    Trying to catch-up on the activity in this thread... So, what does the future hold in store for this plugin? Is it possible to make it so that disabling a command in Essentials does not disable the command from other plugins? It seems possible from my perspective, as I am able to disable /warp and use MyWarp instead without any problems. However, when I disable /tp* and /home, I am unable to use the features of the TelePlus and MyHome plugins. So, Essentials seems to be doing it right with at least one command. :)

    It has been broken for a few days now, which is why I ask. The work-around is a bit messy but if it is the only way, then...

  23. Offline


    I'm glad you guys fixed that, I really hated having to tell people not to use a part of a plugin I endorse so much, but it made my helping on the permissions forum hell lol.
  24. Offline


    Am I going to have to edit plugin yaml file everytime theres an update to disable ban/kick so mcbans works?
  25. Offline


    They could just your little guys off at the wastes huh? I've never seen so many warp and tp plugins on one server, you don't walk anywhere 2 times lol.
    --- merged: Feb 4, 2011 12:10 PM ---
    Actually a smart person would just copy and paste, takes like 2 seconds.
  26. Offline


    The command /pr doesn't work-.-
  27. Offline


    We have 1 TP plugin and 1 Warp plugin. You've not seen that before? ;) They are mainly for moderators and admins though we have some main areas where players are allowed to warp. We also have 1 Home plugin for players. Essentials has other basic stuff we need.

    I prefer the one-plugin-for-one-purpose-model. I would rather see each of the Essentials commands become its own plugin. That way we could implement ONLY what we want and there would be a much lower risk of one plugin breaking another.

    I guess it is my security-mindedness that prefers things this way: If you do not need it, do not run it. It's always safer that way. :p
  28. Offline


    Since updating essentials everyone on my sever, even the people without permission (I am using permissions) can use the command /spawnmob :S it's kinda annoying when i'm trying to run a server that allows younger members. When I uninstall essentials the problem stops. I love the plugin but right now I just can't use it
  29. Offline


    /pr doesn't work for me.....
  30. Offline


    Are you sure the group you're in is permitted to use /pr? And are you sure that Permissions.jar is loaded?
  31. Offline


    I have...


    Fail xD
    I found it...
Thread Status:
Not open for further replies.

Share This Page