Inactive [GEN] Essentials v2.1 [?]

Discussion in 'Inactive/Unsupported Plugins' started by Zenexer, Jan 19, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. Offline


    I havent been here for a while but its cause everything is working perfect ! =)Love this plugin
  3. Offline


    it is done by inheritance, if a group inherits another group it can modgrp that group
    so u guys know too.
  4. Just tired this, get a message saying unknown item
    --- merged: Jan 29, 2011 11:04 PM ---
    /tpdeny denies
  5. Offline


    Whats the permission node for the spawn mob command? it isnt listed in the wiki
  6. Offline


    I understand that, but every plugin that I stack on adds more complications, and more risk to issues arising on the server. I don't need all the other stuff that the plugins you listed offer, and I've heard that people are having issues with world guard when more people log in. Since I run a closed server with just a few friends, it would be great if this command could be added. I'll wait to hear from the dev.
  7. essentials.spawnmob
    --- merged: Jan 29, 2011 11:49 PM ---
    I have just commited the code which should only show commands in /help that that user has access too. Once it has gone through the motions it will be released.
  8. Offline


    This might be unrelated to Essentials but after updating, WorldEdits //wand command doesn't work anymore. Updated WorldEdit. Didn't work.
  9. Offline


    more than that.. i can't get anything with an argument to work...
  10. Offline


    Everytime I try to /modgrp a player to a group I created, it gives me:

    error: You cannot add players to that group

    The console gives me an output with what seems to be the group inheritances when I enter that command as well:

    2011-01-29 18:03:25 [INFO] [PLAYER_COMMAND] Hexadecibel: /modgrp Banjora Vip
    {Vip=Default, Admins=Moderator, Moderator=Default, Builders=Default}

    I can move people to Admin, Moderator, and Default just fine though... And I know I have the config file in Permissions formated correctly.

    What am I doing wrong?


    Well hey! Its working!

    I was using an older version of LWC, once I updated it /modgrp magically worked correctly.
    Weird. But now I can move people to custom groups now! :D
  11. Offline


    Ok i've searched through all 46 pages and didn,t see anything related to my problem. i could have missed it so if i did im sorry.

    Is there a way to get this to play nice with CodeRedEconomy plugin ? Essentials is taken it over. Like when you type /balance it always reports 30 even if you buy or sell something. Also when you sell something it always sells for 1 even thow i setup the items.db file with all the prices. The money you get is also going to Essentials user.yml file instead of to CodeReds

    I tried asking over on CodeRedEconomy page but no reply yet. well any information is greatly appreciated. thanks for your time :)
  12. Offline


    Is there a reason /warp gives me errors???
  13. Offline


    i just modgrped and it totally ruined my permissions config. it added weird [ ] around all of the stuff it changed the permissions from

    - 'essentials.home'
    - 'essentials.sethome'

    [essentials.home, essentials.sethome]

    it did that to pretty much everything.

    Totally ruined all plugins upon modgrping as well, everything disabled including essentials, ichat, iconomy. Only worked again after I manually fixed permissions.

    Why is this plugin touching the permissions file in that way
  14. Offline


    Is there a list of the NPCs used with /mob? I'd like to know which mobs can be spawned. I can't seem to hit the right command for the "Monster"/aggressive human NPC, if it exists.

    I've also had an issue with /mob spawned Ghasts not despawning when the chunk is unloaded for a period of time lol. But, the forest fire wasn't that big, so oh well. [​IMG]
  15. Offline


    Heres my config:

    Do I have to reformat this for /modgrp to work? could someone explain how I would do that? Thanks
  16. Offline


    Slash /warp gives me null and setting a warp says no file!
    --- merged: Jan 30, 2011 5:08 AM ---
    Okay, everytime I try to use /help I get Permission Denied even though I have permmissons set right as I can use everything but /warp
  17. Offline


    Guys, whatever you did in the last update has broken most commands. BigBrother no longer works, nor does GodMode, and probably others.

    Why would you try and handle commands that belong to other plugins? Are these two plugins integrated into Essentials? If not, you shouldn't mess with commands already in use... I haven't had to rollback an Essentials update until now...
  18. Offline


    I had this as well and there was nothing wrong with the file. What had happened is I was changing permissions for people and deleted a few users from permissions.yml but there was still a reference in the essentials users.yml and it was causing a null reference. I hope this helps you!

    Took me forever to track down as the error message is worse than useless. In fact YML is the worst file format I've ever seen. Any decent parser should be able to remove characters that are not allowed and errors should reference the actual file where there is an error.
  19. Offline


    Why dont you read back a cpl pages and you will see why.
    --- merged: Jan 30, 2011 5:39 AM ---
    What do you mean reformat? That format says the same as the other one does, it just looks different, the code is still good and should not, or the devs here say, it should not effect functionality. Although I can't give my opinion on that because I won't use that command at all. I will edit my things manually!
    --- merged: Jan 30, 2011 5:45 AM ---
    Making a plugin better to cover more areas is what this is all about. I agree if the plugin does something different and uses a command that another plugin does then that's crazy, but if the plugin does the same thing then using the same command only makes sense as you want it when users switch to your plugin they don't have to get used to new commands.

    Essentials has already made MyWarp, MyHome, and General obsolete, and I think as long as they can effectively maintain the updating of the plugin and still add functionality to it's plugin then I say go for it.

    This is the reason I use this plugin now.
  20. Offline


    I know about MyWarp and MyHome, and those two commands work fine. But when you start messing with admin and protection plugins, you better make sure you've actually tested they work before putting it out in an update to your own plugin. LWC, BigBrother and GodMode are pretty important plugins to be taking responsibility for...
  21. Offline


    Hey, I'm not of the team but I think these guys know what they are doing.

    No it isnt, please stop posting on multiple threads and stay with one so people can help you.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  22. Offline


    Sure I did not rule it out all as a good idea was just saying if this was to happen the Disable feature in this plugin will have to undergo some changes so it not only disables the feature but stops it checking for it as well.

    Our server is complicated since we decide to add heavier plugins, I mean on a lag sense its not really adding to lag anymore then the current bukkit is by leaving MC bugs in place and not fixing them as right now I keep seeing new hooks every build thats great but leaving bugs behind is going to slow things down.

    For example the issue with redstone how if its not powerd correctly and its rapidly flashing its very laggy if your near it. I guess they will optimize it all when its relased when ever that is.

    I just wish they would hurry up with permissions API and make it truely multicore already thats were half the issues arise from to start with when you have plugin bulk plus surver running on one core your asking for issues.

    My out server has a Dedicated machine for it running only FTP and bukkit. It got 3gig of ram I dedicate 2gig to bukkit, the only negative side of our current server is I would not mind changing the amd x2 to a Intel core 2 duo as it would kick the snot out of whats in there now and probably allow us to run heavier loads with out issues.

    That simple fix really lol I just need a mainboard for socket 775 :p. and a couple os SATA drives. Our server runs on windows Server 2k8.
  23. Offline


  24. Offline


    Must just be you then as mine works fine with multiple plugins inc worldedit and worldguard both of these got updates recently and the recent version of bukkit broke most worldguard worldedit plugins. If you have this plugin and you did not configure it properly disabling what you dont need thats your fault.
  25. Offline


    So two plugins which I didn't list in my examples work? Wow, that's terrific.

    Thanks for a completely insightful and helpful post. The issue is it shouldn't handle commands already being used by existing plugins. This could be done by a quick scan of loaded/installed plugins and using some smarts to disable it automatically.

    I shouldn't have my configurations broken just because a plugin is written to override other author's commands.
  26. Offline


    Actually I just assume coz you use /god u was using worldedit, it too has a /god command, you going to to rip on that plugin as well ?.

    Sure maybe some internal smarts is needed but your ment to be one with the smarts to realize it shares commands and then react accordingly. I'm sorry I just find it ironic that you complain before you configure and test.

    I don't see how its effecting your bigbrother tho BB command completely seperate from this plugin.
  27. Offline


    BB is a seperate plugin, however the commands are being handled by Essentials as of the last update. I have not updated BigBrother yet the behaviour has changed, which means it could only be caused by Essentials.

    The only plugin that has been changed or updated between it working, and not working, is Essentials, at approximately 6AM on the 29/01/2011 Western Australian time. CraftBukkit was also updated, but if craftbukkit had broken, we'd know about it.

    Please stop telling me I am wrong when you obviously haven't a clue.
  28. Offline

    dark navi

    Not a huge deal, but every time I "/reloadall" I get this error:
    Jan 29, 2011 11:20:20 PM org.bukkit.plugin.SimplePluginManager callEvent
    SEVERE: Could not pass event PLAYER_COMMAND to Essentials
    java.lang.NoClassDefFoundError: com/bukkit/nidefawl/myGeneral/myGeneral
            at java.lang.Class.getDeclaredMethods0(Native Method)
            at java.lang.Class.privateGetDeclaredMethods(Unknown Source)
            at java.lang.Class.getMethod0(Unknown Source)
            at java.lang.Class.getMethod(Unknown Source)
            at org.bukkit.earth2me.essentials.EssentialsListener.onPlayerCommand(Ess
            at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.j
            at net.minecraft.server.NetServerHandler.c(
            at net.minecraft.server.NetServerHandler.a(
            at net.minecraft.server.Packet3Chat.a(SourceFile:24)
            at net.minecraft.server.NetworkManager.a(SourceFile:232)
            at net.minecraft.server.NetServerHandler.a(
            at net.minecraft.server.NetworkListenThread.a(SourceFile:104)
            at net.minecraft.server.MinecraftServer.h(
    Caused by: java.lang.ClassNotFoundException: com.bukkit.nidefawl.myGeneral.myGen
            at$ Source)
            at Method)
            at Source)
            at java.lang.ClassLoader.loadClass(Unknown Source)
            at java.lang.ClassLoader.loadClass(Unknown Source)
            ... 17 more
  29. Offline


    Have you updated craftbukkit and Essentials?
  30. Offline


    Actually craftbukkit has broken as of latest build, It broke worldguard and worldedit almost all of there commands. Go look it up there are even comments about it, That means its a hook that must be broken. I'm not saying its your issue but it could have ruined other plugins as well.

    Looks someone else "haven't a clue".
  31. Offline


    WARNING: A very recent Bukkit update broke all of WorldGuard's commands. Please hold on for a new version or downgrade your version of Bukkit.
Thread Status:
Not open for further replies.

Share This Page