Inactive [GEN] Essentials v2.1 [?]

Discussion in 'Inactive/Unsupported Plugins' started by Zenexer, Jan 19, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    Zenexer

  2. Offline

    fnullerbasse

    You welcome Zenexer ;D
     
  3. Offline

    M1sT3rM4n

    Same thing with rules :p
     
  4. Offline

    chill1977

    rules arent colore because default config doesnt have color, motd color is working fine with me, i just set it up for the first time, great plugin.

    @Zenexer wondering about adding day or night in the config file, is that to much to have it so we can set it to stay daytime for like creative worlds?

    Also, whe i add the {PLAYERLIST} to the motd it actually comes up as {PLAYERLIST} on my welcome screen, noone is on but me so is that common?
    --- merged: Jan 27, 2011 12:39 AM ---
    Code:
    # The number of items given if the quantity parameter is left out in /item or /give.
    default-stack-size: 64
    motd:
      - '&eWelcome, {PLAYER}! &e {IP}'
      - '&CType /help&f for a list of commands.'
      - '&aUPDATE: 1/26 18:00 New Essentials Plugin.'
      - '&aRead the /rules!!!'
      - '&aNew Blog at http://minecraftchill.blog.com'
    rules:
      - '[1] Be respectful'
      - '[2] Be ethical'
      - '[3] Use common sense'
      - '[4] No TNT use around others structures'
      - '[5] Do not use excessive amounts of TNT'
      - 'Breaking these results in 3 day ban'
     
  5. Offline

    SilverbladeNL

    Is it possible to turn off the tree command for pickaxes?
     
  6. Offline

    Alienware777

    What I do is give my members /tpc, /tpchere, and /accept. The only people I give /tp to is staff. That way members can't be abusing tp and trying to use it to find other users chests and the like, plus it would stop your problem.
     
  7. Offline

    sharkh20

    Leaving the nickname prefix blank causes the plugin to fail to load.
    Code:
    nickname-prefix: ''
    Placing any symbol in there lets the plugin load.
     
  8. Offline

    M1sT3rM4n

    Did anyone else have problems with colored MOTD?
     
  9. Offline

    mattmoss

    Does Essentials protect an area around the /setspawn point? I tested an area by digging a hole, which worked; then /setspawn; then attempted digging again and failed (blocks respawn).

    Assuming Essentials is doing that, is there a way to disable that protection? I'd rather use WorldGuard or something else where I can set owner/builders/etc.
     
  10. Offline

    chill1977

    I would say the problem is in your code, if you want to post it maybe we can help, but no , there are no problems with the current build.
     
  11. Offline

    M1sT3rM4n

    Here they are:

    Didn't have problems with then until I updated to 118.
     
  12. Offline

    chill1977

    Anywhere the spawn point is will be that way, that's with minecraft
    --- merged: Jan 27, 2011 12:58 AM ---
    I have no problem getting color with that, I'm using craftbukkit 135 and the latest release here.
     
  13. Offline

    ementalo

    There maybe some changes coming with these... :D
     
  14. Offline

    Nate204

    I <3 you. LMAO, Just made my day!
    THANKS!
    --- merged: Jan 27, 2011 1:12 AM ---
    AHHH! Like what!? That was perfect! No more random -"Hey Admin! How-ya doin!? Wanna come see my castle!?! DO YA DO YA DO YA!!!!!" - crap-tastic TP. I could finaly get a better hold on my members.

    They're free to do what ever, but Admins need to have some structure. Just standing around waving a Ban hammer in peoples faces is a good way to lose a LOT of "worth it" members.
     
  15. Offline

    wwZaraki

    How do I make it so I can use all the commands? It says I don't have permission to use some of the commands...
     
  16. Offline

    ementalo

    Just extending it
     
  17. Offline

    jpDIV

    Essentials isn't working with build 152. Latest version of essentials, I start up my craftbukkit and it outputs this:

    Code:
    2011-01-26 19:15:22 [INFO] Starting minecraft server version Beta 1.2_01
    2011-01-26 19:15:22 [INFO] Loading properties
    2011-01-26 19:15:22 [INFO] Starting Minecraft server on *:25565
    2011-01-26 19:15:23 [INFO] Preparing level "world"
    2011-01-26 19:15:23 [INFO] Preparing start region
    Preparing spawn area: 32%
    Preparing spawn area: 81%
    2011-01-26 19:15:26 [INFO] [Guardian] version [1.2] (Helmet) loaded
    2011-01-26 19:15:26 [INFO] [iChat] version [1.2] (Future Dairy) loaded
    2011-01-26 19:15:26 [INFO] [Permissions] version [1.8] (Handler) loaded
    2011-01-26 19:15:26 [INFO] WorldEdit 2.14.2 loaded.
    2011-01-26 19:15:26 [INFO] WorldEdit: Permissions plugin detected! Using Permiss
    ions plugin for permissions.
    2011-01-26 19:15:26 [INFO] WorldGuard 3.0b2 loaded.
    2011-01-26 19:15:26 [INFO] WorldGuard: Permissions plugin detected! Using Permis
    sions plugin for permissions.
    2011-01-26 19:15:26 [INFO] WorldGuard: Single session is enforced.
    2011-01-26 19:15:26 [INFO] WorldGuard: TNT ignition is blocked.
    2011-01-26 19:15:26 [INFO] WorldGuard: Lighters are blocked.
    2011-01-26 19:15:26 [INFO] WorldGuard: Lava fire is blocked.
    2011-01-26 19:15:26 [INFO] WorldGuard: All fire spread is disabled.
    Jan 26, 2011 7:15:26 PM org.bukkit.plugin.SimplePluginManager loadPlugins
    SEVERE: Could not load plugins\Essentials.jar in plugins: null
    org.bukkit.plugin.InvalidPluginException
            at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.j
    ava:84)
            at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.
    java:117)
            at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager
    .java:82)
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:43)
            at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:153)
            at net.minecraft.server.MinecraftServer.c(MinecraftServer.java:140)
            at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:104)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:177)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:512)
    Caused by: java.lang.reflect.InvocationTargetException
            at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    
            at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
    
            at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Sou
    rce)
            at java.lang.reflect.Constructor.newInstance(Unknown Source)
            at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.j
    ava:82)
            ... 8 more
    Caused by: while parsing a block mapping
     in "<reader>", line 2, column 1:
        version: 32
        ^
    expected <block end>, but found Scalar
     in "<reader>", line 5, column 33:
        motd: '&cWelcome, {PLAYER}! Don't forget to check out the forums ...
                                        ^
    
            at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappingKey.produce(Par
    serImpl.java:576)
            at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:163)
            at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(ParserImpl.java:148)
            at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java
    :228)
            at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
            at org.yaml.snakeyaml.composer.Composer.composeDocument(Composer.java:12
    2)
            at org.yaml.snakeyaml.composer.Composer.getSingleNode(Composer.java:105)
    
            at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseCons
    tructor.java:124)
            at org.yaml.snakeyaml.Yaml.load(Yaml.java:264)
            at org.bukkit.util.config.Configuration.load(Configuration.java:62)
            at org.bukkit.plugin.java.JavaPlugin.<init>(JavaPlugin.java:46)
            at org.bukkit.earth2me.essentials.Essentials.<init>(Essentials.java:38)
            ... 13 more
    Take yourself wonder by wonder, using /magiccarpet or /mc. Magic Carpet version
    1.3 is enabled!
    2011-01-26 19:15:26 [INFO] MCBans: Permissions plugin found, switching to its pe
    rmissions!
    2011-01-26 19:15:26 [INFO] MCBans: MCBans version 2.2 is enabled!
    2011-01-26 19:15:26 [INFO] MCBans: Voting enabled!
    2011-01-26 19:15:26 [INFO] MCBans: Starting backup thread...
    2011-01-26 19:15:26 [INFO] MCBans: Checking mcbans server....
    2011-01-26 19:15:28 [INFO] [MYHOME]: 34 homes loaded
    2011-01-26 19:15:28 [INFO] [MYHOME] Permissions enabled.
    2011-01-26 19:15:28 [INFO] MyHome 1.7.2 enabled
    2011-01-26 19:15:28 [INFO] [MYWARP] Connection with MyHome established.
    2011-01-26 19:15:28 [INFO] [MYWARP]: 175 warps loaded
    2011-01-26 19:15:28 [INFO] [MYWARP] Permissions enabled.
    2011-01-26 19:15:28 [INFO] MyWarp 1.8.2 enabled
    2011-01-26 19:15:28 [INFO] [TELEPLUS] Permissions enabled.
    2011-01-26 19:15:28 [INFO] TelePlus 1.5.3 enabled
    2011-01-26 19:15:28 [INFO] Done! For help, type "help" or "?"
    2011-01-26 19:15:31 [INFO] MCBans: Mcbans is online!
    138 recipes
    
    
     
  18. Offline

    ementalo

    your yam'l file is not formatted correctly, open it in notepad++ and it will give you hints
     
  19. Offline

    chill1977

    permissions:
    - '*'
     
  20. Offline

    wwZaraki

    Sorry I don't know what that means...
     
  21. Offline

    Nate204

    You need to download the Permissions plugin (at the top of the page they provide a link). Then, go into the config file and add:
    - '*'
    To your group. In this case, I would assume you would put yourself in the admin group.
    Then add that line into the permissions section. It will let you use all commands for every plugin supporting the Permissions plugin.
     
  22. Offline

    wwZaraki

    Ok I just did that but I have a server through Servercraft.co how do I upload it on the server that way?
     
  23. Offline

    lavagod

    Can someone help me with this? I added the below to the Config.yml appended to the bottom of the Disable stuff and its not working.

    teleport-cooldown: 300

    Below is a snip of the config where I have it

    Code:
    disable-tpc: false
    disable-accept: false
    disable-essentials: false
    teleport-cooldown: 300
    
    # Restricted commands will only be available to ops.
    # These will have NO EFFECT if you have Permissions installed!
    # These are here only if you want something simpler than Permissions.
    restrict-tp: true
    restrict-tele: true
     
  24. Offline

    Zenexer

    Big update:
    - Added /modgrp (alias: /mod) that allows you to dynamically change which Permissions group a user is in
    - Added /delwarp and warplist via /warp (or, rather, ementalo did ;) )
    - Refined /list--sorry, due to a Minecraft bug, I also had to remove all color :(

    @wwZaraki If you are in ops.txt, you will automatically be able to use all commands.

    @M1sT3rM4n You should not being having issues with a colored MotD. The coloring in /list, however, has been removed.

    @mattmoss Essentials does not do spawn protection: Minecraft itself does. :(

    @chill1977 Update to a newer version, and that problem should cease. :)

    @lavagod You can't test it yourself--ops override the cooldown. :D
     
  25. Offline

    M1sT3rM4n

    Check my MOTD code from a few posts back. I didn't change anything but it doesn't show colors now :\
     
  26. Offline

    chill1977

    The post directly above says he removed color, guess i still have an older version with color and i'll keep it for a bit lol

    I just tried the jar at the download link at the top and i still have color working fine ;)
     
  27. Offline

    M1sT3rM4n

    Do you mean only from /list, or from MOTD and rules as well?
     
  28. Offline

    Zenexer

    I only removed color from /list, not /motd, though you can still crash clients if you aren't careful with your MotD
     
  29. Our server will be running this very soon[​IMG]
     
  30. Offline

    chill1977

    Oh cool, I'm having no problems with b119 and craftbukkit 135 , the motd colors are fine. /list colors i dont care about lol thanks for the update

    {PLAYERLIST} now works as well
     
  31. Offline

    sumTard

    could you make it so we can disable the /g alias for give? that way it doesnt conflict with the guild chat command in the guilds plugin (its also /g) thanks!!
     
Thread Status:
Not open for further replies.

Share This Page