Inactive [GEN] Essentials v2.1 [?]

Discussion in 'Inactive/Unsupported Plugins' started by Zenexer, Jan 19, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. Offline


    Still no tabs, unfortunately, but then I don't mind spaces myself. Actually, I'm guilty of using them for indentation elsewhere too.

    I think it's pretty understandable that YAML would disallow either tabs or spaces for indentation since it causes headaches with Python allowing both, but unfortunately they chose to disallow what I guess many people think was the wrong choice. I think it's good that they don't allow mixing them, at least. I'm not sure why tabs aren't allowed in the inline syntax, though, since indentation doesn't even count there.
  3. Offline


    I can't get /give to work on essentials it worked fine on general

    help plz

    Invalid Item ID

    or something like that
  4. Offline


    @InhumanSkills What item are you trying to spawn, and what is the command that you are using (the entire thing)?

    @Eris Ah, then never mind, I won't make the config too verbose. ;)
  5. Offline


    Gee I am glad you posted so quickly. I had the backup ready to restore. Haven't updated the plugin yet but problem did go away after 5 minutes. It didn't even occur to me that the null item could be on the map. Waiting makes sense. I must have made good time getting back to the area from spawn when I last tested it! All is well! Thanks again!
  6. Offline


  7. Offline


    can we not have ops names default to a certain color? I have specific colors defined with iChat instead and your plugin overwrites them. :(
  8. Offline

    Charles Harvey

    Not sure if I'm doing something wrong; but every time I edit the config.yml and restart the server it appears to revert to its previous form. Have tried editing with nano as well as notepad via ftp client. Sorry if I missed anything regarding this but help would be appreciated.
  9. Offline


    /give 344 30 or /i 344 30 do not work.
  10. Offline


    Yea just any item. None work /give 1 64 for instance
  11. Offline


  12. Offline


    ohh ok but why is it still listed under /help?
  13. Offline


  14. Offline


    OHHH ok figured it out. Thank you might want to add that to the front page and if not just have it say /give 1 64
    "invalid user" or something since "1" is not a user and this line will let people know it is for "giving"
  15. Offline


    Yeah, Can't use the /i or /g to give my self eggs at all. Also Idea if the number of the item is not given make it give only 1 and not a stack. Also use like 35:4 to give our selfs colored wool
  16. Offline


    I'm experiencing server lag when certain people log in. It lasts for 5-10 seconds, and during the time they are stuck at "Downloading Terrain". The console outputs "Can't keep up!". Once they are connected, they are fine.

    While in #bukkit on IRC, another person reported the same problem. The lag goes away completely if we disable Essentials.

    Plugin list:


    Other Person (Zhiland)

    If I am around, you are more than welcome to use my server to reproduce the problem. I can have the person that it happens with log in whenever.

    Edit: While on another server, I noticed the same lag when someone logged in. Asked them, they have essentials too. Perhaps it is a common issue atm? Was also not an issue with General.
  17. Offline


    /Who and /List crash the server
  18. Offline


    Whenever I try to use a commands my console just gets spammed with errors and nothing happens. halp
  19. Offline


    Sorry if this was already asked, but how do you escape characters in the motd? It breaks if I want to use an apostrophe in the motd.
  20. Offline


    Your help system is still clobbering the internal help of other plugins.
    petteyg359 likes this.
  21. Offline


    @Nipper You can change the stack size in config.yml (set it to 1). You can already do 35:4. ;)

    @AskCharlie The latest update should fix that bug.

    @Jezarith Try deleting your config file. Perhaps the MotD is the issue? If not, I think it's a Bukkit bug, because that's the only on-login event. I'll talk to you on IRC in a moment. Note that this is a very common problem without Bukkit, and indicates that you need a better hard drive. Normal SATA/PATA hard drives are inadequate for running large maps. You should use an SLC SSD (best) or striped RAID array, preferably with Ultra320 SCSI HDDs.

    @Apoc_8bit Double-apostrophe to escape an apostrophe. 'Welcome to the Eternity''s End Server' for example. That's two apostrophes, not a double-quote.

    @Shippage Can you show me some of the errors?

    @Beatkidz Perhaps you have another plugin interfering? They shouldn't do that. Those are pretty basic commands. In fact, this plugin should be unable to crash the server whatsoever.

    @ewe2 You can disable it in the config.

    - Removed redundant /help message
    - Added new permissions node for /heal-ing other players: essentials.heal.other
    - Added economy system. Add "cost-xxxxx: 30" in the config to charge 30 for command /xxxxxx.
    - Added /eco give and /eco take.
  22. Offline


    Some reason disabling commands still shows them in /help
  23. Offline


    @Kane Good catch, Kane; fixing that now.
  24. Offline


    This is what it looks like when using /time day, I get an error whenever I do any command.
    This is from a brand new clean install of Essentials, my only other mods are AreaChat and HotSwap.

  25. Offline


    Can you add these commands (taken from the original Minecraft server vanilla software):
    /op (Makes an user an OP, correct usage would be /op Bobby)
    /deop (Makes an OP user a normal user, correct usage would be /deop Bobby)
    /stop (Saves chunks and gracefully stops the server and shuts down Bukkit)
    /save-all (Forces a server wide save.)
    /save-off (Turns off level saving.)
    /save-on (Turns on level saving.)
    /say (Gives a server wide message in purple. I.e, /say Server is going down for five mins)
    /kill (Makes the user kill themselves, returning them to the spawn point. Useful for getting stuck or lost. Also can be used in the form of /kill <username> by admins/mods)
    /me (says something IRC style. Correct usage would be /me eats some cheese, and would come out as "LaDestittute eats some cheese")
  26. Offline


    Those commands are already in the console. In-game just type /#commandname to use them.

    My MotD still displays the motd that the first person who logs in gets, to everyone else.
  27. Offline


    Getting Error:0 when i try to use any commands
  28. Offline


    Sooo so glad this now works with permissions plugin...its a great day :D
    thanks x 10000
    My 3 fav plugins all now have permissions (working)
    WorldEdit, Essentials, and Permissions weoo
  29. Offline


    Error: 0 when i use /who or /home or most commands.
  30. Offline


    when i manage plugins. after unloading one and reloading it the red version of it still stays
  31. Offline


    Same here
Thread Status:
Not open for further replies.

Share This Page