Inactive [GEN] Essentials v2.1 [?]

Discussion in 'Inactive/Unsupported Plugins' started by Zenexer, Jan 19, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. Offline


    is there any way to allow different groups to go to different worlds in multiplayer? like allow only donators to go to the donator world and stuff instead of having anyone can go to any world?
  3. Offline


    This bug needs to be fixed -_-
  4. Offline


    Also, a god mode fix is in order, it has been stuck on go mode for a long time...
  5. Offline


    Can anyone answer this? I so badly want a Nether :)
  6. Offline


    Don't put a border in the nether, and don't let them make default nether gates.

    I run a server with 5 worlds connected to eachother. I use the WormholeXTreme plugin to let players travel between worlds. I have all of Essentials' nether options disabled so there aren't any conflicts. Basically just make a new world with hellworld=true. Build a stargate near the nether spawn using WormholeXTreme and then load your other map back up and build a stargate there.

    Your players will be able to go back and forth via stargates, but they won't be able to build any additional gates. A border on the nether would no longer be necessary, especially considering that traveling long distances in the nether is nearly impossible because of all the Ghasts.
  7. Offline


    Can a player's group be changed from the game's command line? Every time I want to change someone's group, I have to edit three files and place four redundant lines in each file. Then I have to restart the server. Just reloading Essentials doesn't do it.
    I believe you escape them with another apostrophe:

    The '' are two single quotes, not a double quote.
    osholt likes this.
  8. Offline


    sorry if this has been answered, but is there a setting to add a delay to the world portal effect? not the command based ones, but the actual gates themselves, so that you have to stand still for like 5 seconds?
  9. Offline


    Put two single apostrophes together like so:
          suffix: ''
    That will shut it up instantly.
    You can easily change a players group with manpromote or mandemote.
        description: Promote a player in the same heritage line to a higher rank.
        usage: /<command> <player> <group>
        permission: groupmanager.manpromote
        description: Demote a player in the same heritage line to a lower rank.
        usage: /<command> <player> <group>
        permission: groupmanager.mandemote
  10. Offline


    anyone got protect working, whether I use mysql or sqlite, nothing works and no errors in terminal..?
    # +------------------------------------------------------+ #
    # |                 EssentialsProtect                    | #
    # +------------------------------------------------------+ #
      # Database settings for sign/rail protection
      # get mysql.jar and sqlite and place it in your serverroot/lib directory from here:
      # mysql, sqlite or none
      datatype: 'mysql'
      # If you specified MySQL above, you MUST enter the appropriate details here.
      # If you specified SQLite above, these will be IGNORED.
      username: 'UsernameSet'
      password: 'PasswordSet'
      mysqlDb: 'jdbc:mysql://localhost:3306/minecraft'
      # For which block types would you like to be alerted?
      # You can find a list of IDs in plugins/Essentials/Items.db after loading Essentials for the first time.
        # 10: lava
        # 11: still lava
        # 46: TNT
        on-placement: 10,11,46
        # 1: rock (just an example--doesn't actually do much)
        on-use: 1
        # 46: TNT
        on-break: 46
      # Users cannot PLACE these types of blocks/items.
      # < 255 designates a BLOCK
      # > 255 designates an ITEM (Some blocks can be placed as blocks OR items; lava blocks can be placed by lava buckets, for example.)
        placement: 327,326,14,56,46,11,10,9,8
        usage: 327,326,325
      # General physics/behavior modifications
        lava-flow: false
        water-flow: false
        water-bucket-flow: false
        fire-spread: false
        lava-fire-spread: false
        flint-fire: false
        tnt-explosion: false
        creeper-explosion: false
      # Protect various blocks.
        # Protect all signs
        signs: true
        # Prevent users from destroying rails
        rails: true
        # Blocks below rails/signs are also protected if the respective rail/sign is protected.
        # This makes it more difficult to circumvent protection, and should be enabled.
        # This only has an effect if "rails" or "signs" is also enabled.
        block-below: true
       # Prevent placing blocks above protected rails, this is to stop a potential griefing
        prevent-block-on-rails: true
      # Disable various default physics and behaviors
        # Should fall damage be disabled?
        fall: false
        # Users with the essentials.protect.pvp permission will still be able to attack each other if this is set to true.
        # They will be unable to attack users without that same permission node.
        pvp: false
        # Should drowning damage be disabled?
        # (Split into two behaviors; generally, you want both set to the same value)
        drown: false
        suffocate: false
        # Should damage via lava be disabled?  Items that fall into lava will still burn to a crisp. ;)
        lavadmg: false
        # Should arrows cause damage?
        projectiles: false
        # This will disable damage from touching cacti.
        contactdmg: false
        # Burn, baby, burn!  Should fire damage be disabled?
        firedmg: false
        # Should people with build: false in permissions be allowed to build
        # Set true to disable building for those people
        build: false
  11. Offline


    Does anyone know how to fix the warps problem?
    I create a warp and it works but when I restart the server the warps are still in the file but ingame it says not warps defined, so it's not loading the warps from the file I guess.

    Anyone know what I've done wrong?
  12. Offline


    have u updated? I had this prob yesterday.. I use CraftBukkitUpToDate.jar.. very helpful
    have u updated? I had this prob yesterday.. I use CraftBukkitUpToDate.jar.. very helpful
  13. Offline


    FYI most problems that have recently been complained about are a direct result of the Essentials/config.yml file not actually reading any changes being made to it.
  14. Offline

    David Holt

    Having some problems here, please help me out.

    05:34:31 [INFO] Starting minecraft server version Beta 1.3
    05:34:31 [INFO] Loading properties
    05:34:31 [INFO] Starting Minecraft server on
    05:34:31 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-527-
    g41b0e89-b538jnks (MC: 1.3)
    05:34:31 [INFO] Preparing level "LegendsCraft"
    05:34:31 [INFO] Preparing start region
    05:34:32 [SEVERE] Could not load plugins\Essentials.jar in plugins: null
            at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.
            at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(
            at net.minecraft.server.MinecraftServer.e(
            at net.minecraft.server.MinecraftServer.a(
            at net.minecraft.server.MinecraftServer.d(
    Caused by: while parsing a block mapping
     in "<reader>", line 32, column 1:
        nickname-prefix: '~'
    expected <block end>, but found BlockMappingStart
     in "<reader>", line 339, column 3:
          announce-format: '&dWelcome {DIS ...
            at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappingKey.produce(Par
            at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(
            at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(
            at org.yaml.snakeyaml.composer.Composer.composeMappingNode(
            at org.yaml.snakeyaml.composer.Composer.composeNode(
            at org.yaml.snakeyaml.composer.Composer.composeDocument(
            at org.yaml.snakeyaml.composer.Composer.getSingleNode(
            at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseCons
            at org.yaml.snakeyaml.Yaml.load(
            at org.bukkit.util.config.Configuration.load(
            ... 8 more
    05:34:32 [INFO] [Permissions] version [2.5.4] (Phoenix) was Initialized.
    05:34:32 [INFO] Loaded EssentialsChat build 2.0.294 by Zenexer, ementalo, Aelux,
     Brettflan, KimKandor, snowleo and ceulemans.
    05:34:32 [INFO] [Permissions] version [2.5.4] (Phoenix)  loaded
    05:34:32 [INFO] Done (0.108s)! For help, type "help" or "?"
  15. Offline


    Hi, the integration of the big zoo of .jars in one .jar did fix the /pay command for me, finally :D, thanks.

    Still, is there any hope of getting chest-shops? the 1 stack limit prevents easy trade in weapons/tools and food.
  16. Offline


    That appears to be a Group Manager command. I am using Essentials because Permissions wouldn't work with Group Manager installed.
  17. Offline


    Using Craftbukkit version git-Bukkit-0.0.0-516-gdf87bb3-b531jnks (MC: 1.3) and Essentials build 2.0.285.

    The /nick command is enabled and players can get a ~nickname. When doing a /whois on the nick, I don't see any output. When doing a /whois on the real name, I do get the information. Shouldn't it work for nicks too?

    Additionally, the /whois shows a bit too much information that isn't too relevant in my opinion. Wasn't there a /realnick command before? Just one line that shows '~nickname is realname'.
  18. Offline


    The nether generation despite being disabled in the config is now fixed in 2.0.294. Thanks to whichever dev sorted that out!
  19. Offline


    GroupManager is built in to Essentials now. Get it, it's a vast improvement over Permissions.
    This is a simple fix. You have tabs in place of spaces. Change the tabs to spaces and save it in UTF-8.
  20. Offline


    Would anyone like to link me the Essentials they use for Bukkit #493?
    Would be muy bueno.
  21. Offline


    Would it be possible to modify all English sentences by that of another country without having to modify the source code?

    Or it's possible this option will appear in the future? Thank you in advance :).
  22. Offline


    I looked in the /plugins/essentails/config.yml file and saw that it has a item/block blacklist ( :D ) how do you activate it?
  23. Offline


    Thank you!!

    I've was wondering how to do that for ages!
  24. Offline


    I updated to the latest version, and its filled with bugs. I opped someone and they didn't even get a red name, also with GroupManager it will work with 1 user and not 5 others.

    Any loads of other servers im hosting are getting the same issue
  25. Offline


    If the title of this forum doesn't change, it probably means you shouldn't update beyond that version at this time unless you like to play with fire. Also keep to the recommended CB version which is currently #531.

    @essentials devs: I'm on CB #554 with E2.0.294 - Finding things going ok except for economy signs, specifically trade are acting a bit funny. Seems like they are operating in reverse... and buying 1 out of a stock of 20 gives you 19... (this is a dev server just FYI, unlike other ppl I don't go posting to production without thorough testing)
  26. Offline


    can anyone tell me where i am going wrong with my permissions? every time i load up this group.yml file all my mods stop working and everyone is either default or op and thats it.

    Attached Files:

  27. Offline


    Come on, You may not jail that person? What's the fucking deal? I've asked three times now.
  28. Offline


    I get an error:null when i try to tjail someone. hasn't worked for several builds now. It says they are being jailed, but then the red error:null. Useless.
  29. Offline


    This version of Essentials seems to work with the newest CraftBukkit- so does the configs.
    So something messed up in between versions of Essentials.
    I'm using this version for now, no problems with it thus far anyway.
  30. Offline


  31. Offline


    You need to fix your MOTD, can't have an unescaped ' in it. Paste this in:

    - '&fPlease type &c/help&f if it''s your first time online.'

    Anyway, real question:

    /reload has caused Essentials to break ever since v272. I use that command a lot and this is keeping me from upgrading! Any fix in sight?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
Thread Status:
Not open for further replies.

Share This Page