Inactive [GEN] Essentials v2.1 [?]

Discussion in 'Inactive/Unsupported Plugins' started by Zenexer, Jan 19, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. Offline


    Might anyone tell me what I'm doing wrong when everything works except for EssentialsEco? The kit works and it costs money etc. Yet I can't utilize the basic commands like /sell /balance /eco. I've downloaded the EssentialsEco.jar so that shouldn't be a problem!
  3. Offline


    If it don't look like that remake the config.yml or just open the Essentials.jar with 7zip/Winrar.
  4. Offline


    I opened Essentials.jar with WinRAR and changed what you said but i have still two times "Admin" or "User".
  5. Offline


  6. Offline

    Amin Azman

    how to disable eco?
  7. Offline


  8. Offline


    hey, i´ve updated to the new essentials and now all players have they ranks doubled up..
    like so:

    [Villager][Villager]Xin_Tiger: bla bla bla

    how do i remove the first rank in gray?
  9. Offline


    I have deleted the command "eco" in plugins.yml in the jar. Sorry, I can delete my Post when you want.
  10. Offline


    I just use iConomy, then let eco stay on the side.
    Doesnt seem to be used at all.
  11. eco only does something if you set it up :D
  12. Offline


    maino, there's no way you could have deleted eco. It's linked into literally every command. Its roots are too deep. You might be removing the commands, but you're not removing what people consider to be the bloat. :p
    MationMac likes this.
  13. Offline


    Is the [Mail] sign broken/not implemented? all other Signs work fine but the Mail one never seems to work, not even for me with all permissions granted.
  14. Offline


    So, what's the command line that I need to add so I can disable the essentials warp and use MyWarp again.
  15. Offline


    I think Essentials conflicts with Towny. I cant use any commands when i use both Plugins:

    2011-03-11 18:43:43 [INFO] §9[PLAYER_COMMAND] Moe041991: /sethome 
    2011-03-11 18:43:43 [SEVERE] java.lang.NoSuchMethodError: com.earth2me.essentials.User.get(Lorg/bukkit/entity/Player;Lorg/bukkit/Server;)Lcom/earth2me/essentials/User;
    2011-03-11 18:43:43 [SEVERE] 	at com.earth2me.essentials.home.EssentialsHomeWorker.onCommand(
    2011-03-11 18:43:43 [SEVERE] 	at com.earth2me.essentials.home.EssentialsHome.onCommand(
    2011-03-11 18:43:43 [SEVERE] 	at org.bukkit.command.PluginCommand.execute(
    2011-03-11 18:43:43 [SEVERE] 	at org.bukkit.command.SimpleCommandMap.dispatch(
    2011-03-11 18:43:43 [SEVERE] 	at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
    2011-03-11 18:43:43 [SEVERE] 	at net.minecraft.server.NetServerHandler.c(
    2011-03-11 18:43:43 [SEVERE] 	at
    2011-03-11 18:43:43 [SEVERE] 	at net.minecraft.server.NetServerHandler.a(
    2011-03-11 18:43:43 [SEVERE] 	at net.minecraft.server.Packet3Chat.a(SourceFile:24)
    2011-03-11 18:43:43 [SEVERE] 	at net.minecraft.server.NetworkManager.a(SourceFile:230)
    2011-03-11 18:43:43 [SEVERE] 	at net.minecraft.server.NetServerHandler.a(
    2011-03-11 18:43:43 [SEVERE] 	at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    2011-03-11 18:43:43 [SEVERE] 	at net.minecraft.server.MinecraftServer.h(
    2011-03-11 18:43:43 [SEVERE] 	at
    2011-03-11 18:43:43 [SEVERE] 	at
  16. Offline

    Boon Pek

    Essentials is as bad as ever, despite it being my server's main plugin for over a month. The merging of all the files have led to useless commands, clogging up server space and some potential conflict. I have been getting messages like the one above, and would like to see it fixed ASAP as I like Essentials and trust it for I have been utilising it for a long time.
    Otherwise, I'd have no other choice but to move to another more stable plugin D:
  17. Is nether borked? My players can enter, but cannot leave.

    Double-checked and permissions are set to essentials.portal, and portals are enabled in the essentials config. Forgive me if this has been mentioned already.
  18. Offline


    @HH Try having them /home twice. That normally fixes things for me and mine.
  19. Offline


    The requested URL /bukkitEssentialsSpawn.jar was not found on this server.
  20. Offline


    It's a typo on the page. Throw a / between bukkit and Essentials.
  21. Offline


    ah didn't see that...DOH!... long day at work :(
  22. Offline



    can somebody help me with this plz?
  23. Offline


    I'm using GroupManager, HeroChat and Essentials - Essentials is the one responsible for /who and /motd.
    Is it possible to define the Message and the Colors of /who in the same way as you can modify /motd?
    Additionally, Is it possible to enable prefix and suffix in /who and in {playerlist} in /motd?
  24. Offline


    Conflicts with Essentials. I tried Jobsti's settings over and over, couldn't get it to display like his. Players names remained pink no matter what. Was really bugging me, thought maybe I typed something wrong... I literally spent 20+ min going through the config over and over to try and figure out where I went wrong. Finally I was just about to give up, then I thought maybe another plugin was causing the players names to be pink. So I disabled my plugins one by one, finally when I disabled Essentials, the names were formated as dictated in the permissions config.​
  25. Offline


    There's no way to easily search this thread...could someone tell me how to disable certain Essentials functionality? It specifically says "Don't worry: you alternative plugins will still work!" but it's conflicting. :X
  26. Offline


    go to /plugins/Essentials/config.yml and eddit the following section.

    -----------------------------------------+ #
    # |                   EssentialsChat                     | #
    # +------------------------------------------------------+ #
    # If EssentialsChat is installed, this will define how far a player's voice travels, in blocks.  Set to 0 to make all chat global.
    # Note that users with the "" permission will hear everything, regardless of this setting.
    # Users with can override this by prefixing text with an exclamation mark (!)
    # Or with can override this by prefixing text with a question mark (?)
      radius: 0
      # If you want the default chat format, uncomment the next line and comment the other format.
      #format: '<{DISPLAYNAME}> {MESSAGE}'
      format: '&7[{WORLDNAME}]&f {DISPLAYNAME}&7:&f {MESSAGE}'
      # You can also have group-specific formats:
        Default: '{WORLDNAME} {DISPLAYNAME}&7:&f {MESSAGE}'
        Admins: '{WORLDNAME} &c[{GROUP}]&f {DISPLAYNAME}&7:&c {MESSAGE}'
    the line your looking for is this.

    format: '&7[{WORLDNAME}]&f {DISPLAYNAME}&7:&f {MESSAGE}'

    this is mine already changed. where the above says WORLDNAME the default says GROUP, which your permissions or groupmanager is already posting, hence why its twice. by changing it to WORLDNAME it will show the world they are on instead then group then name then message. just remove &7[{WORLDNAME}]&f or &7[{GROUP}]&f to not use either.

    hope this helps.

    What functions are you trying to remove. ill assist you.
  27. Offline


    Hi, I have problem. Whenever i use the /time night command monsters dont spawn naturaly on land (Idk how it works for underground) and i need to reload bukkit for them to spawn again BUT when i reload it all essentials crash and none of essentials commands work. This happens only when any palyer is on server. Im using craftbukkit440 (mainly) and the following plugins:

    And i checked them all, none seemed to cause the error. I also tried it with craftbukkit470, 531 and 537. Also the recomended by Essentials wiki 516. None of them fix the error. Im running the server on Ubuntu 10.10.

    I hope you can help and sorry but i really cant find much help on wiki and on this forum about it.


    P.S. Yay my 1st post on bukkit forums
  28. Offline


    Did you update essentials today? and follow the instructions? if not check the 1st post here, you need to delete alot of old essentials plugins as they are merged into one now.
  29. Offline


    How does this work exactly? By this I mean, when I download it off the website do I download that package? The Essentail.jar? or what?
  30. Offline


    Ah, nope I didn't update anything. I actually started bukkit like 2 days ago and when i downloaded essentials it was 1 plugin all together already.
Thread Status:
Not open for further replies.

Share This Page