Inactive [GEN] Essentials v2.1 [?]

Discussion in 'Inactive/Unsupported Plugins' started by Zenexer, Jan 20, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. Offline


    Hi, this is just a little problem with the /spawn command, it doesn't work and gives this error:
    Code (Text):
    1. 2011-02-27 17:27:54 [SEVERE] java.lang.NullPointerException
    2. 2011-02-27 17:27:54 [SEVERE]    at com.earth2me.essentials.spawn.EssentialsSpawn
    3. Worker.onCommand(
    4. 2011-02-27 17:27:54 [SEVERE]    at com.earth2me.essentials.spawn.EssentialsSpawn
    5. .onCommand(
    6. 2011-02-27 17:27:54 [SEVERE]    at org.bukkit.command.PluginCommand.execute(Plug
    8. 2011-02-27 17:27:54 [SEVERE]    at org.bukkit.command.SimpleCommandMap.dispatch(
    10. 2011-02-27 17:27:54 [SEVERE]    at org.bukkit.craftbukkit.CraftServer.dispatchCo
    11. mmand(
    12. 2011-02-27 17:27:54 [SEVERE]    at net.minecraft.server.NetServerHandler.c(NetSe
    14. 2011-02-27 17:27:54 [SEVERE]    at
    16. 2011-02-27 17:27:54 [SEVERE]    at net.minecraft.server.NetServerHandler.a(NetSe
    18. 2011-02-27 17:27:54 [SEVERE]    at net.minecraft.server.Packet3Chat.a(SourceFile
    19. :24)
    20. 2011-02-27 17:27:54 [SEVERE]    at net.minecraft.server.NetworkManager.a(SourceF
    21. ile:230)
    22. 2011-02-27 17:27:54 [SEVERE]    at net.minecraft.server.NetServerHandler.a(NetSe
    24. 2011-02-27 17:27:54 [SEVERE]    at net.minecraft.server.NetworkListenThread.a(So
    25. urceFile:100)
    26. 2011-02-27 17:27:54 [SEVERE]    at net.minecraft.server.MinecraftServer.h(Minecr
    28. 2011-02-27 17:27:54 [SEVERE]    at
    30. 2011-02-27 17:27:54 [SEVERE]    at net.minecraft.server.ThreadServerApplication.
    31. run(SourceFile:366)
    --- merged: Feb 27, 2011 7:52 AM ---
    Ok, to add to the list: /spawn, /tp, /give and /warp all do not work. Please help, because this is a really big problem.
    --- merged: Feb 27, 2011 8:06 AM ---
    now I'm getting this at login
    Code (Text):
    1. 2011-02-27 18:05:06 [SEVERE] Could not pass event PLAYER_LOGIN to EssentialsServ
    2. erlist
    3. java.lang.NullPointerException
    4.         at net.mcserverlist.bukkit.McslPlayerListener.onPlayerLogin(McslPlayerLi
    6.         at$11.execute(JavaPluginLoader.j
    7. ava:180)
    8.         at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.jav
    9. a:59)
    10.         at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.j
    11. ava:225)
    12.         at net.minecraft.server.ServerConfigurationManager.a(ServerConfiguration
    14.         at net.minecraft.server.NetLoginHandler.b(
    15.         at net.minecraft.server.NetLoginHandler.a(
    16.         at net.minecraft.server.NetworkListenThread.a(SourceFile:87)
    17.         at net.minecraft.server.MinecraftServer.h(
    18.         at
    19.         at
    20. 2011-02-27 18:05:06 [INFO] DJMachette [/] logged in with enti
    21. ty id 106
    22. 2011-02-27 18:05:06 [SEVERE] Could not pass event PLAYER_JOIN to EssentialsSpawn
    24. java.lang.NullPointerException
    25.         at com.earth2me.essentials.spawn.EssentialsSpawnPlayerListener.onPlayerJ
    26. oin(
    27.         at$1.execute(JavaPluginLoader.ja
    28. va:130)
    29.         at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.jav
    30. a:59)
    31.         at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.j
    32. ava:225)
    33.         at net.minecraft.server.ServerConfigurationManager.a(ServerConfiguration
    35.         at net.minecraft.server.NetLoginHandler.b(
    36.         at net.minecraft.server.NetLoginHandler.a(
    37.         at net.minecraft.server.NetworkListenThread.a(SourceFile:87)
    38.         at net.minecraft.server.MinecraftServer.h(
    39.         at
    40.         at
  3. Offline


    Problem found with CB 447, everyone remains in god mode, no one is able to die.
  4. Offline


    Also I have this problem:
    Code (Text):
    1. 2011-02-27 18:24:42 [SEVERE] Could not load plugins\Essentials.jar in plugins: n
    2. ull
    3. org.bukkit.plugin.InvalidPluginException
    4.         at
    5. ava:85)
    6.         at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.
    7. java:129)
    8.         at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager
    9. .java:94)
    10.         at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    11.         at net.minecraft.server.MinecraftServer.e(
    12.         at net.minecraft.server.MinecraftServer.a(
    13.         at net.minecraft.server.MinecraftServer.d(
    14.         at
    15.         at
    16. Caused by: while parsing a block collection
    17.  in "<reader>", line 62, column 3:
    18.       - '[1] Don't grief or block-spam'
    19.       ^
    20. expected <block end>, but found Scalar
    21.  in "<reader>", line 62, column 14:
    22.       - '[1] Don't grief or block-spam'
    23.                  ^
    25.         at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockSequenceEntry.produce(
    27.         at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(
    28.         at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(
    29.         at org.yaml.snakeyaml.composer.Composer.composeSequenceNode(Composer.jav
    30. a:203)
    31.         at org.yaml.snakeyaml.composer.Composer.composeNode(
    32.         at org.yaml.snakeyaml.composer.Composer.composeMappingNode(
    33. :230)
    34.         at org.yaml.snakeyaml.composer.Composer.composeNode(
    35.         at org.yaml.snakeyaml.composer.Composer.composeDocument(
    36. 2)
    37.         at org.yaml.snakeyaml.composer.Composer.getSingleNode(
    39.         at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseCons
    41.         at org.yaml.snakeyaml.Yaml.load(
    42.         at org.bukkit.util.config.Configuration.load(
    43.         at
    44.         at
    45. ava:83)
    What is wrong? Please help this as stuffed up my server...
  5. Offline


    Setspawn just isnt working right for me. When I type /spawn it takes me to the correct spawn. If I die, it spawns me way up in the air somewhere and I fall to my death.
  6. Offline


    Take out the apostrophe, it's messing up the yml syntax.

    aused by: while parsing a block collection
    in "<reader>", line 62, column 3:
    - '[1] Don't grief or block-spam'
    expected <block end>, but found Scalar
    in "<reader>", line 62, column 14:
    - '[1] Don't grief or block-spam'
  7. Offline


    Thank you so much! I had no idea what to do.
    --- merged: Feb 27, 2011 9:33 AM ---
    Everbody please ignore my previous comments, the problem has been fixed
  8. Offline


    Hi everyone how do you download this
  9. Offline


    I got a problem with the use of "TooManyItems" and Essentials v225 on my server. The /give [player] [id] [amount] command works perfectly for me. But if I want to spawn something via TooManyItems I have to relog on my server to make it appear in my inventory. Looking in my server logs, I noticed that TooManyItems uses the /give [player] [id] [amount] command.
    It worked without Essentials so I assume that there's the problem.

    Any ideas?

    Craftbukkit #453
    Essentials (core)
  10. Offline


    Could u add a godmode for only the first 10 seconds at login?
    And a godmode when u die for 10 seconds (or anything else)

    Because sometimes we're doing Arena, with TNT.
    It really sucks when u die and than you're living 3 seconds, and than u die again when u just activated some kits...

    EDIT: Maybe backup zip format?
  11. Offline


    I like this new Sign stuff^^ Healing and Disposal sign works, its cool.
    But the Trading sign isnt :/ And that would be the most important for me -.-

    + Can you change the Buy/Sell signs to accept items not just $ ? Infinite items to buy/sell would be great.
    Btw, Buy/Sell signs doesnt work for me also.
  12. Offline


    Cant we all . . just come to the conclusion that this/these plugins are not working 100%
    I'm changing to another plug-in for general commands till essentials has worked out what it plans to do with itself its just to messy at the moment.

    Waves - TM
  13. So, on the newest CB, this isn't compatible with dynmap :( Is there anyway you could fix? I also throw an error on enable, but the plugin still works fine...

    CB 440
    Essentials +EssentialsWarp v225
    Dynmap 0.13
  14. "You do not have permission to create a SignWarp."
    What am i doing wrong D:
    Essentials 240
    Craftbukkit 250
    Permissions 2.4

    EDIT: Happens whenever anyone finishes making a sign. It just removes the text and says that even though i have ['*'] in permissions
  15. Offline


    i removed the kit part and now want to add one. can someone post the format please? copy/paste is fine.
  16. Offline


    Thats from MyWarp
  17. Offline


    I believe you still have to use GroupManager.
  18. Offline


    im just woundering.. how do i add myself as an admin?? hehe, i've looked trough the Wiki site. but couldent find anyhting
  19. Offline


  20. Use /back or /home or some other teleport command to get to a safe location so that you stop dying, then go to the appropriate place and use /setspawn. You should then properly respawn there on death.
  21. Offline


    I like your Essentials package but could I make a suggestion of which on yoru Wiki page to say what the revision number is on the links for the downloads?

    The title of this thread is 225 but the revisions are much newer but I have no way of knowing which the are until I've downloaded then.
  22. Offline


    I spawn underground, in that infinite air. I have not yet set a home cuz its the first time i ran it.
  23. Offline


    Yeah that...running into that problem to.
  24. Offline


    I'd also like to know this.
  25. Offline


    Any chance an additional "home" could be added to EssentialsHome? For example, my users are setting up shops and would really like to be able to have a 2nd "home" command they can use to get to their shop easily.

    Seems like it just needs another entry in the YML file and some new command links, pretty straightforward yea? :)
  26. Offline


    is there any localshop plugin for essentials eco, since iconomy turned out to be crapy?
  27. Simple, add "mail" to the "disabled-commands" list in the config.yml file.
  28. Offline


    Hello Could tell me if just using essentials.* gives all the commands?
  29. Offline


  30. Offline


    Yea, but it still tells the users to check their mail in the startup MOTD
  31. No, it doesn't, unless you have a really really (really) old version of Essentials.
Thread Status:
Not open for further replies.

Share This Page