Inactive [GEN] DefaultCommands v4.0.0 - The "default" plugin [1.4.5-R0.2]

Discussion in 'Inactive/Unsupported Plugins' started by vildaberper, Mar 2, 2011.

  1. Offline


    Ok, well it is a flatfile and I am using the latest MyWarp v2.0dev, any other suggestions?
  2. Offline


    Name doesn't work for me. i use command and it says i changed name but when i type a message it is my original name again
  3. Offline


    Hey, I got Little problem
    I installed DC and Permissions 3 on my server. Theres config file:
    Now, the problem. I'm op, I can do everything, but can't build. When i place blocks it disappears and shows in my eq. What can I do? :)
  4. Offline


    Try 953, but it should work with 935 as well.
    Try backing up Items.yml anf type '/dc reset items'. If that solves the problem theres something wrong with your item aliases.

    02:22:10 [INFO] Preparing start region for level 3 (Seed: 1864953015476503078)
    02:22:11 [SEVERE] Not in GZIP format

    You do have chunk errors.

    Not caused by DefaultCommands.
    You do know that you get cobblestone from mining stone, right?

    When I tested it, I used this:, with default settings except flatfile.

    Do you have iChat or any other chat plugin?

    Add yourself to a group and set op_permissions to false in Config.yml. :)
  5. Offline


  6. Offline


    I guess thats why it isnt working then. Try removing it. :)
    DefaultCommands does everything nChat does anyways.
  7. Offline


    Heh, I'm Idiot, now thats easy. I writen this file without parse, and "groups:" on top. Works, fine. Thanks :D
  8. Offline


    ok then thanx
  9. Offline


  10. Offline


    Chunk errors are a common thing and as far as I know that is not the source of the problem.
    How could that not let a single plugin work?
  11. Offline


    So it worked even with SQL? :D
    Great that you solved it!

    Please dont say that its not a chunk error, I know what Im talking about. It is a chunk error. xD

    Because DefaultCommands is loading the world.
  12. Offline


    Heyz :)

    I found a thing :) when I load arrows in a dispenser and use /god I still get damage :) Dont know if you knew this so I'd thought I'd post it.. Sorry if anyone else already said it in this thread.

  13. Offline


    Mmmm... I've got a feature request ! :p

    Could you add the possibility to create multiple spawn points ? It could be like for the warps, with a /setspawn <name> and the permissions dc.spawn.* with *=<name>.

    It would be awesome :)
  14. Offline


    Its a bug in bukkit, try reporting it. :)

    I wont add that, theres warps already! xD
    A spawn is a place where you spawn at, not "warp" to.
  15. Offline


    Yeah exactly.
    But for example on my server, I would like to have a spawn point for each city. So when a member of the city (who is in the permission group of this city) die, he will respawn in his city in place of the default spawn point.
  16. Offline


    Thats another plugin, I wont add it in DefaultCommands. "/
  17. Offline


    So bad :p
    Doesn't matter, I like your plugin anyway xD
  18. Offline


    I'm having an issue where players can't pick up items. I know it's from this because it didn't happen until I installed it. I added them to the whitelist, but they still can't pick up items. Ops can, but no players. Can anyone please help?
  19. Offline


    Add '*' permission. :)
  20. Offline


    Hey! its been long since i posted, great job as always. Just dropped by to ask if you were going to re-add /tpd. Which stops other people from teleporting to you.
  21. Offline


    Hey, I'm new to bukkit. Just downloaded and set up my server today, and I have a question about your plugin. How do you edit kits?
  22. Offline


    I updated CraftBukkit and I reset the items to no avail. Even doing /dcgive Chuck67322 1 64 doesn't work. What can I do?
  23. Offline


    nice but i dont will use it because the commands are to long with the "dc.."
  24. Offline


    Yep, Ill add that. :)

    Edit Kits.yml.

    No idea what might be wrong. Update to the dev build and post the error message again, Ill take a look at the source. :)

    Read the main post please:
    "Every command name is configurable, even commands in other plugins. This means that every command doesnt have to start with 'dc'! See Commands.yml
    The plugin comes with a set of command aliases, so you dont have do do anything."
  25. Offline


    oh ok sorry xD its late (germany: 23:49) xP
  26. Offline


    Here ya go:
    15:26:18 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'dcgive' in plugin DefaultCommands v3.5.0
    	at org.bukkit.command.PluginCommand.execute(
    	at org.bukkit.command.SimpleCommandMap.dispatch(
    	at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
    	at net.minecraft.server.NetServerHandler.handleCommand(
    	at com.vildaberper.DefaultCommands.Listener.DCPlayerListener.onPlayerCommandPreprocess(
    	at org.bukkit.plugin.RegisteredListener.callEvent(
    	at org.bukkit.plugin.SimplePluginManager.callEvent(
    	at net.minecraft.server.NetServerHandler.handleCommand(
    	at net.minecraft.server.NetServerHandler.a(
    	at net.minecraft.server.Packet3Chat.a(
    	at net.minecraft.server.NetworkManager.b(
    	at net.minecraft.server.NetServerHandler.a(
    	at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    	at net.minecraft.server.MinecraftServer.h(
    Caused by: java.lang.NullPointerException
    	at com.vildaberper.DefaultCommands.Misc.getPlayers(
    	at com.vildaberper.DefaultCommands.Misc.getPlayers(
    	at com.vildaberper.DefaultCommands.Command.Give.give(
    	at com.vildaberper.DefaultCommands.DefaultCommands.onCommand(
    	at org.bukkit.command.PluginCommand.execute(
    	... 19 more
    EDIT: I'm also having issues with the /name command ever since I updated to the dev build. It says that it changed the name but it doesn't do anything...
  27. Offline


    I don't use permissions. Is there a different fix?
  28. Offline


    Creative mode seems to have some bugs. For example, when you destroy a leaf block you get kicked off the server with an 'internal error.'
  29. Offline

    Clayton Tindale

    IS this compatiable with Beta 1.7.2 with Mod:Craftbukkit ? Because when i have this plugin installed, only admins can place or remove any blocks. It is very irratating.
  30. Offline


    Your "give" is probably wrong, delete DefaultCommands.yml and let it regenerate. :)

    Add it in Config.yml under permissions.

    Redownload the dev build, its been fixed. :)

    What do you mean with Mod:Craftbukkit?
    Add '*' to your permissions.

Share This Page