Inactive [GEN] DefaultCommands v4.0.0 - The "default" plugin [1.4.5-R0.2]

Discussion in 'Inactive/Unsupported Plugins' started by vildaberper, Mar 2, 2011.

  1. Offline


    There are not kits yet! xD

    Oh sry i thought there where because in the DefaultCommands Folder is a kits.yml

    sry for bad english again :(
  2. Offline


    Oh yeah, thats right. Pretty obvious though. :)

    What OS?
    I havent tested this on any Linux dist yet.

    What? Update in large red letters? xD

    Ah, you didnt remove the old config folder. You can remove kits.yml. :)
  3. Offline


    Only problem is my commands aren't working at all. tried to do /dc save and it said an internal error occured. I should have the permissions since I am entitled to have all of them. i'll show you a picture of what my defaultcommands folder looks like right now.


    As I said I have all the permissions so my permissions should be fine...

    Here is the error I get when i try to do a command:
  4. Offline


    What CB build do you have?
    I tried everything, but I cant replicate your problem. So I cant fix it. "/
    Try updating CB or run the server as an Administrator. :)
  5. Offline


    RB 766
    Tried running as Admin still wouldn't work?
    Could plugins [Multi and Single] be messing it up? :eek:
    My plugins should be listed in an above post.

    I don't know if it would help, but all the text document says is:
    [2011/05/13 20:43:44] Enabled DefaultCommands 3.3.0.
    [2011/05/13 20:55:23] Enabled DefaultCommands 3.3.0.
    [2011/05/14 15:08:01] Enabled DefaultCommands 3.3.0.
    [2011/05/14 15:08:26] Drageer connected from, joined Arena.
    [2011/05/14 15:23:12] Enabled DefaultCommands 3.3.0.
    [2011/05/14 15:23:18] Drageer connected from, joined Arena.
    [2011/05/14 15:24:16] Drageer disconnected.
    [2011/05/14 15:24:17] Drageer connected from, joined Arena.
    [2011/05/14 15:25:33] Drageer disconnected.
    [2011/05/14 15:30:18] Enabled DefaultCommands 3.3.0.
    [2011/05/14 15:37:16] Enabled DefaultCommands 3.3.0.
    [2011/05/14 15:37:42] Enabled DefaultCommands 3.3.0.

    So it's enabled, but it's spamming my console and I can't use the commands?
    Do you want to look at my permissions? :eek:?

    EDIT: All my other plugins work too if that could help in a way?
    Also 3.2 worked for me on RB 740 o:
  6. Offline


    Hmm, try making folders in DefaultCommands named after all of your worlds.
    DefaultCommands/Worlds/world/ etc.
  7. Offline


    YES! It worked....Though it was kind of a painstakingly annoying process :p
    i used dc save and it all loaded up. Thanks!
    Though next version please make it a bit easier?
    I love u vildaberper...have my babies? :p
  8. Offline


    Ill add an in-game command "/dc get" or something like that, and it would load the worlds automaticly. :)


    EDIT: Wow, just looked at my source for when a world gets loaded, it was not right. xD
    Worlds will automaticly be loaded in the next version, and Ill add /dc get.
  9. Offline


    Windows 7. No idea what the server host's OS is though.
    Also, please make it so that people without permission to join a certain world can not teleport to people in that world.
  10. Offline


    Ok, wierd. Not much I can do about it. "/

    LOL, why didnt I think of taht before? xD
  11. @vildaberper: is it possible to disable some of the messages that show up? im after disabling the join world command. seems to generate a fair amount of spam when were going round helping people, i tried putting a # infront, but it removes it.. i tried removing the line.. it puts it back! lol!
  12. Offline


    Set it to: '' (Thats ' and not "). :)
  13. Offline


    hey, im using build 766, and the most recent version of defaultcommands (along with like 20-30 other plugins) and it normaly works great, but i upgraded to the most recent version of defaultcommands, and its not generating any files (i deleted the defaultcommands folder so everything was fresh), anyway i can get it to generate?
  14. Offline


    Hmm, thats odd.
    Try the dev build. :)
  15. Offline


    it didn't work D:
  16. Offline


    This is so wierd! :(
    When I delete the folder its just getting regenerated, along with every other config file.
    Is the log beeing created? Thats the only thing that doesnt use bukkits built-in file-creating stuff.
  17. Offline


    yes the log is being generated, but thats it :\

    [2011/05/15 01:42:39] Enabled DefaultCommands 3.3.0.
  18. Offline


    Ok, I think I can fix this.
    Ill probably take a look at it tomorrow though. 3am here. xD
  19. Offline


    uhh ok, do you think you could like, zip up the default files and upload them here? im trying to update everything on my server tonight
  20. Offline


    Sure, but be sure to remove the SPAWN in Config.yml.
  21. Offline


    thanks so much :D

    nice to see a plugin dev. that helps people :)
  22. Offline


    Hi, I downloaded this today and I'm using groupmanager [the most updated version] and i'm getting this error.

    Last login: Sat May 14 23:37:56 on ttys000
    /Users/MilkDud/Desktop/Bukkit\ Server/LaunchServer.command ; exit;
    Mac:~ MilkDud$ /Users/MilkDud/Desktop/Bukkit\ Server/LaunchServer.command ; exit;
    146 recipes
    16 achievements
    23:40:20 [INFO] Starting minecraft server version Beta 1.5_02
    23:40:20 [WARNING] **** NOT ENOUGH RAM!
    23:40:20 [WARNING] To start the server with more ram, launch it as "java -Xmx1024M -Xms1024M -jar minecraft_server.jar"
    23:40:20 [INFO] Loading properties
    23:40:20 [INFO] Starting Minecraft server on *:25565
    23:40:20 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-729-g5ee3f0f-b766jnks (MC: 1.5_02)
    23:40:20 [INFO] Preparing level "world"
    23:40:20 [INFO] Preparing start region
    23:40:21 [INFO] GroupManager - INFO - Scheduled Data Saving is set for every 10 minutes!
    23:40:21 [INFO] GroupManager version 1.0(alpha-5) is enabled!
    23:40:21 [INFO] Fake Permissions version 2.5.1 is enabled!
    23:40:21 [SEVERE] null loading DefaultCommands v3.2.3 (Is it up to date?)
    at com.vildaberper.DefaultCommands.DefaultCommands.onEnable(
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    at net.minecraft.server.MinecraftServer.e(
    at net.minecraft.server.MinecraftServer.a(
    at net.minecraft.server.MinecraftServer.init(
    23:40:21 [INFO] Done (0.120s)! For help, type "help" or "?"

    I fixed the other errors as well. I have also edited the commands so instead of having to type dc infront of everyone i can just type the actual command e.g. /dcfly (old) vs. /fly (new). Don't beat around the bush ok, I know YML and thanks in adv.
  23. Offline


    i feel a bit stupid but.

    Im trying to make a teleport but can't get it to work.
    i want a teleport for a player to a warp point, so they stop bugger me when they die cause they built there town on other side of the world

    /setportal start player:warp

    am i supposed to mark whit stick/280 the player teleport or am i using wrong command ?
  24. this puts spaces in the chat.
    already tried that one :)
  25. Offline


    Not sure if this has been said yet, but portals that go to warps only work for people who have warps set in permissions for them. Not sure if this is bug, or an unintentional mistake, or just something missed.
  26. Offline


    Thanks! :D

    Update GroupManager and FakePermissions, Ive only tested this with the latest Permissions.

    player:warp means that it will teleport to the player "warp". If you want it to teleport to a warp instead, do warp:<warpname>. :)

    Hmm, ok Ill fix it in the next version. :)

    I know, Im changing it to 'dc.portal.warp.<warp>' etc. :)
  27. Offline


    but still can't get it to work for myself as admin whit all comands.
    i call the warp point for "2"
    and can't seem to get it work, how to mark up the portal area
  28. Offline


    Just mark the portal region with a stick, and then do /setportal <portal name> warp:<warp name>
    Whenever someone enter the region, he will be warped to the target if he have permissions for it. :)
  29. Offline


    Hmm I checked, and the inventory folder in the worlds folders remain empty. I used MultiInventory before, maybe that is the problem.
  30. Offline


    That shouldnt matter.
    Is homes, warps, portals and player saving?

Share This Page