Inactive [GEN] DefaultCommands v4.0.0 - The "default" plugin [1.4.5-R0.2]

Discussion in 'Inactive/Unsupported Plugins' started by vildaberper, Mar 2, 2011.

  1. Offline


    well in a little bit i'll give you feedback :)
  2. Offline


    Mkay, third reply to this post. xD
    Added separate_inventory and creative to Config.yml to th dev build, check it out! :D
    Oh, and I changed /dcinventory to NOT UPDATE IN REAL TIME!
    BUT, it is possible to see offline players inventories (and probably edit them in the future).
  3. Offline


    Well it works now but some commands won't work even if there not removed?
  4. Offline


    What commands? (You mean will work even if theyre removed?)
  5. Offline


    i went to the plugin world config and put op permissions false but still they get every permission.But i know my permission plugin works fine.still not sure why this isnt working.
  6. Offline


    I've having some issues modifying basically anything in the config for this plugin. I'm trying to disable the warp commands so I can use a different plugin for those, but every time I change anything in any of the yml files, they just reset to default after I reload the server.

    Using the latest Craftbukkit and DefaultCommands 3.2.3.
  7. Offline


    noisetank, if you edit things while your server is up it will reset to its default when it was first launched. I believe DC has a save and reload function. Use that instead.

    A bug or something : the alias for the commands don't work anymore, i watched commands.yml and it still has it there. Is there anything i need to set to true or something?

    Also creative mode doesn't work anymore since i went from 3.2.2 to 3.2.3
  8. Offline


    Hey guys.. i dont really know how to do the spawn items command.. they keep repeating the message for the give item commands
  9. Offline


    Thanks for the reply vilda, that's a shame but I suspected it may be the case. Another one for you, is there any may of saying what a toggle has been set to? I find that I get myself a bit confused if I, for example, set myself as hidden and unhidden a few times, because the feedback isn't telling me whether it's on/off, true/false etc.

  10. Offline


    Hey, could you integrate the "repair" command (again) :) , now that 3.2.3 has most of the features again, this little extra command would be very nice
  11. Offline


    did you do /dc load or did you reload your server? It saves the config on exit, so do /dc load.


    Hmm, Ill look into the commands.

    I didnt touch creative mode. xD
    What isnt working?

    Thats coming! /hide will tell you with the disconnect messages. ;)
    Itll proably be "<player> <status>d hide for <players>", where status is enable or disable.

    By default, its /<command> <item>[:data] [amount] [player] - /give stone 61 vildaberper
    But its is configurable in DefaultCommands.yml, if you want:
    /<command> <player> <item>[:data] [amont] - /give vildaberper stone 61

    Yep, it will be in the next release. I miss it too on my server. xD
  12. Offline


    Great, thanks :D
  13. Offline


    Tried install this today, it blew up with exceptions in the log file. It looks to be having conflicts with other mods and I have quite a few of them, but here's a partial list:

    CraftBukkit 766
    Essentials 2.2.8
    MotherNature 1.2
    DefaultCommands 3.2.3

    From the two stack traces I've pasted below (which were both repeated many times in the 15 seconds or so I let it run), these seem to be the primary culprits, but I'll post the full list of mods if you need them (WorldProtect, HeroChat, yadda yadda...).

    Since I only ran it 15 seconds or so, there very well could be more conflicts with other mods, but these are the ones preventing me from using DefaultCommands right now.


    2011-05-10 07:40:22 [SEVERE] Could not pass event CREATURE_SPAWN to DefaultCommands
            at com.vildaberper.DefaultCommands.DefaultCommandsEntityListener.onCreatureSpawn(
            at org.bukkit.plugin.RegisteredListener.callEvent(
            at org.bukkit.plugin.SimplePluginManager.callEvent(
            at org.bukkit.craftbukkit.event.CraftEventFactory.callCreatureSpawnEvent(
            at net.minecraft.server.World.a(
            at net.minecraft.server.Chunk.addEntities(
            at net.minecraft.server.ChunkProviderServer.getChunkAt(
            at org.bukkit.craftbukkit.CraftServer.createWorld(
            at org.bukkit.craftbukkit.CraftServer.createWorld(
            at com.earth2me.essentials.Essentials.onEnable(
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(
            at com.earth2me.essentials.spawn.EssentialsSpawn.onEnable(
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(
            at org.bukkit.craftbukkit.CraftServer.loadPlugin(
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(
            at net.minecraft.server.MinecraftServer.e(
            at net.minecraft.server.MinecraftServer.a(
            at net.minecraft.server.MinecraftServer.init(
    2011-05-10 07:40:47 [SEVERE] Could not pass event WEATHER_CHANGE to DefaultCommands
            at com.vildaberper.DefaultCommands.DefaultCommandsWeatherListener.onWeatherChange(
            at org.bukkit.plugin.RegisteredListener.callEvent(
            at org.bukkit.plugin.SimplePluginManager.callEvent(
            at org.bukkit.craftbukkit.CraftWorld.setStorm(
  14. Offline


    Make sure DefaultCommands know of all your worlds, it looks like its trying to get configurations from worlds that doesnt "exist". :)
    Edit: It looks like its a nether world, because the entity that spawned was a pigzombie.
  15. Offline


    I just installed the plugin for the first time. I would assume it should auto-discover worlds and create default configs? I'm willing to put in the effort to fix it, but it seems very bad behavior for a freshly installed plugin to start throwing exceptions rather than working "out of the box".

    Not saying you have to fix it, of course. I recognize plugin development is a labor of love and not a paid gig or anything, just pointing out it's very unfriendly behavior to what is probably a very common scenario, so it would be nice if it behaved a little better in the "freshly installed multi-world" scenario.

    Thanks for the quick reply. I'll try to figure out how to enable configs for all my worlds before starting it up again.
  16. Offline


    I have a onLoad hook for worlds, but it doesnt seem to fire when a world gets loaded. Sorry, but theres nothing I can do about it.
    Just create the world folders in DefaultCommands/Worlds, (ex. DefaultCommands/Worlds/world/).
    Then do /dc save and your config should be in there with default settings.
  17. Offline


    Also, is there any wiki with more documentation? Upon creating a world directory for my nether and copying the one from "world" into it to get started, I notice the first line is "environment: NORMAL", but I have no idea what this means. I don't see it listed in the main thread anywhere. Is this supposed to be "environment: HELL" for nether or something?

    How well does this play together with Essentials? I see things like spawn: and home_on_death defined in the configs, functions I already handle via Essentials. Your plugin offers some unique capabilities I don't have in other mods today (such as command aliases, player freezing, mounting animals, etc) so I'd like to take advantage of them but don't want to have any conflicts with my existing setup.

    Thanks again for taking the time to answer my questions.
  18. Offline


    enviroment can be NORMAL or NETHER. :)

    I dont know actually, but i recommend not using this with any other plugin that does the same thing.
    What does Essentials have that makes you use that one too? Maybe I could add it in DefaultCommands. ;)
  19. Offline


    Well it says it toggles creative mode for myself, but there is no unlimited blocks nor instant break blocks. If you have a suspicion of my commands.yml being configurated wrong (even though i didnt touch it) i can probably pastebin it for ya!
  20. Offline


    Hmm, are you sure?
    It works for me, but you could try the dev build instead.
  21. Offline


    hey if any one have's toomanyitem's and it work's on single player but on smp it does this if any one can help thankz
  22. Offline


    Set TooManyItems.txt to: {1}:{3} {2} {0}
  23. Offline


    on .minecraft or the server to run smp and than you

    like this right and if so yea still same thing ..i use to give item is /i 1 64 and that works lol

    ooo i got it thank you every much we love you man......

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 10, 2016
  24. Offline


    Good that you solved it. :)
    Sometimes the item is invisible, but its still there. Its a bug with toomanyitems.
  25. Offline


    Alright so the development build works with creative, but the alias for the commands do not.
  26. Offline


    They do, I just tested them. xD
    Are you sure you do /dc load and not reloading the server?
  27. Offline


    /dc reload just reloads the plugin while /dc load just loads the files? i use /dc reload when i configure the plugin but i never touched the command.yml
  28. Offline


    /reload - Reloads the server.
    /dc reload - Loads and then saves DefaultCommands comfiguration.
    /dc load - Loads the configuration.
    /dc save - Saves the configuration.

    Are your command aliases still there when the DefaultCommand saves?
  29. Offline


    Yes the command aliases are still there, double checked. Yea i know the part of /reload and /dc reload. Just confused about /dc load because it sounded the same as /dc reload. Im running bukkit 740 btw, could that be a problem?
  30. Offline


    Yep, its probably that. :)
    Update to the latest RB.

Share This Page