Inactive [GEN/CHAT]SimpleCalc v2.4 - Simple but powerful calculator for Console and Chat[SPN1265/CB1.3.1-R2]

Discussion in 'Inactive/Unsupported Plugins' started by Lathanael, Aug 26, 2011.

  1. Offline

    Lathanael

    SimpleCalc

    - inspired by uCalc (Thx Sosser for giving me an idea on what to start making plugins for Bukkit) -
    BukkitDev

    SimpleCalc is a chat/console based calculator. It can calculate any mathematical expression containing decimals and the following operators:
    1. Addition: +
    2. Subtraction: -
    3. Multiplication: *
    4. Division: /
    5. Powers: ^
    6. Remainder: %
    7. Parentheses: ( and )
    8. ANS variable
    9. Functions: sqrt, sin, cos, ln, log, spawnX/Y/Z, locX/Y/Z
    10. Math constants: e, pi

    Here are some examples of propper expressions:
    * 5.6+3.3 or 5,6+3,3
    * 3*4+5
    * (3+4)*3/8
    * (7+2^4)/3
    * -5*3
    * (-7+3*(12%5))/32
    * *After executing one calculation: ANS()+3

    To use pi and the loc and spawn functions, append <font color="#ff0000">()</font>to them!

    You can separate the numbers/operators with spaces or not, both will be accepted and, if the expression is valid, will be calculated. The parantheses in ANS() are needed to work!


    If you have Spout installed and use the Spoutcraft client you can now open a Calculator Window by using "/calc" without any arguments!

    [​IMG]

    Command(s):
    DEV Version:

    Download & Source:
    SimpleCalc is released under GNU GPLv3 for more information, refer here.

    CB 1.1-R6 and Newer:
    <Edit by Moderator: Redacted bit url>
    Mirror v2.4 (BukkitDev)



    Download v2.3 (BukkitDev)

    CB 1.1-R3/CB 1.1-R4:
    Download v2.2 (BukkitDev)

    CB#1185 & CB#1240:
    Download v2.1
    Mirror v2.1 (BukkitDev)

    Download v2.0
    Mirror v2.0 (BukkitDev)

    CB#1060:
    Download v1.0
    Mirror v1.0 (BukkitDev)

    Source:
    Source on GitHub


    TO-DO:

    Changelog:
    * v2.4

    - * Fixed Listener throwing errors when spout was not installed
    * Fixed loading errors if spout was not installed
    * Added two new functions: distance2D() and distance3D(). It calculates the distance between the player and the spawn location either in the xz-plane(2D) and in xyz(3D)
    * Added possibility to use the keyboard while the GUI is open to enter an expression, but currently no capital letters are possible if the text field is not selected.
    * Added a Key-Binding when Spout is installed to open the GUI without the need to enter the command /calc. Default is C but it can be changed by the user!

    * v2.3

    - * Added variables: You can now set variables with /calc set <variable> <value>. A variable is any letter except small e. Like: a,B,Z,O and g
    * Added more functions like: sin, cos, sqrt, ln....
    * Added SpawnX(), SpawnY(), SpawnZ() and LocX(), LocY(), LocZ() to get the locations of the spawn from your current world and your current location. This does only work when used ingame from a player!
    * Added "Sience" window to the gui to use the new functions.

    * v2.2

    - * Updated to new EventSystem

    * Added ANS function.

    * Rearranged CalcWindow
    - v2.1:
    * Change in namespace
    * Made the error messages a bit more specific.
    - v2.0:
    * BUGFIX: Commas threw an error instead of beeing accepted
    * FEATURE: Spout support. You can now use /calc to open a Calculator Window
    * Update to CB #1185

    * v1.0:

    - * Initial release


    Show Spoiler
    Version 0.1 to 0.9 are merely a list of my development progression:
    * v0.1:

    - * Initial start of coding the plugin
    - v0.2:
    * Added all math functions i thought would be nice to have
    - v0.3:
    * Added RegEx functions for normal 2 arguments calculation (this means we do have a working 2 values calculator \o/)
    - v0.4:
    * Started working on a parser to make complex calculations possible
    - v0.5:
    * Removed original RegEx functions
    * Created logic for the parser
    - v0.6:
    * Created logic to compute the given equation
    - v0.7:
    * Created my own Exception class to pass through parser errors
    - v0.8 and v0.9:
    * Several bug fixes and corrections
     
    Last edited by a moderator: Feb 21, 2017
    r3Fuze likes this.
  2. Offline

    Lathanael

    Yep thats correct. If you want to use the "special" features the player needs to use the SpoutCraft client. You can still use the plugin with a normal client, you just do not have the GUI available.
     
  3. Offline

    IsaiahRobichaud

    Does spoutcraft prevent clients like Nodus? Do I just spoutcraft installed or do I need to use the actual client? I will take the one that doesn't require spout.
     
  4. Offline

    Lathanael

    SpoutCraft is a client modification to allow such things like GUI etc.

    The SpoutPlugin should allow all clients to connect to the server if you do not set the config option to force the use of the SpoutCraft client. But i am not 100% sure of that.

    My plugin will work with the default bukkit anyway. So if you do not have Spout installed on your server you won't lose any of the core features. I just use Spout for the "nice" GUI.
     

Share This Page