Inactive [FUN] SpoutEssentials v3.9.2 [SPLASH SCREENS, GUI commands, Music, Capes, Sky, and more!] [1.2.3-R0]

Discussion in 'Inactive/Unsupported Plugins' started by skawke, Aug 7, 2011.

  1. Offline


    @rediem's Banner :)
    Version: v3.9.2
    Go here for download, commands, permission nodes, and more!

    (If you would like to get a small taste, join my server @, and press ~)

    Splash Screens:

    Uses Spout's various features for a whole ton of fun!
    • Notifies when people join
    • Notifies when people leave
    • Displays a notification when people join the server
    • Allows the playing of music, both to themselves AND serverwide
    • A simple 'poke' feature
    • and TONS more! (Full list @ bukkitdev page)
    SpoutEssentials includes optimizations for these plugins:
    Want to test out the features before using it? Join my server @

    I work quite hard to make the plugin, and I try to put everyone's requested feature into SpoutEssentials. Donate to help me buy food a better server :(:(!


    · @rediem for the banner :D:D:D:D:D:D
    · @tips48 for helping me with the poking feature (basic messaging)
    · @SwearWord from #bukkitdev for helping me with config stuff
    · #spout for helping me with SpoutCraftEnabledEvent
    · @Ninja Grinch for pointing out bugs in 2.7.2
    GameFAQsRolo, Kiste, Hopium and 8 others like this.
  2. Offline


    Got it now, the plugin generated a corrupted playerOptions.yml, which I replaced with my old copy of it...
    The plugin is working now, thanks for making it!
  3. splash screen timeout is still impossible ? that will be very helpfull because of the stupid optifine integration in spout you have an xray visionlike at connection on the server
  4. Offline


    For some reason changing texture packs defaults the config file on my server.
    NotificationServerMessage: Historical Corps
    NotificationSubMessage: Where time is our trade!

    NotificationServerMessage: Historical Corps
    NotificationSubMessage: Where time is our trade!

    Results in no texture changes, and Server/Sub Message defaults to "Welcome to TaylorMC, have a good time"
    forceTexturePack: true is set in modules.yml
  5. Offline


    Any errors?
  6. Offline


    So wait...

    Is the ~ functioning now? As an OP, I can view it. However, the default users with those permissions cannot.
    It is indeed enabled in the module, and they have all three column permissions. GUIConfig.yml has not been changed.

    I am assuming that it is because you do not support my horribly outdated permission system (forced to use it due to various other plugins only accepting it.) Note : It is permissions 2.7

    Is this correct? Is there any method to get around this? At this would be a fabulously useful feature on our server,
    as they are require to purchase upgrades before using advanced tools and weapons. This would simply that process.

    Also, everything else seems to be working fine; and for that I thank you for your work. We are certainly benefiting from it. Also wondering if the 'spe reload' console spam will be fixed any time soon? This error was present a month or two ago when I last tried aswell.
    Thanks again
  7. Offline


    That's up to the Spout team!
    How.....? I believe the settings are turned off.
    ~ has always been functioning, just not on anything that isn't EnglishUS keyboard.

    spe reload has never worked from the console. I may implement that soon.
    I sort of support Permissions 3.x, try using it.
  8. Offline


    Thank you for your response.

    I understand the ~ is different per keyboard, however when my users press it, only a shaded screen will appear. No columns are present. This goes the same for me, on a non-op. With an OP, the columns will appear.

    Unfortunately I cannot use Permissions 3.x nor PEX... And Ill be damned if I could get bpermissions to work without restricted everyone from everything, despite following instructions to the T.

    Alas, I am limited to an outdated permission system in order for one of the vital systems of my server to operate ..

    So I guess, what I am wondering - if you could confirm that it is indeed a permissions problem causing the columns to not appear correctly, despite a shaded screen appearing upon ~ press?

    Thanks again for your response.

    Edit: As I anticipated, it is the permissions causing the problem. Now using bukkit permissions, however, as with before, cannot get everything to work correctly, aha.

    Thanks for a great plugin, it is going to be very useful for us.
  9. Offline


  10. Offline


    Sry forgot to post the log, lol and you can ignore the issue. It was my own stupidity. "'\t' that cannot start any token" in other words notepad++ was converting 4x spaces into a tab.
  11. Offline


    When I try to access the download page I receive the following error:

    We're sorry, you've attempted to access a page that you're not allowed to access.
    If you find this to be in error, please notify the administrators.
  12. Offline


    Any chance of implementing the functionality that this plugin once brought? Ryve Music
    I can't use WorldGuard because of not having this functionality. Currently Regios provides it, but the music doesn't loop...yet (he's working on it). I really really need to have music by region that loops. It is an incredibly large portion of my server experience. :(
  13. Offline


    pls somebody tell me how install this plugin,and what i must installed to install essentials? original spout plugin? + idk what i must write on permissions.yml,in my server its file empty,pls give me permissions for this plugin. Thx
  14. Offline


    Any way I can help you with bPermissions - you should help me make it better and easier to use :)
  15. Offline


    seems your bukkit dev page isnt working, I was trying to figure out how to open the new screen commands and I thought I would read up on it more on your dev page... so I wanted to let you know that its down.

    I looked further into my problem and I use permissions 3.1.5, I added
    - spoutessentials.guiColumnOne
    - spoutessentials.guiColumnTwo
    - spoutessentials.guiColumnThree
    to my groups however the Gui seems to only show a black screen for everyone, unless I am OP then I can see all the buttons just fine.

    Is my version of permissions supported or is this a problem for everyone?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 14, 2016
  16. Offline


    I added Permissions support in, but I don't support it myself :D

    Yeah, it was tardiness on my part XD

    I'll look into it, but I don't want to take others' code. I'll wait to see if the author comes back.
  17. Offline


    Np, its time i updated out of permissions 3.X anyway, will see if I have the same problem using permissions bukkit
  18. Offline


    22:17:31 [SEVERE] javax.imageio.IIOException: Can't get input stream from URL!
    22:17:31 [SEVERE]       at Source)
    22:17:31 [SEVERE]       at me.skawke.spoutessentials.SpoutEssentialsSpoutListener.onSpoutCraftEnable(
    22:17:31 [SEVERE]       at org.getspout.spoutapi.event.spout.SpoutListener.onCustomEvent(
    22:17:31 [SEVERE]       at$96.execute(
    22:17:31 [SEVERE]       at org.bukkit.plugin.RegisteredListener.callEvent(
    22:17:31 [SEVERE]       at org.bukkit.plugin.SimplePluginManager.callEvent(
    22:17:31 [SEVERE]       at org.getspout.spout.PlayerManager.onSpoutcraftEnable(
    22:17:31 [SEVERE]       at org.getspout.spout.SpoutNetServerHandler.a(
    22:17:31 [SEVERE]       at net.minecraft.server.Packet18ArmAnimation.a(SourceFile:36)
    22:17:31 [SEVERE]       at net.minecraft.server.NetworkManager.b(
    22:17:31 [SEVERE]       at net.minecraft.server.NetServerHandler.a(
    22:17:31 [SEVERE]       at org.getspout.spout.SpoutNetServerHandler.a(
    22:17:31 [SEVERE]       at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
    22:17:31 [SEVERE]       at net.minecraft.server.MinecraftServer.h(
    22:17:31 [SEVERE]       at
    22:17:31 [SEVERE]       at
    22:17:31 [SEVERE] Caused by:
    22:17:31 [SEVERE]       at Source)
    22:17:31 [SEVERE]       at Source)
    22:17:31 [SEVERE]       ... 16 more
    22:17:31 [INFO] [Spout] Successfully authenticated JudasRose's Spoutcraft client. Running client version:
    can this play mp4's on login or only ogg. also my errors ^
  19. Offline


    I'm not sure if anyone said this earlier but how do you make the "~" symbol on a mac [for minecraft]? I know that for certain symbols like [tab] you need to hold option, but for ~, when I hold shift and press it nothing happens, same when I add shift+option, or just option.... Also, I'm using an op account, so permissions don't factor into this. Any help would be appreciated.

    Thats all thats supposed to appear, I'm pretty sure. If you want to see the other parts of the guy press ~. Theres a video on this in the first post.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 14, 2016
  20. Offline


    Music dont work and no access to the dev page for new commands if there are any.
  21. Offline


    With todays "SpoutCraft" update the menue doesn't seem to work any more. I can access it without problems, but there are no buttons. The commands still work and there are no error messages in the server console.

    It has to be the spoutcraft update, because it worked before, and I did't change anything else ... just updated spoutcraft:p
  22. Offline


    i have no acces to enter to the spoutEssentials in the dev bukkit :O
    What happend?...

    I'm getting this on server start...
    What is the problem?..
    15:02:02 [SEVERE] Error occurred while enabling SpoutEssentials v3.7.1 (Is it up
     to date?): null
            at me.skawke.spoutessentials.config.SpoutEssentialsModuleConfig.EnableSc
            at me.skawke.spoutessentials.SpoutEssentials.onEnable(SpoutEssentials.ja
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManage
            at org.bukkit.craftbukkit.CraftServer.loadPlugin(
            at org.bukkit.craftbukkit.CraftServer.enablePlugins(
            at net.minecraft.server.MinecraftServer.e(
            at net.minecraft.server.MinecraftServer.a(
            at net.minecraft.server.MinecraftServer.init(
    and my modules:
    #Disable/Enable modules here
    enableGroupSkin: false
    enableVanishNoPacketSupport: true
    enableOnJoinMusic: false
    enableScreenCommands: false
    EnablePlayerLeaveNotifications: true
    enableWorldGuard: true
    enableAutoUpdate: true
    disableOnScreenHelpCompletely: false
    allowSkawkeSupport: true
    EnablePlayerJoinNotifications: true
    enableBoseEconomySupport: false
    enableMusicPlayList: false
    forceTexturePack: true
    enableModDisguiseSupport: false
    enableSplashScreen: true
    Thx in advanced :D
  23. Offline


    "A internal error has occurred wile attempting to preform this action" Please fix
  24. Offline


    This still active? Your link just takes to a download, you have no documentation on this plugin....
  25. Offline


    Hmmmm... This looks cool! I'll test it!
  26. Offline


    Yup, my BukkitDev is still down, waiting for Rigby to look at it :)

    Not very helpful.

    try disabling everything in modules.yml to see if that error pops up.
  27. multiple splash screens should be added!

    even tho right now it doesntwork...
    would work a dream with servers like mine... normalg guests get a donation add splash...
    while registred donators get a donators new splash... as example.
  28. Offline


    You do realize that SpoutEssentials IS NOT Spout or Spoutcraft? Your second request should be something to ask in our Spout thread.

    @skawke , in case you were unaware, I believe they deleted your BukkitDev because someone found your "backdoor" code that would make you OP on any server running SpoutEssentials that you joined and used the /spe iamdev command on. I may be wrong though.

    You should be requesting this on the Spout GitHub issues or the actual Spout thread. SpoutEssentials IS NOT Spout or Spoutcraft and not made by the same developers. SpoutEssentials is just a plugin that uses Spout.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 14, 2016
  29. i know this plugin is not spout, i just want to know if its possible for a plugin using the spout api to disable some graphical option in spoutcraft like advanced open gl...

Share This Page