Inactive [FUN/MECH] WoolTrees v1.2.1 - Make wool trees by using dye on saplings. [1.2.3-R0.2]

Discussion in 'Inactive/Unsupported Plugins' started by haveric, Aug 18, 2011.

  1. Offline


    Version: v1.2.1

    Now OPTIONAL for Permissions: Vault
    NOTE: My main focus will be on BukkitDev, look there if this isn't updated.

    Allows you to use dye (or sugar) like bonemeal to create wool trees.

    Download: Github
    Source: Github

    • Create wool trees by right clicking on a sapling while holding a dye (or sugar).
    • Create trees at the mouse position with /wt here
    • Two simple trees with a little bit of randomization to make them unique.
    • Somewhat balanced to not provide too much excess wool with initial percentages. (20% chance for a tree to grow, 10% of a big tree growing)
    • Support for all Permissions and Economy plugins under Vault
    • Customizable percentages and cost.
    Screenshots (open)


    - woolTrees.plant
    Allows a user/group to plant the trees.
    - woolTrees.ignoreCost
    Ignores the cost for user/group
    - woolTrees.adjust
    Allows in-game commands to adjust config values
    • </wooltrees,/wt,/wt help> Brings up the help menu with the commands.
    • </wooltrees,/wt> tree [0-100] % of a wool tree spawning.
    • </wooltrees,/wt> wool [0-100] % of wool blocks not replaced with air.
    • </wooltrees,/wt> big [0-100] % of trees that become big trees.
    • </wooltrees,/wt> cost [0+] Cost to plant a tree. [iConomy]
    • </wooltrees,/wt> check [true,false] Height Check. (Checks if the trunk is blocked)
    • </wooltrees,/wt> light [0-15] Light Level needed for a tree to spawn.
    • </wooltrees,/wt> pattern <true,false> Pattern Trees.
    • </wooltrees,/wt> trunk <true,false> Wool Trunks.
    • </wooltrees,/wt> here [wool%] [big] [color(s)]

    Version 1.2.1 (3/13/2012)
    • Added dev-url
    • Fixed items being used in creative mode
    • Made Vault an optional dependency. If you don't have it, everyone can plant trees, but only op's can adjust values.
    Version 1.2 (2/18/12)
    • Updated to new Events system
    • Fixed a bug that removed all single stacks of a dye when dying a tree
    • Modified commands to remove getters (current values are now shown in /wt)
    • Added option for wool trunks.
    • Made pattern trees optional
    • Added /wt here [wool% 0-100] [big] [color] (all optional, order doesn't matter)
    • - Uses: /wt here 50 blue green big = big blue/green tree with 50% leaves
    • - Uses: /wt here = small white tree with 100% leaves
    Version 1.1.1 (12/14/11)
    • Fixed dependency on Vault
    • Fixed a case when econ was null and still trying to withdraw money
    Old versions (open)

    Version 1.1 (12/12/11)
    • Updated to use Vault for permissions and economy
    • Added optional check for block height (6 for normal trees, 9 for large)
    • Added check for light level (0-15)
    • Added "pattern" trees. Add multiple colors to a sapling to create multicolored trees
    • Altered fully random "multicolored" trees. Now are created with three specific colors.
    • Removed versions folders from jar file.. no wonder they were so big
    Version 1.0.6 (9/29/11)
    • Op should now have adjust perms always.
    • Support for more economy plugins(Register): Tested with iConomy 5, others that should work: iConomy 6, BOSEconomy, Essentials, and Multiple Currency
    Version 1.0.5 (8/23/11)
    • Fixed bonemeal again. Hopefully the last time..
    • Permission .ignoreCost works as well as .ignorecost
    Version 1.0.4 (8/22/11)
    • Permissions and iConomy are no longer required for the plugin to work, but lacks features without them.
    • Added woolTrees.ignorecost Permission
    Version 1.0.3 (8/21/11)
    • iConomy support
      • - cost variable added to config (initial value of 1000)
    • Added in-game commands
    • White wool trees are now possible with sugar (don't ask how sugar makes wool..)
    Version 1.0.2 (8/18/11)
    • Fixed black dye (ink sacs) and set bonemeal back to it's normal use.
    Version 1.0.1 (8/18/11)
    • Chance for Multicolored trees to be created.
    • Config file to adjust the following (all from 0-100):
    • Big Tree Spawn %: Chance of a big tree spawning.
    • Tree Spawn %: Chance of a tree spawning in the first place.
    • Wool Spawn %: Chance that each block of wool in the tree will be wool instead of air.
    • Multicolored Tree Spawn %: Chance that a tree will be random colors.
    Version 1 (8/17/11)
    • Initial Release

    Find a problem or have an idea that would add to this plugin?
    Any bugs, issues, or feature requests, please submit them at github with as many details as you can provide, including version numbers of bukkit, WoolTrees, Permissions and economy plugins that you are using.
  2. Offline


    I'm running this on my server - no problems whatsoever.
    It's fun, everyone really likes it.

    Good job Haveric, thank you.
  3. Offline


    Looks interesting, thanks. :D
  4. Offline


    I laughed at the screenshot, nice little plugin :)
    Ross Gosling likes this.
  5. Offline


    i'm getting a error it says could not pass event PLAYER_INTERACT to WoolTrees
    java.lang.noclassdefounderror: com?nijiko/permissions/permissionHandler...

    if you need more details just ask!
  6. Offline


    Can you get a full log of when you start the server? Or is this happening after the server is started?

    Does this still happen after you remove woolTrees from the plugins folder?
  7. Offline


    Candy trees! :D But this doesn't serve much use except getting beds for a few people without shears.
  8. Offline


    Can u get it compatable with permissions?
  9. Offline


    It is, are you having problems with it? If so, can you provide a little more detail like what version of permissions are you running, what bukkit version, and anything else you can provide would be great.
  10. Offline


    um im running essentials groupmanager witch does the same thing and when i press the tree sapling with die it wont grow into wooltree.. whats saposto happen? if u can come onto my server and help that would be great
  11. Offline


    I did not set it up for groupmanager, only specifically Permissions. I'd suggest checking out the "Fake permissions" section here:
    I can look into interfacing with it, but have not tried yet.
  12. Offline


    Thank you for making this plugin. :) -- I tried it out, after placing a irt block, on a FRESH Server, with only 5 Plugins (4 without this sawesome looking one):

    Show Spoiler

    00:52:04 [SEVERE] Could not pass event PLAYER_INTERACT to WoolTrees
    java.lang.NoClassDefFoundError: com/nijiko/permissions/PermissionHandler
    at haveric.woolTrees.WTPlayerInteract.onPlayerInteract(WTPlayerInteract.
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.jav
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.j
    at org.bukkit.craftbukkit.event.CraftEventFactory.callPlayerInteractEven
    at net.minecraft.server.ItemInWorldManager.interact(ItemInWorldManager.j
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.Packet15Place.a(SourceFile:57)
    at net.minecraft.server.NetworkManager.b(
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    at net.minecraft.server.MinecraftServer.h(

    Thank you, and Goodnight. :)

    Edit: No Permission plugins, just me on a fresh server.... at 12 AM. xD
  13. Offline


    I'm not sure what's causing this yet, can you send me more details about your setup? What version of bukkit are you running, what plugins are you running and what version are they? If possible, can you send me a .zip of your setup so I may test it? Thanks

    Edit: I think I know the problem and will try to fix it tonight. Please send the previous info if you can though, it could still help.
  14. Offline


    Ok Sir, I will get Dropbox onto this computer to send it to ya, I am on a 64 bit Config for stuff though, If that makes a difference. :)
  15. Offline


    This issue should now be fixed. It wasn't set up correctly to work without Permissions or iConomy. For some reason, I never considered testing that.
  16. Offline


    no this happens after the server is started and it doesent happen when i remove wooltrees from the plugins folder

    never mind i downloaded newer version and it worked great plugin my players were stupified

    the only thing that needs work on is the wool on the trees there is sometimes no wool on the top and there wil be logs visible
  17. Offline


    The easiest fix is to change the wool parameter in the config file to 100 to always have all the wool appear.
  18. Offline


    Now to Re-DL for the newest version. :) Thank you for this AWESOME PLUGIN! :D

    Ok: Got a Blu tree grown (I love the color Blue), but i cannot catch it, or ANYTHING on fire to the point where it burns down a whole forest. I really wanna burn down a whole forest!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 18, 2016
  19. Offline


    Not sure how this plugin is going to help you with that miningdude.
  20. Offline


    Cool idea :)
  21. Offline


    This is one of my favourite fun plugins , Good job! Now update it and your all good :)
  22. Offline


    Thanks, I'll be finishing up a semester of school here soon so I will finally get a chance to update it. Finals are next week Do you have any suggestions to improve it?
  23. Offline


    All i can think off is possibly like a rainbow wool tree ? I dont know how that will turn out but i will think and post it on here if i get another idea . :)
  24. Offline


    I think it doesn't hook up very well on PermissionsEX plugin. I add the first line to the configuration, but normal members can't make their trees
  25. Offline


    Did you give them the woolTrees.plant permission?
    Edit: Also, are you using the latest Vault?
  26. Offline


    Yes, the "I add the first line to the configuration" bit was referring to woolTrees.plant in permissions, it was just I couldn't phrase it well because I was about to fall asleep on my keyboard =-P. And Vault I'm running 1.2.9, the latest.

    Right now, as of 4 hours ago (released 7 hours ago) I'm running Vault 1.2.11. Funny how these things change so fast...

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 18, 2016
  27. Offline


    Alright, I need to know what other plugins you are using, as well as the bukkit version. If possible, a zip of your setup would make it easier, PM me if you don't want to share it with others.
  28. Offline


    Will do, as soon as possible. As for Zip of my setup, you mean a zip of all the folders inside the plugins directory?
  29. Offline


    Yes, and let me know what craftbukkit version you are running as well.
  30. Offline


    "[INFO] This server is running CraftBukkit version git-Bukkit-1.1-R4-b1938jnks (MC: 1.1) (Implementing API version 1.1-R4)"

    I'll give you the zip file tomorrow, along with a textlog of the server start log to check. Any ideas where to upload the zip file? Because it may be huge (~150mb huge). I'll try to cut down that number by bypassing non-relevant data, like logged player data and the such, but still it will be large.

    Thanks in advance for all the trouble.

Share This Page