Inactive [FUN/MECH] VoxelAir v2.008 - Configurable Flight and Travel Powers [1317]

Discussion in 'Inactive/Unsupported Plugins' started by Voxel Box, Jan 25, 2011.

  1. Offline

    Voxel Box


    VoxelAir: "We'll have our wings and the wind will be with us."
    written by by: przerwap
    Get it here: <Edit by Moderator: Redacted mediafire url>
    Tested compatible with: #1317
    documentation by: plusnine

    v2.008 - Fly, Ridge, Fly is now VoxelAir, and includes a more robust flight system than ever! Check the documentation for everything that's new, and be sure to remove your flyRidgeFly.jar file and config folder from your server's plugins folder.


    [​IMG] [​IMG] [​IMG] [​IMG] <font color="rgb(16, 97, 179)"> </font><font color="rgb(16, 97, 179)"><font color="rgb(16, 97, 179)">[​IMG]</font> </font>
    Last edited by a moderator: Dec 15, 2016
  2. Offline


    sorry, seems fine... problem was that old version was all small letters and new version has som capitals in it.... so it tried to load both.
  3. Offline


    the fly is working for me, but the commands are not.
    It seems the plugin is activated by default and i cannot turn it off or use any of the commands like /godsays, /letmefly, /derp etc.
  4. Offline

    Voxel Box

    thanks for the catch, stolen! we have fixed this bug and enabled the plugin's permissions file. more details in the installation notes in the OP.
  5. Offline


    holy s, my server is lagging up a storm. dont know if it's incidental or from this addon. going to disable now. Yeah and none of the commands work +shut down my gui.
    --- merged: Feb 12, 2011 10:04 PM ---
    hmm, something definitly wrong with this. My server was having stutter lag and some of the people were lagging 20 seconds or more. Not sure what it was, but after disabling everything is smooth again. Sure hope to see this addon working soon
  6. Offline

    Voxel Box

    Daveyo~ woa, that sounds crazy. What build of bukkit are you running? Without that information, it makes it very difficult to replicate and troubleshoot your issue.
  7. Offline


    Great Plugin Voxel! Love seeing plugins that alter the way players interact with their environment!

    We're working on some classes on my server and I was wondering if you were considering any of the following...?
    1. Permissions Plugin Compatability. (I know lots of other people have asked, but I can't use this until I can give the specific faction/class the sole ability to use the flight function. Perhaps you know another approach to only giving a small non-admin group the ability to use the plugin?)
    2. Would it be possible to limit the height in which individuals can fly? (I am doing a great deal of testing on my server at the moment. Perhaps someone can tell me if players can fly beyond the 128 block building limit? I have walls that I would like individuals to not be able to fly over. I'll add a glass roof if I must, but would rather not.)

    Thank you again for your work on this!
  8. Offline


    SO I put the admns.txt folder with my name! Check!
    THen I put the flyridgefly.jar file in my plugin folder.
    Then I Start My server
    And This error pops up
    SEVERE: org.bukkit.Server.getWorlds()Ljava/util/List; (Is it up to date?)
    java.lang.NoSuchMethodError: org.bukkit.Server.getWorlds()Ljava/util/List;
    at com.thevoxelbox.flyRidgeFly.flyRidgeFly.onEnable(
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    at net.minecraft.server.MinecraftServer.e(
    at net.minecraft.server.MinecraftServer.c(
    at net.minecraft.server.MinecraftServer.d(

    And also the rest of my mods dont work like /day or /god or /creativ
    can anyone help?
  9. Offline


    Well, for one its not a folder but a text file which inside contains names; one per line.
    And two, that message means you are either running an old version of the plugin, or an old version of bukkit.
  10. Offline


    Build 325
    /letmefly: works

    /thrust (#): does not work

    /toggelconsume: displays a change, but does not take effect

    I tried these from the client. I haven't tested in the console.
  11. Offline


    omg No permissions. Such a good addon too :/
    --- merged: Feb 15, 2011 6:30 AM ---
    please take out the extra commands. Or put permission nodes for them
  12. Offline


    Sorry I ment Txt File
    And yes i have one per line
    and I just downloaded the Fly Mod
    I Have a version of bukkit from around 3 weeks ago
    ill try updating . And When i do ill post a post! letting u know if it worked
    --- merged: Feb 15, 2011 7:06 AM ---
    Um hey dave...ur gonna laugh..but where do i download bukkit?
    --- merged: Feb 15, 2011 7:14 AM ---
    Um anyone know WHats the difference between craftbukkit and bukkit?
  13. Offline


    bukkit is for programmers i believe, and cb is for most of us.
  14. Offline


    then the fly ridge fly only works on bukkit?
  15. Offline


    everyone refers to cb as bukkit
    --- merged: Feb 15, 2011 8:59 PM ---
    ok /letmefly works, but all other commands are broken. I think i have admns.txt in the right directory, especially since i can use /letmefly. I love this addon i really hope you get it working soon :D cb 323
  16. Offline


    dave my question is
    Does it only work with bukkit?or cb?
  17. Offline


    soap, if you failed to understand that Bukkit is a programming API and that CraftBukkir is the Server than I cannot help you.
  18. Offline


    i understand
    I have just updated craft bukkit and it still gives me the same error.
    Im just asking What Do I do!
    Thats it
    If You cant help
  19. Offline


    As to this, like I have said in the past in some other post, I will not use Niji-Permissions for any of my plugins due to it being an Over-popular and Over-used piece of poorly written code. Besides; everyone will have to throw it out of their plugins when Bukkit Permissions come out.
  20. Offline


    Understandable. It wouldnt hurt to possibly get the commands working for this addon :D. Would really like to make this available to everyone, just at a cost, and not fly nearly as far.
  21. Offline


    godsays doesnt seem to work for me, i have to turn the admns.txt into plain text?
  22. Offline


    Where has voxel gone to :(. Really want this addon for my server. So fun!
  23. Offline


    I will ask plusnine to update the thread to version 1.3b

    But I don't really see why it wouldn't be working for you guys.
  24. Offline

    Voxel Box

    consider it done. we are running bukkit #321, so it should work for people running similar builds.
  25. Offline


    ok, derp now works, (thank god), however, /thrust and /toggleconsume are still saying unknown console command. no errors. cb 323.

    dDaveYo1 has just turned flight off.

    not sure if the lowercase d has something to do with these issues.
    --- merged: Feb 17, 2011 10:58 PM ---
    found the problem

    2011-02-17 17:33:03 [INFO] flyRidgeFly version 1.3a is enabled!

    the download link is an old one i guess
    (and yes i have admns.txt with my name in it properly capitalized)
    --- merged: Feb 17, 2011 11:03 PM ---
    i noticed there is not folders created when the addon starts, yet there is a config file. Do we have to make a config file in a flyridgefly folder?
    --- merged: Feb 17, 2011 11:07 PM ---
    solved it. Put a folder named "fly" in the plugins folder. Take the "plugin.yml" file out of the jar and place it in that folder. Bingo

    edit: thrust is still not working, and now just the toggle consume returns that it is on or off, yet doesnt actually consume the feathers
  26. Offline


    OK, i had a look into it, i like it with flapping around a bit :)
    There´s no falling damage, but, if you flap into a wall/structure/block you take Damage
    After updating craftbukkit it runs perfect.
    But i had a look into flyListener.class
    there are all commands listed (tested as OP):
    /derp (toggles on and off) ,command works, orange message, but no derp message until now.
    /toggleconsume toggles on or off, command works, but in both states no feather is consumed.
    /togglegroups toggles on or off, comamnd works, but no effect for me.
    instead of /thrust i found
    /cruise # ,this command works (example: /cruise 15) but every value no effect, still flaps 11 blocks wide/high
    /info command works, prints your coordinates :)

    Great for OP´s would be a stable flight postion without having to flap all the time.
    Combined with "vanish" you can have a look over your sheeps, and speak to them as the god... :p
    Also good to Observe possible griefers.

    Maybe i could help a bit.
    Sry for misspelling or for bad sentence structure, my native language is different :)
  27. Offline


    yup, same haldur. The toggleconsume however does work. Someone hopped on the server and it was consuming the feather after a couple clicks
  28. Offline

    Voxel Box

    indeed~ if i recall correctly, it's not a 1 flap : 1 feather consume rate. they just sort of dwindle away after a while.
  29. Offline


    any way to toggle the amount consumed then? or the %. Kinda want a certain price on distance. flap distance to be closer to 5 or so, and 1 feather to be consumed per flap or a set amount. Sell feathers for 150 or so and they will be very balanced
    --- merged: Feb 18, 2011 6:36 AM ---
    can you for real take a second and fix this. Like we are dying to fly, but just unlimited flying will destroy a server. I dont know how it's working for you on cb 320, maybe post your config file or update the link to the right version, just please man. fix!
  30. Offline

    Voxel Box

    i hate to play this card, man but: "make me". until you start paying our tuition, picking up the tab for our groceries and buying us health insurance, you are going to have to learn to be content with "we'll get to it when we get to it". we've released four plugins for bukkit, and have three more in development. the plugin has worked flawlessly for us on cb 319 325 and 339 for our applications, which is what we develop for.

    i'm building minecart stations tonight. sometimes we actually like to play the game ourselves.

  31. Offline


    I understand, but seems like some simply fixes such as changing variables to match the right names. I don't know all that much about programming with java so not going to say this stuffs easy.

    I dont really understand how this works flawlessly for you guys (or do you mean you just dont use the /toggleconsume or /thrust?). Can anyone else post if it's working for them? This has been broken the exact same way on every version since 286-323, so I have to be doing something wrong, just wish i knew what.

    ill try updating to 325 and see if that changes anything. Wasnt trying to say "fix it or else" lol just a plea so you knew that people really like this addon and cant use it due to just a few small errors with the toggles.

    Yeah any amount of donations wont be helping you out with your tuition unfortunatley :/, as for health insurance, obama should be helping you with that lol
    --- merged: Feb 18, 2011 5:05 PM ---
    and as far as i can tell from your most recent post it just look like you forgot update the download link to the post, so was just trying to bring this to your attention

Share This Page