[FUN/MECH] Sploderrows v2.0- Fire and explosive arrows [740]

Discussion in 'Inactive/Unsupported Plugins' started by cowman24, Apr 16, 2011.

  1. Offline


    Version: v2.0 [733]
    Allows usage of exploding arrows and fire arrows.

    [cake]Version 2.0![cake]

    I'm excited to bring a total of 5 new features, 5 mechanics updates, and bug fixes.
    Everything new will be explained in more detail in its own spoiler as I write them, this is just to list everything new.

    NEW in 2.0:
    • Permissions! (In more than one way!)
    • Hunterrows !(or hunt arrows, still deciding on that, if you have a better name for what they do tell me, I might change it)
    • Protected Area!
    • Detonators!
    • [type]price replaces [type]cost and currencyitems.
    • [flintnsteel] gets used when set as a price.
    • Separated out tactical arrows to be a subset of each type instead of only sploderrows.
    • Independent triggering for tactical arrows.
    • LESS LAG! I probably should have put this higher up on the list.
    • Added tacticalradius setting, acts like fireradius but for tactical subset of fire arrows.
    • I didn't feel like commenting out an attempt at area selection wands so now there is a super secret surprise command that works but wasn't working well enough for me to include it in the update. [creeper]
    • Anything that you notice is different that I have not listed here is also in the update, however if said difference screws you over you can safely assume its a bug, and will be fixed.
    Tactical Arrows:
    Show Spoiler

    Explode when you trigger them later.
    You can use a left click with the item you fired them with to trigger them, or a detonator.
    You can fire these by sneaking while shooting any type of arrows.
    Tactical arrows behave differently than normal arrows in other ways.
    Generally this difference is that default power is reduced.
    Actually its the only way besides the trigger ability.

    Show Spoiler

    These are special arrows that you can use for safe hunting, without making the area you are hunting in an eyesore or causing alot of lag.
    They dont destroy blocks, only hurt entities, however they dont make a sound, as other explosions would. They also dont make special effects, which is great for anti lag.

    Show Spoiler

    The base permissions node is sploderrows
    the next level contains sploderrows.bows and sploderrows.splode and sploderrows.det
    splode is for /splode commands
    bows is for firing bows
    det is for detonators permissions

    bows permissons are as follows:

    splode permisssions:

    det permissions:

    there is only one det permission, but soon more

    Protected Areas:
    Show Spoiler

    Right off the bat I should tell you all you MUST have at least 1 protected area for it not to crash, here is a fixer yml file.

        fix: world:0.0:0.0:0.0:0.0

    Show Spoiler

    To make a detonator, you place a sign, and make the first line in this syntax.
    [<type>] <name>
    type is H for hunterrows, S for sploderrows, and F for fire arrows.
    name is the name you choose for the detonator, not your name.
    the last 3 lines are for adding names, it will say they are not valid if the player is not logged on that you add. you MUST include the full name.
    Dont worry about adding yourself, you are defaulty on the members list.

    On right click of the sign, all the tactical arrows of type <type> will be detonated for everyone in the members list. I will work on making the detonators bind to the actual sign and more members signs later.

    You know it worked if you see COLORS!!

    Everything else:
    Show Spoiler

    • Permissions, for now
    • MultiVerse (compatible, not really dependent)


    • Exploding Arrows
    • Tactical Arrows Subsets
    • Fire Arrows
    • Hunting Arrows
    • 11 Configurable Settings:
      • Splode Bow Item #
      • Fire Bow Item #
      • Hunt Bow Item #
      • Radius of fire created by Fire Arrows
      • Radius of fire created by Tactical Fire Arrows
      • Cost of Sploderrows in any item.
      • Cost of Fire Arrows in any item.
      • Cost of Hunterrows in any item.
      • Whether or not arrows can combust/explode mid-air
      • Force of Sploderrows/Hunterrows
      • Force of Tactical Sploderrows/Hunterrows
    • In game configurable
    • Out of game configuration file
    • Multi-World support + (+ only if you create worlds using /mvcreate)
    • Automatic configuration generation for all worlds
    • All commands are under a single /splode command, to make /help less cluttered.
    Don't have permissions? Download this instead!

    Source Code

    • Right click with the item assigned to SplodeBow to fire Sploderrows.
    • Right click with the item assigned to FireBow to fire Fire Arrows.
    • Right click with the item assigned to HuntBow to fire Hunterrows.
    • Right click while sneaking with any bow to fire the tactical version of that bow.
    • Left click to trigger your Tactical Arrows.
    • "/splode help" in-game for help with /splode commands.

    Show Spoiler

    • Sploderrows don't emit a fuse as they are supposed to.
    • Protected Areas dont automatically add an entry, you have to add it yourself. Read the instructions in the protected areas spoiler.

    • Fix bugs.
    • Make blocks be able to trigger a groups Sploderrows when powered by redstone.(?)
    • Make Tactical Sploderrows not despawn.
    • Video?
    • Dispenser support.

    Version 2.0
    -Protected Areas
    -Less Lag
    -Everything else
    Version 1.3
    -Auto-add new worlds
    -currencyItems setting
    -Added Worlds: node
    Version 1.2
    -Fixed the bug that was fixed in 1.1 in a way that did not crash the plugin.
    Version 1.1
    -Fixed a bug where if you didn't have a world named "world" it crashed.
    Version 1.0
    -Initial Release
    -Commented out a lot of code.
    Excessive amounts of arrows, explosion force, or fire radius WILL cause lag.

    When submitting error reports via reply please make sure to include as much relevant information as possible, and make SURE you include console output, otherwise I can only help if the error is an extremely common problem that is easily fixed.
    skillinazn likes this.
  2. Offline


    Shiit, I remember this. I tried using this a while back and fucked my server up, I think I'll just wait until you can update it when you don't need it.
  3. Offline


    Alright I added an alternate download link if you don't have permissions

    there you go :D
  4. Offline


    wow thx i love your plugin good work. i will give you a [diamond]
  5. Offline


    I am still getting the "Nag author" about the PreProcessEvent thing.

    Not sure why.
  6. Offline


    So wait, a Book is a firebow? ( I know you can change it, and all that). It just doesn't seem to "work".
  7. Offline


    Nice i would realy like to have this but i dont know how to install it
  8. Offline


    YES, got it to work finally! Thanks bro 10/10

    Ok, the firebow is the book.. I can't figure out how to get the other types. What objects are default?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  9. Offline


    what do you mean by "work"? as in its not ergonomic? or its broken? or do you mean that it doesn't make sense. The reason I made book the default firebow if you were wondering is because its a raw material that cant be used for anything except making stuff, and its a small reference to Fahrenheit 451.

    Its very simple, you just drag and drop it like all other plugins. The config should auto set up and the areas too, but the areas don't have a first entry automatically. So you have to add a basic one. its in the spoiler about protected areas.

    default bows:
    firebow: book
    splodebow: gunpowder (sulphur)
    huntbow: bone

    each is their own detonator, assigning them to an item with a right click function will make that function not happen.
  10. Offline


    Hi, I am getting an error during start up with this:

    16:54:06 [SEVERE] null loading Sploderrows v2.0 (Is it up to date?)
    at me.cowman94.sploderrows.Sploderrows.restoreAreas(Sploderrows.java:131
    at me.cowman94.sploderrows.Sploderrows.onEnable(Sploderrows.java:162)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:127)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManage
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:116)
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:94)
    at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:217)
    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:204)
    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:144)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:259)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)

    I am running b733 and as you can see at the top it says v.2.0. All my other plugins are working, I also have no plugins that have anything to do with arrows.
  11. Offline


    read the Protected Areas spoiler, it will explain this hopefully. You have to at least have 1 area.
  12. Offline


    Thanks that worked. Unfortunatelly when I tested the sulfur bow it blew up my friend's fortress....but hey good to know it works :D
  13. Offline


    00:54:49 [SEVERE] Nag author: 'cowman94' of 'Sploderrows' about the following: onPlayerCommandPreprocess has been replaced with a new signature, (PlayerCommandPreprocessEvent)

    so you change your cowman number a lot?

    also, you do realise that bone has quite the right-click function, yes?
  14. Offline


    cowman24 is what I normally use, then I use other x4's going down from 9 if that's not available. cowman24 was already taken on minecraft so I used that, if I should use bukkit forums one then I will, was never quite clear on that.

    And no I do not, what does it do? You can change it, its really simple if its that important of a function.
  15. Offline


    I am getting an error when placing signs, not a huge issue.

    Also, I can use the powers as an Op, but players can't. I am trying to get the class to just have fire arrows and hunter arrows for PVP and my GroupManager file looks like this:
        default: false
        - bows.fire
        - bows.hunt
        - essentials.kit
        - essentials.kit.archer
    Is there a permissions I am missing to get them to be able to use those?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  16. Offline


    i probably was bad at specifying that the bows is a stem of the main node sploderrows

    so you should make it sploderrows.bows.fire and sploderrows.bows.hunt

    Yeah, thats probably from me forgetting to take away the exception.printStackTrace() in the block listener. Im guessing it only appears when you dont make a detonator with that sign?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  17. Offline


    Yeah, I haven't touched the detonator feature yet, this is just while placing normal signs
  18. Offline


    Well, I don't get any problems, I just don't know how to use it....
  19. Offline


    The directions are in the main post, and then specific help for specific features is in the spoilers.

    I should probably get working on an instructional video, does anyone have any suggestions for a good screen recorder?
  20. Offline


    I also get the sign error:

    19:05:21 [SEVERE] Could not pass event SIGN_CHANGE to Sploderrows
    java.lang.ArrayIndexOutOfBoundsException: 1
    at me.cowman94.sploderrows.SploderrowsBlockListener.onSignChange(SploderrowsBlockListener.java:64)
    at org.bukkit.plugin.java.JavaPluginLoader$29.execute(JavaPluginLoader.java:376)
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:59)
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:257)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:898)
    at net.minecraft.server.Packet130UpdateSign.a(SourceFile:41)
    at net.minecraft.server.NetworkManager.a(NetworkManager.java:195)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:74)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:370)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:285)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)

    could this be sabotaging my attempts to make a craftbook elevator (lift)?
  21. Offline


    It might be, I'll fix it and release an update soon.
  22. Offline


    i try it and i take book click right and... nothing :( why?
    when i have minecraft 1.4_01 version and old sploderrows version is good but when i have 1.5_01 and sploderrows 2.0 that's bad :( help!
  23. Offline


    If you have permissions you have to make sure you have the permission, also the configuration changed, and you have to have at least 1 area. As mentioned in the instructions. Go to the protected areas spoiler and put that in.
  24. Offline


    I am getting an exception whenever I start the server, preventing the plugin from functioning.

    CB 759 (Just updated, was getting same error on 740)
    Minecraft Server Beta 1.5_01
    Sploderrows 2.0

    22:09:07 [SEVERE] null loading Sploderrows v2.0 (Is it up to date?)
        at me.cowman94.sploderrows.Sploderrows.restoreAreas(Sploderrows.java:131)
        at me.cowman94.sploderrows.Sploderrows.onEnable(Sploderrows.java:162)
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:127)
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:670)
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:234)
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:130)
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:108)
        at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:217)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:204)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:144)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:259)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
  25. Offline


    i delete permissions xD
  26. Offline


    Having a problem with this, I can use it fine but the people we give permissions to cant.

        Evil Flaming Ranger:
            default: false
                prefix: '&4'
                suffix: ''
                build: true
                - Citizen
                - 'bows.fire'
                - 'bows.splode'
                - 'bows.hunt'
    I tried adding these:
    - 'sploderrows'
    - 'sploderrows.bows'
    But they made no difference..
  27. Offline


    sploderrows is the base node, i didnt wright it infront of everything because i thought that was implied.
    sploderrows.bows.* should solve the problem, delete everything else.
    read the thread more closely, you need to write the areas yourself because it doesnt make a default. Copy the one in the spoiler.
  28. Offline


    Sorry, didn't see that. Works fine now, thanks!
  29. Offline


    OK I'll test that now, Could I just also suggest you add that fix into the default file? Seems a lot of people are missing it :p
  30. Offline


    This was working for me, but now it isn't. My nodes are:

        default: false
        - sploderrows.bows.fire
        - sploderrows.bows.hunt
        inheritance: []
          - Blue
          - Red
          prefix: ''
          roles-category: class
          build: true
          suffix: ''
    It works as admin, but players with that class can't fire fire or hunterrows.
  31. Offline


    Could you do me a favor and tell me what the inside of the config file is supposed to look like? In terms of spacing, etc.

Share This Page