[FUN/MECH] Lava Furnace - Furnaces that run on lava [BUKITDEV]

Discussion in 'Archived: Plugin Releases' started by Arcwolf, May 30, 2011.

  1. Offline


    Lava Furnace - Furnaces that run on lava:

    The basic idea of this plugin is to allow players to create a furnace that will run on lava but not consume buckets. It allows for customization by admins for fuel burn time, cook time, per player cook times and amount of furnaces per player. It is by default pretty balanced, but is customizable by admins for personal preference in balancing or even cheating if you so choose.

    • User created Furnaces that consume only the lava not the bucket
    • Also can be used with regular fuel sources through the Minecraft furnace interface.
    • Potential to create infinitely fueled furnaces via config file
    • Can set furnace burn times up to 2147483647 via config
    • Can set furnace cook times from 1 to 4 x normal speed via config
    • Can define the blocks a furnace is created from via config
    • Works with multi-worlds
    • Permissions via PermissionsEX, GroupManager, nijikokun based permissions, bukkit permissions or OPs
    • Lava level is easily viewable through glass door and changes with burn time of furnace
    • Optional small or large Production Chests (*based on Zarius's idea)
    • Optional Custom Smelt-ables via config
    • Production chest smelt priority from TOP LEFT to BOTTOM RIGHT
    • Per user cook times, per item cook times from 1 to 4 x normal speed via commands
    • Per player group build limits
    Tutorial Video & Review (by ValBGaming)

    Production Chest Photo:
    Alternate Chest Setup (open)


    Alternate Furnace Layouts (open)


    And you could just keep going with it.

    [​IMG] if you like this plugin and want to support me. Its much appreciated. :)
  2. Offline


    hmmm... good question... so lets nail this down... exactly, no more beliefs... precision to the max.

    Per the wiki 20,000 is 1000 seconds. Based on the precision that is in the formula I'm using the furnace will burn exactly that fast if you set it to 20,000. So one can determine that 100,000 = 5,000 seconds or 83 minutes. IE
    So, its not exactly ms like I though. Its 20 to 1 OR for every 20 units in the config there is 1 second. So, we have 1200 units every minute. Then that means 2147483647 = 1789569.7058333333333333333333333 minutes. or roughly 3 1/2 years.

    and now I need a Tylenol...
  3. Offline


    I am on Zarius's server and can confirm we have had no end of issues with this one.

    I can also confirm the bug of placing the lava beside the crucible triggering the furnace, had this happen to me the first time by accident and have had it happen a number of times since then. The below images were taken 14 seconds apart.

    Furnace in the ready state.

    Lava placed on side and the furnace activates.
  4. Offline


    Confirmed... although I dont know how its possible that does seem to happen... All I can say for now is.. "What tha hell?"

    I'm on it.
  5. Offline


    full server restart lava furnaces go byby
  6. Offline


    Ok, that bug should be put to bed now. I have placed more checks in and now it should be very difficult to Oops a furnace like that.

    Give 1.37 a shot and let me know how it goes.
  7. Offline


    Hey Arcwolf, I did a tutorial/review of this plugin. :)

  8. Offline


    Thats awesome! Thanks, I've swapped out my old tutorial for your tutorial/review vid.

    Thanks again! :D
  9. Offline


    No problem! Happy to help. :D
  10. Offline


    Well, I got the silly vids made, but they are almost a gig in size. Since I have an absolutely horrible upload speed, and other folks have reproduced my error, I won't upload. Glad to see I really did find a bug.
  11. Offline


    Can we fix the falsebook interference with chest production?
  12. Offline


    I've just tested falsebook 862 alpha out with the production chests and as far as I can tell there is no conflict. Production chests and falsebook work ok together. Both the collect and the deposit work. Simply place a collector rail directly beside a production chest. Then place a collection sign with the ore ID you want to put into the furnace on the supply chest side. Place a deposit sign with the item ID under the rail next to the processed chest. I was able to get it to both deposit and collect from single and double chests. Both while the furnace was smelting and not smelting. The chests worked, the furnace worked and falsebook worked. No conflicts noted. I've removed that as a concern from the OP.

    I dont know why it was a problem before but it appears to have resolved its self.

    Side note, Fixed a bug in production chest break detection. No functionality was affected in how the chests worked. It would simply detect a double chest was broken when no chest was actually there. Easily fixed.
  13. Offline


    Another fun one for you, it seems your fix for the Lava fixes it a bit too well.

    Still having the issue of the furnace not restarting once it's burnt out it's first lot of fuel, normal fix for us has been to remove part of the furnace, re-create it and then re-fuel it.

    Did that today (removed the furnace and one stair block) and now get this error when trying to replace those parts. :-D

    On the plus side, I did test the lava, and it does do that with the lava as well, but destroys the lava in the process.
  14. Offline


    Thats been fixed already. v1.371 should allow you to place anything but lava on the side of a furnace like that. Although interestingly enough that furnace looks broken already, Unless you have belt blocks turned off. In any case, I recommend trying 1.371.

    I'm not sure why you would be having that problem. I've been fueling furnaces all over the place and havent had an issue. They fuel and burn, then can be refueled without issue... I'll need more information then what you are providing to see if I can reproduce your problem. Please provide your Config, how you are fueling the furnace (ie lava block, bucket, or some other fuel like coal) and maybe some steps to recreate the problem.

    If you mean a bucket of lava it isnt destroyed it just appears that the bucket is empty. That is only client side visual. The bucket is still full the client just doesnt realize it.


    yea, I think I see a bug now... Hmmmm, interesting. I'll need to take a look into and figure something out.

    Version 1.372 is a quick fix for the lava fueling issue mentioned in previous posts. I'll have to post another version later with a better fix for it. But until then this should work.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  15. Offline


    People are still having problems opening chests with lavafurnace. :( Could it be a problem with lockette?
  16. Offline


    Not sure, I dont use lockette so I havent tested it against it... do you mean all chests or just lavafurnace production chests. If you set lavafurnace chests to free for all then I dont make any attempts to control who accesses chests and lockette or any other plugin can control access freely.

    If its something I can fix on my end then now's the time to do it :) I'm up to my elbows in lavafurnace code fighting a godzilla bug...
  17. Offline


    Well, I don't have freeforall set to true. People can use chests they place, just not the ones from lavafurnace.

    Forgot to quote you, sorry XD

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  18. Offline


    what about: allow_freeforall_chests=true

  19. Offline


    I'll enable it and see if it fixes it.

    Could the issue be I have it set to use_large_chests = true?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  20. Offline


    if you had it set to false I would believe that would be the issue. If its true then I dont know what would be the problem. True means I dont care who accesses the chest. I dont block any access what so ever. I dont even check.
  21. Offline


    =/ So I have large_chest = true and freeforall chests = true. But still doesn't work.
  22. Offline


    So what error message is it saying?

    If it says:

    The chest lid wont budge.
    You can't open it!

    then something isnt right and I'll have to think about that. Else I dont know?
  23. Offline


    My users don't get any message and they have all the right permissions.
  24. Offline


    That just doesnt make sense. If you are not getting an error message then its not lavafurnace causing it. The only check is encased inside a conditional check. If the check is triggered that error message is displayed. If you dont see the error message then lavafurnace is not preventing you from opening the chest.

    The only thing I do to a chest besides that check is add and remove items from the chests. That should not change access rights.

    Lockette you say... I'll have to test it out and see. But as of right now I see no reason for a conflict to occur if you are setting freeforall chests to true.
  25. Offline


    xD Fixed the issue somehow. Not sure how, but apparently you can't have large chests set to true if FFA chests are false, even with permissions, it won't work.
  26. Offline


    Strange, because thats exactly how my config is set up...


    I'll look around the code, maybe something I'm missing?

    v1.373 is up and should be a MUCH better fix for the lava oopsing. IE it should work correctly now.

    I've looked and looked and can find no reason for what you say has happened. I've tried all kinds of stuff, different permissions, different furnace configurations... I just cant reproduce that problem.

    The Large chests config value is not linked to permissions in any way. Not even a little bit. The only thing Large chests in the config does is tell the plugin to use the extra capacity. Thats all it does. I'm stumped. <shrugs>

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  27. Offline


    How to disable belt_blocks?
  28. Offline


    In the config there is an option to set the block type for belt blocks. Set it to 0
  29. Offline


    v1.374 is just a quick update for Bukkit 1000. Protection from pistons pushing or pulling a furnace block.

    Ok, v1.375 I have in beta right now, If anyone wants to test it out to make sure I have it correct.

    The update includes compatibility for Bukkit's permissions system.

    lavafurnace.*                         <- gives all admin permissions + chest access
    lavafurnace.admin.*                   <- gives all admin permissions
    lavafurnace.player.*                  <- gives all player permissions
    lavafurnace.admin.maxforgeoverride    <- overrides the max forge limit for admin or player
    lavafurnace.player.build              <- Can build lava furnace
    lavafurnace.admin.build               <- Can build lava furnace
    lavafurnace.admin.fuel                <- can fuel any lava furnace...
    lavafurnace.player.fuel               <- can fuel only their own lava furnace...
    lavafurnace.admin.lavablockfuel       <- can fuel any lava furnace...
    lavafurnace.player.lavablockfuel      <- can fuel only their own lava furnace...
    lavafurnace.admin.destroy             <- can destroy any lava furnace...
    lavafurnace.player.destroy            <- can only destroy their own lava furnace...
    lavafurnace.admin.use                 <- can use any lava furnace
    lavafurnace.player.use                <- can only use a lava furnace they create
    lavafurnace.chests                    <- can place production chests limited by config
    Now the plugin should check for GroupManager or niji based permissions. Then it'll check for Bukkit Permissions and finally if all that fails it will default to OPs.

    I've tested the permissions out and it seems to be working ok but you never know...

    --file removed--

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  30. Offline


    loaded up and got error

    i am on 953 bukkit
  31. Offline


    Requires at least Bukkit 1000. Block_piston_extend is a method only available in bukkit 1000.

Share This Page