[FUN/MECH] ElixirMod v1.00 - A Drink to Victory! [1060]

Discussion in 'Inactive/Unsupported Plugins' started by Steeveeo, Jun 18, 2011.

  1. Offline


    ElixirMod - A Drink to Victory!
    Version: v1.00

    ElixirMod is my first plugin for Bukkit, and is tested and working under build 860. This plugin adds a few "simulated items" that users can toy with, which are listed in Features.
    The way this mod works is that a user holds an empty bowl in hand, right clicks, and if they have the proper ingredients, will give them a buff for a period of time. But if they are not careful, they could hurt themselves, as each drink racks up "Toxicity" which can hurt more than it helps.

    • Works with Permissions 2.7.4 and equivalent (tested with Essentials Group Manager).
    • Every aspect of each Elixir is, or will be modifiable.
    • Several fun and useful Potions and Elixirs, see the Potion List below for details
    [​IMG] Download ElixirMod.jar
    [​IMG] Source Code

    Having issues with ElixirMod? Have a suggestion? Posting it here tends to get lost in chatter, instead:

    PermissionsBukkit Hotfix:
    When version 1.00 of ElixirMod came out, it did not support PermissionsBukkit. The fix for this is relatively simple, and just requires a quick edit to the ElixirMod.jar file. Make sure the server is off before attempting this, and then open ElixirMod.jar in something like 7zip, open "plugin.yml" and replace its content with the stuff in the following spoiler tag, save and make sure your archive program updated the file inside it, then run the server and enjoy ElixirMod on PermissionsBukkit (note, requires SuperPermsBridge):
    Show Spoiler

    1. name: ElixirMod
    2. main: me.steeveeo.ElixirMod.ElixirMod
    3. version: 1.00
    4. load: startup
    5. commands:
    6. elixir:
    7. description: Command container for all ElixirMod Admin commands.
    8. permissions:
    9. elixirmod.*:
    10. description: Gives access to all ElixirMod permissions.
    11. default: false
    12. children:
    13. elixirmod.command.*: true
    14. elixirmod.allpotions: true
    15. elixirmod.command.*:
    16. description: Gives access to all ElixirMod chat commands
    17. default: false
    18. children:
    19. elixirmod.command.gettox: true
    20. elixirmod.command.gettox.others: true
    21. elixirmod.command.settox: true
    22. elixirmod.command.settox.others: true
    23. elixirmod.command.reset: true
    24. elixirmod.command.reset.others: true
    25. elixirmod.command.givebuff: true
    26. elixirmod.command.takebuff: true
    27. elixirmod.allpotions:
    28. description: Grants access to all ElixirMod potions
    29. default: true
    30. children:
    31. elixirmod.cactusrum: true
    32. elixirmod.firetouch: true
    33. elixirmod.haste: true
    34. elixirmod.obbyskin: true
    35. elixirmod.wheatseedtea: true
    36. elixirmod.featherfall: true
    37. elixirmod.diversale: true
    38. elixirmod.frosttouch: true
    39. elixirmod.health: true
    40. elixirmod.dragonsdraught: true
    41. elixirmod.command.gettox:
    42. default: false
    43. elixirmod.command.gettox.others:
    44. default: false
    45. elixirmod.command.settox:
    46. default: false
    47. elixirmod.command.settox.others:
    48. default: false
    49. elixirmod.command.reset:
    50. default: false
    51. elixirmod.command.reset.others:
    52. default: false
    53. elixirmod.command.givebuff:
    54. default: false
    55. elixirmod.command.takebuff:
    56. default: false
    57. elixirmod.cactusrum:
    58. default: true
    59. elixirmod.firetouch:
    60. default: true
    61. elixirmod.haste:
    62. default: true
    63. elixirmod.obbyskin:
    64. default: true
    65. elixirmod.wheatseedtea:
    66. default: true
    67. elixirmod.featherfall:
    68. default: true
    69. elixirmod.diversale:
    70. default: true
    71. elixirmod.frosttouch:
    72. default: true
    73. elixirmod.health:
    74. default: true
    75. elixirmod.dragonsdraught:
    76. default: true

    Note, when updating to or through any version with the "(Config Reinstall Required)" flag in the changelog, you must delete the ElixirMod folder in Plugins, then run the server to let the plugin regenerate the file.

    Version 1.00
    (Config Reinstall Required)
    • First off, a note. Many, many things changed, so this is not a complete list. Instead, just the main points of the changes made, nothing fine.
    • Complete rewrite of how potions work and act, systematically. Now uses a modular class-based system instead of the stupid CopyPasta I had going on in prior versions. YAY, it's now officially an Object Oriented Program! Derp.
    • Added some new stuff to the config files for existing potions.
    • Made the ability for Firetouch users to ignite Netherrack with rightclick. This casts a BLOCK_IGNITE_EVENT with the cause of FLINTANDSTEEL before igniting, so it can be canceled. Handy for region protection.
    • Added support for specifying the ENTIRE recipe within the config files. Syntax is as follows: "Item : Data * Amount,..." Specifically, Item is the type of inventory item to look for, Data is the datavalue associated with the item (use them for dyes, it's what I built it for), and amount is, well, the amount. 351:1*5,1*1 would be 5 Rose Red dye and 1 Stone, for example.
    • Added Diver's Ale. Costs 8 glowstone dust and 1 rose, gives 5 times the breath underwater.
    • Added Elixir of Frosttouch. Costs 4 Snowblocks and 1 waterbucket. 75% chance to stun a hit target for 3 seconds.
    • Added Health Potion (generic name HO!). Costs 1 brown mushroom, 1 red mushroom, and 1 milkbucket. Gives a half-heart per 1 second for 15 seconds.
    • Added Dragon's Draught. Costs 2 lavabuckets and 4 obsidian. Gives heat-damage immunity. Lava immunity is on by default, but is a toggle in the config for admins who don't like it.
    • Added a Chat Command system. Commands are as follows (player can be the * wildcard to select the entire server):
      • /elixir Prints out the help and usage
      • /elixir gettox[ player] Prints out your toxicity, or the specified player(s)
      • /elixir settox[ player] amount Sets the Toxicity variable on self or player(s).
      • /elixir givebuff player buffname Grants a buff by name to player(s).
      • /elixir takebuff player buffname Inverse of the above.
    • Got rid of some useless and unused events. All of the other events are handled in the potion objects now, and there's no need for a joiner event anymore.
    • Made the util.takeItemAmount() function check for data values as well as special behavior for bucket contents. If a potion recipe asks for, say, a lava bucket, this function will now replace the lava bucket with an empty one.
    Previous Versions (open)

    Version 0.75:
    Show Spoiler
    (Config Reinstall Required)
    • Removed "Plugin Enabled" from config, really didn't do anything and was a remnant from the config tutorial I based it on.
    • Fixed some pretty severe NullPointerError spam with the Elixir of Haste and some with Elixir of Obbyskin. This was due to reloading plugins making my hashtables reset. Now checks for null hashes before doing anything with them.
    • Added Elixir of Featherfall. Costs 16 feathers and negates fall damage for 2 minutes.
    • Added Elixir of Firetouch. Costs 16 netherrack and gives the user a 75% chance to ignite a target for 5 seconds. Currently ignites via any damage from a user, but can be configured to only work when unarmed.

    Version 0.66:
    Show Spoiler

    • Fixed Wheatseed Tea use check. Failed copypasta from Obsidian Skin made it check to see if the user had leather as well as the required ingredients.

    Version 0.65:
    Show Spoiler
    (Config Reinstall Required)
    • Added Elixir of Obsidian Skin - 50% damage reduction for 5 minutes, takes 1 obsidian and 8 leather.
    • Added Wheatseed Tea - 50% toxicity reduction, 25% buff reduction, 2 hearts health regen. Takes 16 seeds.
    • Reworked Toxicity system, will now cause damage over time if overtoxic.
    • Added in more options and renamed some entries on the Config file to make them more clear.
    • Added in the ability to toggle each Elixir in the Config file.

    Version 0.31
    Show Spoiler

    • Fixed a divide-by-zero error in Cactus Rum that enabled users to get infinite health by taking a second dose after the first wore off.

    Version 0.3
    Show Spoiler

    • Official Public Release.
    • Redid entire "Toxicity" system to work with multiple types of potion buffs.
    • Added in Elixir of Haste. Note, this is just a LITTLE bit out of whack, and admins might want to restrict this for now.

    Version 0.2
    Show Spoiler

    • Refactored the plugin to be called ElixirMod, as a brainstorm session with fellow players pushed me to expand this.
    • Added Config File support.
    • Added Permissions support.

    Version 0.1
    Show Spoiler

    • Plugin Created under the name CactusRum.
    • Got Cactus Rum working.

    List of Elixirs and Potions
    Show Spoiler

    • Cactus Rum - Requires 16 cactus. Does a default of 3 hearts of damage, then grants 3 minutes of health regen (1/2 heart every 3 seconds).
      • Permission Node: elixirmod.cactusrum
    • Elixir of Haste - Requires 16 sugar. Makes the drinker run much faster than normal. Currently not working 100% as intended, but still fun to play with.
      • Permission Node: elixirmod.haste
    • Elixir of Obsidian Skin - Requires 1 obsidian, 8 leather. Drinker gets 50% damage reduction for a default of 5 minutes.
      • Permission Node: elixirmod.obbyskin
    • Wheatseed Tea - Requires 16 seeds. Reduces toxicity by half, and for balance, reduces buff durations by 25%. Also restores 4 (2 hearts of) health.
      • Permission Node: elixirmod.wheatseedtea
    • Elixir of Featherfall - Requires 16 feathers. Negates fall damage while active for a default of 2 minutes.
      • Permission Node: elixirmod.featherfall
    • Elixir of Firetouch - Requires 16 netherrack. Default 75% chance to ignite mobs on-hit. Defaults to working with any damage, but configs allow the ability to limit it to unarmed only.
      • Permission Node: elixirmod.firetouch
    • Elixir of Frosttouch - Requires 4 snowblocks, 1 water bucket. 75% chance to stun a target for 3 seconds.
      • Permission Node: elixirmod.frosttouch
    • Diver's Ale - Requires 8 glowstone dust, 1 rose. Default 5 minutes of 5 times the breath underwater.
      • Permission Node: elixirmod.diversale
    • Health Potion - Requires 1 red mushroom, 1 brown mushroom, 1 milk bucket. Gives 1 half heart per 1 second for 15 seconds.
      • Permission Node: elixirmod.health
    • Dragon's Draught - Requires 2 lava buckets, 4 obsidian. Gives fire immunity for default 5 minutes. Lava immunity can be toggled.
      • Permission Node: elixirmod.dragonsdraught

    Admin Commands
    Show Spoiler

    Note, all <player> fields can be either a player's partial name, full name, or the * wildcard to select everyone in the server. Fields surrounded by [ ] are optional (in the case of <player>, if not specified, will act on the calling player).
    • /elixir - Prints out the help and usage for all ElixirMod commands.
    • /elixir gettox[ <player>] - Prints out the toxicity level over the maximum "safe" toxicity level (i.e., greater than the second number = damage over time from being toxic).
    • /elixir settox[ <player>] <amount> - Sets the toxicity level of a player.
    • /elixir givebuff <player> <buffname> - Gives a buff by potion name to a player. Bypasses the "Drink" function, so toxicity is not applied.
    • /elixir takebuff <player> <buffname> - Inverse of the above.

    Planned Potions
    Note, I am generally only a moderately original creator, and thus I can only come up with a finite number of ideas. New suggestions are always welcome!
    Show Spoiler
    (Subject to change due to new ideas and limits on possibility.)
    • Elixir of Stealth - Blocks mob targeting unless the user attacks.
    • Greater Potion of Invulnerability - Very expensive potion that would grant godmode to the user. By "expensive", I mean it. Probably as bad as a diamond version of a Golden Apple, but more likely a callback to the Yogscast's Mistral City ark with its ingredients. ;)
    • Elixir of Protection - Gives a stackable "over-shield" buff for some time that absorbs a flat amount of damage (possibly 5 for the default, might bump that up when I enter the balancing phase of the next version.
    • Potion of Blinding Strikes - Gives a chance to "blind" the target on-hit. This will not affect player visibility or mob targeting, but will make attacks have a high chance to miss.
    • Thornskin Brew - Returns about 30% of damage taken back to its source.
    • Dread Venom - Causes the next attack to poison the target, reducing damage output by half, blocking healing (or reducing it by half, if possible), and perhaps a light slow in future versions. The Health Potion would act as an antidote and resume healing as normal.

    Known Issues
    This is a list of all the bugs that I personally know about and am planning to fix in the next couple of versions.
    Show Spoiler

    • Elixir of Haste - Wildly uncontrollable, jumping impossible while hasting. This is due to Minecraft not having any way via stock functions to get what keys a player is pressing down, meaning that the only way to Haste is to throw the player in the direction he/she is looking. Sadly, this also means that it overrides the jump velocity, due to how movement is broadcast across the net. In order to jump in the current version, you need to stop speeding by holding "Sneak". I plan to fix this by adding BukkitContrib support in the next version (planned version 1.2). Those without BukkitContrib Client installed will still have to deal with the same crappy movement code, sadly.
    • Dragon's Draught - Sinking into lava and hitting the bottom of a pool more than 2-deep will cause damage. This is due to how Minecraft treats lava, which is more like Web than Water. The user actually takes fall damage while sinking, and I am not sure how to go about fixing this, other than some wildly extensive checks that might actually bring the server to its knees if I do it improperly.
    • Heroes plugin - Health-restoring potions do not work with this plugin, as Heroes completely rewrites how health works in Bukkit, and ElixirMod uses stock Bukkit health. No plans to write an interface for this.
    CJits and kahlilnc like this.
  2. Offline


    Pretty sure it was 5 gunpowder and two golden apples, plus some feathers (which Fumblemore stripped off some arrows).
  3. whenever i try using a potion my console says:
    [SEVERE] Could not pass event PLAYER_INTERACT to ElixirMod
    java.lang.NoClassDefFoundError: com/nijiko/permissions/PermissionHandler
    at me.steeveeo.ElixirMod.ElixirModPlayerListener.onPlayerInteract(ElixirModPlayerListener.java:55)
    at org.bukkit.plugin.java.JavaPluginLoader$10.execute(JavaPluginLoader.java:307)
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:321)
    at org.bukkit.craftbukkit.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:168)
    at org.bukkit.craftbukkit.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:139)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:520)
    at net.minecraft.server.Packet15Place.a(SourceFile:57)
    at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:84)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)

    ive tries using no permissions and i have tried using the latest permission

    the mod seems great, so i would really love to see it on my server :)
  4. Offline


    That's a very strange callstack, considering that line 55 of ElixirModPlayerListener is:
                    Material blockMat = clicked.getType();
    Nevertheless, some debugging things. First, try removing the ElixirMod folder from Plugins and restarting your server. You already said you tried the latest version of Permissions, so I'm sure it's not that it's outdated. However, this plugin is made for Permission 2.X.X, are you using 3.X.X?

    If the first doesn't work and you're using Permissions 2 (or equivalent, as with Essentials Group Manager), try redownloading the plugin, removing ElixirMod completely from your server (have it off at this time) including the folder, and then put the redownloaded Jar in and restart the server.
  5. :13:39 [ALLVARLIG] Could not pass event PLAYER_INTERACT to ElixirMod
    at me.steeveeo.ElixirMod.ElixirModPlayerListener.onPlayerInteract(Elixir
    at org.bukkit.plugin.java.JavaPluginLoader$10.execute(JavaPluginLoader.j
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.jav
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.j
    at org.bukkit.craftbukkit.event.CraftEventFactory.callPlayerInteractEven
    at net.minecraft.server.ItemInWorldManager.interact(ItemInWorldManager.j
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:553)
    at net.minecraft.server.Packet15Place.a(SourceFile:57)
    at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:85)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    using permissions 2.7 now, tried everything you said, dunno if its any different now :-(, but it still doesnt work,
    and how do i add "spoiler"? theese error logs are kinda long
  6. Offline


    Well it certainly is different this time, the permissions error actually points to a line that accesses Permissions, so that's a start. Well, we can try this then: please post your config file's contents here. You can find it at: "<server folder>/plugins/ElixirMod/config.yml", let's see if it contains the right stuff. The only NPEs I ran into while testing the release version seemed to come from me forgetting to delete the aforementioned file before running, so this is new to me.
  7. oohhhhh, here it is

    Minimum Toxicity For Damage: 50
    Toxicity Per Damage: 20
    Toxicity Tick Length: 3
    Cactus Rum:
    Enable: true
    baseDamage: 6
    toxicityPerDamage: 6
    toxicityPerDrink: 55
    ticksPerDrink: 60
    tickLength: 3
    Recipe: 81*16
    Elixir of Firetouch:
    Enable: true
    toxicityPerDrink: 50
    ticksPerDrink: 15
    tickLength: 6
    igniteLength: 5
    igniteChance: 75
    Unarmed Only: false
    Ignite Netherrack: true
    Recipe: 87*16
    Elixir of Haste:
    Enable: true
    toxicityPerDrink: 20
    ticksPerDrink: 10
    tickLength: 6
    Recipe: 353*16
    Elixir of Obsidian Skin:
    Enable: true
    toxicityPerDrink: 50
    ticksPerDrink: 30
    tickLength: 10
    Recipe: 49*1,334*8
    Wheatseed Tea:
    Enable: true
    toxicityDivisor: 2
    Reduce Buff Ticks: true
    buffTickDivisor: 1.5
    healthRecovery: 4
    Recipe: 295*16
    Elixir of Featherfall:
    Enable: true
    toxicityPerDrink: 40
    ticksPerDrink: 20
    tickLength: 6
    Recipe: 288*16
    Divers Ale:
    Enable: true
    toxicityPerDrink: 30
    ticksPerDrink: 50
    tickLength: 6
    defaultAirTicks: 300
    maxAirMult: 5
    Recipe: 348*8,38*1
    Elixir of Frosttouch:
    Enable: true
    toxicityPerDrink: 50
    ticksPerDrink: 90
    tickLength: 1
    stunLength: 3
    stunChance: 75
    Unarmed Only: false
    Freeze Players: true
    Recipe: 80*4,326*1
    Health Potion:
    Enable: true
    toxicityPerDrink: 20
    ticksPerDrink: 15
    tickLength: 1
    Health Per Tick: 1
    Recipe: 39*1,40*1,335*1
    Dragons Draught:
    Enable: true
    toxicityPerDrink: 60
    ticksPerDrink: 50
    tickLength: 6
    Block Lava Damage: true
    Extinguish Fire: false
    Recipe: 327*2,49*4
  8. Offline


    No no no, the ElixirMod config file, at the directory location I put in my post.
  9. wasnt that it
    (first i took the permission config, then i edited my post and i think i took the right one

    and thanks for always answering so FAST!
    you rock and your mod looks great
  10. Offline


    There it is. Hmm, is it really not spaced out right? Or is that a forum formatting issue?

    The only other thing I can think of is perhaps a plugin conflict. How many other plugins do you have installed and what version of Bukkit are you running?
  11. im runnig version 1000 i think, how do i check?
    i got the plugins:
    and permissions 2.7
  12. Offline


    Well it normally says the version number when you first load up the server. I am pretty sure none of those mods interfere with ElixirMod. I am unsure of what Praecantatio is, but I am pretty sure there wouldn't be a conflict there (it's not that big of a plugin).

    If you have access to the server console, could you paste the log from when you start up the server until when it says "Done! (0.### ms)" (in [ code] tags) so I can see if anything is erroring on-load?

    In the interim, I'm going to download the released Jar myself and make sure it all runs properly, might have been an uncaught build error (though I could have swore I uploaded the one I was using on a live server).
  13. i think youve found the issue ust look

    151 recipes
    16 achievements
    16:49:09 [INFO] Starting minecraft server version Beta 1.7.3
    16:49:09 [INFO] Loading properties
    16:49:09 [INFO] Starting Minecraft server on *:25565
    16:49:09 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-945-
    g73697a4-b1000jnks (MC: 1.7.3)
    16:49:09 [ALLVARLIG] Could not load 'plugins\Permissions.jar' in folder 'plugins
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

    at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)

    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Sou
    at java.lang.reflect.Constructor.newInstance(Unknown Source)
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.j
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:128)
    at org.bukkit.craftbukkit.CraftServer.<init>(CraftServer.java:97)
    at net.minecraft.server.ServerConfigurationManager.<init>(ServerConfigur
    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:132)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:335)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Caused by: while scanning for the next token
    found character '\t' that cannot start any token
    in "<reader>", line 70, column 1:
    - '*'

    at org.yaml.snakeyaml.scanner.ScannerImpl.fetchMoreTokens(ScannerImpl.ja
    at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(ScannerImpl.java:18
    at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockSequenceEntry.produce(
    at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockSequenceFirstEntry.pro
    at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:163)
    at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(ParserImpl.java:148)
    at org.yaml.snakeyaml.composer.Composer.composeSequenceNode(Composer.jav
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:158)
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
    at org.yaml.snakeyaml.composer.Composer.composeDocument(Composer.java:12
    at org.yaml.snakeyaml.composer.Composer.getSingleNode(Composer.java:105)

    at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseCons
    at org.yaml.snakeyaml.Yaml.load(Yaml.java:264)
    at com.nijiko.configuration.NotNullConfiguration.load(NotNullConfigurati
    at com.nijikokun.bukkit.Permissions.Permissions.<init>(Permissions.java:
    ... 13 more
    16:49:09 [INFO] [ElixirMod] Permissions system not detected, defaulting to OP.
    16:49:09 [INFO] [ElixirMod] - Version 1.00 Started.
    16:49:09 [INFO] Preparing level "world"
    16:49:09 [INFO] Preparing start region for level 0 (Seed: 3168373711284245451)
    16:49:10 [INFO] Preparing start region for level 1 (Seed: 5508873668152775494)
    16:49:10 [INFO] BleedingMobs Version: 2.0 by Perdog has been Enabled!
    16:49:10 [INFO] [ChopTree] Permissions not detected, defaulting to ops.
    16:49:10 [INFO] ChopTree 1.23 enabled!
    16:49:10 [INFO] [Praecantatio] Permission system not detected, defaulting to OP
    16:49:10 [INFO] [Praecantatio] v1.2 active.
    16:49:10 [INFO] Server permissions file permissions.yml is empty, ignoring it
    16:49:10 [INFO] Done (0,079s)! For help, type "help" or "?"
  14. Offline


    Seems you've got an errant [Tab] in your Permissions config somewhere. Sometimes I absolutely despise YAML configs, but they're easy to program for. I would start by looking character-by-character at the Permissions config file until you find that tab that's killing it. Or, if you can't be arsed to do that, delete it and let Permissions regenerate it.

    Also on my list of chores for the next version: change the default behavior for when Permissions is not found.

    PS: Please, PLEASE wrap your long pastes in [code ] tags, it makes things readable and less spammy! XD
  15. Code:
    like this?
    how do i do then, if i shall not tab?
    oh sorry didnt know how to do that
  16. Offline


    YAML's "Tabs" are done with 4 spaces instead.
  17. now sorry being a total noob but how do i make it so th "default group" can use all potions?

    wait got it working THANKS ALOT!!!!!
    youve been so extremely patient and instructive OMG THANKS im so HAPPY!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  18. Offline


    No problem.
  19. Offline


    Alright, the config file for changing the recipes are all set up and I'm loving it. My players are just still very confused on how to control what elixir they are drinking... Some way to change the selected elixir or control what ones will activate would be great. It is making it hard to strategically use elixirs for combat scenarios.
  20. Offline


    Currently, the plugin selects the elixir by the first ingredients it encounters from the top left of the inventory (from my tests, at least). I am not sure why it doesn't start from the quickbar, but I plan to do some modifications to how it selects in later patches.

    Quite frankly, I want to steer away from using chat commands to select potions, as that's rather unwieldy and not quite how I plan it (like using an actual item without having to mod the client). I might do something strange like checking the inventory spaces above the bowl first if I can figure that out, but currently, it's just whatever's first in the inventory.
  21. Offline


    Yeah... being able to cycle through them would be good.

    Or just add options...

    Config file wise, you could turn cycling off/on, you could search from quickslots first when off, and also you can use chat commands as an option to get finer control.
  22. Offline


  23. Offline


  24. Offline


    umm not try to be rude or a smart ass but spout is BukkitContrib for the most part they changed the name etc and it is now spout *goes back into coner*
  25. Offline


    Ah, well that makes a fair bit more sense. However, the thing was talking about custom launchers and all that (possibly a misread), so I thought it was something that did the same thing in a different way. Seems I completely failed to read the first danged line in the thing, so there's that. [creeper]
  26. Offline


    no worries it confused me as well when I first saw it :eek:
  27. Offline


    Don't know whether I've misread is or something, but is there no way for users to check their toxicity levels without being an admin? It's listed under admin commands and there doesn't seem to be a permission node to let my players use the command for it. As cool as the mod is, it's not very useful being blind to your own toxicity level...
  28. Offline


    Give users the permission node 'elixirmod.command.gettox' and tell them to use the command '/elixir gettox'.

    If you don't have permissions installed, you might have to wait until the next version, as the default behavior is to check for OP currently (copypasta from the Permissions API setup tutorial did that much).
  29. Offline


    uhm... do i use a command to make a potion? ^-^
    or you i right click or sumting..
  30. Offline


    Read the first paragraph of the first post, please.
  31. Offline


    Ah I do have Permissions, but I must not have seen that node. Thanks for the reply, much appreciated.

Share This Page