Inactive [FUN/MECH] ChopTree 1.24 - Chop Trees by Removing Lowest Block - Like Cacti [1000] (by Arcwolf)

Discussion in 'Inactive/Unsupported Plugins' started by askmeaboutlo0m, May 1, 2011.

  1. Offline


    ChopTree - Chop trees like cacti or make logs move down while chopping
    Version: 1.24

    There seems to be a plugin conflict where the client crashes with a blue-white screen and keeps crashing for minutes after that.
    If you encounter the error please give me a list of the plugins you are using, with enough lists I will be able to outrule what causes it. Please also tell me if you are using any client-side mods.

    Thanks very much to Arcwolf for developing version 1.24!

    Tested with Craftbukkit build [740], [766], [798], [818], [1000].
    Supports: Permissions v. 2.7.2 (Phoenix) and mcMMO v. 1.0.07.
    Please give me feedback, ask any questions you like and/or provide suggestions!
    Thank you!

    • Lets trees act like cacti - remove a block and all blocks above are yieled too.
    • Or you can make that log blocks move down one by one instead - no more climbing trees.
    • Works with all three tree types (they all yeild their own wood).
    • Also works with "big" trees that have multiple branches - makes felling them a lot easier.
    • Restrict using this plugin to certain tools only.
    • Supports mcMMO and Permissions.
    • Only works on trees, houses made of logs are safe!
    • Chunk protection to make your tree houses safe.
    Download (JAR file) | Source (ZIP file)

    This plugin was requested by Britich and is inspired by the Canary plugin RealTree by billyoyo.
    However, it is not just a simple port of that plugin, it was made from scratch after Britich's description.

    Show Spoiler

    Approach tree...

    ...and punch it.

    All logs will be yielded.

    The leaves will decay like normal.


    Even though I added a lot of things for version 1.2 it will act like the original one if you don't change any settings - with the exception of players are able to toggle the plugin.​
    To run this plugin just copy it into your plugins folder. On first startup it will create a ChopTree folder and a file, which you can edit.​
    There will be a ChopTree.players file which saves player toggles and a ChopTree.chunks file which saves protected chunks.​

    Properties File:
    Show Spoiler

    The file will look like this when first created:
    # -ChopTree Properties-
    # You can add or change the command and toggle command aliases here.
    # Because of technical limitations the console commands will always be "ChopTree" and "ct", but the in-game comments will be taken from here.
    Command = ChopTree, ct
    Toggle = ToggleChop, tc
    # Here you can change the options (can also be done in-game).
    ActiveByDefault = true
    UseAnything = true
    MoreDamageToTools = false
    InterruptIfToolBreaks = false
    SupportMcmmoIfAvailable = true
    TreeFellerNeeded = false
    LogsMoveDown = false
    OnlyTrees = true
    # -Material List-
    # If the "UseAnything" option is false, the plugin will take the items you can use to chop trees with from here.
    # You can either put in the material's name or its ID.
    mat = WOOD_AXE
    mat = STONE_AXE
    mat = IRON_AXE
    mat = GOLD_AXE
    mat = DIAMOND_AXE
    Command and Toggle can be changed manually by just adding more aliases for them, seperated by commas. Note that if you run the command from the console it will always have the aliases "ChopTree" and "ct", no matter what it says in your file.
    You can also remove either of the lines to disable the command for players completely.

    The options can be changed manually in the file too. To find out which option has which effect look at the "Commands" section below.

    The material list will only be used if the option UseAnything is false. In that case you can specify which items players can use to chop trees with this plugin, other items will not trigger plugin effects (except chunk protection). You can either use the item ID or it's name.
    If you want to make tree chopping more costly you can only allow gold axes for example.
    List of item IDs on Minecraft Wiki, list of all item names in the Bukkit documentation.

    Show Spoiler

    ChopTree - show status of all options.
    ChopTree (option) - show status of specified option.
    ChopTree (option) (true/false) - switch option on or off.
    ChopTree chunk - shows if your current chunk is protected.
    ChopTree protect - deactivates the plugin in your chunk.
    ChopTree fullprotect - disables destroying logs in general (not only with plugin) in your chunk.
    ChopTree reload - reloades changes from your properties file (the normal reload won't do that)
    ToggleChop - toggles the plugin on and off for a player.

    (option) can be:
    ActiveByDefault - choose if plugin will be toggled on or off for players (on).​
    UseAnything - if activated players can use any item to chop trees, else materials list will be used (off).​
    MoreDamageToTools - toggles damage to tools for every chooped log (off).​
    InterruptIfToolBreaks - if activated tree chopping will interrupt if the tool breaks (off).​
    SupportMcmmoIfAvailable - if activated plugin will support mcMMO if it can find it (on).​
    TreeFellerNeeded - choose if players need to have mcMMO's tree feller enabled (off).​
    LogsMoveDown - if activated logs will move down when chopped instead of popping like cacti (off).​
    OnlyTrees - if enabled only trees can be chopped, else all logs can be (on).​
    EnableOverride - if enabled choptree.override nodes can be used (off)​

    Show Spoiler

    ct or "command" in properties file for ChopTree.
    tc or "toggle" in properties file for ToggleChop.
    c for chunk.
    p for protect.
    f or full for fullprotect.
    r for reload
    a or default for ActiveByDefault.
    u or anything for UseAnything.
    m or damage for MoreDamageToTools.
    i or interrupt for InterruptIfToolBreaks.
    l or down for LogsMoveDown.
    o or trees for OnlyTrees.
    e or override for EnableOverride.

    Show Spoiler

    Permissions node - description (default if you are not using Permissions)

    choptree.chop - chop trees using this plugin (all)

    choptree.command.check - check what status the options have (all)
    choptree.command.change - change status of options (ops)
    choptree.command.toggle - toggle plugin per player (all)
    choptree.command.protect - protect/unprotect chunks (ops)
    choptree.command.chunk - see if the chunk is protected (all)
    choptree.command.reload - reload properties file (ops)

    Override nodes will be ignored if EnableOverride is false.

    choptree.override.moredamagetotools - will not have tools damaged for every log (off)
    choptree.override.useanything - can use any item (off)
    choptree.override.interruptiftoolbreaks - chopping won't interrupt when the tool breaks (off)
    choptree.override.treefellerneeded - tree feller is never needed (off)
    choptree.override.onlytrees - can chop all logs, not only trees (off)
    choptree.override.chunkprotection - chunk protection will be ignored (ops)

    To Do:
    • (Medium) Test with WorldGuard, remove conflict
    • (Medium) Enhance isTree algorithm a bit more
    • (Medium) Add [tools], [non-tools] and [hands] to material list
    • (Low) Add configurable drops
    • (Low) Add automatic sapling replant
    • Version 1.24 by Arcwolf - Download (JAR file) | Source (ZIP file) - July 28. '11
      • Removed deprecated methods
      • Fixed mcMMO compatibility
      • Updated for Craftbukkit build [1000]
    • Version 1.23 - Download (JAR file) | Source (ZIP file) - June 02. '11
      • Fixed an error with iron axe receiving double damage as if it wasn't an axe
      • Added /ct reload command to reload changes from properties file
    • Version 1.22_2 - Download (JAR file) | Source (ZIP file) - June 01. '11
      • Recompiled for Minecraft 1.6.6/Craftbukkit [818]
    • Version 1.22_1 - Download (JAR file) | Source (ZIP file) - May 22. '11
      • Fixed chunk protection Permissions
    • Version 1.22 - Download (JAR file) | Source (ZIP file) - May 22. '11
      • Fixed chunk protection
    • Version 1.21 - Download (JAR file) | Source (ZIP file) - May 16. '11
      • Added EnableOverride option (off by default) to fix wildcard problem
    • Version 1.2 - Download (JAR file) | Source (ZIP file) - May 14. '11
      • Rewrote tree finding algorithm
      • Fixed some bugs leading clients to crash
      • Fixed and extended Permissions support
      • Added toggle commands
      • Added mcMMO support
      • Added option that player has to have mcMMO's TreeFeller enabled
      • Added optional damage to tools
      • Added optional tools list to restrict using this plugin only with certian tools
      • Added option to let trees go down one by one instead of popping like cacti
      • Added chunk-wise protection
      • Included plugin.yml into source download
      • Probably more
    • Version 1.1 - Download (JAR file) | Source (ZIP file) - May 5. '11
      • Added Permissions support
      • Fixed bug with some pine trees not being chopped
    • Version 1.0 - Download (JAR file) | Source (ZIP file) - May 1. '11
      • Initial Release
  2. Offline


    Probably a plugin conflict.
    Which plugins are you running?
    Does it work if you disable them all and only run ChopTree?
  3. Offline


    This plugin is great, but doesn't re-load properly.
    /reload all doesn't initiate changes made to the config file.
    Unfortunately the entire server has to be restarted.

    Scratch that it doesn't read from the config after a server reset either
  4. Offline


    It doesn't save changes because it saves everything on disabling.
    So once you reload it it's just going to override everything you changed and save the options that are active at the moment.
    //Actually I think I should make a /ct reload command.
  5. Offline


    ok, now it says 818 and it still crashes, my screen and my other friends screen goes gray and crashes the game, please fix the bug, maybe its when you cut a lot of wood? i dunno about coding, but please fix it, its annoying, it does not say anithing in the console in my case, it stop saying it in the console when i fixed my permissions, but still, crashes, all the people in my server think this is the best thing ever, they are always amused, please developer heeelpp!!!!!!!
  6. Offline


    Can you have this supported by levelcraft? Would really appreciate it, you got an awesome plugin.
  7. Offline


    I can't help you if you don't give my anything whatsoever to help you.
    What error does your server and client show?
    What plugins are you using?
    Does it work if you deactivate all plugins except this one?
    If you answer all those questions I'll probably be able to help :p

    It's already a pretty big problem to make this work with mcMMO, LevelCraft seems to have parts scattered all over the place :p
    I can have a look into it though, if there's a source code available for woodcutting it should be possible somehow.
    But supporting other plugins breaks support with WorldGuard it seems.
  8. Offline


    That would be handy, thanks for the help. Once i closed the server, made changes and THEN started the server up again, the options stuck :D
  9. Offline


    Works great, love it, but found a bug. Currently, when asked not to I am using close to double durability for (at least) the iron axe. I chopped 136 blocks of wood where it should last for 251 blocks (according to minecraft wiki).
    Relavant parts from properties file:
    ActiveByDefault = true
    UseAnything = true
    MoreDamageToTools = false
    InterruptIfToolBreaks = false
    SupportMcmmoIfAvailable = false
    TreeFellerNeeded = false
    LogsMoveDown = true
    OnlyTrees = true
    EnableOverride = false
  10. Offline


    Added /ct reload.

    That was a typo, the iron axe wasn't being recognised as an axe :p
    Fixed in 1.23.
  11. Offline


    Awesome! Thanks for the fix =)
    Additionally, might it be possible to add a wget friendly link?
  12. Offline


    Installed the mod, chopped one tree, client crashed. Now I can't go anywhere near that chunk without crashing and the screen going bright blue. ;(

    Bukkit 819
    Choptree 1.23
  13. Offline


    I don't know how that link would look like :p

    What other plugins are you using?
    Are you using WorldGuard? That one ignores my plugin's cancellation of a block break event and tries to look at a block that doesn't exist.
  14. Offline


    Ah, bummer!-- That'd be it. I suppose you'll have to wait for WorldGuard to update before anything can be done about it? :O
  15. Offline


    I don't think WorldGuard is going to update too soon :p
    Before I can fix the problem I have to work myself into WorldGuard first though.
  16. Offline


    bedrockcontrol, chaircraft, choptree, claygen, flt detector, performance tweaks, permissions, portalgun, simplelog, wolfpound
    these are the plugins i use, now in the console or whatever its called, does not appear anithing, my screen goes gray and my minecraft closes, mmmm no, it appears it also happens when i deactivate all plugins except this one, well, i tried some combinations not all of them so sorry, not know exactly, i am in 1.6.6 whit bukki ¿818? i guess, the newest stable, if you need anything else to solve this bug please ask it
  17. Offline


    I really wish this plugin would work. It is by far my favorite. Like many others, chopping a tree causes the client to crash, and cause the area to become a crash zone until the loot disappears.

    Running Minecraft Server 1.6.6
    Running Craftbukkit version b818<MC: 1.6.6>

    All plugins are up to date. Everything is Up To Date. I get no error in the Server Log. What do? I really don't want to give up on this plugin. I got so excited when I saw it was updated for 1.6.6, but am /crying now.

    EDIT: Works if it is the only plugin running. Going to add the rest of the plugins one by one to catch the culprit.

    EDIT2: I decided to go with mcMMO first and it crashed first chop. I have version 1.0.09, and I see in the OP that ChopTree supports up to 1.0.07, unfortunately I can't get a hold of 1.0.07. Anybody have a link to it?
  18. Offline


    Oh, I didn't notice it updated. Gotta have a look how to implement the newest version of mcMMO.
    There has to be a better way of breaking the blocks than the way I am doing.
    I am pretty sure I know what the problem is though, I am cancelling an event and then change the block by hand. Other plugins ignore my cancellation and try to play around with the block I changed.
  19. Offline


    By cancelling an event I assume you mean the first break, can you allow the break to happen and after a delay bring down the tree (just enough to keep other plugins happy)
    I don't know java so just chucking out ideas
  20. Offline


    That's the way I am trying to do it, but now I'm getting the strange gray screen bug too.
  21. Offline


    I configured both property files in the old and new folders that spawn and setup permissions, this plugin doesn't work with Bukkit 818.
  22. Offline


    Yes it works.
    If you give me more information on what isn't working I can help you, saying "doesn't work" tells me nothing.
  23. Offline


    Lol I gave you the information. Both configs are correct and your plugin is extremely simple so it should work. Permissions are setup correctly, but it doesn chop the tree... pretty straight forward. What information are you looking for?
  24. Offline


    You didn't give me anything at all :p
    You didn't even say what doesn't work, you just say it doesn't. What exactly happens? Is there an error message?
    Second: there are no two folders in this plugin. There is only one called ChopTree and only one file called So what folders are there?
    Then you say that it's set up "correctly", what does that mean? Give me the content of your properties file(s?).
    And lastly: what other plugins are you using?
    If you answer all those questions I can probably help you.
    You could also read this here:
    That's how you write a bug report.
  25. Offline


    Nothing happens. That's why it doesn't work. No errors... nothing. I was thinking of another plugin with that 2 folders thing so scratch that. Here is the config of my choptree:
    # -ChopTree Properties-
    # You can add or change the command and toggle command aliases here.
    # Because of technical limitations the console commands will always be "ChopTree" and "ct", but the in-game comments will be taken from here.
    Command = ChopTree, ct
    Toggle = ToggleChop, tc
    # Here you can change the options (can also be done in-game).
    ActiveByDefault = true
    UseAnything = false
    MoreDamageToTools = false
    InterruptIfToolBreaks = false
    SupportMcmmoIfAvailable = false
    TreeFellerNeeded = false
    LogsMoveDown = false
    OnlyTrees = false
    EnableOverride = false
    # -Material List-
    # If the "UseAnything" option is false, the plugin will take the items you can use to chop trees with from here.
    # You can either put in the material's name or its ID.
    mat = WOOD_AXE
    mat = STONE_AXE
    mat = IRON_AXE
    mat = GOLD_AXE
    mat = DIAMOND_AXE
    And my plugin list:
    14:50:33 [INFO] Plugins: AppleTree, AutoPlant, ServerAutoStop, BlocksOnGlass, ChopTree, CombatTag, E
    atSugar, Factions, HeroicDeath, HomeX, Lockette, MobArena, motd, NoCheat, Permissions, PlgLogCmd, Re
    pairChest, SimpleGod, SimpleWhisper, SpawnX, TweakedCycle, DefaultPermissions
  26. Offline


    I don't see a conflict with any plugin.
    Do you have the choptree.chop node? If yes then try deactivating all other plugins and see if it works. If it doesn't I really don't know.
  27. Offline


    hey, im using this and world guard. im getting the 'MC BSOD' :p (bright blue screen when chopped a tree) and i would just like to inform every one of how to get back into the game.

    Delete your player .dat file in the %server%\world\players folder, this will empty your ivn and sed u to starting spawn when u login. then you should be able to walk slowly close to the chopped tree and if u lucky it wont crash and problem solved. Sorry dude but i deleted choptree, thought it lost my 2.5 weeks of building there...

    Please put a warning about this up on the main thread post :)
  28. Offline


    hello again, i guess we just have to wair untill this supports mcmmo and about the gray screen, heres a solution after sertain time passes, the logs you chopped eventually disapear, when they disappear, you can log in again
  29. Offline


    Bright screen seems to come at random, I haven't quite figured out why it occurs.
    But there is a warning already, it says that there's a WorldGuard conflict :p
  30. Dont know if u are aware. But this plugin overrides various protection plugins. For example protected areas by worldguard, or protected areas with precious stones. in these you are still able to chop trees :)
  31. Offline


    That is why you can protect your chunks with /ct p and /ct f :p

Share This Page