Inactive [FUN] MagicSpells - Add magic to your server

Discussion in 'Inactive/Unsupported Plugins' started by nisovin, May 8, 2011.

  1. Offline


    MagicSpells - Add magic to your server!

    View the plugin on BukkitDev!

    MagicSpells is a plugin that creates spells your players can use. Its main purpose is to give your players access to certain abilities that you might not want to give them unlimited access to. Each spell can be assigned customized reagent (item) costs, cooldowns. durations, ranges, and so on. Spells can be cast by using the /cast command, swinging a wand, or both. It's all customizable.


    Important: Read before downloading! There is a lot of information in this post. I know, it's a lot to read. However, I spent quite a while writing it all in what I hope is a clear, informative, and understandable manner. So, please, read the entire post before asking a question. Chances are, the answer is already here. I also suggest taking a nice look through the configuration file. Is it a massive file? Yes, it is. But if your question is "can I do this?" then a look through the configuration options would be a good idea.
    Plugin Manual

    There is a lot of useful information in the plugin manual, which can be found here:

    MagicSpells Plugin Manual


    Spells can be cast either by using the /cast command or by using a wand item. To cast a spell, a player must first know the spell. Server operators know all spells by default. They can teach spells to other players by using the teach spell. For example, to teach bob the blink spell, an operator would type: /cast teach bob blink.

    Bob can now use the blink spell. He can either cast it by command, by typing /cast blink, or he can cast it with a wand item. To select the spell, he holds the wand in his hand and right clicks. Right clicking will cycle through any spells assigned to the item he is holding. When he has the one he wants, he left clicks to cast.

    If Bob does not have the required reagents for the spell, or if he has cast it recently and it is still on cooldown, he will not be able to cast the spell and will instead receive an error message.

    If mana is enabled, a player can use the /mana command to see how much mana they currently have.


    View Spell List


    The zip file contains a config.yml file that should go into the MagicSpells folder within your plugins directory. The default configuration has appropriate spell costs, durations, and messages for each spell. However, you will most likely want to customize this to fit your server.

    You can modify the config.yml file directly, or you can choose to leave it intact and instead create an alternate config file, by default altConfig.yml. Any configuration values in this alternate file will override the values in the main config file.

    There are some general configuration options that apply to all spells, as well as options for each individual spell. Important: The default configuration file does NOT contain all config options, it is just an example. Just because a config option isn't in the default doesn't mean it is not available. For example, it's possible to add a duration to any buff spell, even though the default configuration file does not have a duration on all buff spells.

    To reload the configuration, simply cast the fake reload spell (/cast reload). Only server operators can do this (it can also be done from the command line).

    Please see the plugin manual for information about all of the various configuration options.

    Frequently Asked Questions

    Help me! Why isn't it working?
    If - after reading through this entire post - you can't figure out why it isn't working, please take the time to submit a proper help request. You can post your request either on in this thread or in the MagicSpells forum. You should provide the following information:
    • The CraftBukkit build you're using.
    • The MagicSpells version you're using.
    • Which permissions plugin (if any) you are using.
    • The error in the console, if there is one.
    • Your config file(s). Please don't post them directly , use a service like and just post the link.
    It says I need reagents whenever I cast a spell! Where do I get reagents?
    One of the main ideas behind this plugin is to give players cool abilities, but with a cost. The reagents are the spell's cost. This can be configured in the config.yml file individually for every spell. The config option name is "cost". You can also add your name to the list of exceptions in the general.cast-for-free option.

    Can I unbind spells from items?
    Yes. Simply use the bind spell to bind the spell to your empty hand, and it will no longer be bound to any item.

    Why can't my players cast spells?
    Why does it say "You cannot cast that spell right now" when I try to cast any spell?
    If you're using Permissions, please make sure your permissions are all set up correctly. Look in the Configuration: Permissions section for more information. Also double check and make sure your use-permissions config option is set to true.

    What are the Permissions nodes?
    The nodes are listed on the permissions information page in the plugin manual.

    I can't get my Permissions working! Can you help me?
    Remember that all nodes use the "real" spell name, rather than the name you define with the "name" option. If you cannot get your permissions working, feel free to ask for help. Make sure you specify which permissions plugin you are using, and all of the items from the "Help Me!" question above.

    Will you add iConomy (or another economy plugin) support?
    With the addition of the 'tome' and 'scroll' spells, I currently have no plans to add special support for an economy plugin. You should be able to create tomes and scrolls and sell them using any plugin that allows you to sell items, thus allowing you to sell spells.

    I have a great spell idea! Will you add it?
    Please tell me about it by submitting a ticket! I can't guarantee that I'll make it, but if it's a feasible idea, I'll definitely consider it. I'm always looking for new spell ideas. Note that I may not respond directly to your idea, but I always read the suggestions.

    I've found a bug! What do I do?
    Please submit a ticket! Please include your CraftBukkit build number, any error in the console, the situation that caused the error (if known), and if you think it's applicable, the list of plugins you use.

    Change Log

    View full change log

    Donate: Always gotta have a donate link for those who love their plugin authors.
  2. Offline


    yes i just allowed the powertool but now i must remove it i guess
    im going to add it to the disabled commmands
  3. Offline

    For Ceral

    Nisovin, I have had a problem while trying to load your plugin onto my server. I get this error:
    2:39:31 [SEVERE] Error occurred while enabling MagicSpells v1.0 (Is it up to date?): org/bukkit/permissions/PermissionDefault
    java. lang. NoClassDefFoundError: org/bukkti/permissions/PermissionDefault
    at com.nisovin.MagicSpells.MagicSpells.load(
    (A bunch of meaningless errors later)
    Caused by: java.lang.ClassNotFoundException: org.bukkit.permissions.PermissionDefault
    (Blah Blah Blah)
    at java.lang.ClassLoader.loadClass(UnknownSource)
    ... 12 more
    I think you got the idea so I don't think I have to post all of it. Can you tell me what is wrong? I'm sure you have seen this type of error before, so can you please help me?
  4. Request.

    Could we get a config flag for "scroll" that defines if spell reagents are used upon creation of scroll?

    For example, Combust costs 1 RSD. Creating a scroll of Combust with 5 uses cost 5 RSD + possible spell cost configured for Scroll.

    Otherwise I see no way to balance the Scroll spell for us at least :)
  5. Offline


    Are you running CraftBukkit 1000?
  6. And a bug.

    Using default config for Scroll, I enchanted Paper with Leap.

    "You have created a spell scroll for %s."

    The %s was not replaced with string Leap. And I do have name: Leap in the Leap section.

    Spell suggestion:

    Ritual, channeled - Summons a Giant \o/

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 16, 2016
  7. Offline


    Nice update!
    Drain is great and I found a neat way of selling scrolls through Showcase.
  8. Offline


    Hi dude, great update once again!

    I have this one, however.. (on bukkit1000):

  9. Offline

    For Ceral

    I probably sound like a complete idiot, but where does it tell me that?
  10. Offline


    Really? how?
    oh and i cant seem to get confuse working, and how do u cast a channel with two people? just tells me cannot cast or something.
  11. Offline


    Are you absolutely certain you're running build 1000? That looks exactly like the kind of error you'd get if you were running an older version.
    You should know what build you're running. But you can type "version" into the console to see.
    Both players just cast the spell at the same time.
  12. Offline

    For Ceral

    Thanks for the help. It seems that I am running version 904. Again, I am an idiot, but where can I get build 1000? If I cannot get 1000 what other plugins do you recommend that are based on magic?
  13. Offline



    "A wild update appears!
    It's super-effective!"

    Now it seems work with a second version of [1000]. Weird, i was sure that i installed that before. Thanks anyway, OP, and good work!
  14. Offline


    There's a "Get CraftBukkit" tab on this website that has a link to the latest recommended build (which is 1000).
  15. Offline

    For Ceral

    Thank you so much for your help! I can now run the plugin. :) If I can convince my parents to give me some money, Lol, then I'll try to donate to you!
  16. Offline


    So as ive heard, the new Heroes plugin will be supporting this?

    And maybe a channeled spell to be able to bring one down b4 it stomps you in the face =p.

    Channel spell ideas:
    Meteors, (noticed plugin NeoMeteors, might probly work) - create a meteor storm.
    Lightning Storm - multiple lightning strikes.
    Conjure Food - summons some food.

    maybe have 3 people cast at once for higher level spells, but that might cause some timing issues, especially with lag. And is there a way to put a channel timer/delay b4 it activates?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 16, 2016
  17. Offline


    So I copied this precisely and I can't get my copy to function at all... I even tried mixing it up!

    Here is what I have entered:

    I have also tried to format it exactly like the rest like this:

    and also reversed it to read:
    - dirtvision=stonevision

    Any help would be amazing... I just don't undertand what I am doing wrong.
  18. Offline


    Could you put your config in code tags instead of quote tags? I need to be able to see how your config is indented.
  19. Offline


    Reloading, full server or magic specific, seems to wipe the scrolls. Am I doing something wrong?
  20. Offline


    Here is the pastebin of the same code I showed above, it is all correctly formatted according to your walk-through in your OP, and the default config it generated automatically.
  21. Offline


    The spellcopies node should be at the same root level as the spells node, but in your config it is indented.
  22. Offline


    Can i add creepers and slime in my summon spell?
  23. Offline


    Creepers seem to work great. Slimes not so much. For some reason I can't detect whether they're targeting a player, so they will immediately attack the caster.
  24. Offline


    Deh slimes are so dumbass. So, great great great.
  25. Offline


  26. Offline


    Found an annoying glitch, when you don't have an target when using a scroll it still counts an one use with the scroll
  27. Offline


    Oh my god I'm an idiot. I had use-permissions: false

    Stupid stupid stupid stupid... I'm good now, thanks ;)

    I'm having an issue where, regardless of what spell I try to cast, I get the: You do not know a spell with that name. This is happening with regular spells and meta spells (such as /cast fireball or /cast blink, as well as /cast list or /cast help).

    I am running quite a few plugins but I don't see anything that would conflict. Config is the default. I've attempted casting as an admin with the permissions '*' as well as a member of a group with the permissions magicspells.grant.* and magicspells.cast.*, same results.

    The console isn't showing any errors when I make the attempt. The config I'm using is the default (completely unedited, tried both downloading with the config as well as deleting it and letting the plugin generate a new config). Bukkit b1000. Running Permissions 3.1.5 (also tested with 3.1.6 just to be sure, same thing).

    Worth noting, casting via the console seems okay (rather, /cast reload works fine from the console, and I get the appropriate Cannot cast that spell from the console. error when trying anything else). I've also tried loading in debug mode and it goes through the list of spells for each user without issue. I'm a bit stumped...

    For the hell of it, I've posted my server log when I ran it with a very reduced list of plugins. Maybe someone knows more than I do. Will happily post anything else that's needed.

    2011-07-26 07:19:21 [INFO] Starting minecraft server version Beta 1.7.3[/S]
    [S]2011-07-26 07:19:21 [INFO] Loading properties[/S]
    [S]2011-07-26 07:19:21 [INFO] Starting Minecraft server on *:25565[/S]
    [S]2011-07-26 07:19:21 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-945-g73697a4-b1000jnks (MC: 1.7.3)[/S]
    [S]2011-07-26 07:19:22 [INFO] LWC: Loading shared objects[/S]
    [S]2011-07-26 07:19:22 [INFO] LWC: Protection cache: 0/10000[/S]
    [S]2011-07-26 07:19:22 [INFO] LWC: Native library: plugins/LWC/lib/native/Windows/amd64/sqlitejdbc.dll[/S]
    [S]2011-07-26 07:19:22 [INFO] [Permissions] (Yeti) was initialized.[/S]
    [S]2011-07-26 07:19:22 [INFO] Preparing level "world"[/S]
    [S]2011-07-26 07:19:22 [INFO] Preparing start region for level 0 (Seed: 5983377018323455891)[/S]
    [S]2011-07-26 07:19:23 [INFO] Preparing start region for level 1 (Seed: 5306553840736633935)[/S]
    [S]2011-07-26 07:19:23 [INFO] Preparing spawn area: 20%[/S]
    [S]2011-07-26 07:19:24 [INFO] [FalseBook Block] 3100 Books loaded![/S]
    [S]2011-07-26 07:19:24 [INFO] FalseBookBlock v0.87alpha DEV#3 by GeMo enabled[/S]
    [S]2011-07-26 07:19:24 [INFO] [FalseBook Block] 2 Cauldrons successfully loaded.[/S]
    [S]2011-07-26 07:19:24 [INFO] FalseBookCart v0.87alpha DEV#3 by GeMo enabled[/S]
    [S]2011-07-26 07:19:24 [INFO] [FalseBook Chat] 0 ChatRooms loaded.[/S]
    [S]2011-07-26 07:19:24 [INFO] FalseBookChat v0.87alpha DEV#2 by GeMo enabled[/S]
    [S]2011-07-26 07:19:24 [INFO] [FalseBook Core] FalseBookCore v0.87alpha DEV#3 by GeMo enabled![/S]
    [S]2011-07-26 07:19:24 [INFO] FalseBookExtra v0.87alpha DEV#3 by GeMo enabled[/S]
    [S]2011-07-26 07:19:24 [INFO] FalseBookIC v0.87alpha DEV#3 by GeMo enabled[/S]
    [S]2011-07-26 07:19:25 [INFO] [iConomy] Logging is currently disabled.[/S]
    [S]2011-07-26 07:19:25 [INFO] [iConomy] v5.01 (Eruanna) loaded.[/S]
    [S]2011-07-26 07:19:25 [INFO] [iConomy] Developed by: [Nijikokun][/S]
    [S]2011-07-26 07:19:25 [INFO] [Permissions] version [3.1.5] (Yeti)  loaded[/S]
    [S]2011-07-26 07:19:25 [INFO] [iConomy] hooked into Permissions.[/S]
    [S]2011-07-26 07:19:25 [INFO] [Permissions] SQL Interface enabled![/S]
    [S]2011-07-26 07:19:25 [INFO] [Statistician] Version 1.3 By ChaseHQ Starting Up...[/S]
    [S]2011-07-26 07:19:25 [INFO] [Statistician] Found Permissions Plugin[/S]
    [S]2011-07-26 07:19:25 [INFO] [Statistician] Succesfully Hooked Into Permissions[/S]
    [S]2011-07-26 07:19:25 [INFO] WorldEdit 4.6 enabled.[/S]
    [S]2011-07-26 07:19:25 [INFO] WorldEdit: Permissions plugin detected! Using Permissions plugin for permissions.[/S]
    [S]2011-07-26 07:19:25 [INFO] WorldGuard: Permissions plugin detected! Using Permissions plugin for permissions.[/S]
    [S]2011-07-26 07:19:25 [INFO] WorldGuard: (world) Single session is enforced.[/S]
    [S]2011-07-26 07:19:25 [INFO] WorldGuard: (world) TNT ignition is PERMITTED.[/S]
    [S]2011-07-26 07:19:25 [INFO] WorldGuard: (world) Lighters are PERMITTED.[/S]
    [S]2011-07-26 07:19:25 [INFO] WorldGuard: (world) Lava fire is blocked.[/S]
    [S]2011-07-26 07:19:25 [INFO] WorldGuard: (world) All fire spread is disabled.[/S]
    [S]2011-07-26 07:19:25 [INFO] WorldGuard: Loaded configuration for world 'world"[/S]
    [S]2011-07-26 07:19:25 [INFO] WorldGuard: (world_nether) Single session is enforced.[/S]
    [S]2011-07-26 07:19:25 [INFO] WorldGuard: (world_nether) TNT ignition is PERMITTED.[/S]
    [S]2011-07-26 07:19:25 [INFO] WorldGuard: (world_nether) Lighters are PERMITTED.[/S]
    [S]2011-07-26 07:19:25 [INFO] WorldGuard: (world_nether) Lava fire is blocked.[/S]
    [S]2011-07-26 07:19:25 [INFO] WorldGuard: (world_nether) All fire spread is disabled.[/S]
    [S]2011-07-26 07:19:25 [INFO] WorldGuard: Loaded configuration for world 'world_nether"[/S]
    [S]2011-07-26 07:19:25 [INFO] WorldGuard: 52 regions loaded for 'world'[/S]
    [S]2011-07-26 07:19:25 [INFO] WorldGuard: 4 regions loaded for 'world_nether'[/S]
    [S]2011-07-26 07:19:25 [INFO] WorldGuard 5.2.2 enabled.[/S]
    [S]2011-07-26 07:19:25 [INFO] Preparing start region for level 2 (Seed: -4783981438527837350)[/S]
    [S]2011-07-26 07:19:26 [INFO] Preparing start region for level 3 (Seed: 6770595191457778209)[/S]
    [S]2011-07-26 07:19:26 [INFO] WorldManager version 1.0 is enabled![/S]
    [S]2011-07-26 07:19:26 [INFO] [iChat] Found Permissions (v3.1.5)[/S]
    [S]2011-07-26 07:19:26 [INFO] iChat (v2.3.2-p3) enabled[/S]
    [S]2011-07-26 07:19:26 [INFO] LWC: Loaded 135 locale strings (0 overrides)[/S]
    [S]2011-07-26 07:19:26 [INFO] Using Permissions API[/S]
    [S]2011-07-26 07:19:26 [INFO] LWC: Loading SQLite[/S]
    [S]2011-07-26 07:19:26 [INFO] LWC: Using: Native[/S]
    [S]2011-07-26 07:19:27 [INFO] LWC: Precached 1684 protections.[/S]
    [S]2011-07-26 07:19:27 [INFO] LWC: At version: 3.30-git-LWC-94b93dd42195692ed1823346544359d5917274a2-b69jnks[/S]
    [S]2011-07-26 07:19:27 [INFO] MagicSpells v1.0 loaded![/S]
    [S]2011-07-26 07:19:27 [INFO] Server permissions file permissions.yml is empty, ignoring it[/S]
    [S]2011-07-26 07:19:27 [INFO] Done (0.462s)! For help, type "help" or "?"[/S]
    [S]2011-07-26 07:19:27 [INFO] [FalseBook Block] 1 Areas loaded from 1.db.[/S]
    [S]2011-07-26 07:19:27 [INFO] [FalseBook Block] 1 Areas loaded from 2.db.[/S]
    [S]2011-07-26 07:19:27 [INFO] [FalseBook Block] 1 Areas loaded from door2.db.[/S]
    [S]2011-07-26 07:19:27 [INFO] [FalseBook Block] 1 Areas loaded from glassroof.db.[/S]
    [S]2011-07-26 07:19:27 [INFO] [FalseBook Block] 1 Areas loaded from lightroof.db.[/S]
    [S]2011-07-26 07:19:27 [INFO] [FalseBook Block] 0 Bridges successfully loaded.[/S]
    [S]2011-07-26 07:19:27 [INFO] [FalseBook Block] 0 Doors successfully loaded.[/S]
    [S]2011-07-26 07:19:27 [INFO] [FalseBook Block] 80 protected gateblocks successfully loaded.[/S]
    [S]2011-07-26 07:19:30 [INFO] [FalseBook IC] Loaded selftriggered ICs: 21 done[/S]
    [S]2011-07-26 07:19:30 [INFO] [FalseBook IC] Loaded selftriggered ICs: 4 failed[/S]
    [S]2011-07-26 07:19:30 [INFO] [FalseBook IC] List of failed ICs:[/S]
    [S]2011-07-26 07:19:30 [INFO] [FalseBook IC] ID: 16, [MC0420] @ Location - World: world , X: 285 , Y: 61 , Z: -382[/S]
    [S]2011-07-26 07:19:30 [INFO] [FalseBook IC] ID: 17, [MC0420] @ Location - World: world , X: 281 , Y: 61 , Z: -385[/S]
    [S]2011-07-26 07:19:30 [INFO] [FalseBook IC] ID: 19, [MC0111] @ Location - World: world , X: 281 , Y: 61 , Z: -387[/S]
    [S]2011-07-26 07:19:30 [INFO] [FalseBook IC] ID: 22, [MC0271] @ Location - World: world , X: 52 , Y: 69 , Z: -404[/S]
    [S]2011-07-26 07:19:38 [INFO] FaeDine [/] logged in with entity id 359 at ([world] 299.21254614228985, 64.0, -312.3742217530575)
  28. Offline


    Ive noticed the confuse spell isnt in the config, perhaps why it wont work?
  29. Offline


    Indeed, it does not seem to be in the config included in the zip, but it is in the direct link to the config in the first post. I just copied that over and it worked perfectly.
  30. Offline


    Yes, I noticed this. It'll be fixed in the next version.
    This is so you can write your own spells.
    Yeah, I forgot to put it in, so I added it to the config file in the post.

    Do you have the use-permissions option set to true?

    Version 1.0.1 released! No new spells this time, just a bunch of new features that were requested, and a few bug fixes.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 16, 2016
  31. Offline


    Thanks nisovin, good work. Also liking the idea of creating external spells, but ill wait for a guide, as id probably screw it up. btw, is there also a way to use the system chat to make a timer for channeled spells, as you have done with your mana system. Maybe something like this:
    |.... |
    |......... |
    |............... | } Cast time/Delay
    |................... |
    |.......................| -> Cast

    Maybe also configurable timers.
    Dont want to burden you, just to jog some ideas.

    Drawing looked better b4 post =p

Share This Page