Inactive [FUN/EDIT/RPG] DungeonBuilder v0.9.7 - Player created dungeons [1.2.4-R1.0]

Discussion in 'Inactive/Unsupported Plugins' started by Zimp, Jun 24, 2011.

  1. Offline


    Grifhell and Kevinflu like this.
  2. Offline


    i have been using another plugin similar to this, but its still in WIP and very buggy, this seems like it may be easier to work with, especially due to the creating dungeon commands and set teleport location, very helpful and just what i was looking for.

    Definitely going to try it out. just waiting for rewards! possible iconomy or mcmmo support would be amazing


    so erm, i installed it, most seems to be working fine, except when i had it running, other users could not break blocks anywhere in the world? i have no idea where to start troubleshooting that issue, so i turnd it off for now.
  3. Offline


    Updated description to meet shadrxninga's suggestions.

    Updated plugin file to fix the issue described by Dec64. There was some unfinished test code I had left active from when I was exploring the ability to restrict users from destroying or placing blocks in dungeons.
  4. Offline


    so i used the /saveDungeon alias command, and it saves the dungeon (well it says it does) then i make a change (e.g. set TNT off) then i load it again, expecting the TNT to be back? yet it isnt, is that an error? or am i using the function incorrectly?


    i also get the error "Failed to save dungeon: Failed to backup existing dungeon file"

    when i try to save the dungeon
  5. Offline


    It sounds like you might be running into some platform differences on how the files are managed. What platform are you running the plugin on?

    In the meantime I've provided an updated plugin file that may help resolve the issue you have with backing up existing dungeon files. Though I can't guarantee a fix until I get to the root problem.
  6. Offline


    Currently i am on a small server hosted by Xenon, so i only have basic FTP access and no information on the server, i will be moving to a fully dedicated linux box as soon as it gets set up, sometime this week, so if that is the case, i will have more information then? i will most likely be running CentOS 5.5 64.

    In the meantime i will try the updated file, thanks for the great plugin tho!

    ok so i tried the altered version, so far it says it saves/loads fine, but again, tnt does not come back, i added some monster spawn locations, said it did that, saved, used the command to spawn the monsters, did not work, again, said it worked, but nothing appeared.

    but when i enter the dungeon after it is published, the monsters where spawned, but the actual dungeon structure was altered to the state it was in when i first saved it, it appears it is unable to overwrite the save?

    also the diamond block does not move to my location when i set the entrance point in the dungeon

    ok i left the dungeon, came back into the dungeon again, via the set entrance point, the dungeon was reverted back to the most recent state of build, but now no monsters spawn
  7. Offline


    Reviewing the code it should be loading the dungeons from memory, which would eliminate any potential issues with the files themselves. My own tests with saving dungeons with tnt/monsters haven't been able to reproduce the issue. Are you using the same dungeon alias for every command? For example:

    /createEmptyDungeon dungeon1 10 10 10

    *place tnt*

    /saveDungeon dungeon1

    *destroy tnt*

    /loadDungeon dungeon1

    In any case, when you do switch to a dedicated host I should be able to help more than just speculate. I do my testing/development work on a linux machine myself.
  8. Offline


    so i did a quick test dungeon, using the same commands as you did, to try and replicate the issue, and i was unable to replicate it myself, but the issue always happens on one specific dungeon, but on other dungeons i create and save/load, they work perfectly, possible the save for this dungeon is corrupted to some degree? anyway to reset it?
  9. Offline



    If you happen to remember the original dimensions (or use the /viewDungeonParameters command to find out) you specified for the dungeon then you can attempt the following:

    /teleportToDungeonCenter dungeonname
    Place a marker on it so you know where the origin of the dungeon is.
    /teleportToDungeon dungeonname <- required for deleting dungeon
    /deleteDungeon dungeonname
    Go back to where your marker is and stand in the same location
    /createDungeon new-dungeon-name old-dungeon-width old-dungeon-depth old-dungeon-height

    The delete dungeon command has the effect of deleting the old dungeon's bedrock shell, while leaving the contents intact. Create dungeon has the opposite effect (just make sure you *dont* use createEmptyDungeon in this case).

    Another option is to do the following:

    /teleportToDungeonCenter dungeonname
    dont move from teleport in location
    /createDungeon new-dungeon-name old-dungeon-width old-dungeon-depth old-dungeon-height

    This would mean you would basically have two dungeons overlapping with the same size and coordinates. This may result in weird behavior whenever the plugin is reloaded since it would not guarantee the fixed dungeon is loaded last.

    Updated to version 5.3: added the /teleportToDungeonCenter and /viewDungeonParameters commands

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  10. Offline


    ok ill do that as soon as i get my new server, my current one is playing up in general so hard to narrow down issues with a crappy server, also multiworld is not supported? i create a dungeon in a flatlands generated world, and it shows up later in the normal world?

    if so, multiworld support would be a awesome if u could be included?
  11. Offline


    Version 0.5.4 released - Added multiworld support

    Dungeons created in previous releases will be added to the default "world".

    Two new utility commands were added to facilitate multiworld support:

    I also included support for setting dungeon teleporters in one world and have the dungeons themselves in another world. This should make it possible to dedicate a separate world just for storing the dungeons.
  12. Offline


    This sounds exactly like something that was on my to-do list to write. I'm going to try it out; hopefully you wrote it instead of me. :D

    EDIT: Suggestion for economy: use the Register API. It hooks into iConomy 4, iConomy 5, BOSEconomy, and Essentials Economy.
  13. Offline


    Curious to know... On my server a few mods and I had a competition to build a dungeon and see whose was hardest.

    How hard would it be to use these precreated dungeons/..

    This makes me nervous..../createEmptyDungeon alias width depth height
  14. Offline


    that is the command you need @fatmarley , you will need to stand in the center point of your pre made dungeon at the lowest point, and type it, before you do, go measure up the width/height/depth of your dungen, and always add a few more to that figure just for safety.

    I did the same, added this plugin to a pre made dungeon and it worked fine.
  15. Offline


    Exactly what Dec64 said, the /createDungeon command (*not* createEmptyDungeon) will construct the bedrock shell out of a pre-existing chunk of the world, which means the shell itself will replace the existing blocks with bedrock, but the inside will be left unaltered. I intended it for this kind of situation where you have already constructed something you want to convert into a dungeon.

    Updated to v. 0.5.5

    Cleaned up behavior for loading dungeons a bit (mostly regarding the order certain blocks are loaded)
    Tested plugin against build 953.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  16. Offline


    Sorry, if this was mentioned...but...Chance for permissions. permissions to create and permissions to use?
  17. Offline


    I suggest using a spoiler for all those commands at the end
  18. Offline


    Erm this was real weird.

    Code (Text):
    1. 2011-07-02 12:40:28 [INFO] Loading dungeon - region:r.0.-1.mcr
    2. 2011-07-02 12:40:28 [SEVERE] java.lang.Exception: The following line in the dungeon file is missing parameters: BCDEFGHIUbz ;<=>?@AJVc{ 2345678KXd|
    3. 2011-07-02 12:40:28 [SEVERE] at net.virtuallyabstract.minecraft.Dungeon.loadFromFile(
    4. 2011-07-02 12:40:28 [SEVERE] at net.virtuallyabstract.minecraft.Dungeon.<init>(
    5. 2011-07-02 12:40:28 [SEVERE] at net.virtuallyabstract.minecraft.DungeonBuilder.loadDungeons(
    6. 2011-07-02 12:40:28 [SEVERE] at net.virtuallyabstract.minecraft.DungeonBuilder.onEnable(
    7. 2011-07-02 12:40:28 [SEVERE] at
    8. 2011-07-02 12:40:28 [SEVERE] at
    9. 2011-07-02 12:40:28 [SEVERE] at org.bukkit.plugin.SimplePluginManager.enablePlugin(
    10. 2011-07-02 12:40:28 [SEVERE] at org.bukkit.craftbukkit.CraftServer.loadPlugin(
    11. 2011-07-02 12:40:28 [SEVERE] at org.bukkit.craftbukkit.CraftServer.enablePlugins(
    12. 2011-07-02 12:40:28 [SEVERE] at net.minecraft.server.MinecraftServer.e(
    13. 2011-07-02 12:40:28 [SEVERE] at net.minecraft.server.MinecraftServer.a(
    14. 2011-07-02 12:40:28 [SEVERE] at net.minecraft.server.MinecraftServer.init(
    15. 2011-07-02 12:40:28 [SEVERE] at
    16. 2011-07-02 12:40:28 [SEVERE] at
    17. 2011-07-02 12:40:28 [INFO] Loading dungeon - region:r.0.-2.mcr
    18. 2011-07-02 12:40:28 [SEVERE] java.lang.Exception: The following line in the dungeon file is missing parameters:
    19. 2011-07-02 12:40:28 [SEVERE] at net.virtuallyabstract.minecraft.Dungeon.loadFromFile(
    20. 2011-07-02 12:40:28 [SEVERE] at net.virtuallyabstract.minecraft.Dungeon.<init>(
    21. 2011-07-02 12:40:28 [SEVERE] at net.virtuallyabstract.minecraft.DungeonBuilder.loadDungeons(
    22. 2011-07-02 12:40:28 [SEVERE] at net.virtuallyabstract.minecraft.DungeonBuilder.onEnable(
    23. 2011-07-02 12:40:28 [SEVERE] at
    24. 2011-07-02 12:40:28 [SEVERE] at
    25. 2011-07-02 12:40:28 [SEVERE] at org.bukkit.plugin.SimplePluginManager.enablePlugin(
    26. 2011-07-02 12:40:28 [SEVERE] at org.bukkit.craftbukkit.CraftServer.loadPlugin(
    27. 2011-07-02 12:40:28 [SEVERE] at org.bukkit.craftbukkit.CraftServer.enablePlugins(
    28. 2011-07-02 12:40:28 [SEVERE] at net.minecraft.server.MinecraftServer.e(
    29. 2011-07-02 12:40:28 [SEVERE] at net.minecraft.server.MinecraftServer.a(
    30. 2011-07-02 12:40:28 [SEVERE] at net.minecraft.server.MinecraftServer.init(
    31. 2011-07-02 12:40:28 [SEVERE] at
    32. 2011-07-02 12:40:28 [SEVERE] at
    33. 2011-07-02 12:40:28 [INFO] Loading dungeon - region:r.0.0.mcr
  19. Offline


    Is it possible to like make so that players can use a certin block only in the dungeon?
  20. Offline


    Definitely on my list of things to do.

    *Edit* See next reply

    Eventually I would like to start introducing this kind of functionality, for right now I am focused on hardening the code for loading and saving dungeons, then introducing the economy and permission features.

    Looking at this more closely, it looks like my plugin is picking up on some world files. Do you happen to have a world named "dungeons" on your server?

    Updated to version 0.5.6

    Added support for rewarding players upon finishing dungeons using economy plugins and Nijikokun's Register API.
    Added configurable location for storing dungeon files.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  21. Offline


    Well your plugin uses the world dungeons...just seemed fitting.
  22. Someone should make a video of this =P
  23. Offline


    Lol, yea in hindsight I should have expected this outcome when I added the /createworld command. Those error messages you see wont mess anything up though. I'll make a note to add some logic to check for this since I expect it will be a very common use case.
  24. Offline


    @Zimp please consider permissions?
  25. Offline


    Next on the list
  26. Offline


    Hope to see the compatible version with permissions soon. Not trying to rush the process or anything, only stating the fact. Don't think it would be wise just to have this free to use for anyone.
  27. Offline


    Updated to version 0.6.0 to include permission support. This is a first draft of how permissions will work. At this point I am looking for feedback on situations where the current system does not match, or conflicts with, expected use cases.
  28. Offline


    Code (Text):
    1. 2011-07-15 12:36:57 [SEVERE] Could not pass event CREATURE_SPAWN to WorldGuard
    2. java.lang.NullPointerException
    3.     at com.sk89q.worldguard.bukkit.WorldGuardEntityListener.onCreatureSpawn(
    4.     at$63.execute(
    5.     at org.bukkit.plugin.RegisteredListener.callEvent(
    6.     at org.bukkit.plugin.SimplePluginManager.callEvent(
    7.     at org.bukkit.craftbukkit.event.CraftEventFactory.callCreatureSpawnEvent(
    8.     at net.minecraft.server.World.addEntity(
    9.     at net.minecraft.server.SpawnerCreature.spawnEntities(
    10.     at net.minecraft.server.World.doTick(
    11.     at net.minecraft.server.MinecraftServer.h(
    12.     at
    13.     at
    it donĀ“t works with Worldguard? D:
  29. Offline


    @Arianon I am unable to reproduce the issue you posted. Do you have steps to reproduce it, including which versions of Worldguard and DungeonBuilder you are using?

Share This Page