Inactive [FUN/ECON/DEV] uQuest v1.50 - Overly customizable quest system [793 - 602]

Discussion in 'Inactive/Unsupported Plugins' started by Hawox, Mar 4, 2011.

  1. Offline


    As most of you can guess I have not worked on this plugin in a long time. I'm working full time at a grocery store as well as going to college. I literally have no time for sleep let alone Minecraft. Recently someone has contacted me saying they are working on my plugin. I appreciate his work and effort while I am away. This is a link to his topic. His download can be found at
    uQuest - Overly customizable quest system!
    German Questlist 5/16/11
    Coming Soon!
    Gui Questmaker (Heres a beta build!)
    Upload/download area for quests!
    mcMMO extension!

    Laxlux - New German quest list maintainer
    HiMyNameIsAJ - Creating a uQuest website
    Looking for:
    • Someone to make a nice looking website for uquest (Not my cup of java).
    • Someone to add MySql support.
    • Plugin attachment devs!
    • Someone with ideas on different quest types!
    • People to write some random quests to be thrown in the defaults!

    -----------------------Plugin summery below this point-----------------------
    ~Comes preloaded with 53 quests!~

    Support for: (You don't NEED any of these for the plugin to work.)
    Permissions (but not needed!)
      -"uQuest.CanQuest.*" - Allows all these sub permissions
      -"uQuest.CanReloadQuests" - Allows the use of /reloadquests
      -"uQuest.CanReloadQuestConfig" - Allows the use of /reloadquestconfig
     iConomy (but not needed!)
     BOSEconomy (Again, not needed!)
     Essentials! (Again, not needed!)
    Alright here goes, theres a lot to cover so I may miss something on this first go threw! Want a better way to get money into your server economy that selling items to the server or random lottery's? Do you like QUESTS?!?! Do you want your users to compete to see who is a better quester? Then uQuest might be for you!

    uQuest offers your users a simple way to quest! No need to walk miles and miles to a random NPC or click on some block at spawn. All they need to do is type '/uquest give' and uQuest will give them a random quest from it's database! A yml file is provided where you type out each quest for your users. That's right. YOU can decide how many quests there are, what they are, and how you want your users to do them (creating and editing this file are explained on the wiki). You can broadcast every x quests someone finishes to the server as well as give out rewards for x amount of quests. I'll leave the rest for the features section, just thought I'd get you hooked with that :3 If you grab the .zip (which you need to if you want to store your users in a SQLite database!) I have included 53 quests inside!

    All of that not enough? Well theres an API! Other plugin authors can use this as a base for their own plugins!

    Here's a quick screenshot of what the text looks like:

    (I may miss a few, there's quite a bit)

    ~Quest Types~
    All of these can have specific locations set to them! (Can only do in this area etc)
    (More to come I promise!!)

    (More to come I promise!!)

    ~Watch out~
    With great power (of customization)... Come's great responsibility.... There is a lot that can go wrong if you don't pay attention when your changing files. Thankfully, I've tried to have the plugin spew out as many warnings as it could on the servers start. Always give it a check to make sure the plugin loaded all of your work!!!

    ~Plugin Attachments~
    (These plugins add new features to the basic uQuest system)
    Just started this as an example of what people can do. All it currently has is /qadmin givequest
    OP's and people with the permissions (not required for this either) node 'uQuest.MoreModCommands' can use it.
    Simply shows someones progress on a quest everytime they do something for it. IE. I punch a log as part of my quest (grey text)Log Punches 7/10.
    Just put the jar into your plugins folder and it will work on it's own!
    Updates needed: Move quests | Picking up items. | Support for uQuest levels
    Completes quests automagicly! Works with the same methods as showtracker so it has the same flaws. There is this weird bug when running both at the same time that spams some weird extra text. Try to ignore it for now.
    Just put the jar into your plugins folder and it will work on it's own!
    Updates needed: Move quests | Picking up items. | Unknown status on working with quest levels. | Odd text bug with showtracker/this mix.

    ~Plugins using the API~
    (These plugins use the uQuest API to shape their own plugin)

    Since people don't read the above, I'll post this again here so I don't have to write the reply back to this anymore.
  2. Offline


    dude i think this dude is gone. someone who is smart need to revive this plugin. you should do it NPC quester dude
  3. Offline


    Dude, this dude said they would be doing some things with some other dudes for a little while but would be back to fix things for us dudes when they had a chance. Dudes just need to chill for a while.

    Ouch, that really hurt to write.
  4. Offline

    Randy Schouten

    Yep, he's doing his finals if I recall correctly.
    He'll be back.
  5. Offline


    Hope there's support to do more than 1 quest at a time for the next version.
    And choose what quest you can do if not restricted to getting a quest from a special event.
    And maybe restrict some to random occurrences? (randomly given, assigned from random quest list)
    The possibilities are endless. :D
    *I could list more, but a lot of ideas are either on the to-do list, or have already been mentioned.
  6. Offline


    does this support Economy?
  7. Offline


    Does it works for [680] ?
  8. Offline


  9. Offline


    I currently have 3 worlds on my server (survival, freebuild, nether). If I only want players to be able to complete objectives in the survival and nether worlds, how do I specify that in the quests.yml?

    The survival world is named "town".
    The freebuild world is named "world".
    The nether world is name "world_nether".

    I have no clue what Point: does and what Give_Range does. If someone could clear this up for me, that would be awesome.

    Btw, I don't want any part of "town" or "world_nether" restricted from the quests. Just the whole freebuild world.

    Would the objective look something like this:

          Type: Block_Damage
          Display_Name: Log Punches
          Objective_ID: 17
          Amount: 10
              World: town, world_nether
    Yes, I realize that there are no coordinates for my locations but I figured that I'd leave it like that so it DOESN'T specify a location in the worlds but only specify the worlds.
  10. Offline


    Please don't let this plugin die. :)
  11. Offline


    Hey. Cool plugin! I tested this plugin and it works for craftbukkit version 860, just so you know.
  12. Offline


    Comes an update for 818 or 860???
  13. Offline


    I thought i posted something about this but i can't seem to find it. But my users keep getting there quests reset! how can i stop this from happening.
  14. Offline


    My server was having awful luck getting uQuest to give out $$$ without errors, it loaded fine, permissions were working with PermissionsEX, but Essentials appears to be the culprit: Caused by: java.lang.NoSuchMethodError: com.earth2me.essentials.User.get(Lorg/bukkit/entity/Player;)Lcom/earth2me/essentials/User;

    10:55:29 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'quest' in plugin uQuest v1.5
            at org.bukkit.command.PluginCommand.execute(
            at org.bukkit.command.SimpleCommandMap.dispatch(
            at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
            at net.minecraft.server.NetServerHandler.handleCommand(
            at net.minecraft.server.NetServerHandler.a(
            at net.minecraft.server.Packet3Chat.a(
            at net.minecraft.server.NetworkManager.b(
            at net.minecraft.server.NetServerHandler.a(
            at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
            at net.minecraft.server.MinecraftServer.h(
    Caused by: java.lang.NoSuchMethodError: com.earth2me.essentials.User.get(Lorg/bukkit/entity/Player;)Lcom/earth2me/essentials/User;
            at hawox.uquest.QuestInteraction.getMoney(
            at hawox.uquest.QuestInteraction.addMoney(
            at hawox.uquest.QuestInteraction.addMoney(
            at hawox.uquest.questclasses.Reward.giveReward(
            at hawox.uquest.questclasses.LoadedQuest.finish(
            at hawox.uquest.QuestInteraction.questTurnInForceDone(
            at hawox.uquest.QuestInteraction.questTurnInAttempt(
            at hawox.uquest.QuestInteraction.questTurnInAttempt(
            at hawox.uquest.commands.Cmd_uquest.onCommand(
            at org.bukkit.command.PluginCommand.execute(
    Went ahead and copied my server files to my PC, and ran the server as a Local Host... I swapped out Essentials.jar and Essentialsspawn.jar with older versions and relaunched the server each time, 2.3 was not working and 2.2 was not working..... HOWEVER Essentials 2.1 Economy Works Fine! (so far, have not fully tested, but I am no longer receiving this error.) it appears that after 2.1 Essentials has changed the way plugins hook into their Economy system.

    Install iConomy 5 with essentials econ and this plugin worked with out fail....

    Either uQuest Will need an update or you need to roll back to Essentials 2.1.38 if you want to use Essentials Economy as your Money Plugin. I'd really like to see support for Essentials Economy, I like having virtual Currency but I don't need ALL the stuff iConomy has....

    Keep up the good work, and thanks for reading
  15. Offline


    Every time i reload the server, it deletes all the permissions for uquest. Is there something i'm doing wrong? i have use uquest as true, and use plugins as true. i'm using Groupmanager with fakepermissions, would that cause it?
  16. Offline


    I stole your quest file, you may have already fixed this but,
    you have the wrong value for water bucket, you pasted in the hex value instead of the decimal, you need 326 instead of 146.... sweet quest.yml

      Name: The Pig Rider - Heat wave
      Start_Info: I am the Pig Rider, it is hot and my pigs are thirsty. I need water.
      Finish_Info: Thanks for keeping my pigs wet.
        Money: 50
          Type: Gather
            Item_ID: 146
            Display_Name: Water bucket
            Amount: 1
            Durability: 0
    Do you mean to say that the following permissions(posted below) are being removed from your permissions.yml file each time you reboot your server? I'll try and help troubleshoot it, but i need more information.


    There quest_player file is getting cleared or the number of completed quests is reset?
    Does it happen when you reboot the server or when a Player relogs, or does it seem to happen randomly?
    are you using the default settings and quest.yml or custom ones?

    Confirmed working with Bukkit 860 Essentials Economy 2.3 with iConomy enabled and a custom Quests.yml

    680: yes.
    860: yes, but make sure you have either essentials 2.1.38 or iConomy 5 or Essentials Economy 2.3 & iConomy 5,

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 11, 2016
  17. Offline


    Hey, I have a problem with creating a quest. When I'm starting my server, he give me an error : error occured while enabling uquest java.lang.NullPointerException .
    this error only occures with hand made quest.
    Here is the quest.

    Name: God's Wish
    Start_Info: God want to see these zombies die!
    Finish_Info: Finally...
    Money: 100
    Type: Kill
    Display_Name: Kill zombies
    Objective_ID: kill_zombie
    Amount: 10

    It was constructed with the quest-maker.
  18. Offline


    Does this support iConomy 4, or is it just iConomy 5?
  19. Offline

    Randy Schouten

    iConomy 5 should do fine.
  20. Offline


    Why can't I change what the quests are without uQuest saying 'An internal error has occured'?
  21. Offline


    works on boseconomy?
  22. Offline


    I have the same problem! can u help me with that?
  23. Offline


    Please tell me if you fix it :/ Making a seriously awesome RPG server and this is essential D:
  24. Offline


    No, I mean, does it support iConomy 4. I use iConomy 4 on my server and want to know if this plugin works for it.
  25. Can someone help me with this error i keep getting?....
    Also here a link to my yml file
    14:30:52 [SEVERE] Error occurred while enabling uQuest v1.5 (Is it up to date?):
     while parsing a block mapping; expected <block end>, but found BlockMappingStar
    while parsing a block mapping
     in "<reader>", line 1, column 1:
    expected <block end>, but found BlockMappingStart
     in "<reader>", line 670, column 2:
            at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappingKey.produce(Par
            at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(
            at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(
            at org.yaml.snakeyaml.composer.Composer.composeMappingNode(
            at org.yaml.snakeyaml.composer.Composer.composeNode(
            at org.yaml.snakeyaml.composer.Composer.composeDocument(
            at org.yaml.snakeyaml.composer.Composer.getSingleNode(
            at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseCons
            at org.yaml.snakeyaml.Yaml.load(
            at hawox.uquest.questclasses.QuestLoader.<init>(
            at hawox.uquest.UQuest.theQuestsLoadAllIntoArray(
            at hawox.uquest.UQuest.onEnable(
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManage
            at org.bukkit.craftbukkit.CraftServer.loadPlugin(
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(
            at org.bukkit.craftbukkit.CraftServer.reload(
            at org.bukkit.command.SimpleCommandMap$ReloadCommand.execute(SimpleComma
            at org.bukkit.command.SimpleCommandMap.dispatch(
            at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
            at net.minecraft.server.MinecraftServer.b(
            at net.minecraft.server.MinecraftServer.h(
  26. Offline


    So it seems this plugin is EXTREMELY picky with people changing the quests...not good news...
  27. Offline


    It really isn't the plugin but instead with how yml is set up. It is very picky about how things are spaced and formatted.

    You need 1 extra space before Objectives on line 670 and 691.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 11, 2016
  28. Thanks a lot
  29. Offline


    Error loading quest number: 0
    Objective format error:
    Value:{Type=Gather, Item={Item_ID=null, Display_Name=Logs, Amount=20, Durabilit

    What needs changing on mine?

  30. Offline


    Thank you for the quick response, but i figured it out. you have to stop the server completely instead of just reloading the plugins when you edit the permissions file, otherwise it doesn't save it properly, sorry to waste your time.



    What about a quest mode that tells you to go somewhere? When making the quest, you just input coordinants

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 11, 2016
  31. Offline


    The quests dont give me money :s
    I have the Essentials plugin isntalled, and this plugin have moey.
    When i do the quest ai say /balance to see my money and still the same as before, the quest dont give me money :(
    Please help me :s
    hidman likes this.

Share This Page