Inactive [FUN/ECON/DEV] uQuest v1.50 - Overly customizable quest system [793 - 602]

Discussion in 'Inactive/Unsupported Plugins' started by Hawox, Mar 4, 2011.

  1. Offline


    As most of you can guess I have not worked on this plugin in a long time. I'm working full time at a grocery store as well as going to college. I literally have no time for sleep let alone Minecraft. Recently someone has contacted me saying they are working on my plugin. I appreciate his work and effort while I am away. This is a link to his topic. His download can be found at
    uQuest - Overly customizable quest system!
    German Questlist 5/16/11
    Coming Soon!
    Gui Questmaker (Heres a beta build!)
    Upload/download area for quests!
    mcMMO extension!

    Laxlux - New German quest list maintainer
    HiMyNameIsAJ - Creating a uQuest website
    Looking for:
    • Someone to make a nice looking website for uquest (Not my cup of java).
    • Someone to add MySql support.
    • Plugin attachment devs!
    • Someone with ideas on different quest types!
    • People to write some random quests to be thrown in the defaults!

    -----------------------Plugin summery below this point-----------------------
    ~Comes preloaded with 53 quests!~

    Support for: (You don't NEED any of these for the plugin to work.)
    Permissions (but not needed!)
      -"uQuest.CanQuest.*" - Allows all these sub permissions
      -"uQuest.CanReloadQuests" - Allows the use of /reloadquests
      -"uQuest.CanReloadQuestConfig" - Allows the use of /reloadquestconfig
     iConomy (but not needed!)
     BOSEconomy (Again, not needed!)
     Essentials! (Again, not needed!)
    Alright here goes, theres a lot to cover so I may miss something on this first go threw! Want a better way to get money into your server economy that selling items to the server or random lottery's? Do you like QUESTS?!?! Do you want your users to compete to see who is a better quester? Then uQuest might be for you!

    uQuest offers your users a simple way to quest! No need to walk miles and miles to a random NPC or click on some block at spawn. All they need to do is type '/uquest give' and uQuest will give them a random quest from it's database! A yml file is provided where you type out each quest for your users. That's right. YOU can decide how many quests there are, what they are, and how you want your users to do them (creating and editing this file are explained on the wiki). You can broadcast every x quests someone finishes to the server as well as give out rewards for x amount of quests. I'll leave the rest for the features section, just thought I'd get you hooked with that :3 If you grab the .zip (which you need to if you want to store your users in a SQLite database!) I have included 53 quests inside!

    All of that not enough? Well theres an API! Other plugin authors can use this as a base for their own plugins!

    Here's a quick screenshot of what the text looks like:

    (I may miss a few, there's quite a bit)

    ~Quest Types~
    All of these can have specific locations set to them! (Can only do in this area etc)
    (More to come I promise!!)

    (More to come I promise!!)

    ~Watch out~
    With great power (of customization)... Come's great responsibility.... There is a lot that can go wrong if you don't pay attention when your changing files. Thankfully, I've tried to have the plugin spew out as many warnings as it could on the servers start. Always give it a check to make sure the plugin loaded all of your work!!!

    ~Plugin Attachments~
    (These plugins add new features to the basic uQuest system)
    Just started this as an example of what people can do. All it currently has is /qadmin givequest
    OP's and people with the permissions (not required for this either) node 'uQuest.MoreModCommands' can use it.
    Simply shows someones progress on a quest everytime they do something for it. IE. I punch a log as part of my quest (grey text)Log Punches 7/10.
    Just put the jar into your plugins folder and it will work on it's own!
    Updates needed: Move quests | Picking up items. | Support for uQuest levels
    Completes quests automagicly! Works with the same methods as showtracker so it has the same flaws. There is this weird bug when running both at the same time that spams some weird extra text. Try to ignore it for now.
    Just put the jar into your plugins folder and it will work on it's own!
    Updates needed: Move quests | Picking up items. | Unknown status on working with quest levels. | Odd text bug with showtracker/this mix.

    ~Plugins using the API~
    (These plugins use the uQuest API to shape their own plugin)

    Since people don't read the above, I'll post this again here so I don't have to write the reply back to this anymore.
  2. Offline

    Chris Lewis

    Yes newest recommended build is 602 and this plugin (amongst a slew of others) does not work. But patience is a virtue they say....
  3. Offline


    It updated a few hours ago and I just heard of this. I'll work on it later today.
  4. Offline


    I know that when a player ask to be giving a quest, he got one randomly from the list but what happen when he already finished them all ?
    Also, to give a random reward I have to type Reward: item:block in the quests file ?
  5. Offline


    They are not removed from the 'random bag' of quests when they get one. They can get the same quests. No. Random rewards are not related the the quests file. The rewards in there WILL ALWAYS be given to the player on creation. The rewards that are given to players randomly after X amount of quests are in the config.yml file. Read on the wiki on how to mess with the random rewards. I need to make it nested like the rest of the nice looking yml stuff but it's not top on my list currently.

    !!Update!! v1.03
    Version 1.03

    • Updated for CB[602]
    • Added /reloadquests
      • Reloads the quests from the yml file. (Yay no more restarts for quest fixes needed!)
      • Will work even if yoru not using the default uQuest
      • Works from console, ops, and (if using permissions) players with the permission "uQuest.CanReloadQuests"

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 11, 2016
  6. Offline


    How do you make it so that the user cannot see the money reward he will get, but only seeing his reward when he completes the chest.
  7. Offline


    You can't. Should I make a variable to hide the rewards from the players?
  8. Offline


    Yes please =) , when do you think youll put it in?
  9. Offline


    When I get the time. I'm currently rewriting AutoPlant. After this I need to spend time with my boytoy. Maybe tomorrow, but I have another paper to write then as well...
  10. Offline


    it would be greatly appreciated.
  11. Offline


    Is it possible to limit how often a player can perform quests or set a daily limit?
  12. Offline


    After turning in a quest with /q done it gives our server an internal error. It did say that i finished the quest. Iconomy was up to date when that happened.
  13. Offline


    Thanks so much!
    Works on 602 :)
  14. Offline


    hey can you check the dl link because when i go to it it looks like its still loading and i waited for an hr for the dl and it didnt work.... thanx.
  15. Offline


    @Jessicadawn Could you post the error so I actually know what happened...?'

    Edit: @tooy66 1.03 zip works for me.

    Edit2: This is in the top post. Please read it again.

  16. Offline


    she is the other owner of our server. there is no error log it just simply says the error.
  17. Offline


    Can you post your config for me then? I might know the issue.

    EDIT: All the info you can. The console SHOULD give you an error when that text pop's up. So if it's not giving you one I need more info on trying to fix it. Also, did you try it again without using any custom quests/configs? You might have an error in one of your quests... but that would send a message to console telling you to fix it.
  18. Offline


    Using permissions 2.2.4 for 556 and this and it doesnt let anyone besides OP use the commands?
  19. Offline


    Is that a question or are you telling me it's a bug? The permission nodes are in the post. Read it.
  20. Offline


    I added the nodes to the farming class and it still says DOES NOT HAVE ENOUGH PERMISSIONS :(.
    Permissions section:
    default: false
    prefix: '&a[Farmer]'
    suffix: ''
    build: true
    - ',localshops.buysell,localshops.manage,mcmmo.ability.woodcutting,mcmmo.skills.herbalism,mcmmo.skills.woodcutting,uQuest.*
    I have also individually went and did uQuest.CanDropQuest and uQuest.CanQuest and still 0% success

    Heres your config file:

    #### PluginSupport:
    #The number of seconds after enabling to check for plugin linkage. Make this larger if your having issues with uQuest detecting plugins.
    pluginTimerCheck: 10
    #Set to true if you want to have support for multiple plugins.
    useiConomy: true
    usePermissions: true
    useBOSEconomy: false
    moneyName: Coin
  21. Offline


    What version? The newest version is only for CB 602. Other than that I don't know what the problem is. If the permissions were not working it would give everyone the rights to quest and not just OP's. =/

    Post your entire server startup?
  22. Offline


    ive switched many permission ones..
    15:40:46 [INFO] Starting minecraft server version Beta 1.3
    15:40:46 [INFO] Loading properties
    15:40:46 [INFO] Starting Minecraft server on
    15:40:46 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-544-
    g6c6c30a-b556jnks (MC: 1.3)
    15:40:46 [INFO] Preparing level ""
    15:40:46 [INFO] Preparing start region
    15:40:47 [INFO] LWC     Loading shared objects
    15:40:47 [INFO] LWC     Native library: plugins/LWC/lib/native/Windows/x86/sqlit
    15:40:47 [INFO] [Permissions] version [2.3] (Phoenix) was Initialized.
    15:40:47 [INFO] WorldGuard loaded.
    15:40:47 [INFO] ChestLock 0.5 is enabled!
    15:40:47 [INFO] ChestLock Successfully linked with Permissions!
    15:40:47 [INFO] CraftBookCommon 3.0-alpha1 enabled.
    15:40:47 [INFO] CraftBookCircuits 3.0-alpha1 enabled.
    15:40:47 [INFO] CraftBookMechanisms 3.0-alpha1 enabled.
    15:40:47 [INFO] CraftBookVehicles 3.0-alpha1 enabled.
    15:40:47 [INFO] [DelayedStop] Enabling Delayed Stop v0.16
    15:40:47 [INFO] [DelayedStop] Permission system found
    15:40:47 [INFO] [DelayedStop] version 0.16 enabled
    15:40:47 [INFO] [General] version [] (Chernobyl) loaded
    15:40:47 [INFO] [General] hooked into Permissions.
    15:40:47 [INFO] [General] hooked into iConomy.
    15:40:47 [INFO] [HELP] 44 extra help entries loaded
    15:40:47 [INFO] [HELP] Permissions enabled using: Permissions v2.3
    15:40:47 [INFO] [HELP] Help 0.2 enabled
    15:40:47 [INFO] Help
    15:40:47 [INFO] General is giving help to Help
    15:40:47 [INFO] [Permissions] version [2.3] (Phoenix)  loaded
    15:40:47 [INFO] Permissions
    15:40:47 [INFO] [General] hooked into Permissions.
    15:40:47 [INFO] [iChat] Using Permissions 2.3 for permissions
    15:40:47 [INFO] iChat (v2.05) enabled
    15:40:47 [INFO] iChat
    15:40:47 [INFO] [iConomy] Logging is currently disabled.
    15:40:50 [INFO] [iConomy] v4.63 (Kenzi) loaded.
    15:40:50 [INFO] [iConomy] Developed by: [Nijikokun, Coelho]
    15:40:50 [INFO] iConomy
    15:40:50 [INFO] [General] hooked into iConomy.
    15:40:50 [INFO] [iConomy] hooked into Permissions.
    15:40:50 [INFO] [INFORMANT]version 1.6 is enabled
    15:40:50 [INFO] [INFORMANT]Loading Settings
    15:40:50 [INFO] [INFORMANT]Loading Previous Players
    15:40:50 [INFO] Informant
    15:40:50 [INFO] [InventorySort] Using [Permissions v2.3] for Permissions.
    15:40:50 [INFO] [InventorySort] version 1.6.2 is enabled!
    15:40:50 [INFO] InventorySort
    15:40:50 [INFO] LocalShops: Permissions found.
    15:40:50 [INFO] LocalShops: iConomy found.
    15:40:50 [INFO] LocalShops: Loaded 0 shop(s).
    15:40:50 [INFO] LocalShops: version 2.0b is enabled!
    15:40:50 [INFO] LocalShops
    15:40:50 [INFO] Lottery version 0.2.2 is enabled
    15:40:50 [INFO] Lottery
    15:40:50 [INFO] [Lottery] Successfully linked with iConomy.
    15:40:50 [INFO] LWC     Loaded 107 locale strings (0 overrides)
    15:40:50 [INFO] LWC     Using Nijikokun's permissions plugin for permissions
    15:40:50 [INFO] LWC     Loading SQLite
    15:40:50 [INFO] SQLite  Using: Native
    15:40:50 [INFO] LWC     At version: v2.10
    15:40:50 [INFO] LWC
    15:40:50 [INFO] Take yourself wonder by wonder, using /magiccarpet or /mc. Magic
    Carpet version 1.4.5 is enabled!
    15:40:50 [INFO] MagicCarpet
    15:40:50 [INFO] [mcMMO] Permissions enabled.
    15:40:50 [INFO] mcMMO version 0.9.12 is enabled!
    15:40:50 [INFO] mcMMO
    15:40:50 [INFO] MobRider enabled
    15:40:50 [INFO] MobRider - Permissions Plugin Detected
    15:40:50 [INFO] MobRider
    15:40:50 [INFO] [MYHOME]: 4 homes loaded
    15:40:50 [INFO] [MYHOME] Permissions enabled using: Permissions v2.3
    15:40:50 [INFO] [MYHOME] 'Help' support enabled.
    15:40:50 [INFO] [MYHOME] MyHome 1.9.3 enabled
    15:40:50 [INFO] MyHome
    15:40:50 [INFO] [MYWARP]: 1 warps loaded
    15:40:50 [INFO] [MYWARP] Permissions enabled.
    15:40:50 [INFO] MyWarp 1.10.2 enabled
    15:40:50 [INFO] MyWarp
    15:40:50 [INFO] SignColours
    15:40:50 [INFO] Stargate v.0.3.1-1 is enabled.
    15:40:50 [INFO] [Stargate] {} No stargates for world
    15:40:50 [INFO] [Stargate] Found Permissions (v2.3)
    15:40:50 [INFO] [Stargate] Found iConomy (v4.63)
    15:40:50 [INFO] Stargate
    15:40:50 [INFO] [Towny] Database: [Load] flatfile [Save] flatfile
    15:40:50 [INFO] [Towny] Using: Permissions, iConomy
    15:40:50 [INFO] [Towny] Version: 0.6 - Mod Enabled
    15:40:50 [INFO] Towny
    15:40:50 [INFO] [Hawox's uQuest] Loaded with Flatfile!
    15:40:50 [INFO] [Hawox's uQuest] v1.01 enabled! With 53 quests loaded!
    15:40:50 [INFO] Hawox's uQuest
    15:40:50 [INFO] [Hawox's UQuest] Successfully linked with iConomy.
    15:40:50 [INFO] [Vampire v1.4] Found and will use plugin Permissions v2.3
    15:40:50 [INFO] [Vampire v1.4] Found and will use plugin Help v0.2
    15:40:50 [INFO] [Vampire v1.4] Enabled
    15:40:50 [INFO] Vampire
    15:40:50 [INFO] WorldEdit 4.0-beta8 enabled.
    15:40:50 [INFO] WorldEdit: Permissions plugin detected! Using Permissions plugin
     for permissions.
    15:40:50 [INFO] WorldEdit
    15:40:50 [INFO] WorldGuard: Permissions plugin detected! Using Permissions plugi
    n for permissions.
    15:40:50 [INFO] WorldGuard: Single session is enforced.
    15:40:50 [INFO] WorldGuard: TNT ignition is blocked.
    15:40:50 [INFO] WorldGuard: Lighters are PERMITTED.
    15:40:50 [INFO] WorldGuard: Lava fire is blocked.
    15:40:50 [INFO] WorldGuard: All fire spread is disabled.
    15:40:50 [INFO] WorldGuard 4.0-alpha1 enabled.
    15:40:50 [INFO] WorldGuard
    15:40:50 [INFO] XSigns info: 1 XSigns loaded
    15:40:50 [INFO] XSigns version 0.6 is enabled!
    15:40:50 [INFO] XSigns
    15:40:50 [INFO] Done (0.466s)! For help, type "help" or "?"
    15:42:41 [INFO] 143 recipes
    15:42:41 [INFO] DillonVPS [/] logged in with entity id 378
    15:42:42 [INFO] Loaded world:
    15:42:44 [INFO] DillonVPS tried command: questy
    ok it turns out only ADMINS (op or not) can do it? Am I doing something wrong lol?
    Double post please merge :p ... ALSO I found out what was wrong.. I did an inheritance and it fixed it (I am doing permissions wrong I havent tested it but im 99.5% sure that i cant use ,'s i must keep doing - 'xxdxxx.xxxxx' - 'xxddfggxx.xrddx' not ,fdfxfc.sxf,xfdxf.fdf :p

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 11, 2016
  23. Offline


    Your not adding the node in correctly/in the correct place...
  24. Offline


    am i not able to delete all the original quests and create my own? if so, then how? i tried clearing the Quests.yml
    then added, but it just gave me an internal error.
      Name: The Helmet of the Defensive.
      Start_Info: Oh, this unique helmet will fit my head perfectly!
        Money: 10000
          Type: Gather
            Item_ID: 302
            Display_Name: Chainmail Helmet
            Amount: 1
            Durability: 0
  25. Offline


    That looks right. Did you start with 0 or 1?

    EDIT: Oh you need to start with 0 btw.
  26. Offline


    i did start with a 0 but its still giving me internal error :/ am i supposed to change anything else but the quests.yml?
  27. Offline


    It says block damage was not loaded, help?
  28. Offline


    2011-04-01 22:41:19 [SEVERE] Could not pass event PLAYER_JOIN to Hawox's uQuest
        at sqLiteStor.SqLiteKeyValStor.put(
        at hawox.uquest.UQuestPlayerListener.onPlayerJoin(
        at org.bukkit.plugin.RegisteredListener.callEvent(
        at org.bukkit.plugin.SimplePluginManager.callEvent(
        at net.minecraft.server.ServerConfigurationManager.a(
        at net.minecraft.server.NetLoginHandler.b(
        at net.minecraft.server.NetLoginHandler.a(
        at net.minecraft.server.NetworkListenThread.a(SourceFile:87)
        at net.minecraft.server.MinecraftServer.h(
    thats all im saying
  29. Offline


    I can fix that woodzy. All others your not modifying your quests right. Also remember to check bukkit build compatibilities.
  30. Offline


    Kinda funny you are saying that its wrongly modified, if there is something wrong with this
      Name: The Helmet of the Defender
      Start_Info: OOoh, can i haz der shiny helmet?!
      Finish_Info: Hehe, i guess i could have the shiny helmet ;).
        Money: 200
          Item_ID: 302
          Display_Name: Chain Helmet
          Amount: 1
          Durability: 0
          Type: Gather
          Display_Name: Chain Helmet
          Objective_ID: 302
          Amount: 1
    i will applaud!
  31. Offline


    nope not modifying quests kind sir. but that would great for a fix! me and my players LOVE this plugin sooo much

Share This Page