[FUN] Citizens v2.0.11 - Human NPCs for Bukkit [1.7.2]

Discussion in 'Archived: Plugin Releases' started by Citizens, Mar 5, 2011.

  1. Offline


    Citizens - Human NPCs for Bukkit
    Version: 2.0.11
    Authors: @fullwall and @aPunch
    Source: Citizens on GitHub

    Citizens is now on BukkitDev

    This thread will no longer be updated. We encourage you to use our page on BukkitDev. You can find information, links to our wiki and website, and the download page there.

    Showing Your Support

    We work hard to maintain Citizens. We've been working on Citizens2 around the clock on new and exciting features. A little motivation never hurts, so feel free to donate to us - fullwall and aPunch.

    If you can't donate, we appreciate a "hello" every now and then. Stop by the IRC channel #citizens on irc.esper.net to discuss Citizens and give thanks!
  2. Offline


    stoneminer02 SkizzlePig - when you get strange errors like NoClassDefFoundError, generally the best thing to do is use the dev builds of both Blacksmith and Citizens at http://ci.citizensnpcs.com. I changed a method to be more specific, I'll be putting a 2.0.3 build out soon when internationalisation is finished to address this particular error.
    guilty_spark_117 likes this.
  3. Wow. How could I be so stupid... You're right. Thanks a million!
  4. Offline


    Ok thanks fullwall!
  5. Offline


    fullwall, that did it. I loaded the latest Citizens 2 dev build and TA DA it works. Thanks for your help!
  6. Offline


    Look I'm really clueless and I need help really bad understanding this plugin. Some one PLEASE HELP ME! :(
  7. Offline


    I'm writing the bot's sentences in my own language and when I use accents (like "é" for example) the assignments file doesn't appear to load (the bots revert to the standard sentences). Is there any escape character I can use to add non-english characters to the bot's repertoire?

    Thanks for the great plugin!
  8. Offline


    Is there a way to make an (sentry) NPC attack someone?
  9. Offline


    Why after hit npc are teleport to spawn ?
  10. Offline


    newest citizens2 + denizen + sentry before updateting it was working.

    2012-10-16 22:50:55 [INFO] Denizen: An error has occured.
    2012-10-16 22:50:55 [INFO] --- Error follows: java.lang.IllegalArgumentException: No enum constant org.bukkit.Material.REDSTONE_TORCH
    edit: ok got it, new config for sentry solved it but

    every hit is a crit hit... thats not really cool.
  11. Offline


    you should be able to see out of an npc eyes by doing something like /npc see (id)
  12. Offline


  13. Offline


  14. Awesome thing and fast update. Working fine so far!


    /npc equip -> right clicking items for NPC to wear , they do not show in puplic!
    If i right click again to remove them, they will pop out to floor as usual. But the problem is: NO EQUIPMENT SHOWN
  15. Offline


    Tested every available command with the latest dev build, haven't found any bugs yet. Thanks for the quick update.
    Sketaful likes this.
  16. Yes the commands work fine but what about what the command should do? if u saw my post over urs, youll see what i had problem
  17. Offline


    Yeah, didn't notice that.

    How to reproduce:
    1. Select an NPC.
    2. Run /npc equip and try to equip an item, doesn't equip properly.
    3. Try to equip another item and it drops the item from before that didn't equip properly.
  18. Offline


    I'll take a look at the equip problem tonight, and add mob equipping.
  19. Offline


    Something odd is going on with player equipping... need to relog to see the changes. Also, I'm holding off on mob equipping until API is added, but I added /npc skeletontype for wither skeletons.
  20. Offline


    I'm having a heck of a time trying to configure new recipes for the alchemist character mod. The default one works fine, but when I tried a second one (poision), it'll only accept the glass bottle. I've searched everywhere to try to find out what's wrong, and I'm positive it has to do with item names, but it doesn't seem to accept what I'm putting in. Below is the config file as I've modified it:

    # Alchemist Configuration

    cooldown-not-expired: You've already had your turn. Come back later!
    initialization-message: §eHello there, <player>. Give me what I need and I will brew you a potion!
    success-message: §eI have combined the ingredients to concoct a potion of §a<potion>§e.
    cooldown-in-seconds: 60
    effect: fire-resistance
    duration: 60
    amplifier: 1
    splash: false
    name: sugar
    amount: 1
    name: glass-bottle
    amount: 1
    name: wool
    amount: 1
    data: 6
    effect: poision
    duration: 60
    amplifier: 1
    splash: true
    name: dandelion
    amount: 1
    name: glass-bottle
    amount: 1
    name: mycelium
    amount: 1

    If anyone (or the author) can see what I did wrong, please let me know. Its very frustrating and I wish there was a more detailed description on the wikki. Thanks in advance! :)

    Edit - The spacing in the .yml file is correct, but it just didn't copy over for some reason when I pasted it here.
  21. Offline


    First off, I would like to thank you and your...team if you will for creating such a great plugin. Secondly, your right. NPC equipping is not working for the latest version of Citizens2. When ever you get the time I would REALLY appreciate you looking into this error. Citizens is pretty much the backbone of my server and is very important. Thanks again for creating the plugin and I hope to see a fix in the future :D
  22. Offline


    break2471 likes this.
  23. Offline


    citizens is coming up corrupted for me
  24. Offline


    Thank you very much. Works fine with a few bugs here and there. But nothing a quick reconnect to the server won't fix.
  25. Offline


    Okay so, I did some basic commands on my server --example /npc create /npc equip and those seemed to work fine. The only problem im experiencing is the Sentry trait. When ever I have a npc selected and i type /trait sentry i get the NoSuchFieldError. I understand that your not the author of this add-on plugin, but is there anyways you could inform them about my problem or direct me to a forum that they manage? Thanks ~ break2471
  26. Offline


  27. Offline


    can't use "/toggle guard" when i use citizens2.0.4 :S
    is it something that I have done wrong, or doesn't it work for that version of citizens??
  28. Offline


  29. Citizens

    Is there a way to block people from killing npcs with bows? or prevent players from flying around citizens?

    i made factions, both have their guards & they drop their stuff when die... but people "abuse" their flying privileges (donators) and fly over them and start throwing either potions or shoot with bows and get easy items for free.
    Can someone help ?
  30. Offline



    First thank you for your awesome plugin, keep up the good work, and sorry for my english... ;)

    I have plenty of quests that I'd rather not rewrite again, as it was very simple to write them with the first Citizens, and I dont want to download 2 or 3 more plugin to have quests working with Citizens 2, and dont really want to learn a new way to write quests... and those plugins are not lightweight at all.

    So I thought that the update of Citizens (8 days ago) here: http://ci.citizensnpcs.com/ was working with 1.4.2 but seems not, I have this error when trying to create an npc:

    14:52:29 [SEVERE] java.lang.NoSuchMethodError: net.minecraft.server.MinecraftServer.E()Ljava/security/KeyPair;
    14:52:29 [SEVERE]at net.citizensnpcs.resources.npclib.CraftNPC.<init>(CraftNPC.java:27)
    14:52:29 [SEVERE]at net.citizensnpcs.resources.npclib.NPCSpawner.spawnNPC(NPCSpawner.java:64)
    14:52:29 [SEVERE]at net.citizensnpcs.resources.npclib.NPCManager.register(NPCManager.java:112)
    14:52:29 [SEVERE]at net.citizensnpcs.resources.npclib.NPCManager.register(NPCManager.java:138)
    14:52:29 [SEVERE]at net.citizensnpcs.commands.BasicCommands.create(BasicCommands.java:218)
    14:52:29 [SEVERE]at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    14:52:29 [SEVERE]at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    14:52:29 [SEVERE]at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    14:52:29 [SEVERE]at java.lang.reflect.Method.invoke(Unknown Source)
    14:52:29 [SEVERE]at net.citizensnpcs.resources.sk89q.CommandsManager.executeMethod(CommandsManager.java:254)
    14:52:29 [SEVERE]at net.citizensnpcs.resources.sk89q.CommandsManager.execute(CommandsManager.java:146)
    14:52:29 [SEVERE]at net.citizensnpcs.Citizens.onCommand(Citizens.java:144)
    14:52:29 [SEVERE]at org.bukkit.command.PluginCommand.execute(PluginCommand.java:44)
    14:52:29 [SEVERE]at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:185)
    14:52:29 [SEVERE]at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:504)
    14:52:29 [SEVERE]at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:911)
    14:52:29 [SEVERE]at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:824)
    14:52:29 [SEVERE]at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:806)
    14:52:29 [SEVERE]at net.minecraft.server.Packet3Chat.handle(Packet3Chat.java:44)
    14:52:29 [SEVERE]at net.minecraft.server.NetworkManager.b(NetworkManager.java:282)
    14:52:30 [SEVERE]at net.minecraft.server.NetServerHandler.d(NetServerHandler.java:111)
    14:52:30 [SEVERE]at net.minecraft.server.ServerConnection.b(SourceFile:35)
    14:52:30 [SEVERE]at net.minecraft.server.DedicatedServerConnection.b(SourceFile:30)
    14:52:30 [SEVERE]at net.minecraft.server.MinecraftServer.r(MinecraftServer.java:578)
    14:52:30 [SEVERE]at net.minecraft.server.DedicatedServer.r(DedicatedServer.java:215)
    14:52:30 [SEVERE]at net.minecraft.server.MinecraftServer.q(MinecraftServer.java:495)
    14:52:30 [SEVERE]at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:428)
    14:52:30 [SEVERE]at net.minecraft.server.ThreadServerApplication.run(SourceFile:818)
    Is it not working with 1.4.2 at all?
    Should I delete all my quests on my server? :(
    I dont really have time to rewrite them from zero :(
    thank you a lot and again sorry for my english,
    good bye!
  31. Offline


    LoulouteFlore - hmm... are you sure you extracted the JAR properly? The latest build from 8 days ago definitely updates that...

Share This Page