[FUN] Citizens v2.0.11 - Human NPCs for Bukkit [1.7.2]

Discussion in 'Archived: Plugin Releases' started by Citizens, Mar 5, 2011.

  1. Offline


    Citizens - Human NPCs for Bukkit
    Version: 2.0.11
    Authors: @fullwall and @aPunch
    Source: Citizens on GitHub

    Citizens is now on BukkitDev

    This thread will no longer be updated. We encourage you to use our page on BukkitDev. You can find information, links to our wiki and website, and the download page there.

    Showing Your Support

    We work hard to maintain Citizens. We've been working on Citizens2 around the clock on new and exciting features. A little motivation never hurts, so feel free to donate to us - fullwall and aPunch.

    If you can't donate, we appreciate a "hello" every now and then. Stop by the IRC channel #citizens on irc.esper.net to discuss Citizens and give thanks!
  2. Offline


    Did you put the NPC types jar-Files in /plugins/Citizens/types ? They don't get installed there if you simply unzip the citizens file.
    Create NPCs this way:
    /npc create [name]
    select Npc by rightclick or use /npc select [id]
    /toggle Guard
    Now Alice should be a Guard NPC.[/quote]
    Well first i did it without changing anything and it still said it.

    EDIT: Ok It's fixed the citizens folder was just created
  3. Offline


    This is a warning. If you use the default database, which is accounts.mini, you'll probably loose your data due to a bug.
    However, you can ignore this, if your playing alone or with just a few friends. Because its easier to simply create a new accounts file and restore the data instead of learning MySQL and setting up a database. So thats the lazy option. ;)
    If you want to learn something, or have 5+ player on your server, i suggest to use a sql Database.
    This should help:
  4. Offline


    So, it would seem that when I create an NPC and then reload the plugins/restart the server, the NPC is gone.

  5. Offline


    As ive said a few times before, it has to do with incompatible plugins or a false configuration of citizens.
    But 99% its a plugin. So deinstall all mods (or simply create a new server on your pc) and add them one by one.
    Start with bukkit, iconomy, permissions and citizens.
    Nobody can help you, if you only post "help, doesn't work!" There are millions of plugins and billions of possible combinations and configurations. So i can't help you without getting some info from you.
  6. Offline


    i edit config

    i have database minecraft but is another urs //localhost/sqlbuddy/#page=home
    i add url up like this
    Database URL without table at the end.
    URL: '//localhost/sqlbuddy/'

    but still show this

    13:10:17 [SEVERE] iConomy6 - If you are using Flatfile storage be aware that iCo6 has a CRITICAL bug which can wipe ALL iconomy data.
    13:10:17 [SEVERE] if you're using Votifier, or any other plugin which handles economy data in a threaded manner your server is at risk!
    13:10:17 [SEVERE] it is highly suggested to use SQL with iCo6 or to use an alternative economy plugin!

    maybe i smting wrong make?
  7. Offline


    The warning displays regardless of how you've configured iCo6 - if it's detected as loaded the message displays to let you know that you're using an incredibly buggy, mostly abandoned project by a developer who likes to chain the userbase by coming back and making a few minor patches every 2-3 months just to 'keep it going'

    You can of course simply ignore the message and continue to use the software at your own risk.
  8. Offline


    >02:01:42 [INFO] [Citizens] Unable to fetch player map from CraftEntity: players. Conflicting names will do funny things.
  9. Offline


    Its an actual npc that you can see
  10. Offline


    Thats a bit late of a reply considering it was made in March of 2011 :p
  11. Offline


    davc - don't mind that message, the player map has been removed.
    DinoScope - do you use MineBackup?
  12. Offline


    Ok so, i made a npc with /npc create phoenix_8754 then i toggled him to guard but when i make him bodyguard it will say Phoenix_8754 is now a bodyguard! But, he wont follow me, he wont attack anything even after i set the flag, ive looked in config, ive re-downloaded plugin, ive tried doing the commands over again. nothing seems to work, any suggestions? Thanks
  13. Offline


    haha didnt see the date oops
  14. Offline


    No, should I?
  15. Offline


    Everytime I restart everything disappears...
  16. Offline


    Possible to edit how long an NPC's text can be? I'd like long-ish dialogue but that appears impossible, even if I edit it by config. Is this possible to be editted in the source? If so, could you point me where?
  17. Yes, I have been wondering this for a long time..But i know have the answer I gave up on it for then decided to google how to use commandsigns plugin and when to forums and all that well the answer is simply install Vault to your server http://dev.bukkit.org/server-mods/vault/ simple as that
  18. Yes, I have been wondering this for a long time..But i know have the answer I gave up on it for then decided to google how to use commandsigns plugin and when to forums and all that well the answer is simply install Vault to your serverhttp://dev.bukkit.org/server-mods/vault/ simple as that
  19. Offline


    Doesn't essentials come with vault?
  20. Offline


  21. Offline


    my npc's keep disapearing anyone know how to fix this? i make an npc i name him smithy then i run the command /citizens save i also do /save-all but when the server gets reset he is gone
  22. Offline


    I have a very annoying bug:
    1) My NPC doesn't talk/look if you dont right click on them
    2)If I restarts my server the NPCs is gone?

    Why? Please reply back.
  23. Offline


    Hi, I am still on version 1.2 - i updated to your jenkins dev build #61 to fix an issue with players double clicking traders and robbing them blind, and another issue where a player was able to execute /npc remove all without the admin permission! Catastrophy! But now the quester NPCs fail to give any details in /quest status - quests work, you just cant see status - should I just grab an earlier build of the quester types jar file, or is the issue in the main citizens jar?

    So far other that some quirkyness with the original spawn location still, everything is working as expected. Just quests are a bit hard as players don't know what they need to do to complete them! (also NPCs seem to ignore gravity, if they get lured off an edge they just levitate!? and evils spawn mid air or half in blocks so cant use them, nor can they be tamed no matter how much cake you toss at them!)

    --- Below questions only relate to v2.0+ beta ---
    In 1.2; Much to my irritation the trader npc is not able to trade in enchanted items (or rather the players irritation!) as he simply removes enchantments from them. Looking at the trader settings in plugin folder looks like there is no provision for it using the "buys: ,itemcode,item,etc format" blah in there.
    Is this supported at all in version 2.0? (ie trading enchanted stuff)

    Another 2.0 question - Evils, can you set a way to allow(or set) or block evils spawning in particular areas. Eg - spawn, villages(worldguard ID?), blocked; roads between villages, dark forests, caves, etc allowed. Even if it is simply "borrowing" (or checking) the "spawn mobs" type flags in worldguard. At the moment in 1.2 they just seem to spawn near whereever a player logs in if it is a recently loaded chunk after a reboot.
  24. Offline


    HELP...the plugin looks really cool but no matter what i do i cant get it to work right. i can spawn npcs but i cant get them to look at me or talk or hit them, the only interaction i can do is if i click on them . PLEASE HELP ME FIX THIS CAUSE I REALLY WANT TO USE THIS PLUGIN!!!!!
  25. Offline


    Is there any way I can TP to a citizen?
  26. Ok so I started off getting citizens hoping to get quests. This did not work for me because whenever I tried to /toggle quester it would say invalid NPC so I downloaded the previous citizens and then dragged all the types into the empty types folder I downloaded with the new one. No problems, until I went to right click to accept the quest... It gives me a bunch of errors.

    PS When I start the server it says [citizens] Unable to fetch player map from CraftEntity: players. Conflicting names will do funny things.
  27. Offline


    Please HELP, when I reload or stop server all NPCs disapear!
  28. Read one page back. You should have vault installed and after creating your npc's always typ "/citizens save".
  29. Offline


    could someone write me a quest and tell me EXACTLY what to do with it i dont understan anything lol please:confused::D
  30. Can you make a NPC attack a player?
  31. Offline


    As BukkitDev is down is ask this question here:

    I use CommandHelper with Citizens to implement some advanced quests. Invoking aliases from initial and reward nodes works fine, as long as the server executes them. If server option is set to false it ansers with "Unkown command". Invoking the same alias from the players console directly works fine though!

    Any ideas ?

    alias in config.xml:
    /doTell $player $text = /tell $player $text
            description: "Description"
            acceptance: "Acceptance"
            completion: "Completion"
        repeats: -1
                type: item   
                id: 19          # sponge
                amount: 1
                type: command
                command: doTell <player> TestText1  #works fine
                server: true             
                type: command
                command: doTell <player> TestText2 #doesn't work
                server: false
                type: delivery
                materialid: 19        # sponge
                amount: 1   
                npcdestination: 16
                type: command
                command: doTell <player> TestText3  #works fine
                server: true 
                type: command
                command: doTell <player> TestText4  #doesn't work
                server: false  
    Right click to accept.
    [Console -> me] TestText1
    Unknown command. Type "help" for help
    [Console -> me] TestText3
    Unknown command. Type "help" for help

    Further information: Running Bukkit 1.2.5 - R1


    BlockBlocker - blablubbabc
    CashFlow 1.186 - Unknown Author
    Citizens 1.2 - fullwall, aPunch
    CommandHelper "3.3.0" - Unknown Author
    Essentials 2.9.1 - Zenexer, ementalo, Aelux, Brettflan, KimKandor, snowleo, ceulemans, Xeology, KHobbits, md_5
    GroupManager 1.9 (2.9.1) (Phoenix) - Unknown Author
    EssentialsProtect 2.9.1 - Zenexer, ementalo, Aelux, Brettflan, KimKandor, snowleo, ceulemans, Xeology, KHobbits
    OpenInv 1.8.4 - lishid
    Vault 1.2.14-b164 - cereal, Sleaker, mung3r
    WorldEdit 5.3 - Unknown Author
    WorldGuard "5.5.2" - Unknown Author
    WormholeXTreme 1.017 - Lologarithm, alron, lycano

Share This Page