[FUN] Citizens v2.0.11 - Human NPCs for Bukkit [1.7.2]

Discussion in 'Archived: Plugin Releases' started by Citizens, Mar 5, 2011.

  1. Offline


    Citizens - Human NPCs for Bukkit
    Version: 2.0.11
    Authors: @fullwall and @aPunch
    Source: Citizens on GitHub

    Citizens is now on BukkitDev

    This thread will no longer be updated. We encourage you to use our page on BukkitDev. You can find information, links to our wiki and website, and the download page there.

    Showing Your Support

    We work hard to maintain Citizens. We've been working on Citizens2 around the clock on new and exciting features. A little motivation never hurts, so feel free to donate to us - fullwall and aPunch.

    If you can't donate, we appreciate a "hello" every now and then. Stop by the IRC channel #citizens on irc.esper.net to discuss Citizens and give thanks!
  2. Offline


    Okay um is there an attack function to make NPC guards attack mobs? SOrry I haven't really read the comments but frankly there's 358 pages and my entire server populace working would take a few months to do that, sorry if this question is a bother but we'd really like to know...
  3. Offline


    Yes but doesn't working for me...
    (Toggle guard type bouncer)
  4. Offline


    same problem here
  5. Offline


    I know how to equip NPCs if they stand infront of me via console. ;)
    I was asking for a solution inside the quest.yml, so that i can create them a few times for this quest.
    But theres no solution for atm, at least i could find none till now.
    A workaround could be to "resurrect" them, if this is possible, and move them to a saferoom, where they wait to be moved again to the right spot, if a new player starts that quest.

    did you gave them the citizens.basic.create permission?
    should work if you do so...
  6. Offline


    Is there a way to change the price of an npc guard death. Meaing when you kill a guard, it give you a said amout of money. How do you change the price.
  7. Offline


    Hmm I made this

    /npc create Test
    /npc add Test Cool Items
    /npc talkclose

    then I made rightclick on him and it only says "There are no items to take"

    How can I make him walk in my home and talk to people ?

    AND ... how to make Mob-NPCs ?

    /npc create Piggie --type pig -b

    then he only says

    "Did you mean /npc create ?"

  8. http://citizens.wikia.com/wiki/Your_first_NPC
  9. Offline


    I love this plugin however; is there currently a way to replace the displayed name of a npc without changing the appearance? This could be a more simplified solution to the skinning issue at hand. A command could be implemented such as "/npc create blc1973 display Raven" A command like this would show the skin of blc973 but display the name of Raven. I understand if blc1973 changed his skin the npc would reflect that change, but it would ultimately offer more freedom to the OP to create the rpg utility this plugin is designed for.

    How close are we to harnessing a way to import custom skins into the plugin? I know about spout, and while this method may work for others, I refuse to require my players to mod their own game to meet server functionality. (To see the server as I intended)

    I can only imagine the hardships involved in creating a plug-in of such dynamic use so I apologize if I have offended, that is not my aim. I fully support this plugin and would love to see it's ideals and vision set to fruition. I offer a humble word of thanks to those who developed this and I look forward to many great things from you!
  10. Offline


    That won't affect the game any It's just telling you that mcMMO is not compatible with Citizens this won't make them unusable or anything though they just don't work together. If this is error is really clogging up your server terminal and your annoyed by it delete mcMMO or Citizens.
  11. Offline


    blc1973 - the problem is that the display of nameplates is entirely clientside. While you can change names in chat, you can't change what name, and thus what skin, is displayed clientside.
  12. Offline


    Anyone have a fix for the invisible NPC's issue?

    Tried use-economy to false: no
    tried removing minebackup: nope
    tried setting the save time to 600 ticks: nope

    Keep getting

    and I'm totally stuck.

    Full PL:
    Plugins (60): BlockDoor, BetterDispensers, EnchantAnything, EconXP, LegendZero, VoxelSniper, Vault, SignLift, Multiverse-Core, RemoteToolkitPlugin, dynmap, Chairs, SpawnerAdjuster, EasyEnchant, SurvivalGames, CraftBay, ChestBank, BlocksOnGlass, StickyBlock, BiomeEdit, Citizens, NoCheatPlus, Spout, PotionsPlus, WirelessRedstone, Cookbook, Snowballer, SoftLimit, Broker, JSONAPI, PermissionsEx, CombatTag, CasinoSlots, LotteryPlus, iBank, Turnstile, Gods, BKCommonLib, HGGifts, CodeLock, Essentials, ShowCaseStandalone, TempleCraft, HeroBounty, Multiverse-Portals, StainedGlass, CitizenSkins, NoLagg, EssentialsChat, MobArena, WorldEdit, EssentialsProtect, WorldGuard, EnchantMore, MobHealth, Factions, SpoutEssentials, Dynmap-Factions, RSP, FactionsPlus

    Tested with as little as Essentials, WorldGuard, WorldEdit, Citizens. Still happening.
  13. Offline



    I found a problem with Heroes!
    Citizens is partially incompatible with this plugin.
    Why? Heroes thinks NPCs are players! So some armors and tools can't be equiped...And NPCs doesn't execute order or "flags" correctly.
  14. Offline


    When ever I shut down my server (/stop) the NPCs from Citizens disapear and dont come back when i turn my server back on. Is this a error?
  15. Offline


    may be adding this or should I wait till citizens 2?
  16. Offline


    i get that 2...

    ( Help Citizens )
  17. Offline


    Yes it is. Normally they should not disappear. However, due to Plugin incompatibility such problems occur.
    Im waiting for Citizens 2 and hopefully they fix those errors (and improve the questsystem).
    edit: wrong quote ^^
  18. Offline


    Ok so how do I get other types of Citizens? And when I do like /guard it says "The command wasnt reconized. See /guard help for a list of commands. And then I do /guard help and it does the same thing.
  19. Offline


    [19:05:34] mickey mouse: 19:03:26 [SEVERE] Error occurred while enabling Citizens v1.2 (Is it up to date?)
    19:03:26 java.lang.NoClassDefFoundError: net/milkbowl/vault/economy/Economy
    19:03:26 at net.citizensnpcs.Economy.init(Economy.java:21)
    19:03:26 at net.citizensnpcs.Citizens.onEnable(Citizens.java:122)
    19:03:26 at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:215)
    19:03:26 at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:337)
    19:03:26 at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:381)
    19:03:26 at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:256)
    19:03:26 at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:238)
    19:03:26 at net.minecraft.server.MinecraftServer.t(MinecraftServer.java:381)
    19:03:26 at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:368)
    19:03:26 at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:197)
    19:03:26 at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:432)
    19:03:26 at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)
    19:03:26 Caused by: java.lang.ClassNotFoundException: net.milkbowl.vault.economy.Economy
    19:03:26 at java.net.URLClassLoader$1.run(Unknown Source)
    19:03:26 at java.net.URLClassLoader$1.run(Unknown Source)
    19:03:26 at java.security.AccessController.doPrivileged(Native Method)
    19:03:26 at java.net.URLClassLoader.findClass(Unknown Source)
    19:03:26 at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:41)
    19:03:26 at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:29)
    19:03:26 at java.lang.ClassLoader.loadClass(Unknown Source)
    19:03:26 at java.lang.ClassLoader.loadClass(Unknown Source)
    19:03:26 ... 12 more

    how can fix this ? :O
  20. Offline


    Hey guys,

    sorry for my bad english but I have an problem with Citizens. Today I download it and install it on my bukkit server. But now we have problems with the guards! Everytime when I spawn Guards the server said:

    2012-06-01 13:49:51 [WARNING] Task of 'Citizens' generated an exception
    java.lang.UnsupportedOperationException: SuperPerms no group permissions.
        at net.milkbowl.vault.permission.plugins.Permission_SuperPerms.getPlayerGroups(Permission_SuperPerms.java:91)
        at net.milkbowl.vault.permission.Permission.getPlayerGroups(Permission.java:522)
        at net.citizensnpcs.permissions.PermissionManager.getGroups(PermissionManager.java:105)
        at net.citizensnpcs.guards.flags.FlagSorter$6.apply(FlagSorter.java:99)
        at net.citizensnpcs.guards.flags.FlagSorter$6.apply(FlagSorter.java:76)
        at com.google.common.collect.Iterators$7.computeNext(Iterators.java:645)
        at com.google.common.collect.AbstractIterator.tryToComputeNext(AbstractIterator.java:141)
        at com.google.common.collect.AbstractIterator.hasNext(AbstractIterator.java:136)
        at net.citizensnpcs.guards.flags.FlagSorter.getPossible(FlagSorter.java:142)
        at net.citizensnpcs.guards.flags.FlagList.process(FlagList.java:33)
        at net.citizensnpcs.guards.flags.FlagList.processEntities(FlagList.java:57)
        at net.citizensnpcs.guards.Targeter.findTarget(Targeter.java:14)
        at net.citizensnpcs.guards.types.Bodyguard.findTarget(Bodyguard.java:86)
        at net.citizensnpcs.guards.types.Bodyguard.updateStatus(Bodyguard.java:47)
        at net.citizensnpcs.guards.Guard.updateStatus(Guard.java:135)
        at net.citizensnpcs.guards.GuardTask.run(GuardTask.java:23)
        at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:126)
        at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:533)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:459)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)
    My Plugins are:

    Can you please help me? Great Thanks :)

    Greetings ;)
  21. Bug:
    npcs with items, while killed when they have those items -> items are dropped on ground.
  22. Offline


    Install Vault for permissions and economy and it should be fixed!
  23. Offline


    now work but wtf is this ?
    18:07:16 [SEVERE] iConomy6 - If you are using Flatfile storage be aware that iCo6 has a CRITICAL bug which can wipe ALL iconomy data.
    18:07:16 [SEVERE] if you're using Votifier, or any other plugin which handles economy data in a threaded manner your server is at risk!
    18:07:16 [SEVERE] it is highly suggested to use SQL with iCo6 or to use an alternative economy plugin!
  24. Offline


    and why /toggle commands dont work?
  25. Offline


    Can I create a NPC in other worlds?
  26. Offline


    "2012-06-03 14:42:14 [INFO] [Citizens] Unable to fetch player map from CraftEntity: players. Conflicting names will do funny things."
    This message arrived after starting my server. What does it mean? o.o
  27. Offline


    When i log off the server, all the NPC's go away....
    Also the NPC's dont talk by themselves even if i use /npc talkclose, i need a book to make them talk. Please help!
  28. Offline


    When I try to make a npc a guard it says Invalid NPC Type And yes i did /toggle guard
  29. Offline


    i add
    - citizens.npc.talk

    for members but still say you dont have premission anyone know why?
  30. Offline


    Use an SQL Database for Iconomy. Flatfile means that your Data is stored in one or more .txt files, .yml files, ...
    If you open the accounts.mini file inside the iConomy folder you'll see.

    Dont know. But you can use the "moveto" command to move them to another world.

    I am not sure, but i think this means that you shouldnt create NPCs which play as player on your server
    Strange enough, i think this message appeared after i installed WorldEdit. Gonna check that tomorrow.

    Had this issue too when vault plugin was not installed.

    Did you put the NPC types jar-Files in /plugins/Citizens/types ? They don't get installed there if you simply unzip the citizens file.
    Create NPCs this way:
    /npc create [name]
    select Npc by rightclick or use /npc select [id]
    /toggle Guard
    Now Alice should be a Guard NPC.
  31. Offline



    what you mean i dont understend im nub
    i need make 1 sql database whit wamp server will be ok? and name database?

Share This Page