[FUN] Citizens v2.0.11 - Human NPCs for Bukkit [1.7.2]

Discussion in 'Archived: Plugin Releases' started by Citizens, Mar 5, 2011.

  1. Offline


    Citizens - Human NPCs for Bukkit
    Version: 2.0.11
    Authors: @fullwall and @aPunch
    Source: Citizens on GitHub

    Citizens is now on BukkitDev

    This thread will no longer be updated. We encourage you to use our page on BukkitDev. You can find information, links to our wiki and website, and the download page there.

    Showing Your Support

    We work hard to maintain Citizens. We've been working on Citizens2 around the clock on new and exciting features. A little motivation never hurts, so feel free to donate to us - fullwall and aPunch.

    If you can't donate, we appreciate a "hello" every now and then. Stop by the IRC channel #citizens on irc.esper.net to discuss Citizens and give thanks!
  2. Offline


    Couldn't you only check if NPCManager.isNPC(Entity) after you have checked if Citizens is enabled?
  3. Offline


    Every time now that I try to create an npc it doesn't work since 1.1 is this just my stupidity? Is this working for you guys?
  4. Offline


    i can't use the plugin when i have downloaded it
    plz help
  5. Offline


    Does citizens give NPCs some walking around town AI? Or do I need to find an AI plug in for the plug in? Not sure if i'm using it right, but my NPCs just stand there doing nothing. I was looking for something that makes the act like they have a place to be and they're on their way. just looking to populate a town with the illusion of activity. is this built in or no? great plug-in!
  6. /npc path
  7. Offline


    This method seems to only let me make a path of about 16 blocks. not sure if thats a bug or not. i was hoping for a way to just have them path between zones at their leisure and not just like .. . . well . . .bots.
  8. Offline


    So there is no way to get Custom skins unless a player logs in and we use their username or if we use SpoutCraft?
  9. Offline


    Good one. Will try that.
  10. Offline


    I get a Error and i dont know why
    whats wrong ?

    2012-01-21 15:38:07 [WARNING] Task of 'Citizens' generated an exception
        at net.citizensnpcs.traders.TraderTask.run(TraderTask.java:71)
        at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:137)
        at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:502)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:434)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:465)
  11. Offline


    Citizens have to be updated. Anyone know when Citizens for 1.1 will be ready?
  12. Offline


  13. Offline


    Does this work with MC 1.1?
  14. Offline


  15. Offline


  16. Offline


    hey, I've used Citizens for a long time, but with this most recent update, whenever I type /npc create "and then whatever name" it responds with:please report this error: [See console] java.lang.NoSuchMethodError: net.minecraft.server.ItemInWorldManager.a(I)V This only started happening after the newest version for 1.1 any help would be appreciated. Thanks!
  17. Using newest 1.13 citizens with Minecraft 1.1 non-recommended bukkit build.

    Tried to create NPC with /npc create NAME

    2012-01-22 13:36:56 [SEVERE] java.lang.NoSuchMethodError: net.minecraft.server.ItemInWorldManager.a(I)V
    2012-01-22 13:36:56 [SEVERE]at net.citizensnpcs.resources.npclib.CraftNPC.<init>(CraftNPC.java:17)
    2012-01-22 13:36:56 [SEVERE]at net.citizensnpcs.resources.npclib.NPCSpawner.spawnNPC(NPCSpawner.java:75)
    2012-01-22 13:36:56 [SEVERE]at net.citizensnpcs.resources.npclib.NPCManager.register(NPCManager.java:159)
    2012-01-22 13:36:56 [SEVERE]at net.citizensnpcs.resources.npclib.NPCManager.register(NPCManager.java:189)
    2012-01-22 13:36:56 [SEVERE]at net.citizensnpcs.commands.BasicCommands.create(BasicCommands.java:226)
    2012-01-22 13:36:56 [SEVERE]at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    2012-01-22 13:36:56 [SEVERE]at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    2012-01-22 13:36:56 [SEVERE]at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    2012-01-22 13:36:56 [SEVERE]at java.lang.reflect.Method.invoke(Unknown Source)
    2012-01-22 13:36:56 [SEVERE]at net.citizensnpcs.resources.sk89q.CommandsManager.executeMethod(CommandsManager.java:530)
    2012-01-22 13:36:56 [SEVERE]at net.citizensnpcs.resources.sk89q.CommandsManager.execute(CommandsManager.java:407)
    2012-01-22 13:36:56 [SEVERE]at net.citizensnpcs.Citizens.onCommand(Citizens.java:200)
    2012-01-22 13:36:56 [SEVERE]at org.bukkit.command.PluginCommand.execute(PluginCommand.java:40)
    2012-01-22 13:36:56 [SEVERE]at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:168)
    2012-01-22 13:36:56 [SEVERE]at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:386)
    2012-01-22 13:36:56 [SEVERE]at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:777)
    2012-01-22 13:36:56 [SEVERE]at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:737)
    2012-01-22 13:36:56 [SEVERE]at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:725)
    2012-01-22 13:36:56 [SEVERE]at org.getspout.spout.SpoutNetServerHandler.a(SpoutNetServerHandler.java:178)
    2012-01-22 13:36:56 [SEVERE]at net.minecraft.server.Packet3Chat.handle(Packet3Chat.java:33)
    2012-01-22 13:36:56 [SEVERE]at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    2012-01-22 13:36:56 [SEVERE]at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:100)
    2012-01-22 13:36:56 [SEVERE]at org.getspout.spout.SpoutNetServerHandler.a(SpoutNetServerHandler.java:587)
    2012-01-22 13:36:56 [SEVERE]at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
    2012-01-22 13:36:56 [SEVERE]at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:536)
    2012-01-22 13:36:56 [SEVERE]at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:434)
    2012-01-22 13:36:56 [SEVERE]at net.minecraft.server.ThreadServerApplication.run(SourceFile:465)
  18. Offline


    I have two plugins installed. bPermissions and Citizens. When I type "/npc create Fred" it says:
    Please report this error: [See console]
    java.lang.NoSuchMethodError: net.minecraft.server.ItemInWorldManager.a(I)V
    What shall I do? Also, is there some way to change the skin of the npc's? Or do you need a plugin with a database for that?
  19. Offline


    Why it dont work with the newest Bukkit Build and with Minecraft 1.1 ? Only the experimental Build works the stable Build crash all Time!
  20. Offline


    When I try to kill a guard with a bow, after a few shots.
    The server crash...
    A solution ?
  21. Go into the citizens.yml file

        min: 3
        max: 13
      look: 5
      pathfinding: 16.0
    Edit the "pathfinding" number to like 100.0, Then it will let you take the NPC 100 blocks from the original spot before it sends that message.. You could even do like 500.0 If you was going to make them go a long distance!
  22. Offline


    Oh ok cool. I saw that in there but I thought it was a measure of how far off a direct line the npc would go before he gave up path finding.

    So there no AI built in to the default citizens then I take it? Has anyone made a plug in that drops in to give them some AI controlled activity?
  23. Offline


    Why is my npc gone after every restart?
    I'm using 1.1
  24. Offline


    McGarnicle - it serves that purpose as well. There's no AI available (a wander AI is implemented, but not accessible). This will be added in Citizens2.
  25. Offline


    Hmm I'm having a bit of a lasting problem on the server I play on but I can't give you the exact error for it since I don't have access to the server logs atm, it's been happening since 1.0, using citizens 1.3 i'm not sure what bukkit build it is though, I write the quests for my server and if I try to use the reward type: teleport the console gets spammed with some kind of entity movement error, I thought maybe this was just a bug with that reward type and maybe it wasn't fully implemented yet but then I tried having it teleport players using essentials warp commands and not only did the entity movement error come up but a player movement error joined it. Any idea's on what would cause this?

    Love the plugin btw, it's by far my favorite along with MagicSpells(they are wonderful together) The possibilities are endless when you really think about it :) just started setting up a nice quest lineage system(complete one quest to gain access to the next area) through the use of world guard and command quest rewards.
  26. Offline


    wtf howthefuck does this work?? the wiki is the lastcrap i read everything and i cant even bring the npc to follow me. i set it to guard then to bodyguard and i also set the radius, but he doesnt do ANYTHING! WTH
  27. Offline


    when come the 1.1 update???
  28. Offline


    it's not 1.1 compatible...
  29. Offline


    it works perfectly fine on my server with citizens 1.1.3 with bukkit 1744
  30. Offline


    was it updated?
  31. Offline


    fullwall aPunch we need a more in depth how-to for pretty much all the npc types. The wiki sheds no light on any of the guard types. It simply tells you the command structure but gives no examples. And the soldier type has literally no info on how to command it.

Share This Page