[FUN] Citizens v2.0.11 - Human NPCs for Bukkit [1.7.2]

Discussion in 'Archived: Plugin Releases' started by Citizens, Mar 5, 2011.

  1. Offline


    Citizens - Human NPCs for Bukkit
    Version: 2.0.11
    Authors: @fullwall and @aPunch
    Source: Citizens on GitHub

    Citizens is now on BukkitDev

    This thread will no longer be updated. We encourage you to use our page on BukkitDev. You can find information, links to our wiki and website, and the download page there.

    Showing Your Support

    We work hard to maintain Citizens. We've been working on Citizens2 around the clock on new and exciting features. A little motivation never hurts, so feel free to donate to us - fullwall and aPunch.

    If you can't donate, we appreciate a "hello" every now and then. Stop by the IRC channel #citizens on irc.esper.net to discuss Citizens and give thanks!
  2. Offline


    Ignore my old post, it was done and I failed the syntax :p
  3. Offline


    i have a problem on citizens im using citizens 1.1.3 ingame it says "version devBuild-" my craftbukkit is 1.0.1.R1 when i try to use a trader it lets me make it, stock it, and sell items, but the economy is not working with it (im using Wurkit for the money and BOSEconomy) is there something i can do to fix it? i checked the citizens.yml and it says "use-economy: true" if anyone knows whats going on please let me know.
  4. Offline


  5. Offline


    the guards won't work correct. Bodyguards doesn't follow me. I tried "/guard bodyguard" but the NPC stands still. I tried to download an "experimental"-version of citizens from your website. I klicked on guard and experimental and got a 0 byte version of the "guard.jar". On your wiki i found nothing about the soldiers. When i delete a flag, the enemies or player will still be attacked by the guard.
    I use version 1.1.3
  6. Offline


    Mai I also make an suggestion?
    would it be possible to make an quest give xp since we are in 1.0.1 and need xp to start?
    sol ike u need to be lvl 6 to start a certain quest?
    and will be able to gain lvls after?
  7. Offline


    when I try to use /toggle "trader" or any toggle like it, it says "Invalid NPC type" what should I do. when i open my Citizens file theres an empty floder thats named "types" does that have anything to do with it? HELP!
  8. Offline


    I got the same thing whenever i try to make an npc
  9. Offline


    The types folder has separate .jar's that go in it. You need to download the full citizens zip file and not just the .jar.
  10. Offline


    It seems like more than a few people are getting errors involving Packet17EntityLocation.
    Citizens 1.1.3 requires the 1.0 CraftBukkit Recommended Build - without it, these errors occur.
  11. Offline


    Hello guys! In my confing file I have: talk-when-close: 'true' but the npcs still not talking when i get close, why?
  12. Offline


    Done, sorry!
  13. Offline


    I have a little request regarding quests requiring quests:

    At the moment, the quest will show up and give you an error when you didn't complete the requirement yet.
    What I would like is that the quest is invisible (showing only available quests or saying no quests are available) until you can actually start it.
    This would also be nice if people don't meet a rank requirement (meaning I can put up a rank for quest testing and only those people are able to see the quests and test them)

    Another request: It would be nice to have some kind of indication if a quester NPC has a quest for you. I know that it's probably not possible to add an icon above their head, but maybe change the name color dynamically if that is possible.
    To be clear: I don't mean having all quester npcs having another color, but only if they have a quest for a certain player it shows another color for him.
  14. Offline


    Hi, i have a problem with the traders. I add all permissions, admins can trade with traders but normal users cant. This is my permissions:
    - citizens.trader.use.help
    - citizens.trader.use.list
    - citizens.trader.use.trade
    - citizens.trader.modify.stock
    - citizens.trader.use.trade.*
    - citizens.use.trader
    - citizens.modify.trader
    Plz, help me :D
  15. Offline


    Another request for quests:

    I am currently making a quest that uses teleportation to get to other parts of the quests, but when people die past a point they can't get back.
    A workaround is add an optional objective to each other objective to talk to the begin NPC who will then teleport you again.
    This works, until people die on the same objective twice (in which case the optional is completed already)

    A nice feature would be objectives that never complete or maybe another system to dynamically teleport the player depending on their quest progress.
  16. Offline


    I have the same problem like Mystyk
  17. Offline


    can someone help me, when I try to use /toggle (for instance blacksmith) it says it an invalid npc type. what do i do?
    theres an empty folder thats called types do i have to add something to it???
  18. Offline


    I've had this working before but now I can't seem to get it working, my guards are able to attack other players but the players can't fight back, I have nothing on my server preventing pvp or pve and no one is in creative mode. Any ideas anyone? I'm using the recommended build of bukkit and the devBuild- of citizens
  19. Offline


    The types folder has separate .jar's that go in it. You need to download the full citizens zip file and not just the .jar.
  20. Offline


    I need help please. I've set everything up correctly, flags and all but the guard/bouncer doesn't attack players.

            priority: '1'
            safe: 'false'
            type: PLAYER
        toggle: 'true'
        aggressive: 'true'
        radius: '10.0'
        type: BOUNCER
        talk: 'true'
        name: Bandit_Leader
        location: DC,-7.375,69.0,1041.625,274.95523,26.85017
        color: '12'
        owner: Tohclan
        balance: '0.0'
        text: Hand over your money and die fool!
        inventory: 267/1/0,AIR*35,
        talk-when-close: 'true'
        items: 267:0,298:0,299:0,300:0,301:0,
        look-when-close: 'false'
    I would also like to mention I google'd and searched the citizens wiki for help on this but nothing explains it proper.
  21. Offline


    help i got
    : *ALERT*(in green) A new version of citizens is availeble! The later version is (in yellow) devBUILD-devBuild and if i do /npc create bob its says: Please report this error: [See console] java.lang.noClassDefFoundError
    ­: net/.minecraft/server.packet17
  22. Offline


    How come all my ranks can make citizens even though they dont have the permissions.
    PS: Also I use GroupManager(Essentials)
  23. Offline


    How can I disable the /t completely? Is it possible? Its mighty annoying. Overrides the tell cmd. And our players need tell more than /toggle ^^"
  24. Problems here (just because I do'nt figure out how to do it reading the prject pages ...
    1. I want a guard to attack all hostile npc mobs ... I do this:
    A: create the npc
    B: toggle it to guard
    C: /guard addflag -m
    It tells me "no name given".. what does it mean ? I tried: /guard addflag 1 -m (as 1 is the guard's ID) but doesn't work
  25. Offline


    did you also toggle it as a bouncer?
    /guard bouncer
    as for attacking mobs you can do
    /guard af -am
    the guard will attack all mobs including cows and sheep

    if you want to add just the hostile mobs, you need to include the name:

    /guard af creeper -m
    /guard af spider -m
    /guard af skeleton -m
    /guard af zombie -m
  26. That works :) THANKS
    One more followup question! How do I make a guard patrol a predefined path ?
  27. Offline


    /npc path
    then left click the ground to add pathways, just make sure the points arent too far apart
    after youre done do /npc path again
  28. EDIT: Ok the numbers don't change anything :( I used /npc lookat and then made him turn by moving exactly like I wanted my guard to stand, then did /npc lookat again and he was indeed immobile and exactly perfect .... that was until I disconnected and reconnected and bam hes crooked again :(
    Thanks, hmm last 30 minutes ive been battling to get my body faced corrently :( no matter what I do my guards seem to have a diagonal body when placed :(
    There head goes perfect to where i watch but the body doesn't :(
    I have been altering the config files manually hoping to find the sweet numbers but whatever
    number I am trying I never get the body straight :(
    Does anyone have the numbers toget straight "North, South, West & East" bodies ?
    With numbers I mean like this:
    location: myworld,65.48886178656024,33.0,-415.94390002052006,-179.4141,-3.4500105
    I figured it's only the last 2 numbers that are important (I'm guessing the first three are XYZ) but no matter what I do they always stand crooked :(
    I have a problem with /npc path... it seems to work fine the first 3 or so points i place but from there on it starts giving me "waypoints need to be withing 16 blocks" or something .. now that wouldn't be a problem if it actually worked cause at waypoint 4 or 5 EVERYTHING is not "within 16 blocks" for some reason, even if it's only 2 blocks further from the last waypoint ...
    Question 2 EDIT
    k, I fixed it by changing this value in the settings:
    pathfinding: 500.0 (was 16)
    Does this affect performance for some reason ? it allows me to create my full path ...
  29. Offline


    Thanks very much man! -_- -_- -_- I didnt get them because in the Winrar file I only dragged the .jar! sorry for wasting your time.
  30. Offline


    Any help with this one?

    2012-01-09 03:37:20 [WARNING] Task of 'Citizens' generated an exception
    java.lang.IllegalArgumentException: Cannot measure distance between worlds or to null
    at org.bukkit.Location.distance(Location.java:364)
    at net.citizensnpcs.resources.npclib.PathNPC.distance(PathNPC.java:95)
    at net.citizensnpcs.resources.npclib.PathNPC.updateTarget(PathNPC.java:325)
    at net.citizensnpcs.resources.npclib.PathNPC.moveTick(PathNPC.java:206)
    at net.citizensnpcs.resources.npclib.HumanNPC.doTick(HumanNPC.java:84)
    at net.citizensnpcs.TickTask.run(TickTask.java:31)
    at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:137)
    at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:493)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:425)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:457)
    Something about distance between worlds. Citizens supports multiworlds. I can never seem to narrow down what is causing this as it happens completely randomly. It causes every citizens to stop functioning completely and just stand there idle until a server restart
  31. Offline


    @gummby8 - it looks like a guard is targeting a player that then moves world.

Share This Page