[FUN] Citizens v2.0.11 - Human NPCs for Bukkit [1.7.2]

Discussion in 'Archived: Plugin Releases' started by Citizens, Mar 5, 2011.

  1. Offline


    Citizens - Human NPCs for Bukkit
    Version: 2.0.11
    Authors: @fullwall and @aPunch
    Source: Citizens on GitHub

    Citizens is now on BukkitDev

    This thread will no longer be updated. We encourage you to use our page on BukkitDev. You can find information, links to our wiki and website, and the download page there.

    Showing Your Support

    We work hard to maintain Citizens. We've been working on Citizens2 around the clock on new and exciting features. A little motivation never hurts, so feel free to donate to us - fullwall and aPunch.

    If you can't donate, we appreciate a "hello" every now and then. Stop by the IRC channel #citizens on irc.esper.net to discuss Citizens and give thanks!
  2. Offline


    I was looking for long time some post about slowing my problem, but could not find it.
    Quests are written correctly, I do it in "QuestWriter" for citizens, and seems all are working fine, but when I come back to finish quest and take reward, I don't get items rewards, only money reward.
    What should I do to get it work correctly?

    Here is example of the quest, console of bukkit doesn't shows any errors.
            description: "Massage 1"
            completion: "Massage 2"
            acceptance: "Massage 3"
        repeats: 2
                    type: destroy block
                    materialid: 89
                    amount: 20
                    optional: False
                    finishhere: False
                    message: "Massage 4"
                type: money
                money: 120
                type: item
                id: 378
                amount: 1
                take: True
  3. Offline


    Problem: I've got Permission Ex, Citizens and Who are you...

    Everytime i do "who" or "list" ... It shows the NPC's as a guest. Thats cruel.
    I tried to create an "NPC" Rank in PermissionEx, gave this to the NPC Names... but there are always Guests ...
    Can i fix this somehow?
  4. Offline



    I'm having the problem where items I equip to NPCs are not being worn/equipped. It takes it from my inv.

    I cannot see any errors in the log or consol.

    Is there any way to get guard/bouncers to go back to their exact original place after they attack a mob?

    I find that they just tend to stay where they are once the mob has been killed.
  5. Offline


    Can anyone tell me whats wrong with this quest? It doesn't complete once i gather the objectives...
    Thing ive tried:
    - First i spawned the items to test the quest.
    - I collected the items without spawning.
    - Another marerialid.
    The quest status doesn't even count the items i have in the inventory...
    EDIT: I use QuestWriter.

    "Melon affinity":
            description: "Want to earn money? Well there is a food shortage in the Castle so i need men to farm me 300 melon slices. They'll be rewarded greatly!"
            completion: "Quest completed! Go get your reward."
            acceptance: "Quest accepted."
        repeats: -1
                    type: collect
                    materialid: 296
                    amount: 300
                    optional: False
                    finishhere: True
                    message: "Good job! That will keep food stocks filled for another month. Here is your reward."
                type: money
                money: 150
                type: item
                id: 357
                amount: 10
                take: True
  6. Offline


    Make it so that normal players can trade too
  7. Offline


    Thx for reminding me of this... but i still can't check if the completion works with the quest status not working correctly.
    It rarely counts the melons. It counted 3 out of 20 of the plucked melons.
    EDIT: Does completing quests even work with spawned items?
  8. Offline


    errrr.... help?

    16:21:41 [SEVERE] java.lang.NoClassDefFoundError: net/minecraft/server/Packet17

    Sorry for the trouble... i'm new to bukkit
  9. Offline


    may i ask?
    -does it conflict with mods?
    because since i installed it it crashes my server
    mods installed:
    :D what a list.
    but server was running good without citizens
    couldnt find any errors though.
  10. Offline


    You set take to "True"
    This means the NPC is going to "Take" that item from you
    If you want the quest to "Give" the player that item, this needs to be false
  11. Offline


    The amount needs to be <= One stack, I don't so the most it could ever be for any 1 item is 64
    your take is also set to true so it is going to remove qty 10 of item 357 from the player inve, if you want to give this, take needs to be false
  12. Offline


    @Sp1tz - note that you need to break 300 melons to complete this quest due to collect quest's current exploit protection (this is obviously irritating, so I've removed the protection in recent versions). Have you considered perhaps a delivery quest?
  13. Offline


    Thanks for the heads up guys.

    It is totally the point breaking 300 Melons... got pro farmers on my server xD

    I tested the Delivery option but i couldn't pick a NPC with QuestWriter so i added it manually but then Citizens wouldn't read that quest whenever i restart the server, i would get an "is it up to date?" error...

    So its 64 instead 300?
  14. Offline


    @Spl1tz - no, 300 should work.
  15. We are having problems getting guards to work. Both Bouncers, soldiers and bodyguards... non of them work probably . they wont move or will almost never attack what they are flagged to attack
  16. Offline


    How do you make guards follow you?
  17. Offline


    Flagged to attack what?
    If you want them to attack players "guard addflag -a" will work, but they literaly attack anything with the exception of the owner

    "/guard addflag -g default" will get thtem to attack anyone with the default permission (you need to be using permisions) I use the following to make NPC mobs inside our dungeons

    /toggle guard
    /guard bouncer
    /guard aggro
    /guard addflag -g default
    /guard radius 30 (I want them to chase you for quite a while)
  18. Offline


    Thank you!
    It's working now correctly!

    But I have another simple question for you dear developers of citizens!
    Is it possible to change somehow that players can't skip quests?
    Because when player clicks:
    1st RMB: He select npc
    2nd RMB: He reads quest description
    And he can skip 1st quest by clicking LMB to second quest!
    If its possible somehow to lock that for players I'd be glad to know how.

  19. My players can't start a quest with 2 repeats if somebody already completed it 2 times. Is that normal or should each player be able to complete the quest 2 times with those settings?
  20. Offline


    Wich economy plugin support the traders?
  21. Offline


    If I place the following command:

    /npc create Test Hello

    I get this
     java.lang.NoClassDefFoundError: net/minecraft/server/Packet17EntityLocationAction
    23:29:55 [SCHWERWIEGEND] java.lang.NoClassDefFoundError: net/minecraft/server/Packet17EntityLocationAction
    23:29:55 [SCHWERWIEGEND]        at net.citizensnpcs.resources.npclib.PathNPC.<init>(PathNPC.java:31)
    23:29:55 [SCHWERWIEGEND]        at net.citizensnpcs.resources.npclib.PathNPC.<init>(PathNPC.java:51)
    23:29:55 [SCHWERWIEGEND]        at net.citizensnpcs.resources.npclib.CraftNPC.<init>(CraftNPC.java:16)
    23:29:55 [SCHWERWIEGEND]        at net.citizensnpcs.resources.npclib.NPCSpawner.spawnNPC(NPCSpawner.java:75)
    23:29:55 [SCHWERWIEGEND]        at net.citizensnpcs.resources.npclib.NPCManager.register(NPCManager.java:159)
    23:29:55 [SCHWERWIEGEND]        at net.citizensnpcs.resources.npclib.NPCManager.register(NPCManager.java:189)
    23:29:55 [SCHWERWIEGEND]        at net.citizensnpcs.commands.BasicCommands.create(BasicCommands.java:226)
    23:29:55 [SCHWERWIEGEND]        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    23:29:55 [SCHWERWIEGEND]        at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    23:29:55 [SCHWERWIEGEND]        at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    23:29:55 [SCHWERWIEGEND]        at java.lang.reflect.Method.invoke(Unknown Source)
    23:29:55 [SCHWERWIEGEND]        at net.citizensnpcs.resources.sk89q.CommandsManager.executeMethod(CommandsManager.java:5
    23:29:55 [SCHWERWIEGEND]        at net.citizensnpcs.resources.sk89q.CommandsManager.execute(CommandsManager.java:407)
    23:29:55 [SCHWERWIEGEND]        at net.citizensnpcs.Citizens.onCommand(Citizens.java:200)
    23:29:55 [SCHWERWIEGEND]        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:40)
    23:29:55 [SCHWERWIEGEND]        at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:163)
    23:29:55 [SCHWERWIEGEND]        at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:364)
    23:29:55 [SCHWERWIEGEND]        at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:756)
    23:29:55 [SCHWERWIEGEND]        at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:721)
    23:29:55 [SCHWERWIEGEND]        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:714)
    23:29:55 [SCHWERWIEGEND]        at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
    23:29:55 [SCHWERWIEGEND]        at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    23:29:55 [SCHWERWIEGEND]        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:92)
    23:29:55 [SCHWERWIEGEND]        at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
    23:29:55 [SCHWERWIEGEND]        at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:516)
    23:29:55 [SCHWERWIEGEND]        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:414)
    23:29:55 [SCHWERWIEGEND]        at net.minecraft.server.ThreadServerApplication.run(SourceFile:457)
    23:29:55 [SCHWERWIEGEND] Caused by: java.lang.ClassNotFoundException: net.minecraft.server.Packet17EntityLocationAction
    23:29:55 [SCHWERWIEGEND]        at java.net.URLClassLoader$1.run(Unknown Source)
    23:29:55 [SCHWERWIEGEND]        at java.security.AccessController.doPrivileged(Native Method)
    23:29:55 [SCHWERWIEGEND]        at java.net.URLClassLoader.findClass(Unknown Source)
    23:29:55 [SCHWERWIEGEND]        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:36)
    23:29:55 [SCHWERWIEGEND]        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:24)
    23:29:55 [SCHWERWIEGEND]        at java.lang.ClassLoader.loadClass(Unknown Source)
    23:29:55 [SCHWERWIEGEND]        at java.lang.ClassLoader.loadClass(Unknown Source)
    23:29:55 [SCHWERWIEGEND]        ... 27 more
    + many other lines but I guess this is the major point.

    What did I wrong here ?
  22. Offline


    Alright, so everything on the wiki is completely outdated for this it seems. The trader no longer has the money command, rather it's been changed to /npc money (and no indication of this on the wiki). Furthermore, I cannot seem to find the permission to give a user to use the /npc money command. Would the developers mind sharing the the rest of the permission nodes with the rest of us?
  23. Offline


    "Test Hello" is the NPC name
    use "Test/Hello" and his name ingame is "Test Hello"
    if u wont the name "Hello" than /npc create Hello
    nothing else
  24. Offline


    give the second quest as a reward for the first one have no NPC offer the second quest.
    FYI doing this only shows the quest acceptance dialog as it auto accepts there is no quest description dialog
  25. Offline


    Thank you, but this is not fixing my Problem with the Error Messages I got my starting the Server and trying create a NPC

    23:29:55 [SCHWERWIEGEND] java.lang.NoClassDefFoundError: net/minecraft/server/Packet17EntityLocationAction
    madmunky1 likes this.
  26. Offline


    @phelanvz - you need to run CraftBukkit 1.0
  27. We have tried to flag to everything. All mobs, specifik mobs, all players, specifik players, and groups.
    We dont have any problems spawning the NPC, naming it or flagging for it.

    But set it to atk spiders and spawn a spider next to it and it wont move! like i posted before, they wont move.
    Set the NPC to bodyguard should have it move with the player but he will stand still.

  28. Offline


    Hello Fullwall,
    I run
    with following Start.bat

    @Echo  off
    "%ProgramFiles(x86)%\Java\jre6\bin\java.exe" -Xms1024M -Xmx1024M -jar craftbukkit-1.0.0-SNAPSHOT.jar
  29. Offline


    @phelanvz - you should use the recommended build.
  30. Offline


    Ahhhhh okay
    recommended is 1.0.1 RB
    I found 1.0.1-R1 I will give it a try.....may I´m to old for those things :-(
  31. Offline


    it works !!!
    Thank you but i had to create all my worlds again but this was no problem no datas was lost

Share This Page