[FUN] Citizens v2.0.11 - Human NPCs for Bukkit [1.7.2]

Discussion in 'Archived: Plugin Releases' started by Citizens, Mar 5, 2011.

  1. Offline


    Citizens - Human NPCs for Bukkit
    Version: 2.0.11
    Authors: @fullwall and @aPunch
    Source: Citizens on GitHub

    Citizens is now on BukkitDev

    This thread will no longer be updated. We encourage you to use our page on BukkitDev. You can find information, links to our wiki and website, and the download page there.

    Showing Your Support

    We work hard to maintain Citizens. We've been working on Citizens2 around the clock on new and exciting features. A little motivation never hurts, so feel free to donate to us - fullwall and aPunch.

    If you can't donate, we appreciate a "hello" every now and then. Stop by the IRC channel #citizens on irc.esper.net to discuss Citizens and give thanks!
  2. I dont have any type jars.....
  3. Offline


  4. Offline


    Sorry i posted part of this, and then updated then posted the rest my bad, this is how the real one is and i type /quester assign Quest1
    and still get the same problem
  5. Offline


    @Squishyman - the '0': type:item part should be under rewards:
  6. Offline


    Thanks ill try it out!
  7. My guards are bouncer they attack mobs but they dont go back to their original spot that they were before they went to attack is there any way to make them go back to their main point? also i cant use paths for guards
  8. Offline


    I have a question. Everytime when i try to create an NPC i become a error message:
    09:41:01 [SEVERE] java.lang.NoSuchMethodError: net.minecraft.server.ItemInWorldManager.<init>(Lnet/minecraft/server/WorldServer;)V

    What i can do to fix that?

    please help!!!
  9. Offline


    If you're getting NoSuchMethodError, you're using the wrong version of CraftBukkit for your Citizens version. 1.1.1 only works with #1185, 1.1.2 only works with #1240 and above.
    @Aufbahrung - which version of CraftBukkit are you using?
  10. Offline


    Thanks for your fast answer.

    I am using Craftbukkit 1317.

    I update to 1240
  11. Offline


    so than means Pex .15 is working for NPC creation?
    and what file did you mean? becuase for me its not working
  12. Offline


    how to make NPC take item at the end of quest?
  13. Offline



    also when i start my server and when i log in they say it exist a newer devbuild...but i downloadet that one from your Jenkins site.
    why is that happend?
  14. Offline


    i have another problem....
    not i started to setting up some quests. The quests are working but when i type "/quest status" i cont an console error but that error dont effect anything so i just can complet the quest anywhy
    here the full error
  15. Offline


    can i get a copy of the quests.yml with the example quests in it? mine was blank :( or maybe someone teach me the format of the quests? like how to write them?
  16. Offline


    Sure, its not a hard thing to do.. It would take you probably 5 munutes to make this command.. And I don't belive it would take longer.
  17. repost, How do i make my guards use paths i make the path but they just stand there, also sometimes ill finish setting up a guard with all his flags ill spawn a zombie but he wont it attack it?
  18. Offline


    here an exaple of a working querst where you need to run to another NPC to finish it!
  19. Offline


    Hello, since the 1.1.2 version of Citizens, I can't create any NPC
    The version of the server is 1.8.1
    When I try to do /npc create "name" I have :

    java.lang.NoSuchMethodError: net.minecraft.server.ItemInWorldManager.<init>(Lnet/minecraft/server/WorldServer;)V 

    Thanks for help. :(
  20. I think i found an error for guards. This only happens to some guards when created but it happens to about 80% on my server.
    1.Create npc
    2. toggle guard
    3. guard bouncer
    4. addflags zombie, skeleton, creeper, spider

    when i spawn a spider or zombie or any other flagged mobs next to the guard it just stands there doing nothing. Although if i just add 1 flag like zombie it will work but if i add another like skeleton it stops attacking again...
  21. Offline


    I haven't really messed with guards, have you tried listing them without commas? Just leave spaces and see how that works.
  22. Offline


    Not update for 1.8.1
    1-10-23 15:45:49 [WARNING] Task of 'Citizens' generated an exception
    java.lang.NoSuchMethodError: net.minecraft.server.ItemInWorldManager.<init>(Lnet/minecraft/server/WorldServer;)V
    at net.citizensnpcs.resources.npclib.NPCSpawner.spawnNPC(NPCSpawner.java:31)
    at net.citizensnpcs.resources.npclib.NPCManager.register(NPCManager.java:164)
    at net.citizensnpcs.Citizens.setupNPCs(Citizens.java:290)
    at net.citizensnpcs.Citizens.access$000(Citizens.java:63)
    at net.citizensnpcs.Citizens$2.run(Citizens.java:137)
    at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:137)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:439)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:374)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
  23. Offline


    You need Craftbukkit #1240 i think
    with one above its some bug with the Permission System.
  24. Offline


    Hey Citizens Team,

    Is there any chance in making a in-game quest creator like a very old plugin "Craftizens" on hMod?
  25. I am just getting so many errors today one to just blurt out guard cant use paths soooo idk about that one but here the real issue this JUST started when making a new trader
    toggle trader
    /trader buy COBBLESTONE 10 3
    Trader is now buying 1 cobblestone for $3.....
  26. Offline


    Strangely somehow, now I can't equip NPC because nothing happens when I give them
    any items and the server glitches when I type /npc equip.

    Plus it will be cooler if you use the gold nuggets rather then using economy plugins like iconomy for the money system when it comes to 1.9
  27. Offline


    my bodyguard will not attack help!!?
  28. Offline


    Thanks, I tried yesterday and that runs. But now it's my Permissions 3.1.6 plugin which abandonned me ! :(
  29. Offline


    @Kaaji - Citizens doesn't support Permissions 3.x
  30. Offline


    Hello, i've been trying to work with this plugin for a few days now, and i can't seem to use it at all.
    I was using Permissions 3.x (fully configured) and tryed adding all the nodes, while being op = You don't have permissions blablla
    Then i installed PEX (i fully configured too), i tried adding the nodes citizens.admin, citizens.*, citizens.admin*, and then all the nodes, while being op = same results
    After that i tried bPermissions (i also took the time to fully configure it) = same results
    Since nothing worked, i removed all my permissions plugins, and while being an op i used /npc create and finally it poped something diferent than the permissions problem, this time a ErrorMethod something...

    Could someone help me? It's really frustrating i don't think im doing anything wrong...
    Thanks for you guidance in advance
  31. Hello
    This is a very good plugin but when I tried to add a new quest to an NPC I got this error (and said report it): View attachment 7172
    my quests.yml:
    description: A fetch quest
    completion: <g>You win! Give me that stone.
    acceptance: <g>Challenge <y>accepted<g>.
    repeats: 1
    type: collect
    materialid: 1
    amount: 3
    message: A voice echoes... "I want that stone now!"
    type: item
    id: 1
    amount: 3
    take: true
    but the same error with any of quest types
    I hope it'll fixed before halloween :D

Share This Page