[FUN] Citizens v2.0.11 - Human NPCs for Bukkit [1.7.2]

Discussion in 'Archived: Plugin Releases' started by Citizens, Mar 5, 2011.

  1. Offline


    Citizens - Human NPCs for Bukkit
    Version: 2.0.11
    Authors: @fullwall and @aPunch
    Source: Citizens on GitHub

    Citizens is now on BukkitDev

    This thread will no longer be updated. We encourage you to use our page on BukkitDev. You can find information, links to our wiki and website, and the download page there.

    Showing Your Support

    We work hard to maintain Citizens. We've been working on Citizens2 around the clock on new and exciting features. A little motivation never hurts, so feel free to donate to us - fullwall and aPunch.

    If you can't donate, we appreciate a "hello" every now and then. Stop by the IRC channel #citizens on irc.esper.net to discuss Citizens and give thanks!
  2. Offline


    Would you like a buggy update then?
  3. Offline


  4. Offline


    You can continue to use other plugins using the SuperPerms Bridge plugin, fooling those "permissions only" plugins into thinking you have Permissions 2.7.x installed. It translates the superperms permissions into current 2.7.x permissions so that you don't have to redo everything.

    Having the devs write in support for permissions 3.x, 2.x, groupmanager, and superperms, is going to do nothing but slow development for all plugins. A standard method alleviates this roadblock.
    Daxiongmao87 and jesse1212 like this.
  5. Offline


    Is it normal that when I make let's say 4 npcs named Knight and I save citizens, then close the server and restart it, all knights stand on exactly the same spot? Isn't that what the ID's are for ?
  6. Offline


    is there anyway to hide the npcs name?
  7. Offline


    This is currently under development on the CitizenSpout plugin. There are still a few bugs from the latest update but it's relatively stable.

    @element If you were using the copy command it fails to save the npcs new location upon execution..this will be fixed in 1.1 and for now..I recommend you follow the command with -/npc move :D
  8. Offline


    With the 1.1 Citizens update, Permissions 2.7/3.x support will be removed. You must now use PermissionsBukkit or any plugin that utilizes superperms (SuperPermsBridge helps ease the transition between the old and new perms systems). This change was made in the hopes that it forces many server admins to switch to the future (i.e. superperms). Sorry for any inconvenience that this causes, but we strongly believe that is for the best.

    Just want to throw my 2 cents, and say I don't really understand why you're doing this. There are plugins out there that support both permissions systems, and both permissions systems do work together. The old Permissions plugin will probably still be around for a long time, because although its annoying it does work better.. Multigroup, groups in general and inheritance all work a lot better than on the Bukkit version.

    You have the code already, so why remove it? Just build on it to support the Bukkit one too, it doesn't hurt... forcing players to change would surely just lose you downloads? I'd still get it, but I wouldn't really be happy about having to reconfigure all my permissions for this plugin when I don't really need to...
    Arton likes this.
  9. Offline


    Yea me to then it's just better to use sign shops or something els alot of peopels got a big load of permissions
  10. Offline


            default-bouncer-protection-radius: '5'
            pathfinding: '16'
            look: '5'
            '30': Cobweb
            '35': Cloth
        item-list-on: 'true'
            select-items: '*'
            talk-items: 340,
            give-health-item: '35'
            take-health-item: '276'
            mana-regen-item: '348'
            interact-item: '288'
            respawn-delay: '100'
            health-regen-increment: '12000'
            mana-regen-rate: '6000'
            save-often: 'true'
            use-task: 'true'
            delay: '72000'
            max-stationary: '25'
            max-pathing: '-1'
            right-click-pause: '70'
            delay: '1'
            npcs-per-player: '10'
            enable-following: 'true'
            talk-when-close: 'false'
        convert-old: 'false'
            pay-for-heal: 'true'
            regen-health: 'true'
        debug-mode: 'false'
            use-npc-colours: 'true'
            npc-colour: f
            max-mana: '100'
            regen-mana: 'true'
            wizard-max-locations: '10'
            selection-message: <g>You selected <y><npc><g> (ID <y><npcid><g>).
            slashes-to-spaces: 'true'
            default-text: Hello.;How are you today?;Having a nice day?;Good weather today.;Stop hitting me!;I'm bored.;
            creation-message: <g>The NPC <y><npc><g> was born!
            format: '[%name%]: '
            quick-select: 'false'
        notify-updates: true
        use-bukkit-permissions: false
    I'm trying to get to 1.0.9d from 1.0.9c. Ugh!
  11. Offline


    What if I want to make a little forest, with npc monsters only in it, would it be possible to set area to spawn for each type of NPC Mobs ?
  12. Offline


    Remove those single quotes, see my post on the last page, there are two places in that yml you need to keep them, all the rest need to be removed.
  13. Offline


    nevermind... i think the latest dev. build fixed the problem... lemme check
    EDIT: the latest dev build fixes the problem... thanks for offering the help though!!!
    ...actually.... i still need a little help...hehe i cant join my own server, i keep getting an error that has nothing to do with citizens..strange...
  14. Offline


    thanks ^^
  15. Offline


    Link's are broken
  16. Offline


    Also, where can I find a proper list of commands and how-to etc? I tried the wiki and it seems to be missing a lot of information. For example, with waypoints, there seems to be an option for special waypoints (/waypoint modifier [type] - but nowhere to see what I can put in the type box.

    Another example... how do I buy from a trader? I've created one that sells stone pickaxes and should have an unlimited supply, but when I right click it just gives me the option to stock him...

    Help would be greatly appreciated - this plugin has come a long way since I removed it (due to lag a while back - which has also been fixed) and I want to get to using it properly.
  17. Offline


    Thank you for this info, I will look more into the superperms bridge plugin.
  18. Offline


    Sorry if I'm breaking off from the topic of the current conversation, but is there any way to make a guard npc attack a player on sight (Add it to its blacklist maybe)?
  19. Offline


    Okay, I want to thank all who have helpedm e set up Citizens, especially the ones who suggested I remove the " ' " symbles from my configs. However, I'm now running into an error and a bug.
    Posted above my comments is a link to my image gallery on imgur containing images corresponding to these problems.
    The error involves loading NPCs. I have 127 npcs yet only 11 of them loaded do to this error:
    18:08:10 [WARNING] Task of 'Citizens' generated an exception
    java.lang.ArrayIndexOutOfBoundsException: 1
            at com.citizens.utils.LocationUtils.loadLocation(LocationUtils.java:64)
            at com.citizens.properties.properties.BasicProperties.getWaypoints(Basic
            at com.citizens.properties.properties.BasicProperties.loadState(BasicPro
            at com.citizens.properties.PropertyManager.load(PropertyManager.java:51)
            at com.citizens.npcs.NPCManager.register(NPCManager.java:64)
            at com.citizens.Citizens.setupNPCs(Citizens.java:305)
            at com.citizens.Citizens.access$0(Citizens.java:286)
            at com.citizens.Citizens$1.run(Citizens.java:120)
            at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbeat(C
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:428)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:363)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    This error lead me to believe the Citizens load NPC function had a problem reading the NPC-Profiles file. After investigating I found that I could not select NPCs above ID 11, I then looked in the NPC-Profiles.yml and saw that NPC-id: 12 was the first NPC with waypoints. If you look back at the error you'll see that this is apparent. I'll include NPC 12's section of NPC-profiles.yml:
                    location: MMOMinecraft,-838.0,67.0,648.0,0.0,0.0
                    delay: '0'
                    location: MMOMinecraft,-840.0,67.0,661.0,0.0,0.0
                    delay: '0'
                    location: MMOMinecraft,-838.0,67.0,661.0,0.0,0.0
                    delay: '0'
                    location: MMOMinecraft,-842.0,67.0,664.0,0.0,0.0
                    delay: '0'
                    delay: '0'
                    location: MMOMinecraft,-840.0,67.0,663.0,0.0,0.0
                    delay: '0'
                    location: MMOMinecraft,-742.0,80.0,653.0,0.0,0.0
                    delay: '0'
                    delay: '0'
                    location: MMOMinecraft,-834.0,67.0,672.0,0.0,0.0
                    location: MMOMinecraft,-842.0,67.0,669.0,0.0,0.0
                    delay: '0'
                    location: MMOMinecraft,-830.0,67.0,658.0,0.0,0.0
                    location: MMOMinecraft,-830.0,67.0,668.0,0.0,0.0
                    delay: '0'
                    location: MMOMinecraft,-830.0,67.0,636.0,0.0,0.0
                    location: MMOMinecraft,-838.0,67.0,636.0,0.0,0.0
                    delay: '0'
                    location: MMOMinecraft,-828.0,67.0,642.0,0.0,0.0
                    delay: '0'
                    delay: '0'
                    location: MMOMinecraft,-823.0,67.0,649.0,0.0,0.0
                    location: MMOMinecraft,-821.0,67.0,653.0,0.0,0.0
                    delay: '0'
                    delay: '0'
                    location: MMOMinecraft,-811.0,68.0,653.0,0.0,0.0
                    delay: '0'
                    location: MMOMinecraft,-806.0,68.0,653.0,0.0,0.0
                    delay: '0'
                    location: MMOMinecraft,-800.0,68.0,653.0,0.0,0.0
                    location: MMOMinecraft,-793.0,70.0,653.0,0.0,0.0
                    delay: '0'
                    location: MMOMinecraft,-785.0,71.0,653.0,0.0,0.0
                    delay: '0'
                    location: MMOMinecraft,-776.0,80.0,655.0,0.0,0.0
                    delay: '0'
                    location: MMOMinecraft,-764.0,80.0,655.0,0.0,0.0
                    delay: '0'
                    location: MMOMinecraft,-825.0,68.0,662.0,0.0,0.0
                    delay: '0'
                    delay: '0'
                    location: MMOMinecraft,-756.0,80.0,655.0,0.0,0.0
                    location: MMOMinecraft,-746.0,80.0,655.0,0.0,0.0
                    location: MMOMinecraft,-801.0,68.0,659.0,0.0,0.0
                    delay: '0'
                    delay: '0'
                    location: MMOMinecraft,-781.0,75.0,653.0,0.0,0.0
                    location: MMOMinecraft,-804.0,68.0,655.0,0.0,0.0
                    delay: '0'
                    location: MMOMinecraft,-797.0,68.0,655.0,0.0,0.0
                    delay: '0'
                    location: MMOMinecraft,-763.0,80.0,653.0,0.0,0.0
                    delay: '0'
                    location: MMOMinecraft,-776.0,80.0,653.0,0.0,0.0
                    delay: '0'
                    location: MMOMinecraft,-812.0,68.0,662.0,0.0,0.0
                    delay: '0'
                    location: MMOMinecraft,-805.0,68.0,661.0,0.0,0.0
                    delay: '0'
            talk-when-close: 'true'
            look-when-close: 'true'
            location: MMOMinecraft,-737.4708241593848,81.0,655.699999988079,49.41948,0.0
            owner: henryjacobs
            name: Tree
            color: '15'
            items: 260,0,0,0,0,
            inventory: 260/1/0,AIR*35,
            text: MOVE;Wonder if they accept stolen credit cards... ermm;Got to move those organs..;
    I'm also quite sure that if I removed him from NPC-Profiles.yml I would also have the same error with another NPC as most of my NPC's past id 11 have waypoints. I'd also like to note that NPC 12 is visable in the world but still cannot be selected with right clicking or using the command (http://imgur.com/QxWDo). In addition NPCs past id 12 are not visable nor selectable. It's very wierd and I'd appreciate some help.
    My second problem is a bug with iConomy and Citizens. See the imgur gallery at the top of this post to gain further insight. Essentially I have econplugin and economy set to true and Citizens even initalizes with iConomy:
        use-econplugin: true
        use-economy: true
    18:08:04 [INFO] [Citizens] Loaded 0 quests.
    18:08:04 [INFO] [Citizens] Permissions enabled.
    18:08:04 [INFO] [Citizens] version [1.0.9d] (Odyssey) loaded
    18:08:04 [INFO] [Citizens] Payment method found (iConomy version: 5)
    Yet when I go to create an NPC or use any features of Citizens relating to my iConomy plugin (version 5) I still am asked to pay in the economy currency (flowers). Another bug which confuses me a whole lot :\.
    Anyway I'd appreciate some help from anyone! Thank you much!
  20. Offline


    @fullwall and @aPunch

    When I do /trader sell bread 1 (it says i don't have no economy plugin)

    But I have the latested iConomy updated!

    Any idea's / suggestion's my dear devs.

    Might be bukkitpermissions
  21. Offline


    Here, ty the solution at this link: http://citizens.wikia.com/wiki/Common_Issues

    It worked for a friend and it might work for you. Hope I helped!
    BioRage likes this.
  22. Offline


  23. Offline


    Can you pastebin your economy.yml from inside the citizens plugin folder for me?
  24. Offline


    Anyinfo on the other error I'm getting, or advice?
  25. Offline



    Your economy config looks good so I'm at a loss there.

    However, I've had something similar happen before.

    Give this a try just for ha-ha's:

    Shut down the server.
    Copy your existing npc-profiles.yml to your desktop (make a backup copy)
    Delete the original npc-profiles.yml from inside the citizens plugin folder
    Start the server, and let it generate a blank yml.
    Check the console for errors, assuming none appear,
    Go create a new npc in game, and see if the problem persists.

    There have been a few occasions where my config gets corrupted (or miswritten), and some whacky data gets written into npc-profiles for waypoints. It doesn't happen all the time.
    Post the results back here.

    Also of note, try making iConomy load BEFORE citizens. If you rename iconomy.jar to 02_iconomy.jar (for example) it will load before citizens, but you'll want to also rename whatever permissions plugin to something like 01_permissionsbukkit.jar so it loads first. This will not affect the corresponding plugin folders, so do not rename them (leave the iConomy and permissionsbukkit folders alone)

    Only do these actions with the server shut down, and never edit a config while the server is running.
  26. Offline


    I get an error in my console every time I shoot an npc with arrows and they die (I haven't tried it with any other types but a guard bouncer). After the error is printed the server stops functioning, any active players get a read timed out error and get kicked. The server is just frozen at that point, nobody can log in and it doesn't display any more errors or any messages in the console whatsoever. I'm using craftbukkit b:1060, essentials 2.5.6, Citizens 1.0.9d.

    2011-08-24 03:47:38 [SEVERE] java.lang.IndexOutOfBoundsException: Index: 178, Size: 178
    2011-08-24 03:47:38 [SEVERE]     at java.util.ArrayList.RangeCheck(Unknown Source)
    2011-08-24 03:47:38 [SEVERE]     at java.util.ArrayList.remove(Unknown Source)
    2011-08-24 03:47:38 [SEVERE]     at net.minecraft.server.World.cleanUp(World.java:1120)
    2011-08-24 03:47:38 [SEVERE]     at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:450)
    2011-08-24 03:47:38 [SEVERE]     at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:363)
    2011-08-24 03:47:38 [SEVERE]     at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    2011-08-24 03:47:38 [SEVERE] Unexpected exception
    java.lang.IndexOutOfBoundsException: Index: 178, Size: 178
        at java.util.ArrayList.RangeCheck(Unknown Source)
        at java.util.ArrayList.remove(Unknown Source)
        at net.minecraft.server.World.cleanUp(World.java:1120)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:450)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:363)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
  27. Offline


    Just got this error during an attempted reload:

    My game told me to bug you about it, so I am.

    2011-08-23 20:40:12 [INFO] [Citizens] Reloading configuration settings....
    2011-08-23 20:40:12 [SEVERE] java.lang.ClassCastException: java.lang.Integer cannot be cast to java.lang.String
    2011-08-23 20:40:12 [SEVERE] at org.bukkit.util.config.ConfigurationNode.recursiveBuilder(ConfigurationNode.java:43)
    2011-08-23 20:40:12 [SEVERE] at org.bukkit.util.config.ConfigurationNode.getAll(ConfigurationNode.java:28)
    2011-08-23 20:40:12 [SEVERE] at com.citizens.properties.CachedYAMLHandler.load(CachedYAMLHandler.java:37)
    2011-08-23 20:40:12 [SEVERE] at com.citizens.properties.PropertyManager.loadAll(PropertyManager.java:99)
    2011-08-23 20:40:12 [SEVERE] at com.citizens.commands.commands.BasicCommands.reload(BasicCommands.java:99)
    2011-08-23 20:40:12 [SEVERE] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    2011-08-23 20:40:12 [SEVERE] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    2011-08-23 20:40:12 [SEVERE] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    2011-08-23 20:40:12 [SEVERE] at java.lang.reflect.Method.invoke(Method.java:597)
    2011-08-23 20:40:12 [SEVERE] at com.citizens.resources.sk89q.CommandsManager.executeMethod(CommandsManager.java:518)
    2011-08-23 20:40:12 [SEVERE] at com.citizens.resources.sk89q.CommandsManager.execute(CommandsManager.java:404)
    2011-08-23 20:40:12 [SEVERE] at com.citizens.Citizens.onCommand(Citizens.java:196)
    2011-08-23 20:40:12 [SEVERE] at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    2011-08-23 20:40:12 [SEVERE] at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:129)
    2011-08-23 20:40:12 [SEVERE] at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:352)
    2011-08-23 20:40:12 [SEVERE] at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:737)
    2011-08-23 20:40:12 [SEVERE] at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:701)
    2011-08-23 20:40:12 [SEVERE] at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:694)
    2011-08-23 20:40:12 [SEVERE] at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
    2011-08-23 20:40:12 [SEVERE] at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    2011-08-23 20:40:12 [SEVERE] at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:89)
    2011-08-23 20:40:12 [SEVERE] at org.getspout.spout.SpoutNetServerHandler.a(SpoutNetServerHandler.java:436)
    2011-08-23 20:40:12 [SEVERE] at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    2011-08-23 20:40:12 [SEVERE] at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:454)
    2011-08-23 20:40:12 [SEVERE] at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:363)
    2011-08-23 20:40:12 [SEVERE] at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
  28. Offline



    Ouch! I see two out of bounds errors from "unknown source" that makes things kind of hard to troubleshoot.

    The next error I see is from "world clean up" which I can't remember if it is part of the essentials suite or not (gets rid of items that are strewn about, specifically arrows)

    I'm guessing these are evil NPCs. To be honest I can't lend much of a hand here, I disabled the evils due to "this is a non-pvp area" warnings when attacking them in cities on my server. (worldguard or MultiVerse saw them as players, allowing them to attack, but not be harmed by real players, in worldguard regions where i have PvP disabled. They even killed me with god mode on)

    If I had to guess, it may be essentials wreaking havoc again.
  29. Offline


    There is very little documentation on this mod... Tutorial videos set up or anything really? I'm going to be using this mod heavily in my server if I knew how to even do anything
  30. Offline


    No problem, glad I could help!

    Could anybody still tell me how to make a guard npc attack players?
  31. Offline


    I think it's still buggy..

Share This Page