[FUN] Citizens v2.0.11 - Human NPCs for Bukkit [1.7.2]

Discussion in 'Archived: Plugin Releases' started by Citizens, Mar 5, 2011.

  1. Offline


    Citizens - Human NPCs for Bukkit
    Version: 2.0.11
    Authors: @fullwall and @aPunch
    Source: Citizens on GitHub

    Citizens is now on BukkitDev

    This thread will no longer be updated. We encourage you to use our page on BukkitDev. You can find information, links to our wiki and website, and the download page there.

    Showing Your Support

    We work hard to maintain Citizens. We've been working on Citizens2 around the clock on new and exciting features. A little motivation never hurts, so feel free to donate to us - fullwall and aPunch.

    If you can't donate, we appreciate a "hello" every now and then. Stop by the IRC channel #citizens on irc.esper.net to discuss Citizens and give thanks!
  2. Offline


    All our NPCs have flat out disappeared. No amount of server restarting or plugin reloading brings them back. They still exist in the npc profiles though.
  3. Offline


    Question ! :

    Could it be possible to improve the blacksmith ? I don't want to pay the same price for a diamond armor and a leather armor...
    Same with tools ... pickaxe not the same price as the shovel
  4. Offline


    Blacksmith pricing has been changed many times. I like the way we have it now, so this most likely will not be changing for awhile.

    @locutus I'm confused. Which version of Citizens are you using when your players don't have permission? We changed permission nodes for v1.0.9d, which can be seen here.
  5. Offline


    I have a problem.. When i type in into Bukkit Permissions
                citizens.wizard.use.interact: true
                citizens.trader.use.trade: true
                citizens.healer.use.heal: true
                citizens.blacksmith.use.repair: true
            default: user
    And then user try to ask wizzard to teleport him it doesn't work, and it says "You don't have a permissions to do that"
    Oh.. And BTW: When wizard run out of mana, it still takes money when you try to teleport or do something else.
  6. Offline


    @fullwall , @aPunch and @NeonMaster
    Any chance at mysql logging of purchases for iConomy? I've got a tracker on my website that I'd like more transactions to be a part of.
  7. Offline


    Read please :D
    Okay. So.. Probably a dumb question, I've spent 3 days trying to get this working because I didn't want to request help due to the fact your busy and the chances of a reply are minimal.

    Problem :
    My problem is..
    Lets say I have a trader that only buys wood so i'd type
    /trader buy wood 100
    Then somebody would open my shop and sell there wood to my trader BUT this is where the problem
    occurs, They will keep there item as it fills the inventory of the trader and gives them money, essentially duplicating the item and paying them for it.

    John has 10 wood
    John opens shop
    Clicks on wood and then clicks to confirm
    Traders inventory starts to fill up with each click
    John still has 10 Wood but gets money for filling the inventory of the Trader
    John leaves Trader with 10 wood lots of money and the Trader has lots of wood.

    Any help will be much appreciated because I know your very busy.


  8. Offline


    Oh! didn't know there was an update. Thanks! btw im new to bukkit so idk how to update without losing everything... do you?
  9. Offline


    May anyone know why this plugin keeps crashing my server? Is this plugin not compatible with some plugins I may not no of? I do not get errors but I see that when I remove this there is no more crashes. Is it that I have not placed a npc yet?
  10. Offline


    Just replace the .jar files and nothing else
  11. Offline


    awesome, i think its working... now how do i make an npc?
  12. Offline


    Creates an npc called God, writes /list , Gods logged in?
  13. Offline


    should be:

    /trader buy wood:1 100
    /trader buy 5:1 100 (wooden plank)
    /trader buy 17:1 100 (logs)

    /trader buy A:B C

    A is Item
    B is amount in the stack up to 64
    C is price

    I prefer using the number to make sure you have the right thing. But in your post you did not specify amount of wood, maybe that is the problem.
  14. Offline


    I have a odd problem that probably is easy to fix.
    I create a trader and write
    "/trader buy 4:10 1"
    the people on my server then tried to sell to him. The message they got was: "You dont have enough money available to buy 10 cobblestones."
    I changed owner to another guy, and got the same message from him.
    Did i forget to do anything?
  15. Offline


    I have the same problem - anyone able to help ?
  16. Offline


    How do I use / npc armor? Try / npc armor iron helmet, but doesn't work
  17. Offline


    is there any way sape or form you can give the npc's more jobs like 1 plugin i have seen had factions for your npc's
    and can npc's attack sertin people if you tell them to eg. /npc property attack MrGamerzLobby
  18. Offline


    It's /npc armor helmet 306

    Remember that you need to have one in your inventory too.
  19. Offline


    If i have this iConomy do i have to use citizens 1.0.9d or 1.0.9c ?

            select-items: '*'
            talk-items: 340,
    What does the ',' means ? That's the citizens.yml file.
  20. Offline


    Both will work fine ^.=.^

    The '*' means that all items, including your hand can be used to select an NPC. The ' ' are there to prevent errors.
  21. Offline


    same here:(
    i called one tom (had a halo skin (didnt knwo tought)) he wouldnt talk or look at you so i i setted another text what he would say, he still didn't say that so i typed /npc save(i forgot the command it was tho save them) he saved.
    and i restarted the server because i hoped that the problem would be fixed, but there where no npc's.
    i had the same with a butler who needed tho say Welcome have a nice visit!(he did disapeared as well and had the same issues as tom).

    owh yeah running latest mc version latest bukkit(build 1000)
    god plug in latest version
    campfire latest
    chaircraft latest
    appletree latest
    simmple chest lock latest
    iconomy latest
    seasons latest
    instabreak latest
    choptree latest
    jail latest
    nanobots latest(nothing to do with bots or npc's just changing of sand--> stone for example)
    npc quester latest(could this be it?)
    sponge restore latest
    voxelsniper latest
    easyflight latest
    epicquest latest
    careers latest
    and at last craftbukkituptodate latest.

    i will delete the npc quester and report back.
    created a new one but still away.
    but since i am looking through the server ehm cmd
    i read there are some errors for citizens he couldnt pass Player_login i have a unacceptable character #0 special characters not allowed.
    the mapping values are not allowed here?
    and some errors of not finding quest(havent added them yet)
    and error of my permission system(i dont have one :/)

    Deleting god bal bla and instabreak atm
    doesnt work
    It is the mapping issue :(
    but does somebody know how tho fix?
    i fixed the Player_login by deleting the godmode thingie
    deleted careers fixe a carreers problem(Duh!)

    Alright i only have on error left and that is with citizens: Null; mapping values are not allowed here.

    i dont have waypoints do you need those?

    how tho post a full error report?
  22. Offline


    I didnt meant ' ', but the comma sign "," a the one of "
    talk-items: 340,".

    And could anyone solve this problem, as I want to finish this and I can't.
  23. Offline


    I keep gettin this message?:
    14:14:44 [WARNING] Task of 'Citizens' generated an exception
    java.lang.ClassCastException: org.bukkit.craftbukkit.entity.CraftBoat cannot be cast to net.minecraft.server.Entity
    at com.citizens.Resources.NPClib.Creatures.PirateCreatureNPC.onSpawn(PirateCreatureNPC.java:31)
    at com.citizens.CreatureTask.onSpawn(CreatureTask.java:63)
    at com.citizens.CreatureTask.spawnCreature(CreatureTask.java:57)
    at com.citizens.CreatureTask.run(CreatureTask.java:44)
    at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:137)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:438)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
  24. Offline


    I don't get it...
    What's the point of having traders on a serveur if only admins can use it because it screws the economy...
    They fixed the account for all the NPCs in 1.09.d but not the traders. Why?
  25. Offline


    @tweeter2 - that is a YAML problem.
    @Hempa - disable pirates.
    @Zykana - there is likely an error on startup causing this. Please look for it and post the error if you see one.
  26. Offline


    Thanks, but how tho fix the YAML problem?

    and if you need tho see a yml tell me which :)
  27. Offline


    @tweeter2 - I need the error itself.
  28. Offline


    how tho post because you cant copy paste the things of the cmd like screen.
  29. Offline


    If your NPCs disappear, try updating. Worked for me... The NPC's seemed to be flying.
  30. Offline


    already have the latest :)
    but wall would help me but he is offline so i need tho wait.
  31. Offline


    @tweeter2 - can you post your citizens.yml on pastebin or pastie or similar?

Share This Page