[FUN] Citizens v2.0.11 - Human NPCs for Bukkit [1.7.2]

Discussion in 'Archived: Plugin Releases' started by Citizens, Mar 5, 2011.

  1. Offline


    Citizens - Human NPCs for Bukkit
    Version: 2.0.11
    Authors: @fullwall and @aPunch
    Source: Citizens on GitHub

    Citizens is now on BukkitDev

    This thread will no longer be updated. We encourage you to use our page on BukkitDev. You can find information, links to our wiki and website, and the download page there.

    Showing Your Support

    We work hard to maintain Citizens. We've been working on Citizens2 around the clock on new and exciting features. A little motivation never hurts, so feel free to donate to us - fullwall and aPunch.

    If you can't donate, we appreciate a "hello" every now and then. Stop by the IRC channel #citizens on irc.esper.net to discuss Citizens and give thanks!
  2. Offline


    @RaginMc Have you looked at the new permission nodes here?
  3. Offline


    @aPunch Yesser,.. Yesser i did.... after some "looking around" i see that i was running
    • 1.0.9c - Minecraft Beta 1.7.3, CraftBukkit 953-1000
    So, i thought what a dumb A** i am,.. but what i didn't remember was that i tried the 1.0.9d onces before then downgraded to 1.0.9c because i got two errors when using 1.0.9d, maybe me using the C was messing with me permissions?.. but anyways,.. i just updataed to 1.0.9d again and heres my errors,.. maybe if we fix errors in D permissions might work =D ( note every time i try a command in 1.0.9D i get this error

    2011-07-29 04:56:58 [SEVERE] java.lang.NullPointerException
    2011-07-29 04:56:58 [SEVERE]    at com.citizens.resources.sk89q.CommandsManager.hasCommand(CommandsManager.java:252)
    2011-07-29 04:56:58 [SEVERE]    at com.citizens.Citizens.onCommand(Citizens.java:184)
    2011-07-29 04:56:58 [SEVERE]    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    2011-07-29 04:56:58 [SEVERE]    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:129)
    2011-07-29 04:56:58 [SEVERE]    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:298)
    2011-07-29 04:56:58 [SEVERE]    at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:711)
    2011-07-29 04:56:58 [SEVERE]    at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:676)
    2011-07-29 04:56:58 [SEVERE]    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:669)
    2011-07-29 04:56:58 [SEVERE]    at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
    2011-07-29 04:56:58 [SEVERE]    at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    2011-07-29 04:56:58 [SEVERE]    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:84)
    2011-07-29 04:56:58 [SEVERE]    at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    2011-07-29 04:56:58 [SEVERE]    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451)
    2011-07-29 04:56:58 [SEVERE]    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
    2011-07-29 04:56:58 [SEVERE]    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    When i frist start the server i get this error

    [SEVERE] Error occurred while enabling Citizens v1.0.9 (Is it up to date?): com/google/common/collect/Maps
    java.lang.NoClassDefFoundError: com/google/common/collect/Maps
        at com.citizens.npcs.NPCTypeManager.<clinit>(NPCTypeManager.java:10)
        at com.citizens.Citizens.registerTypes(Citizens.java:271)
        at com.citizens.Citizens.onEnable(Citizens.java:87)
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:126)
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:857)
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:264)
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:151)
        at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:136)
        at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:284)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:271)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:148)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:335)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Caused by: java.lang.ClassNotFoundException: com.google.common.collect.Maps
        at java.net.URLClassLoader$1.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(Unknown Source)
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:36)
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:24)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        ... 13 more
    now to my understanding, 1.0.9d is the updated one (witch is the one i get thses errors with)
    allso to note none of my older npcs are there,.. alltho that does not matter because i only had test bots added sofar =P

    and with 1.0.9c only prob i have is the permissions wont work (as i might of said before) i can add citizens.admin to builders and builders can use bot,.. if i take a way citizens.admin and add "ALL" orther permissions builders cant use bots or any /npc commands
  4. Offline


    @RaginMc - 1.0.9d requires build 1000 or above.
  5. Offline


    Hi there..! Just a heads up (FYI):

    The plugin works nicely, after I had some troubles in the start that I was able to pin down (I think).

    For some reason everything was working nicely, except that for some reason I wasnt able to give thNPC items or armor. It said it changed the hand value to diamond word for example but it was not displaying...

    After fiddling around with it for a while I though there could be a collision with dome other plugin maybe.
    And after further fiddling I found out that these problems only occur when the NPC has been created (spawned) in a sub-(multi)world.

    After that I tried spawning an NPC in the main world (world 0) and I was able to sucessfully give him items and armor.
    Then i moved him to another world, a subworld, and he kept his stuff on him...
    After that I was even able to change his stuff in the subworld and it would work as it should.
    I guess it has something to do with inventorymanagement of different worlds (for example i use XcraftGate and players have the same inventory throughout all worlds.

    So all you have to do in order to avoid those funny problems (that dont even show errors on the console at all) is to make sure you spawn the NPC in the main world first, then move him to the world you like, and then you can edit its items/armor sucessfully.

    I hope this helps the further develeopment of this awesome plugin.

  6. Offline


    This is a truly great plugin, as I've already said :)
    Only thing I've had trouble with is that the enemy mobs seem to be ignoring /god commands... no Essentials support? And they don't seem to be reacting to cake much...
  7. Offline


    @Boltblaster - supporting every other plugin that implements a /god is not good :p. Sorry about that.
  8. Offline


    Nevermind, ty for the fast reply :)
    A suggestion: Restrict spawn areas for evil mobs (no spawning in other's houses 0.o)
  9. Offline


    Disabled a few addons and the problem is still there, will experiment further..

    HOWEVER... i found out something weird in the way the despawning/respawning works!
    Some of the despawning NPCs are range dependend it seems!
    I just logged on on a freshly rebooted server and i was alone, all npcs loaded.
    I started walking and a few npcs despawned which went one by one. When back tracking, they reloading again!
    For example: When i walked 50 meter, npc A despawned. I walked 10more meters, npc B despawned. Walking back a couple of meters made B respawn and walking further back made A respawn aswell!

    Pretty weird huh?

    When logging out a bunch more despawned, sort of simular when gating to a different world... it seems to unload NPCs simply because they are out of range!
    Does that make sense somehow?
  10. Offline


    It's a Bot
  11. Offline


    5 months too late! ;)
  12. Offline


    @fullwall: I've disabled 1 addon at a time and logged in every time, then quite straight away which made a bunch of npcs respawn. So either it isn't a plugin issue ór Citizens clashes with more then 1 of my plugins :S
    Will disable them all in the weekend and add them 1 by 1 and hope i find the plugin that cause this.
  13. Offline


    upps :S
  14. Offline


    The only thing I can think of is that the plugin creates NPC's as creatures, like the ones already in Minecraft (spider, skeleton etc.). If these entities despawn when you are a certain distance away, and the NPCs are such entities, that's why they would despawn. For spawning again, I would assume that since the server is ordered to spawn a NPC at a precise location, when you get close again, cross the "despawning line", the NPC would appear again. If this makes any sense :)
  15. Offline


    is there a way to change thier skins with BukkitContrib ?
  16. Offline


    Or a plugin that uses chunks incorrectly or a way that citizens isn't prepared for, causing the chunk load/unload to fail and not return the physical npc form. If this makes any sense. Such dreamworld which was a conflict when fullwall checked, if my memory serves me.
  17. Offline


    how can i change wizard teleport location ?i dont really see the poing in addloc if i cant change TP locations,wizard always will teleport to first added location
  18. Offline


    @mbsuperstar1 is correct when mentioning DreamWorld, it uses a non-standard chunk refresh method. However, it seems to also happen on servers without this plugin. @Exanimo - walking backwards to reload seems strange. Debug messages may help here - 'despawned at' means a chunk unload event happened while 'reloaded at' means a reload event happened. A despawned at without an accompanying reload at could narrow down the cause.
  19. Offline


    @Nibelton - if you have PVP disabled on your server, you won't be able to switch locations. If not, then try changing the wizard interact item (by default it's a feather and left click changes location).
  20. Offline


    A problem we've noticed with citizens for quite a few versions is that when we have quite a few NPCs on the server (e.g. 42), some of them start to disappear and we have to reload all plugins to get them back again. I've not noticed any errors on the console to do with it but I just thought I'd make you aware of it :)
  21. Offline


    Has anyone used this mod for creation of MOB bosses for group raid dungeons? I need something to create repeatable bosses with random loot generation. not sure if this is going to work for my needs.

  22. Offline


    Thx @aPunch and @fullwall , after up dating everything and then removing all the quotes, its working,..

    i know that it was gonna be sometime simple i missed,..

    Ps. nice server @ halfcraft.net
  23. Offline


    @coomdoom - thanks, yes, we are aware. Could you post your plugin list to help?
    @razoreqx - 'boss' npcs aren't possible yet, but may be done in the future when we can get around to it.
  24. Offline


    Is there a comprehensive setup and usage guide for this mod? I don't want to go through 224 pages just to find an undocumented answer.
    The Gethub wiki has 5 pages and minimal information.
    The in-game help (which is undocumented but I was lucky enough to stumble on it) doesn't give me all the information I want and the mod itself doesn't generate any readme file.

    Edit: Apparently there is more than one command and more than one help file. I don't mean to sound like an ass, but there's no consistency in this at all.
  25. Offline


    Hello everyone, I might found a bug in the newest version 1.0.9d:

    I've tried to make a NPC following a path of 5 waypoints in a circle, but the NPC walks between them randomly:
    3,1,5,4,3,2,5,4,3,1,4,3,1,4,3,1,4,2,5,1,4,2,5,2,1,5,4,3,1 ...
    Additional, after I have logged out, the console log showed that the NPC has despawned (with debug mode turned on). After I logged in myself again, it seems that the NPC has respawned, but wasn't moving anymore (not even randomly).

    After I've downloaded version 1.0.9c, everything is working fine (1,2,3,4,5,1,2,3...), and the NPC now continue his path after I have logged out and back in.

    Technical information: Bukkit build 1000, performed clean install of Citizens (no other NPCs, no config changes). Permissions plugin 3.1.6.

    Will this issue be fixed in one of the next releases?
  26. Offline


    I would just like to point out a cool client mod by the name of mcOverhaul created by a fellow Bukkit plugin developer @Coelho . I highly recommend downloading it and voting our server (halfcraft.net) up if you want to give something to the Citizens team instead of money. :D
  27. Offline


    can this plugin wrok whit iconomy
  28. Offline


    @razoreqx - 'boss' npcs aren't possible yet, but may be done in the future when we can get around to it.[/quote]

    @fullwall thanks for the quick reply!! Look forward to that addition. BTW we love the plugin!
  29. Offline


    I've been wondering for a while, so if anyone can answer me, I'd appreciate it.
    I don't really know how to spawn EVIL NPCS and I heard they take damage and attack. So I'd appreciate it if Anyone could tell me further details or how to spawn them.
  30. Offline


    Simple. The way you say it, I assume you have quite limited knowledge on the subject, so I'll make it step by step.

    1) Download Notepad++ and install. Accept default settings.
    2) Download Citizens, and put it in the plugins folder.
    3) Open the Citizens folder and find the file mobs.yml
    4) Right-click and select the option: Edit with Notepad++
    5) Set the spawn setting from false to true for what evil mobs you want to spawn. BTW, pirates aren't totally fixed yet.
    6) Save.
    7) Open/Restart your server
    8) Enjoy!

    I know I didn't need to post it step by step, but I'm just in a smart, show-off mood right now. You understand :p

    Edit: @dark2222 yes... Read the first post.
  31. Offline


    Love the plugin! I think it has a great potential.
    I'm waiting for your guard to use them in my plugin and saw your working on.
    I don't know if you have planned these features, hope you can include them (otherwise I'll have to do it by myself) :
    Is it possible to enable the collision between the NPC ? When they follow me (in bodyguard mod) they are mingled. Not really pleasant.
    Have you planned multi-selection ? Attacking every enemy until a point ? Attacking a selected enemy under order? Defend a selected unit ?
    How do you recognize the enemy ? Is it easy to make teams ? :)

    And are you French ?


Share This Page